Jump to content
Not connected, Your IP: 3.226.97.214
Staff

Eddie Desktop 2.19beta released

Recommended Posts

Hello!

 

We're very glad to inform you that a new Eddie Air client version has been released: 2.19beta. It is ready for public beta testing.

 

How to test our experimental release:

  • Go to download page of your OS
  • Click on Other versions

    client-experimental-howto-1.png

  • Click on Experimental

    client-experimental-howto-2.png

  • Look at the changelog if you wish
  • Download and install

Please see the changelog:

https://eddie.website/changelog/?software=client&format=html





 

PLEASE CONSIDER THIS AS A BETA VERSION.
Don't use it for real connection, it's only for those who want to collaborate to the project as beta-tester.


 

Share this post


Link to post

This version contains some bug fixes (in Windows and some OS X and macOS versions) we discovered after 2.18.9 stable version had been released. You don't need to download it if you don't have any issue with the latest stable release.
 

Version 2.19.0 (Tue, 07 Apr 2020 13:11:42 +0000)

  • [bugfix] - Windows, Custom DNS
  • [change] - Windows, DNS, switch only UP network adapter
  • [bugfix] - MacOS, fix PKG package (relocation disabled)
  • [bugfix] - MacOS, fix signature issue with older Yosemite

Share this post


Link to post

Installer hanged for me when installing the CLI elevated, had to stop it in task manager before running installer again (win10)

Share this post


Link to post

Thanks a lot for this update!
Now Eddie works like a charm with wintun drivers 😉
I had issues with other sw (e.g. NextDNS) because of TAP drivers, now everything is fine.
Just a question (maybe very stupid, but I don't want to be again in a mess with TAP drivers...).
I use portable version of Eddie UI, which I set up to use the wintun drivers. In the Eddie folder I see there is also the CLI version, Eddie-CLI.exe. Does the CLI version share the same settings of UI?
I suppose yes, but I'd like to be 100% sure about this before I try it: I don't want to unistall/install again all TAP drivers, network interfaces and sw everytime I want to use Eddie or NextDNS...

Share this post


Link to post

I risk sounding stupid, but here it goes

is SSH/SSL tunnel TCP or UDP?

If UDP, any chance to make it TCP? My connections drops often on UDP

Share this post


Link to post

Version 2.19.1 (Sat, 18 Apr 2020 11:14:36 +0000)

  • [bugfix] Linux - Fix issue with Network Lock IPv6-only incoming whitelist
  • [bugfix] - http-100-continue issue
  • [bugfix] - Special condition elevation checks (may resolve "Unable to start (no-socket)" issues).
  • [change] - Removed curl binary dependencies
  • [new] Linux - New Network Lock with nftables (if nft is present, it is used by default in "Automatic" mode)
  • [new] Windows - New option "Use wintun driver (OpenVPN>=2.5)" under "Preferences -> Advanced" automates ovpn directive

Share this post


Link to post

Seeing your notice of the 2.19.1 beta, I downloaded it and attempted to install it.  On my system (the Ubuntu 20.04 release candidate, running Wayland), which had been running Eddie 2.19.0 (as well as previous versions before), the installation process seemed to go well, but then I was unable to open Eddie.  I got a quick flash telling me it was opening, but then nothing.  I tried rebooting, still no luck.  I uninstalled it, then reinstalled 2.19.0, and it is working fine again.

Share this post


Link to post
9 minutes ago, Grindle222 said:

Seeing your notice of the 2.19.1 beta, I downloaded it and attempted to install it.  On my system (the Ubuntu 20.04 release candidate, running Wayland), which had been running Eddie 2.19.0 (as well as previous versions before), the installation process seemed to go well, but then I was unable to open Eddie.  I got a quick flash telling me it was opening, but then nothing.  I tried rebooting, still no luck.  I uninstalled it, then reinstalled 2.19.0, and it is working fine again.

Same for me here; also running Ubuntu 20.04.

Installation went fine, but then upon opening, the splash window appears and then disappears again.

EDIT: Tried to open eddie-ui in a root-terminal; this is the output of the CLI:

Unable to initialize native library. Maybe a CPU architecture issue.
. 2020.04.18 17:47:49 - Shutdown in progress
. 2020.04.18 17:47:49 - Shutdown complete

Hope this helps.


 

AMD Ryzen 3950X @ 105W PPL

Gigabyte X570 Aorus Elite

Gainward GTX 970

Corsair DDR4-3200 32GB

 

Share this post


Link to post
17 minutes ago, Grindle222 said:

Seeing your notice of the 2.19.1 beta, I downloaded it and attempted to install it.  On my system (the Ubuntu 20.04 release candidate, running Wayland), which had been running Eddie 2.19.0 (as well as previous versions before), the installation process seemed to go well, but then I was unable to open Eddie.  I got a quick flash telling me it was opening, but then nothing.  I tried rebooting, still no luck.  I uninstalled it, then reinstalled 2.19.0, and it is working fine again.

 
8 minutes ago, BlueBanana said:

EDIT: Tried to open eddie-ui in a root-terminal; this is the output of the CLI:

Unable to initialize native library. Maybe a CPU architecture issue.
. 2020.04.18 17:47:49 - Shutdown in progress
. 2020.04.18 17:47:49 - Shutdown complete


Can reproduce on

$ uname -a
Linux hostname 5.5.0-1-amd64 #1 SMP Debian 5.5.13-2 (2020-03-30) x86_64 GNU/Linux


» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post
2 hours ago, Clodo said:

Version 2.19.1 (Sat, 18 Apr 2020 11:14:36 +0000)

  • [bugfix] Linux - Fix issue with Network Lock IPv6-only incoming whitelist
  • [bugfix] - http-100-continue issue
  • [bugfix] - Special condition elevation checks (may resolve "Unable to start (no-socket)" issues).
  • [change] - Removed curl binary dependencies
  • [new] Linux - New Network Lock with nftables (if nft is present, it is used by default in "Automatic" mode)
  • [new] Windows - New option "Use wintun driver (OpenVPN>=2.5)" under "Preferences -> Advanced" automates ovpn directive

For the wintun option do I need to install openvpn 2.5 (thus the wintun driver) manually or does this version of eddie install it automatically?

Share this post


Link to post
Quote

Installation went fine, but then upon opening, the splash window appears and then disappears again.



Same here on Buster.  2.19.0 was running perfectly on this end.

Share this post


Link to post
Quote

Clodo ----[new] Linux - New Network Lock with nftables (if nft is present, it is used by default in "Automatic" mode)



Does this mean that I could add nft to a Buster system and then block all incoming and outgoing during boot of my system?  Proceeding:

My wish list   ---------------- > After booting the system ONLY Eddie could gain a connection leaving no chance for an accidental connection outside of the tunnel.  Before upgrading to Buster I could do that on Stretch using UFW (IP tables frontend).  Just asking!

ps - I want to use Eddie and not have to enter individual IP's for the servers I use while creating the firewall.  Just a general closed system where Eddie creates the way out and then writes back my firewall upon exit.

Share this post


Link to post

Eddie 2.19.1 beta immediately crashes on Linux Mint 19.3.  Sorry.  Unable to post logs because the UI just force closes - reverted back to 2.18.9 stable. 

Share this post


Link to post
22 hours ago, go558a83nk said:

For the wintun option do I need to install openvpn 2.5 (thus the wintun driver) manually or does this version of eddie install it automatically?

good point, everything should be automated

Share this post


Link to post

We cleaned the above post on Linux build crash for simplicity's sake. We have detected the issue and we are working to resolve it.

Share this post


Link to post

Guys, on the new version on the log-in page of Eddie, that nice padlock symbol that shadow reflects behind it has disappeared. Can we have that back please? It looked nice as a design. Also, I'm unable to resize the Eddie window, on Eddie 2.16.3 this was easily done by going to the edge and just dragging the side closer or wider. These should be easy to implement. :)

Now the difficult bit.
In Eddie, under "Microsoft Windows Only", there are two boxes. "Uninstall standard driver" and the wintun driver box that is shaded grey at the moment. For the future updates, if feasible, can we install both drivers in the installation stage and from that part in Eddie we can select which driver it should use? That way we can check with which driver it performs best.

If I should post this somewhere, please let me know.

All the best with the design and thanks for the hard-work behind the scenes.

Share this post


Link to post

issues I encountered w/ this beta on Win 10 LTSC:

(1) cannot resize GUI other than making it larger
(2) the auto TAP driver upgrade from 2.23.x to 2.24.x failed - GUI froze/hung for 2 mins (disabled that option in prefs then, once GUI was responsive again)

I was going to use wintun driver anyways, which I successfully did - DL speed doubled.

Share this post


Link to post

Version 2.19.2 (Tue, 21 Apr 2020 12:42:14 +0000)

  • [bugfix] - Linux - Fixed crash at startup
  • [bugfix] - Windows - Fixed an issue about detection of wintun driver
Other feedbacks are under investigation. Thx.

Share this post


Link to post
6 hours ago, BlueBanana said:

Hmm, when i go to Ubunu/Debian -> Other Versions -> Experimental, nothing happens when i click the download button...

 


Yep, I got exactly the same: nothing happens when I click the download button.  I, too, am using - or trying to use - the Debian/Ubuntu version.
(Just to check things out further, I checked and found that the download button works with the OpenSUSE and Fedora versions, and so I suspect for the rest of the Linux OSes, too. 
That's no help for those of us using Debian/Ubuntu, of course.)

Share this post


Link to post
2 hours ago, Clodo said:

linux .deb x64 resolved, thx, my apologies, an issue in deployment system.


I just downloaded it and installed it.  Thanks!  So far, so good.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...