Jump to content
Not connected, Your IP: 18.234.255.5
Staff

Eddie Desktop 2.19beta released

Recommended Posts

On 7/5/2020 at 12:16 PM, puccettone said:

Hello,
download of windows portable version for 2.19.3 is not available.
Will you release it soon or you will relase directly the 2.19.4 version?
 

Fixed, sorry.

Share this post


Link to post

So I tried beta 2.19.4 - same error message..
disabled Gatekeeper completely, still same problem even after restart.

*edit* since the update of macOS 10.15.6 I can run the latest beta! *thumbsup*
love Hummingbird - thanks for your work

*edit2* I saw Eddie 2.19.4 still uses Hummingbird 1.0.3 - while 1.1.0 is already out. Any specific reason for this?
I was troubled with some connection errors after a while, so I copied v1.1.0 to /usr/local/bin and defined that path to Eddie, which works in this version. 

Share this post


Link to post

Win10 Home 64bit. Wanted to check out the beta with Wintun. Uninstalled 2.18.9, deleted associated directories/folders and cleaned the registry. Installed 2.19.4. Went in and checked to use Wintun in Preferences/Advanced. It remained checked. Got to thinking, is Wintun really being used? The Uninstall Wintun button on the Advanced window was greyed out. Hmm. Read the "How to use wintun driver in Windows" forum article. Okay. Downloaded the tech preview with Wintun driver and chose only to install the Wintun driver. It installed. Confirmed by finding it in Device Manager as well as the Uninstall Wintun Driver button in the Eddie Advanced window was no longer greyed out. Restarted the PC. Wintun was stilled checked in the Advanced window. Figured all is good until I went into the PC's Adapter Options to find Eddie only using the TAP driver. The Wintun adapter was there with a red X not being used. Tried a few things, but could never get Eddie to go active with Wintun driver. So... uninstalled the Wintun driver and uninstalled Eddie beta and went back to 2.18.9.

So, consider a non-techy person using AirVPN with Eddie who goes in and checks the Wintun driver option thinking all is good. Yet, the Wintun driver is not installed when Eddie beta is installed, yet it can be checked in the Advanced window and remains checked.

Share this post


Link to post
3 hours ago, Fly AirVPN said:

Downloaded the tech preview with Wintun driver and chose only to install the Wintun driver.


Hello!

Wintun driver can only be used by OpenVPN 2.5 with the proper directive. Make sure you have installed OpenVPN 2.5 and configure Eddie to run OpenVPN 2.5 and enforce windows-driver wintun directive, according to the very same instructions you mention.

Kind regards
 

Share this post


Link to post
On 7/1/2020 at 10:20 AM, Clodo said:
On 6/26/2020 at 4:57 PM, boblinthewild said:

Hi,

I'm running Eddie 2.19.3 beta on Windows 10 64 bit. All seems to be good, except after some amount of time the speed display becomes frozen in both the Overview display panel and the Speed display panel. Restarting Eddie makes it work again, but it always freezes later. Apart from the frozen speed display, Eddie seems to run fine. This was also happening in 2.19.2. I can supply logs if needed.

Yes thanks, if it is reproducible, enable in Preferences -> Logs both 'Log Debug' and 'Log on File'. Here or open a ticket if you prefer, thanks.
I'm now running Eddie 2.19.4 and the problem reappeared. I'm not sure when the status display froze so I am enclosing logs for the last several days, going back to my most recent server connection.

eddie_2020-07-12.log eddie_2020-07-17.log eddie_2020-07-16.log eddie_2020-07-15.log eddie_2020-07-14.log eddie_2020-07-13.log

Share this post


Link to post
On 7/1/2020 at 5:23 PM, Clodo said:
On 5/28/2020 at 7:54 PM, X7iGmXYQBrnz said:

One minor change please - can the tooltip on the systray icon show the connection status ("Connecting to...") like previous versions, rather than the UL/DL speed.  It saves me opening the GUI while I wait impatiently for it to connect at startup.

This was an already resolved bug, does it still occur in 2.19.3?
I have skipped to 2.19.4, can confirm fixed - thanks.

Share this post


Link to post

I was running beta 2.19.4 for the last 24h - there seems to be a problem with disconnects happening. At first I thought it was Hummingbird - happily used 1.1.0 until I noticed every hour a reset - but since that I've switched back to OVPN 2.4.9 there is a disconnect every few minutes..
 

. 2020.07.17 19:50:22 - Eddie version: 2.19.4 / macos_x64, System: MacOS, Name: macOS 10.15.6, Version: 10.15.6 (Build 19G73), Mono/.Net: v4.0.30319
. 2020.07.17 19:50:22 - Command line arguments (0):
. 2020.07.17 19:50:24 - Profile path: /Users/inet/.config/eddie/default.profile
. 2020.07.17 19:50:24 - Reading options from /Users/inet/.config/eddie/default.profile
. 2020.07.17 19:50:25 - Tun Driver - Expected
. 2020.07.17 19:50:25 - OpenVPN - Version: 2.4.9 - OpenSSL 1.1.1f  31 Mar 2020, LZO 2.10 (/Applications/Eddie.app/Contents/MacOS/openvpn)
. 2020.07.17 19:50:25 - SSH - Version: OpenSSH_8.1p1, LibreSSL 2.7.3 (/usr/bin/ssh)
. 2020.07.17 19:50:25 - SSL - Version: stunnel 5.56 (/Applications/Eddie.app/Contents/MacOS/stunnel)
. 2020.07.17 19:50:25 - Recovery. Unexpected crash?
. 2020.07.17 19:50:25 - Routes, removed an existing route, 91.214.169.69 for gateway 10.20.10.1
. 2020.07.17 19:50:25 - Above log line repeated 2 times more
! 2020.07.17 19:50:25 - Activation of Network Lock - macOS - PF
I 2020.07.17 19:50:27 - Ready
. 2020.07.17 19:50:28 - Collect information about AirVPN completed
I 2020.07.17 19:51:44 - Session starting.
I 2020.07.17 19:51:44 - Checking authorization ...
. 2020.07.17 19:51:45 - IPv6 disabled on network adapter (Thunderbolt Bridge)
. 2020.07.17 19:51:45 - IPv6 disabled on network adapter (Wi-Fi)
. 2020.07.17 19:51:45 - IPv6 disabled on network adapter (Bluetooth PAN)
! 2020.07.17 19:51:45 - Connecting to Sextans (Switzerland, Zurich)
. 2020.07.17 19:51:45 - OpenVPN > OpenVPN 2.4.9 x86_64-apple-darwin19.5.0 [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [MH/RECVDA] [AEAD] built on Jun 18 2020
. 2020.07.17 19:51:45 - OpenVPN > library versions: OpenSSL 1.1.1f  31 Mar 2020, LZO 2.10
. 2020.07.17 19:51:45 - OpenVPN > Outgoing Control Channel Encryption: Cipher 'AES-256-CTR' initialized with 256 bit key
. 2020.07.17 19:51:45 - OpenVPN > Outgoing Control Channel Encryption: Using 256 bit message hash 'SHA256' for HMAC authentication
. 2020.07.17 19:51:45 - OpenVPN > Incoming Control Channel Encryption: Cipher 'AES-256-CTR' initialized with 256 bit key
. 2020.07.17 19:51:45 - OpenVPN > Incoming Control Channel Encryption: Using 256 bit message hash 'SHA256' for HMAC authentication
. 2020.07.17 19:51:45 - OpenVPN > TCP/UDP: Preserving recently used remote address: [AF_INET]195.206.105.205:53
. 2020.07.17 19:51:45 - OpenVPN > Socket Buffers: R=[786896->262144] S=[9216->262144]
. 2020.07.17 19:51:45 - OpenVPN > UDP link local: (not bound)
. 2020.07.17 19:51:45 - OpenVPN > UDP link remote: [AF_INET]195.206.105.205:53
. 2020.07.17 19:51:45 - OpenVPN > TLS: Initial packet from [AF_INET]195.206.105.205:53, sid=2c659a21 e4bb4908
. 2020.07.17 19:51:45 - OpenVPN > VERIFY OK: depth=1, C=IT, ST=IT, L=Perugia, O=airvpn.org, CN=airvpn.org CA, emailAddress=info@airvpn.org
. 2020.07.17 19:51:45 - OpenVPN > VERIFY KU OK
. 2020.07.17 19:51:45 - OpenVPN > Validating certificate extended key usage
. 2020.07.17 19:51:45 - OpenVPN > ++ Certificate has EKU (str) TLS Web Server Authentication, expects TLS Web Server Authentication
. 2020.07.17 19:51:45 - OpenVPN > VERIFY EKU OK
. 2020.07.17 19:51:45 - OpenVPN > VERIFY OK: depth=0, C=IT, ST=IT, L=Perugia, O=airvpn.org, CN=Sextans, emailAddress=info@airvpn.org
. 2020.07.17 19:51:45 - OpenVPN > Control Channel: TLSv1.2, cipher TLSv1.2 DHE-RSA-AES256-GCM-SHA384, 4096 bit RSA
. 2020.07.17 19:51:45 - OpenVPN > [Sextans] Peer Connection Initiated with [AF_INET]195.206.105.205:53
. 2020.07.17 19:51:46 - OpenVPN > ifconfig: ioctl (SIOCDIFADDR): Can't assign requested address
. 2020.07.17 19:51:46 - OpenVPN > SENT CONTROL [Sextans]: 'PUSH_REQUEST' (status=1)
. 2020.07.17 19:51:46 - OpenVPN > PUSH: Received control message: 'PUSH_REPLY,comp-lzo no,redirect-gateway ipv6 def1 bypass-dhcp,dhcp-option DNS 10.17.154.1,dhcp-option DNS6 fde6:7a:7d20:d9a::1,tun-ipv6,route-gateway 10.17.154.1,topology subnet,ping 10,ping-restart 60,ifconfig-ipv6 fde6:7a:7d20:d9a::1068/64 fde6:7a:7d20:d9a::1,ifconfig 10.17.154.106 255.255.255.0,peer-id 0,cipher AES-256-GCM'
. 2020.07.17 19:51:46 - OpenVPN > Pushed option removed by filter: 'redirect-gateway ipv6 def1 bypass-dhcp'
. 2020.07.17 19:51:46 - OpenVPN > Pushed option removed by filter: 'dhcp-option DNS6 fde6:7a:7d20:d9a::1'
. 2020.07.17 19:51:46 - OpenVPN > Pushed option removed by filter: 'tun-ipv6'
. 2020.07.17 19:51:46 - OpenVPN > Pushed option removed by filter: 'ifconfig-ipv6 fde6:7a:7d20:d9a::1068/64 fde6:7a:7d20:d9a::1'
. 2020.07.17 19:51:46 - OpenVPN > OPTIONS IMPORT: timers and/or timeouts modified
. 2020.07.17 19:51:46 - OpenVPN > OPTIONS IMPORT: compression parms modified
. 2020.07.17 19:51:46 - OpenVPN > OPTIONS IMPORT: --ifconfig/up options modified
. 2020.07.17 19:51:46 - OpenVPN > OPTIONS IMPORT: route-related options modified
. 2020.07.17 19:51:46 - OpenVPN > OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified
. 2020.07.17 19:51:46 - OpenVPN > OPTIONS IMPORT: peer-id set
. 2020.07.17 19:51:46 - OpenVPN > OPTIONS IMPORT: adjusting link_mtu to 1625
. 2020.07.17 19:51:46 - OpenVPN > OPTIONS IMPORT: data channel crypto options modified
. 2020.07.17 19:51:46 - OpenVPN > Data Channel: using negotiated cipher 'AES-256-GCM'
. 2020.07.17 19:51:46 - OpenVPN > Outgoing Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key
. 2020.07.17 19:51:46 - OpenVPN > Incoming Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key
. 2020.07.17 19:51:46 - OpenVPN > ROUTE_GATEWAY 192.168.178.1/255.255.255.0 IFACE=en0 HWADDR=18:65:90:d6:c1:dd
. 2020.07.17 19:51:46 - OpenVPN > Opening utun (connect(AF_SYS_CONTROL)): Resource busy (errno=16)
. 2020.07.17 19:51:46 - Above log line repeated 1 times more
. 2020.07.17 19:51:46 - OpenVPN > Opened utun device utun2
. 2020.07.17 19:51:46 - OpenVPN > /sbin/ifconfig utun2 delete
. 2020.07.17 19:51:46 - OpenVPN > NOTE: Tried to delete pre-existing tun/tap instance -- No Problem if failure
. 2020.07.17 19:51:46 - OpenVPN > /sbin/ifconfig utun2 10.17.154.106 10.17.154.106 netmask 255.255.255.0 mtu 1500 up
. 2020.07.17 19:51:46 - OpenVPN > /sbin/route add -net 10.17.154.0 10.17.154.106 255.255.255.0
. 2020.07.17 19:51:46 - OpenVPN > add net 10.17.154.0: gateway 10.17.154.106
. 2020.07.17 19:51:46 - OpenVPN > /sbin/route add -net 195.206.105.205 192.168.178.1 255.255.255.255
. 2020.07.17 19:51:46 - OpenVPN > add net 195.206.105.205: gateway 192.168.178.1
. 2020.07.17 19:51:46 - OpenVPN > /sbin/route add -net 0.0.0.0 10.17.154.1 128.0.0.0
. 2020.07.17 19:51:46 - OpenVPN > add net 0.0.0.0: gateway 10.17.154.1
. 2020.07.17 19:51:46 - OpenVPN > /sbin/route add -net 128.0.0.0 10.17.154.1 128.0.0.0
. 2020.07.17 19:51:46 - OpenVPN > add net 128.0.0.0: gateway 10.17.154.1
. 2020.07.17 19:51:47 - DNS of a network adapter forced (Thunderbolt Bridge, from 10.11.94.1 to 10.17.154.1)
. 2020.07.17 19:51:47 - DNS of a network adapter forced (Wi-Fi, from 10.11.94.1 to 10.17.154.1)
. 2020.07.17 19:51:47 - DNS of a network adapter forced (Bluetooth PAN, from 10.11.94.1 to 10.17.154.1)
. 2020.07.17 19:51:47 - Routes, added a new route, 195.206.105.203 for gateway 10.17.154.1
. 2020.07.17 19:51:47 - Unable to compute route for 2001:ac8:28:32:c700:a8eb:c503:94c0: IPv6 VPN gateway not available.
. 2020.07.17 19:51:47 - Flushing DNS
. 2020.07.17 19:51:47 - Flush DNS via dscacheutil
. 2020.07.17 19:51:47 - Flush DNS via nDNSResponder
I 2020.07.17 19:51:48 - Checking route IPv4
I 2020.07.17 19:51:49 - Checking DNS
! 2020.07.17 19:51:49 - Connected.
. 2020.07.17 19:51:49 - OpenVPN > Initialization Sequence Completed
. 2020.07.17 19:59:45 - OpenVPN > [Sextans] Inactivity timeout (--ping-restart), restarting
. 2020.07.17 19:59:45 - OpenVPN > SIGUSR1[soft,ping-restart] received, process restarting
. 2020.07.17 19:59:45 - OpenVPN > Restart pause, 5 second(s)
! 2020.07.17 19:59:50 - Disconnecting
. 2020.07.17 19:59:50 - Routes, removed a route previously added, 195.206.105.203 for gateway 10.17.154.1
. 2020.07.17 19:59:50 - OpenVPN > TCP/UDP: Preserving recently used remote address: [AF_INET]195.206.105.205:53
. 2020.07.17 19:59:50 - OpenVPN > Socket Buffers: R=[786896->262144] S=[9216->262144]
. 2020.07.17 19:59:50 - OpenVPN > UDP link local: (not bound)
. 2020.07.17 19:59:50 - OpenVPN > UDP link remote: [AF_INET]195.206.105.205:53
. 2020.07.17 19:59:50 - OpenVPN > TLS: Initial packet from [AF_INET]195.206.105.205:53, sid=be7c0d85 46514512
. 2020.07.17 19:59:50 - OpenVPN > VERIFY OK: depth=1, C=IT, ST=IT, L=Perugia, O=airvpn.org, CN=airvpn.org CA, emailAddress=info@airvpn.org
. 2020.07.17 19:59:50 - OpenVPN > VERIFY KU OK
. 2020.07.17 19:59:50 - OpenVPN > Validating certificate extended key usage
. 2020.07.17 19:59:50 - OpenVPN > ++ Certificate has EKU (str) TLS Web Server Authentication, expects TLS Web Server Authentication
. 2020.07.17 19:59:50 - OpenVPN > VERIFY EKU OK
. 2020.07.17 19:59:50 - OpenVPN > VERIFY OK: depth=0, C=IT, ST=IT, L=Perugia, O=airvpn.org, CN=Sextans, emailAddress=info@airvpn.org
. 2020.07.17 19:59:50 - OpenVPN > Control Channel: TLSv1.2, cipher TLSv1.2 DHE-RSA-AES256-GCM-SHA384, 4096 bit RSA
. 2020.07.17 19:59:50 - OpenVPN > [Sextans] Peer Connection Initiated with [AF_INET]195.206.105.205:53
. 2020.07.17 19:59:50 - Sending soft termination signal
. 2020.07.17 19:59:51 - OpenVPN > event_wait : Interrupted system call (code=4)
. 2020.07.17 19:59:51 - OpenVPN > SIGTERM received, sending exit notification to peer
. 2020.07.17 19:59:52 - OpenVPN > SENT CONTROL [Sextans]: 'PUSH_REQUEST' (status=1)
. 2020.07.17 19:59:52 - OpenVPN > PUSH: Received control message: 'PUSH_REPLY,comp-lzo no,redirect-gateway ipv6 def1 bypass-dhcp,dhcp-option DNS 10.17.154.1,dhcp-option DNS6 fde6:7a:7d20:d9a::1,tun-ipv6,route-gateway 10.17.154.1,topology subnet,ping 10,ping-restart 60,ifconfig-ipv6 fde6:7a:7d20:d9a::1068/64 fde6:7a:7d20:d9a::1,ifconfig 10.17.154.106 255.255.255.0,peer-id 2,cipher AES-256-GCM'
. 2020.07.17 19:59:52 - OpenVPN > Pushed option removed by filter: 'redirect-gateway ipv6 def1 bypass-dhcp'
. 2020.07.17 19:59:52 - OpenVPN > Pushed option removed by filter: 'dhcp-option DNS6 fde6:7a:7d20:d9a::1'
. 2020.07.17 19:59:52 - OpenVPN > Pushed option removed by filter: 'tun-ipv6'
. 2020.07.17 19:59:52 - OpenVPN > Pushed option removed by filter: 'ifconfig-ipv6 fde6:7a:7d20:d9a::1068/64 fde6:7a:7d20:d9a::1'
. 2020.07.17 19:59:52 - OpenVPN > OPTIONS IMPORT: timers and/or timeouts modified
. 2020.07.17 19:59:52 - OpenVPN > OPTIONS IMPORT: compression parms modified
. 2020.07.17 19:59:52 - OpenVPN > OPTIONS IMPORT: --ifconfig/up options modified
. 2020.07.17 19:59:52 - OpenVPN > OPTIONS IMPORT: route-related options modified
. 2020.07.17 19:59:52 - OpenVPN > OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified
. 2020.07.17 19:59:52 - OpenVPN > OPTIONS IMPORT: peer-id set
. 2020.07.17 19:59:52 - OpenVPN > OPTIONS IMPORT: adjusting link_mtu to 1625
. 2020.07.17 19:59:52 - OpenVPN > OPTIONS IMPORT: data channel crypto options modified
. 2020.07.17 19:59:52 - OpenVPN > Data Channel: using negotiated cipher 'AES-256-GCM'
. 2020.07.17 19:59:52 - OpenVPN > Outgoing Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key
. 2020.07.17 19:59:52 - OpenVPN > Incoming Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key
. 2020.07.17 19:59:52 - OpenVPN > Preserving previous TUN/TAP instance: utun2
. 2020.07.17 19:59:52 - Routes, added a new route, 195.206.105.203 for gateway 10.17.154.1
. 2020.07.17 19:59:52 - Unable to compute route for 2001:ac8:28:32:c700:a8eb:c503:94c0: IPv6 VPN gateway not available.
. 2020.07.17 19:59:52 - Flushing DNS
. 2020.07.17 19:59:52 - Flush DNS via dscacheutil
. 2020.07.17 19:59:52 - Flush DNS via nDNSResponder
. 2020.07.17 19:59:54 - OpenVPN > Initialization Sequence Completed
. 2020.07.17 19:59:56 - OpenVPN > /sbin/route delete -net 195.206.105.205 192.168.178.1 255.255.255.255
. 2020.07.17 19:59:56 - OpenVPN > delete net 195.206.105.205: gateway 192.168.178.1
. 2020.07.17 19:59:56 - OpenVPN > /sbin/route delete -net 0.0.0.0 10.17.154.1 128.0.0.0
. 2020.07.17 19:59:56 - OpenVPN > delete net 0.0.0.0: gateway 10.17.154.1
. 2020.07.17 19:59:56 - OpenVPN > /sbin/route delete -net 128.0.0.0 10.17.154.1 128.0.0.0
. 2020.07.17 19:59:56 - OpenVPN > delete net 128.0.0.0: gateway 10.17.154.1
. 2020.07.17 19:59:56 - OpenVPN > Closing TUN/TAP interface
. 2020.07.17 19:59:56 - OpenVPN > SIGTERM[soft,exit-with-notification] received, process exiting
. 2020.07.17 19:59:56 - Connection terminated.
. 2020.07.17 19:59:56 - IPv6 restored on network adapter (Thunderbolt Bridge)
. 2020.07.17 19:59:56 - IPv6 restored on network adapter (Wi-Fi)
. 2020.07.17 19:59:56 - IPv6 restored on network adapter (Bluetooth PAN)
. 2020.07.17 19:59:56 - DNS of a network adapter restored to original settings (Thunderbolt Bridge, to 10.11.94.1)
. 2020.07.17 19:59:56 - DNS of a network adapter restored to original settings (Wi-Fi, to 10.11.94.1)
. 2020.07.17 19:59:56 - DNS of a network adapter restored to original settings (Bluetooth PAN, to 10.11.94.1)
. 2020.07.17 19:59:59 - Flushing DNS
. 2020.07.17 19:59:59 - Flush DNS via dscacheutil
. 2020.07.17 19:59:59 - Flush DNS via nDNSResponder
! 2020.07.17 19:59:59 - Session terminated.

I'm back on beta 2.19.2 for now

*edit* same thing happens now on 2.19.2 - I don't get it.. Is this a server-side issue?
*edit2* doesn't seem sever-side related - it stopped for now - strange world
. 2020.07.17 20:34:01 - OpenVPN > [Baiten] Inactivity timeout (--ping-restart), restarting
. 2020.07.17 20:34:01 - OpenVPN > SIGUSR1[soft,ping-restart] received, process restarting
. 2020.07.17 20:34:01 - OpenVPN > Restart pause, 5 second(s)
! 2020.07.17 20:34:04 - Disconnecting
. 2020.07.17 20:34:04 - Routes, removed a route previously added, 185.156.175.51 for gateway 10.11.90.1
. 2020.07.17 20:34:04 - Sending soft termination signal

Share this post


Link to post

Haven't seen it mentioned yet (I think).. Latest macOS Catalina with beta 4 here, Eddie itself is running great as usual but It seems to be somehow messing with the Mac's 'Hide' function. If I hide Eddie, it does something weird where all of the other apps that are open think they're already hidden. All the other open apps have 'Hide Appname' greyed out and its unselectable. The only option is 'Show All'. You have to click 'Show All' for it to start working right again. After that I can hide my other open apps, but Eddie will then have 'Hide Eddie' greyed out and only 'Show All' as an option. Ive just been closing the Eddie window and leaving it for now, but occasionally when I hide an app, Eddie will pop back up and stick on the screen until you 'fix' everything again or just close the window. For a while it worked perfect finally, but now its back to where if you select 'Hide Main Window' in the taskbar menu, it doesn't hide it, it minimizes the open window to the right side of the dock. Its not affection the functionality though, that part is still rock solid hehe!

Share this post


Link to post
On 7/7/2020 at 6:08 AM, Maggie144 said:

*edit2* I saw Eddie 2.19.4 still uses Hummingbird 1.0.3 - while 1.1.0 is already out. Any specific reason for this?
I was troubled with some connection errors after a while, so I copied v1.1.0 to /usr/local/bin and defined that path to Eddie, which works in this version. 

How did you do that (define the path to Eddie)? The only way I could make Eddie (gui version, 2.19.4) use Hummingbird v1.1.0 was to replace the unix executable in Eddie-->Contents-->MacOS with 1.1.0, but then I had to resign Eddie with an adhoc codesign to make the app work. I don't like doing that (unintended consequences, etc.). Your way is much cleaner.

Share this post


Link to post
21 hours ago, dedo299 said:
How did you do that (define the path to Eddie)? The only way I could make Eddie (gui version, 2.19.4) use Hummingbird v1.1.0 was to replace the unix executable in Eddie-->Contents-->MacOS with 1.1.0, but then I had to resign Eddie with an adhoc codesign to make the app work. I don't like doing that (unintended consequences, etc.). Your way is much cleaner.

In case you have not found the solution;
In Eddie's Settings -> Advanced -> Use Hummingbird [check] 
on the right side next to it, there is a path field (only on 2.19.4) free to paste the path of Hummingbird

Share this post


Link to post
33 minutes ago, Maggie144 said:

In Eddie's Settings -> Advanced -> Use Hummingbird [check] 
on the right side next to it, there is a path field (only on 2.19.4) free to paste the path of Hummingbird

Bingo! I didn't know what that field was for (he said, dumbly). At first I got the old not-owned-by-root error, but sudo chown root:wheel took care of that. Hummingbird 1.1.0 is now happily humming in Eddie 2.19.4. Thank you very much.

Share this post


Link to post

I think I'm missing something obvious, so I'm hoping someone can help me out.

I'm running Windows 10 Pro x64, and I only use the portable Eddies.

I downloaded and ran Eddie 2.19.4.  It works just fine when it's using TAP, but refuses to use my wintun adapter.

Story time:
First, I already use v2.18.9 with wintun and it works just fine.  Though, to get it to work, I had to roll my own wintun driver (used 0.8.1 files), and it'd only work with the OpenVPN 2.5 x86 files.
When 2.19.4 with wintun didn't work right away, I downloaded and tried files from both OpenVPN-2.5-rc2-I601-amd64 and x86.  Didn't work, and I keep getting this error:

. 2020.10.02 11:15:44 - OpenVPN > 2020-10-02 11:15:44 open_tun
. 2020.10.02 11:15:44 - OpenVPN > 2020-10-02 11:15:44 ERROR:  Wintun requires SYSTEM privileges and therefore should be used with interactive service. If you want to use openvpn from command line, you need to do SYSTEM elevation yourself (for example with psexec).


Never seen it before.  Never had to use psexec before either (only ever needed putty).  So a bit lost.  I tried installing OpenVPN hoping it meant I needed the OpenVPN services running, but no, same issue.

Feels like I'm missing something simple.  Am I using the wrong OpenVPN 2.5 files or missing some setting/config?

Share this post


Link to post

There are reports of the same issue here, but it doesn't look like it's been resolved.  However, I previously had wintun working fine using these instructions, so maybe you need to revert back to a previous version of either wintun or Eddie.  I went back to TAP as wintun gave me no throughput benefit and took longer to connect.

Share this post


Link to post
On 10/2/2020 at 4:14 PM, X7iGmXYQBrnz said:

There are reports of the same issue here, but it doesn't look like it's been resolved.


Hey thanks man.  I feel like I should've remembered that How-to existed.
Yeah, Clodo says it's a known incompatibility.  It should be fixed in the next beta release, but it won't be released yet because they're investigating some priority stuff for that release.  Makes sense, and I can wait since 2.18.9 works perfectly.

 
On 10/2/2020 at 4:14 PM, X7iGmXYQBrnz said:

However, I previously had wintun working fine using these instructions, so maybe you need to revert back to a previous version of either wintun or Eddie.


Yup, I still use 2.18.9 mainly.
Months ago, I followed the wintun instructions and it worked once, but I think I might have messed up my wintin driver or something.  I had to do everything all over on my own.  The wintun drivers aren't finished after all so bugs are expected.

 
On 10/2/2020 at 4:14 PM, X7iGmXYQBrnz said:

I went back to TAP as wintun gave me no throughput benefit and took longer to connect.


Yeah the throughput benefit is weird.  I seen/read some mixed results.  However, I've tested for a few months and I can say for sure it does work.

I'll find a reliable Air server (Eddie 2.19.4 seems really good at finding great servers for me :dunno:), and run tests with multiple sites.  testmy.net, dslreports.com, and fast.com, are my main sites.  If my ISP isn't being a problem, I'll see an average of +20% when using wintun.  Though, it will fluctuate during high traffic times, but it's kinda hard to tell if the issue is with Air or my ISP.  Long work hours and general priorities keep me from figuring that out anytime soon.

Oh, and the advantage pretty much disappears if you're using SSH/SSL over TCP.  Though my connection is under 100mbps so I don't know for sure.

Share this post


Link to post

Cant wait to try it here either. I get kernel panics on my Mac with the network lock when I use it with Little Snitch so Im hoping .5 'fixes' whatever Apple has done in Big Sur hehe.. Seems to connect fine, but the minute the network lock is on BOOM.

Share this post


Link to post
19 hours ago, zsam288 said:

any news on 2.19.5? As wintun is currently not working anymore with 2.19.4

Which OS are you using?. I am using Windows 10 v2004 + October update  and AirVPN v2.19.4 and the Wintun driver is working just fine for me.

Share this post


Link to post
3 hours ago, bluesjunior said:
23 hours ago, zsam288 said:

any news on 2.19.5? As wintun is currently not working anymore with 2.19.4

Which OS are you using?. I am using Windows 10 v2004 + October update  and AirVPN v2.19.4 and the Wintun driver is working just fine for me.

Problem is it doesn't work with newer versions of the 2.5.0 openvpn ; has been clarified by the dev it is only working with some betas
 
On 10/5/2020 at 7:44 PM, Clodo said:

The problem with OpenVPN2.5 rc2 (or rc1, or beta5) with Eddie is caused by recent changes in OpenVPN that produce a compatibility issue.
Please be patient, both errors above ("Object reference not set to an instance of an object." and "ERROR:  Wintun requires SYSTEM privilege") will be fixed in the next Eddie release, please wait.
We plan to release version 2.19.5 in a few days, and another one (or maybe the same) in bundle with OpenVPN 2.5 STABLE when a stable version is released.

Share this post


Link to post
20 hours ago, zsam288 said:

Problem is it doesn't work with newer versions of the 2.5.0 openvpn ; has been clarified by the dev it is only working with some betas
 
Aha, thanks for that, I visited yesterday as SUMO told me there was an OpenVPN 2.5.0 update and wanted to know if it was okay to install it. Glad I didn't now and will just wait for AirVPN v2.19.5

Share this post


Link to post

Version 2.19.5 (Wed, 04 Nov 2020 11:22:24 +0000)

  • [bugfix] Minor bugfixes
  • [bugfix] Occasionally wrong order in DNS restoring
  • [change] OpenVPN 2.5.0 - Hummingbird 1.1.0
  • [change] Minor changes

The primary objective of this version is OpenVPN 2.5.0.
Other issues are still under investigation, thx.
AUR (Arch repository) will be updated ASAP.

Share this post


Link to post

The Windows 7/8 64 bit version of Eddie 2.19.5 is still using OVPN version 2.4.8.0.  I discovered it after the wintun option didn't work.

 

















 

Share this post


Link to post

updating to new beta gave me an elevated prompted. After that the progam could not open, so i can not post any logs.

Schermafbeelding 2020-11-05 111050.png

Share this post


Link to post
19 hours ago, Staff said:

Version 2.19.5 (Wed, 04 Nov 2020 11:22:24 +0000)

  • [bugfix] Minor bugfixes
  • [bugfix] Occasionally wrong order in DNS restoring
  • [change] OpenVPN 2.5.0 - Hummingbird 1.1.0
  • [change] Minor changes

The primary objective of this version is OpenVPN 2.5.0.
Other issues are still under investigation, thx.
AUR (Arch repository) will be updated ASAP.

Working great here, stable at high speeds

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...