Jump to content
Not connected, Your IP: 18.207.106.142
Staff

Eddie 2.11beta available

Recommended Posts

Hello!

We're very glad to inform you that a new Eddie Air client version has been released: 2.11beta. This software has passed successfully internal alpha testing weeks ago, and finally passed internal beta testing now. It is ready for public beta testing and we consider it a Release Candidate of the 2.11 stable version. Anyway, remember that it's still a beta version, so if you don't feel adventurous you might like to stay with 2.10.3 (stable).
 
To download Eddie 2.11beta please select "Other versions" > "Experimental" from the download page.

 

UPDATE 30-Jan-17: version 2.11.15 stable has been released.

 

UPDATE 24-Jan-17: version 2.11.12 is available. No changes from 2.11.11, just a version revision to prepare distribution via repositories properly.
 
UPDATE 17-Jan-17: version 2.11.11beta RC8 has been released. Please see all the updates here:
https://airvpn.org/topic/18625-eddie-211beta-available/page-22?do=findComment&comment=55393

 

Changelog:
https://eddie.website/changelog/?software=client&format=html

 

 

 

The current Eddie status: a message from the chief developer

 
First of all, we apologize for the delay of this release.
 
We are working on two different versions of Eddie: 2.x and 3.x.
 
Eddie 3.x will have a new UI engine (also based on GTK+ under Linux, to drop Mono WinForms that are affected by a lot of unresolved bug) and a lot of new features. We plan to release Eddie 3.x soon, but it's not ready/stable yet, so we decided to port some of the new features back to Eddie 2.x edition. 
This was the cause of the delay: a lot of features are totally rewritten (for example the OpenVPN directives manager).
We promise that next releases and bugfixes will be faster.
 
Biggest changes in Eddie 2.11:
 
- Latest versions of OpenVPN (2.3.11) and stunnel (5.32), built with OpenSSL 1.0.2h.
- A new Network Lock method under Windows (Windows Firewall not used anymore)
- A new IPv6 lock method under Windows
- A new DNS lock method under Windows
- Built with Mono 4 under GNU/Linux
- New ports/protocols available
- DPI-Aware UI under Windows. System fonts used both in Windows and Linux.
- Various bug fixes
- And so many other internal changes and minor UI updates.
 
 
Please see the changelog:
https://airvpn.org/services/changelog.php?software=client&format=html
 

===

 
Windows users, please be aware that the new Network Lock method uses the WFP in persistent mode, so the Network Lock settings will survive even a reboot, when Network Lock is not disabled properly in Eddie. If you kill Eddie without grace, or Eddie crashes, just re-run it (even after a reboot) to cancel Network Lock. We might change this behavior according to your feedback.
 
Eddie 2.11beta for GNU Linux can be downloaded here: https://airvpn.org/linux
Eddie 2.11beta for Windows can be downloaded here: https://airvpn.org/windows
Eddie 2.11beta for OS X Mavericks, Yosemite and El Capitan only can be downloaded here: https://airvpn.org/macosx
PLEASE NOTE: Eddie 2.11.10beta package includes an OpenVPN version re-compiled by us from OpenVPN 2.4 source code with OpenSSL 1.0.2h for security reasons and to fix this bug: https://community.openvpn.net/openvpn/ticket/328

Eddie overview is available here: https://airvpn.org/software
Eddie includes a Network Lock feature: https://airvpn.org/faq/software_lock
Eddie 2.11 is free and open source software released under GPLv3. GitHub repository https://github.com/AirVPN/airvpn-client


Kind regards & datalove
AirVPN Staff

Share this post


Link to post
Posted ... (edited)

I like the sound of the new method, however when I tried to use it I couldn't see any of the servers on server list and the protocol list was empty too, when I switched it to Windows firewall it worked just fine. Loving the new UI design however.

 

EDIT: May I suggest adding in 2.11 stable or 3.X so that on server browser you can remove tabs like Score/latency/load/users as you see fit so they don't take up space if you don't use them or if pinger is disabled latency is just empty.

 

 

EDIT2: After trying the WFP network lock mode, and trying to connect to a server the client crashed with this error http://i.imgur.com/WWvOdDx.png

Edited ... by EdensSpire

Share this post


Link to post

Hi,

 

that's very good news. I have been waiting for an update of Eddie quite eagerly, especially for Linux.  

 

Currently i am on Ubuntu 16.04, and the new version works quite fine. I had to manually install stunnel4 though, otherwise the installation would not have worked.

 

I am glad that the responsiveness has improved significantly, the prior version was quite sluggish and a bit hard to use. The new interface does also look modern and neatly arranged, with a fresh look.

 

I haven't encountered any problems so far, apart from one minor bug: The number of servers displayed in the "Countries" section is not correct.

 

I have not yet tested the Windows version, so i cannot say anything regarding the problems mentioned in the threads above.

 

Regards

 

Fox

Share this post


Link to post

Is this the proper thread to report problems?

 

For now I'll write here I guess.

 

Using 2.11 in a Mint 17.3 VM on a win10 host.  The .deb installer worked smoothly.

 

First startup of the app seems a little out of sorts - says there are no servers at first.  Then it seems to behave properly.

 

I took the time to arrange the columns in the servers window but they didn't survive a reboot of the machine.  That annoyance should be fixed.

 

Appreciate very much the new ports available!

Share this post


Link to post
Hi, good news.

 

Try using 2.11beta in a Ubuntu LTS 16.04, clean install. Please, check this simple case: Setting in Preferenses-Routes-Not specified routes go - "Outside the VPN" - causes an error - "Unrecognized directive or missing parameter:"

Thanks.

Share this post


Link to post

It's working fine on Windows 10 except for the TAP driver, I had to revert to 9.9.2 again. I'm surprised nothing has been done about it yet as it's a very big issue, things like torrents are unusable with the included TAP driver.

Share this post


Link to post

Hello !

​AHA! So THATS why it's called Eddie ! Very clever Staff! Nice Easteregg, hahahahaha.

​Good work. make sure to give that Dev lots of datalove. But you know, Staff, you never specified which interfaces or ports we should forward for this Datalove you're sending, so how do we receive it?! I mean, does love come in a TCP or UDP stream for instance? zhang had advice on that. Kind regards!

​@harry987

​Did you remember to click on "Other Versions", selecting "Experimental" and then selecting the one for Win 10, after going to the download page?


Moderators do not speak on behalf of AirVPN. Only the Official Staff account does. Please also do not run Tor Exit Servers behind AirVPN, thank you.
Did you make a guide or how-to for something? Then contact me to get it listed in my new user guide's Guides Section, so that the community can find it more easily.

Share this post


Link to post

It's working fine on Windows 10 except for the TAP driver, I had to revert to 9.9.2 again. I'm surprised nothing has been done about it yet as it's a very big issue, things like torrents are unusable with the included TAP driver.

Have you tried the new one then?

 

@internet_user

That looks so sexy!


Moderators do not speak on behalf of AirVPN. Only the Official Staff account does. Please also do not run Tor Exit Servers behind AirVPN, thank you.
Did you make a guide or how-to for something? Then contact me to get it listed in my new user guide's Guides Section, so that the community can find it more easily.

Share this post


Link to post

The portable version (without installer) crashes with a different error message. Seems like it is missing something.

http://imgur.com/qu87YNi

 

Unfortunately no further logs are available I could provide.

 

Same error here, on WIN 7 x64. Does not even start...

Share this post


Link to post

Using Manjaro 64-bit, I tried upgrading mono to 4.4.0.40 and installing eddie 2.11-beta, but it didn't launch. I downgraded mono back to 4.0.4.1 and eddie 2.11-beta launched just fine. Aside from the mono problem, everything else appears to be working and the graphics look very nice, a big improvement over 2.10. I am also excited to hear about eddie 3.x 

Share this post


Link to post

I just noticed, under Settings, in the Protocol section, that I can't scroll. The list of available protocols extends beyond the box containing it, to the bottom and to the right. There are bars on the right and bottom which would normally contain a slider which you could click and drag to scroll, but there is no slider button. There are also arrows at the ends of the bars which would normally scroll when you click them but the arrows are greyed out. The only way to see more of the content in the "protocols" box, is to enlarge the entire application GUI, but even when it is full screen there are still some protocols which extend off the bottom of the screen and are not visible.

Share this post


Link to post

Just installed this one on my linux machine (opensuse leap). was not able to connect to any server, so uninstalled and reinstalled latest stable client. now i'm not able to login at all

 

 

Cannot login. ()
 

That's all the log tells me :/

Tried reboot. still same behaviour.

Feel kinda naked now :/

 

any thoughts? suggestions appreciated

Share this post


Link to post

nevermind. i deleted the .airvpn folder and relogged in successfully. seems the problem was i had to agree to the tos again, but wasn't promted. thus the error i guess.

 

to mod: either delete this and previous post or pass both for other users that might run into this sorry didn't try the above mentioned before posting at all

 

regards

Share this post


Link to post

Concerning the Windows version: Does that mean it works with all kind of firewalls, not just the built in Windows firewall?

Share this post


Link to post

The portable version seems to run flawlessly under Linux Mint 18 Cinnamon 64 bit. At least during the last few hours I've been using it.

Share this post


Link to post

Concerning the Windows version: Does that mean it works with all kind of firewalls, not just the built in Windows firewall?

 

The point was the new version is supposed to use another method and NOT the firewall meaning yes you don't need to be using the windows firewall anymore but it seems it causes crashes of the client for most of us from the looks of it

Share this post


Link to post

for me 2.11 don't works

 

UupXyu9.png

 

Fist I only installed over the old version - maybe is this the problem = I use Geek Uninstaller and removed all settings - reboot - install 2.11 - same problem

 

Win 7 x64


Was wir an Niedern rühmen als Geduld, ist blasse Feigheit in der Brust - William Shakespeare

Share this post


Link to post

for me 2.11 don't works

 

UupXyu9.png

 

Fist I only installed over the old version - maybe is this the problem = I use Geek Uninstaller and removed all settings - reboot - install 2.11 - same problem

 

Win 7 x64

 

I was told they'd start bugfixing today on the new version 

Share this post


Link to post

Hello!

 

The issues with Windows Vista/7 are under investigation as well as other ones, like the OS X missing digital signature.

In general, if we don't reply to a feedback, it's because it's under investigation.

 

 

EDIT: May I suggest adding in 2.11 stable or 3.X so that on server browser you can remove tabs like Score/latency/load/users as you see fit so they don't take up space if you don't use them or if pinger is disabled latency is just empty.

 

Acknowledged and planned, however with low priority.

 

 

The number of servers displayed in the "Countries" section is not correct.

 

 

Ok, it will be fixed in the next 2.11.x release.

 

 

It's working fine on Windows 10 except for the TAP driver, I had to revert to 9.9.2 again. I'm surprised nothing has been done about it yet as it's a very big issue, things like torrents are unusable with the included TAP driver.

 

The 9.21.2 TAP driver version will be bundled in the next 2.11.x release.

 

 

still getting the dependency issuse for the libmono file or whichever it was, using linux mint 18

 

Please provide us with more info, other people with Mint 18 don't report this issue.

 

 

Using Manjaro 64-bit, I tried upgrading mono to 4.4.0.40 and installing eddie 2.11-beta, but it didn't launch. I downgraded mono back to 4.0.4.1 and eddie 2.11-beta launched just fine.

 

We are are adding Manjaro in our testing platforms today.

On top of that, we are interested in an AUR release following guidelines for ArchLinux, with the correct packages dependencies like our .deb and .rpm package.

https://aur.archlinux.org/packages/?O=0&K=airvpn

 

You can still be the "Maintainer", we simply want to deploy a right/perfect package into AUR.

We shall investigate about this after fixes of current issues have been deployed.

 

 

I just noticed, under Settings, in the Protocol section, that I can't scroll. The list of available protocols extends beyond the box containing it, to the bottom and to the right. There are bars on the right and bottom which would normally contain a slider which you could click and drag to scroll, but there is no slider button. There are also arrows at the ends of the bars which would normally scroll when you click them but the arrows are greyed out. The only way to see more of the content in the "protocols" box, is to enlarge the entire application GUI, but even when it is full screen there are still some protocols which extend off the bottom of the screen and are not visible.

 

Did you un-check the "Automatic" checkbox?

 

Kind regards

Share this post


Link to post

Fedora 24 is still a no-go. Does not connect.

Share this post


Link to post

Hello!

 

The issues with Windows Vista/7 are under investigation as well as other ones, like the OS X missing digital signature.

In general, if we don't reply to a feedback, it's because it's under investigation.

 

 

EDIT: May I suggest adding in 2.11 stable or 3.X so that on server browser you can remove tabs like Score/latency/load/users as you see fit so they don't take up space if you don't use them or if pinger is disabled latency is just empty.

 

Acknowledged and planned, however with low priority.

 

 

>>>>

The number of servers displayed in the "Countries" section is not correct.

 

 

Ok, it will be fixed in the next 2.11.x release.

 

 

It's working fine on Windows 10 except for the TAP driver, I had to revert to 9.9.2 again. I'm surprised nothing has been done about it yet as it's a very big issue, things like torrents are unusable with the included TAP driver.

 

The 9.21.2 TAP driver version will be bundled in the next 2.11.x release.

 

 

still getting the dependency issuse for the libmono file or whichever it was, using linux mint 18

 

Please provide us with more info, other people with Mint 18 don't report this issue.

 

 

Using Manjaro 64-bit, I tried upgrading mono to 4.4.0.40 and installing eddie 2.11-beta, but it didn't launch. I downgraded mono back to 4.0.4.1 and eddie 2.11-beta launched just fine.

 

We are are adding Manjaro in our testing platforms today.

 

On top of that, we are interested in an AUR release following guidelines for ArchLinux, with the correct packages dependencies like our .deb and .rpm package.

https://aur.archlinux.org/packages/?O=0&K=airvpn

 

You can still be the "Maintainer", we simply want to deploy a right/perfect package into AUR.

We shall investigate about this after fixes of current issues have been deployed.

 

 

I just noticed, under Settings, in the Protocol section, that I can't scroll. The list of available protocols extends beyond the box containing it, to the bottom and to the right. There are bars on the right and bottom which would normally contain a slider which you could click and drag to scroll, but there is no slider button. There are also arrows at the ends of the bars which would normally scroll when you click them but the arrows are greyed out. The only way to see more of the content in the "protocols" box, is to enlarge the entire application GUI, but even when it is full screen there are still some protocols which extend off the bottom of the screen and are not visible.

 

Did you un-check the "Automatic" checkbox?

 

Kind regards

 

 

@Staff, good to hear about your interest in AirVPN AUR packages If you have any suggestions to improve the packages I maintain (airvpn-bin and airvpn-beta-bin) I would be happy to implement them. In regards to scrolling in the "protocols" window, I unchecked "automatic" and was indeed then able to scroll through the available options. I did a little more experimenting with using the most recent version of mono, and have a a little more info. to report. The specific version of Manjaro I am running, is the 64-bit Cinnamon community edition, BTW. I tried launching the 2.11 beta version of eddie from the command line, using the command "/usr/bin/airvpn" and got the following results:

 

unclehunto@COMPUTER ~:  /usr/bin/airvpn

I 2016.07.19 12:35:58 - Eddie client version: 2.11 / x64, System: Linux, Name: Manjaro Linux \r (\n) (\l) / x64

. 2016.07.19 12:35:58 - Restarting with admin privileges

unclehunto@COMPUTER ~:  ;19R

I 2016.07.19 12:35:59 - Eddie client version: 2.11 / x64, System: Linux, Name: Manjaro Linux \r (\n) (\l) / x64

. 2016.07.19 12:35:59 - Restarting with admin privileges

 

Then nothing, I had to ctrl-C to return to the bash prompt. I tried changing the launch command in the AirVPN menu button from "/usr/bin/airvpn" to "sudo /usr/bin/airvpn". This worked only if I checked "launch in terminal" which would open a terminal where I would have to enter my sudo password, then eddie would launch. The terminal window where I entered my password would of course have to remain open while eddie was running. I was not able to connect, however, because the DNS check always failed, even after I tried all of the available DNS switching methods. The logs did not seem to provide much information as to why the DNS check failed, but I have included the section of the log relevant to the DNS check:

 

. 2016.07.19 12:41:45 - Starting Management Interface

. 2016.07.19 12:41:45 - OpenVPN > Initialization Sequence Completed

I 2016.07.19 12:41:45 - /etc/resolv.conf renamed to /etc/resolv.conf.airvpn as backup

I 2016.07.19 12:41:45 - DNS of the system updated to VPN DNS (Rename method: /etc/resolv.conf generated)

. 2016.07.19 12:41:45 - Shell of 'sh','-c 'route -n -ee'' done sync in 6 ms

I 2016.07.19 12:41:45 - Flushing DNS

. 2016.07.19 12:41:45 - Shell of 'sh','-c '/etc/rc.d/init.d/nscd restart'' done sync in 5 ms

I 2016.07.19 12:41:45 - Checking route

I 2016.07.19 12:41:48 - Checking DNS

E 2016.07.19 12:41:49 - DNS checking failed.

. 2016.07.19 12:41:49 - OpenVPN > MANAGEMENT: Client connected from [AF_INET]127.0.0.1:3100

! 2016.07.19 12:41:49 - Disconnecting

. 2016.07.19 12:41:49 - Management - Send 'signal SIGTERM'

. 2016.07.19 12:41:49 - OpenVPN > MANAGEMENT: CMD 'signal SIGTERM'

. 2016.07.19 12:41:49 - OpenVPN > SIGTERM received, sending exit notification to peer

. 2016.07.19 12:41:49 - OpenVpn Management > >INFO:OpenVPN Management Interface Version 1 -- type 'help' for more info

. 2016.07.19 12:41:49 - OpenVpn Management > SUCCESS: signal SIGTERM thrown

 

A couple days ago when I was successfully testing out eddie 2.11 (using the old mono version 4.0.4.1) it was working fine for a while, but then after a while the eddie graphical interface completely froze and was unresponsive, although traffic appeared to still be flowing through the connection. I ended up restarting my computer to (ungracefully) shutdown the frozen eddie. Unfortunately I didn't have logging enabled at the time, but I have now reinstalled eddie 2.11 and turned on logging, so I will let it run for a while and see if I have the same problem again, and whether the logs capture any information relevant to said problem.

 

Keep up the good work!

-Uncle Hunto

Share this post


Link to post

very solid in mint 18. my dependency issue was due to the website not actually downloading the experimental version.

 

one odd issue though, running any kind of system update, either through GUI or command line is unbelievably slow and often times failing. attempting to connect to package database for driver manager fails every time with the prompt to "check internet connection." if i kill the vpn and deactivate network lock, it blazes though and updates without a problem. 

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...