Jump to content
Not connected, Your IP: 35.170.81.210
casting.ldp

Connection problem when not using Airvpn

Recommended Posts

I had the same problem again this evening - no Internet access without Air VPN - but at least this time I had a fair idea what to do! After a three hour session this evening, most of it with Air VPN running - I ran Windows Update before logging in - I disconnected/exited Air VPN and cleared my browser history. Before shutting down the PC, I tried to access my ISP's webmail to clear all messages, because I hadn't been able to connect to it earlier with Air VPN running. That's when I discovered that I had no Internet access! I looked at the Network Connection properties for Ethernet, Ethernet 2 (which Air VPN uses instead of Ethernet) and Wi-Fi. DHCP was enabled on all three connections, but DNS server was not set to obtain address automatically on Ethernet 2 and Wi-Fi. When I changed the settings back to obtain address automatically, Internet access was restored. It didn't take long to fix the problem this time - writing this post took longer! - but I don't know what happened to change the DNS Server option to manual. Oh well.

Share this post


Link to post

I still have the problem, I've updated my last post in this topic.

To AirVPN staff : I'm ok to share the ipconfig/all results while AirVPN is not running and disconnected (I've got it right now), but should I blur some informations before posting it here ?

Many thanks

Share this post


Link to post

Thanks, so here it is (it has been translated by Translator, because I've got a french computer, sorry about that...).

If some relevant informations are blured by mistakes or if some personnals remains just tell me, I'll edit that out :

 

Windows IP Configuration

   Hostname . . . . . . . . . . : ########
   primary DNS suffix. . . . . . :
   node type. . . . . . . . . . : Peer Peer
   enabled IP routing. . . . . . . . : No
   WINS Proxy enabled. . . . . . . . : No
   search list of the DNS suffix .: home

Ethernet Ethernet card:

   Media status. . . . . . . . . . . . : Media disconnected
   Specific DNS Suffix connection. . . : home
   Description. . . . . . . . . . . . . . Killer e2200 Gigabit Ethernet Controller
   Physical address . . . . . . . . . . . : D8-CB-8A-EE-A3-05
   DHCP enabled. . . . . . . . . . . . . . : Yes
   enabled automatic configuration. . . : Yes

wireless card Local Area Connection * 2:

   Media status. . . . . . . . . . . . : Media disconnected
   Specific DNS Suffix connection. . . :
   Description. . . . . . . . . . . . . . Microsoft Virtual Wi-Fi Direct Adapter
   Physical address . . . . . . . . . . . : 78-0C-B8-C5-51-03
   DHCP enabled. . . . . . . . . . . . . . : Yes
   enabled automatic configuration. . . : Yes

Tunnel adapter Local Area Connection:

   Specific DNS Suffix connection. . . :
   Description. . . . . . . . . . . . . . BlackBerry Virtual Private Network
   Physical address . . . . . . . . . . . : 02-60-60-97-1B-01
   DHCP enabled. . . . . . . . . . . . . . : Yes
   enabled automatic configuration. . . : Yes
   autoconfiguration of IPv4 address. . . : 169.254.###.## (preferred)
   Subnet Mask. . . . . . . . . : 255.255.0.0
   Default Gateway. . . . . . . . . :
   NetBIOS over Tcpip. . . . . . . . . . . : Enabled

Ethernet Ethernet 4:

   Media status. . . . . . . . . . . . : Media disconnected
   Specific DNS Suffix connection. . . :
   Description. . . . . . . . . . . . . . TAP-Windows Adapter V9
   Physical address . . . . . . . . . . . : 00-FF-74-9A-9D-55
   DHCP enabled. . . . . . . . . . . . . . : Yes
   enabled automatic configuration. . . : Yes

wireless Wi-Fi card:

   Specific DNS Suffix connection. . . : home
   Description. . . . . . . . . . . . . . Intel ® Dual Band Wireless-AC 3160
   Physical address . . . . . . . . . . . : 78-0C-B8-C5-51-02
   DHCP enabled. . . . . . . . . . . . . . : Yes
   enabled automatic configuration. . . : Yes
   IPv4 address. . . . . . . . . . . . . .: 192.168.###.## (preferred)
   Subnet Mask. . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . . . . . : Sunday, June 26, 2016 2:04:57 p.m.
   Lease expiring. . . . . . . . . . . . . : Monday, June 27, 2016 10:31:52 p.m.
   Default Gateway. . . . . . . . . : 192.168.1.1
   DHCP server. . . . . . . . . . . . . : 192.168.1.1
   DNS servers. . . . . . . . . . . . . : 10.4.0.1
   NetBIOS over Tcpip. . . . . . . . . . . : Enabled

Share this post


Link to post

Yaul, I keep getting the same problem after exiting from an AirVPN session, but now I know what to check, it only takes about one minute to fix. This evening, it was DNS at fault again, and I suspect that is causing your problem too. Your wireless DNS setting is 10.4.0.1, which is what I see when connected to Air VPN, and when I have no internet access when not connected to AIR VPN. After changing DNS server properties back to obtain address automatically - which restores internet access outside Air VPN - the ipconfig /all report changes to DNS Servers....192.168.0.1, which is the same as my DHCP address when enabled. It wouldn't take you long to check! There's more info from the link in my post #24.

Share this post


Link to post

Airvpn client has a few but very annoying bugs...I and a few others I kknow experienced the issue.

 

The reason you can't reconnect without Airvpn client is because your Wifi or Ethernet has been assigned a fixed IP. You have to manually reset your devices to DHCP:

 

1. Launch a command line using cmd.exe

2. type

 

netsh interface show interface
   and identify which network interface you are connected to.

 

winfix1.png

 

3. Type 

netsh interface IPv4 set dnsserver "Local Area Connection" dhcp
where "Local Area Connection" is of course to be adapted to the name of the "connected" device in previous step...

This solution worked for me. Thank you very much.

Share this post


Link to post

@simba937 has the easiest fix. However this situation can be avoided by completely exiting the vpn app, not just exiting the vpn connection but exiting the app as well                       

Share this post


Link to post

Airvpn client has a few but very annoying bugs...I and a few others I kknow experienced the issue.

 

The reason you can't reconnect without Airvpn client is because your Wifi or Ethernet has been assigned a fixed IP. You have to manually reset your devices to DHCP:

 

1. Launch a command line using cmd.exe

2. type

netsh interface show interface

   and identify which network interface you are connected to.

 

winfix1.png

 

3. Type 

netsh interface IPv4 set dnsserver "Local Area Connection" dhcp

where "Local Area Connection" is of course to be adapted to the name of the "connected" device in previous step...

 

 

Helped a lot! Thank you!

Share this post


Link to post

 

I had this same problem. Another thread posted this solution and it worked for me:

 

- Go to Control Panel
- Click Network and Internet
- Click Network and Sharing Center
- Click Change adapter settings
- Right click your network
- Click Properties
- Click Internet Protocol Version 4 (TCP/IPv4)
- Click Properties
- Select Obtain DNS server address automatically.
- Click OK
- Click Close

Thanks so much! Network Lock now works as it's suppose to. It use to only work when connected to the VPN even when Network Lock was off.

Share this post


Link to post

Anyone know how to fix this on a Mac?

Hello!

 

If you mean the thing with obtaining IPv4 automatically, then you can just go to your Mac network settings and look for similar settings.

 

It's also not a serious bug, in the sense that it's not a security problem.


Moderators do not speak on behalf of AirVPN. Only the Official Staff account does. Please also do not run Tor Exit Servers behind AirVPN, thank you.
Did you make a guide or how-to for something? Then contact me to get it listed in my new user guide's Guides Section, so that the community can find it more easily.


Tired of Windows? Why Linux Is Better.

Share this post


Link to post

If it hampers the normal operation of the computer then it's a serious bug IMO. Not in the security sense, but in the 'hey this software f**d up my computer' sense.

 

Whatever, tech support helped me and what I had to do was clear the DNS settings -- AirVPN had left the wrong DNS setting in the Network settings when the computer's power went off.

Share this post


Link to post

If it hampers the normal operation of the computer then it's a serious bug IMO. Not in the security sense, but in the 'hey this software f**d up my computer' sense.

 

Whatever, tech support helped me and what I had to do was clear the DNS settings -- AirVPN had left the wrong DNS setting in the Network settings when the computer's power went off.

 

 

 

Hi!

 

We're glad to know that the problem is solved.

 

This is not an Eddie bug and never was in OS X or macOS. In Windows, Eddie 2.10.3 or older version had a bug for which the original DNS settings of a network interface missing one or both DNS settings could be not restored under certain circumstances, but it was fixed in 2.11. When the system is shut down without closing first Eddie, or in any case when Eddie is killed without grace, it can't of course restore settings, but this not a bug (no program can do anything when killed without grace). However Eddie keeps a safety backup and it will restore such settings at the next run/shut down cycle.

 

Kind regards

Share this post


Link to post

Hi!

 

We're glad to know that the problem is solved.

 

This is not an Eddie bug and never was in OS X or macOS. In Windows, Eddie 2.10.3 or older version had a bug for which the original DNS settings of a network interface missing one or both DNS settings could be not restored under certain circumstances, but it was fixed in 2.11. When the system is shut down without closing first Eddie, or in any case when Eddie is killed without grace, it can't of course restore settings, but this not a bug (no program can do anything when killed without grace). However Eddie keeps a safety backup and it will restore such settings at the next run/shut down cycle.

 

Kind regards

 

Hi, 

 

I'm having this issue as well, except that I am using macOS High Sierra 10.13.4 with AirVPN version 2.13.6

I have tried setting Network Lock to 'None' and to 'OS X - PF' but neither has allowed me to connect to the internet unless I am connected to AirVPN.

Also, I did search on the issue and this was the article that came up, but please point me in the right direction if I'm using the wrong forum/thread, etc.

 

Thanks!

Share this post


Link to post

 

Hi!

 

We're glad to know that the problem is solved.

 

This is not an Eddie bug and never was in OS X or macOS. In Windows, Eddie 2.10.3 or older version had a bug for which the original DNS settings of a network interface missing one or both DNS settings could be not restored under certain circumstances, but it was fixed in 2.11. When the system is shut down without closing first Eddie, or in any case when Eddie is killed without grace, it can't of course restore settings, but this not a bug (no program can do anything when killed without grace). However Eddie keeps a safety backup and it will restore such settings at the next run/shut down cycle.

 

Kind regards

 

Hi, 

 

I'm having this issue as well, except that I am using macOS High Sierra 10.13.4 with AirVPN version 2.13.6

I have tried setting Network Lock to 'None' and to 'OS X - PF' but neither has allowed me to connect to the internet unless I am connected to AirVPN.

Also, I did search on the issue and this was the article that came up, but please point me in the right direction if I'm using the wrong forum/thread, etc.

 

Thanks!

Hi,

 

I have a Mac Mini running as a headless server with a static IP. I have the above problem, as it will disconnect all network connections once Eddie looses connection. I have network lock off, and tried to do a fresh install to no avail. 

 

I have Eddie running at all times, but it frequently looses connection and gets stuck trying to reconnect. Therefore i cannot log on to the server with VNC and my entire server is out of function. This is very frustrating.

 

Can someone please help us out? 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...