Jump to content
Not connected, Your IP: 3.90.56.90
casting.ldp

Connection problem when not using Airvpn

Recommended Posts

Hey I just started using Airvpn a week ago and it works fine when the program is open but when I disconnect I can't connect to my network regularly. I only get internet access when Airvpn is connected. Is this an ISP problem or something on my end? Thanks

Share this post


Link to post

Do you have network lock on by chance? (It's in Preferences -> Advanced -> Network Lock). With the feature enabled, all internet access must be tunnelled through the VPN, and if the VPN is off, you can't access the internet. 

Share this post


Link to post

I have exactly the same issue. No connection when AirVPN is not running. I never used NetLock, but it was set  to "automatic" in the settings. I changed it to "none" and the issue persists. Any help with that would be appreciated...

Share this post


Link to post
Guest Chaf

Airvpn client has a few but very annoying bugs...I and a few others I kknow experienced the issue.

 

The reason you can't reconnect without Airvpn client is because your Wifi or Ethernet has been assigned a fixed IP. You have to manually reset your devices to DHCP:

 

1. Launch a command line using cmd.exe

2. type

netsh interface show interface

   and identify which network interface you are connected to.

 

winfix1.png

 

3. Type 

netsh interface IPv4 set dnsserver "Local Area Connection" dhcp

where "Local Area Connection" is of course to be adapted to the name of the "connected" device in previous step...

Share this post


Link to post

In windows re-set the DNS to auto in the IPv4 settings in your network adaptor

 

How about telling us how to do that?

 

wow, stupid AirVPN completely ruined my internet connection. How come there's no information about this?

Share this post


Link to post

My system is Windows 7 64bit

 

In AirVPN Preferences> Advanced I have enabled all the Windows only options.

 

In this case,if you do not close down AirVPN correctly, but crash out of it for some reason, I find you cannot then connect to the internet. I presume this is because DHCP has not been reset to normal by the client.

 

Restarting AirVPN client and then exiting correctly resolves the matter

Share this post


Link to post

go to network and sharing centre-change adaptor settings-right click over the adaptor you use regularly-properties-scroll down to Internet Protocol version 4-click on it so it highlights-properties again-then make sure obtain dns server address automatically is ticked in the bottom menu.

 

This issue will not arise if you disconnect from the vpn completely before shutting down your pc

 

Share this post


Link to post

So I have been having these issues, and the above fix using the command prompt fixed it, but that no longer remedies the case.  I checked the DNS server setting for IPv4, and it is set to automatic; however, the internet will still only function when connected to the VPN now, and never otherwise.  Is there anything else that might have been broken?

 

Am using Win 7 Ultimate.  Any advice helps, thanks.

Share this post


Link to post

So apparently mine went crazy.  My fixes were as follows, uninstalled Airvpn (because it continually failed authorizations), reset my DHCP, and went into Windows Firewall and reset it to default (this seemed to be what was causing it, as network lock was playing around with it).  After that, I was able to surf the net normally. Then reinstalled AirVPN, and now it seems to be functioning as intended.

Share this post


Link to post

I to have been having the same problems as described above. After following the instructions I've managed to get my internet going again when not connected to the VPN. Does anyone know if this problem with occur again once I start using the VPN again?

Share this post


Link to post

So apparently mine went crazy.  My fixes were as follows, uninstalled Airvpn (because it continually failed authorizations), reset my DHCP, and went into Windows Firewall and reset it to default (this seemed to be what was causing it, as network lock was playing around with it).  After that, I was able to surf the net normally. Then reinstalled AirVPN, and now it seems to be functioning as intended.

 

This sorted mine.  The firewwall bit specifically. 

 

Please can Staff comment on this please?  I would like to switch between Airvpn Network Lock effectively as even when connected on a home country VPN, some websites are not liking my IP address?

 

Thanks in advance 

Share this post


Link to post

I had this same problem. Another thread posted this solution and it worked for me:

 

- Go to Control Panel
- Click Network and Internet
- Click Network and Sharing Center
- Click Change adapter settings
- Right click your network
- Click Properties
- Click Internet Protocol Version 4 (TCP/IPv4)
- Click Properties
- Select Obtain DNS server address automatically.
- Click OK
- Click Close

Share this post


Link to post

I had to deal with the same issue on Win 7 64bit.

Here's how I've fixed it :

 

1. Uninstall AirVPN client

2. Reset Windows firewall to its default settings

3. Reboot

4. Reinstall AirVPN client

 

Now everything is working fine.

Share this post


Link to post

Good lord, this killed my internet. Completely forgot I even used AirVPN.

 

It crashed one day so I guess that's when it started. But setting the DNS to automatic in the network properties fixed it.

 

Thank you so much for asking the question.

 

I'm on Windows 10. I could have saved so much time.

 

I hope this check can be implemented into the program.

Share this post


Link to post

go to network and sharing centre-change adaptor settings-right click over the adaptor you use regularly-properties-scroll down to Internet Protocol version 4-click on it so it highlights-properties again-then make sure obtain dns server address automatically is ticked in the bottom menu.

 

This issue will not arise if you disconnect from the vpn completely before shutting down your pc

 

 

That is not exactly true.  I've been using AirVPN for over a year, know how to disconnect from the VPN and I began having this exact same problem just recently.  I DO close down AirVPN "completely"  And I always check my IPV4 settings afterwards to make sure they are back to automatically assigning DNS etc.   I always release the network lock, then exit AirVPN as usual.

But as of right now I cannot connect to the internet unless the VPN is activated despite Windows (W7 64 bit)  telling me that my LAN connection is working as it should.  As soon as I activate AirVPN it begins working again.  There is some sort of bug.

Share this post


Link to post

I had to deal with the same issue on Win 7 64bit.

Here's how I've fixed it :

 

1. Uninstall AirVPN client

2. Reset Windows firewall to its default settings

3. Reboot

4. Reinstall AirVPN client

 

Now everything is working fine.

Thank you!   This fixes the issue for me.  The problem was apparently with Windows FIrewall hanging.  Now my connection is back to working both wit and without AirVPN. 

Share this post


Link to post

I joined Air VPN (for 12 months) yesterday, and installed it on two Dell PCs, both running Windows 8.1. It's still working OK on the other PC, but this one has developed the "no internet connection without Air VPN" fault. The only "unusual" event I can recall is that Air VPN was blocking a restart for Windows Update, so I had to cancel the restart, exit Air VPN (disconnect, then exit), then restart. (I later installed the same update on the second PC - exiting Air VPN before running Windows Update! - and there were no problems.)
 
I've tried all the solutions mentioned in this topic:
 
- setting DCHP on connected devices
- setting  IPv4 to obtain DNS server address automatically
- uninstalling Air VPN, setting Windows Firewall to defaults, rebooting and reinstalling Air VPN
 
I've also run Windows Diagnostics, and rebooted my router. No help.
 
It's no real hardship working with Air VPN "always on". I'd planned to try to do that anyway, although I would prefer to have the choice! The Air VPN speeds are excellent, and seem much better than I was getting from HMA VPN (which I've left two months before my current subscription expires. Yes, I uninstalled their software!). But I'd be grateful if anyone can think of another likely solution.

 
Using Snipping Tool, I was able to paste relevant screen grabs into my Word copy, but I can't work out how to get them into this post, so I'll describe them:

 

- netsh showed two connected devices: Ethernet 2 and Wi-Fi. A third device - Ethernet - was shown as disconnected.

 

- Network Connections showed Wi-Fi as OK, Ethernet as "Network cable unplugged" and Ethernet 2 as "Unidentified network, TAP-Windows Adapter V9". With Air VPN off, Ethernet 2 shows as "Network cable unplugged".

Share this post


Link to post

I've got the exact same problem of after_lunch :

- I'm using the AirVPN client for Windows 10 64 bit

- Old user of HMA (I don't think this is related to the problem but why not ?) HMA client uninstalled of course.

- DHCP trick mentionned above done.

- Uninstalled AirVPN and uncheck the autolock, reset the firewall, reboot, reinstall AirVPN (so, the lock shouldn't be there anymore, because of the reset of the firewall and I didn't launch back the network lock)

- I've been advised to change the DNS to Google's DNS, didn't change anything, went back to the automatic DNS option.

- Tried to disable my security software + the windows firewall.

 

The problem is I can't connect to my university Wi-Fi with AirVPN, and without internet don't work...

 

EDIT : I didn't see the post about the ipconfig/all results, should I "blur" some informations that figure in it before posting it here ? (like my ip, or other stuff ?)

EDIT 2 : My ipconfig/all result is in french, any way to display it in english? I think it will be easier for the staff to read it

EDIT 3 : All my devices are DHCP Enabled

Edited by Yaul

Share this post


Link to post

I have the details as plain text in a Notepad file. I don't know what I'm doing wrong, but I cannot copy and paste them into this post. I can't even copy and paste text within this post - I can only cut it! What works on other forums doesn't seem to work here. Can someone please help a newbie!!!?

 

UPDATE: I subsequently discovered that my inability to "copy and paste" in this topic was due to Internet Explorer (my default browser at the time was IE11). I've now changed my default browser to Firefox, which cured the "copy and paste" problem, and a few others!

Share this post


Link to post

After half a glass of sherry, half a Terry's Chocolate orange, and half of Tetsuo: The Iron Man, I remembered that in the output from ipconfig /all, several devices were shown as "DHCP Enabled.......No". I googled some DHCP help on my other PC [http://www.computerhope.com/issues/ch001048.htm - address typed here by hand, still can't paste!], then enabled DHCP on Wi-Fi and Ethernet 2. It worked: although Air VPN was not running on this PC, Internet access was restored immediately. Of course, this may only be a temporary cure, which the next Air VPN connect/disconnect will ruin. But perhaps it will help Yaul until a permanent solution is found!

Share this post


Link to post

Looks like the problem was DHCP all along. I switched the PC back on at 7 p.m., and had internet access straight away, without Air VPN. I logged in to  Air VPN, did an hour's work, and exited, and I still had internet access. So why didn't Chaf's command line fix work for me? Two possible reasons: I did it for Ethernet 2 but not for Wi-Fi; I did it when still logged in to Air VPN. So the only remaining mystery is why I can't paste content in these posts! I wonder whether it might be tied in with the 5 post probation for newbies. I need one more post before I can test that!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...