Jump to content
Not connected, Your IP: 54.87.61.215

Recommended Posts

I haven't used this to watch content from another country, nor tried - I've only used this to be able to watch netflix while using AirVPN for all my other traffic.

Rabbit.it - host a private room (or let everyone in, that's up to use). Netflix works fine this way.

Share this post


Link to post

Hello!

 

That's a really ingenious solution!

 

On top of that, you can now access Netflix USA from all Air VPN servers except UK servers, provided that you use VPN DNS. Can you please test?

 

Kind regards

Share this post


Link to post

We are told that Netfilx USA can be accessed provided that you use VPN DNS.

 

I have searched the AIRVPN site, but have not been able to find out how to set this up in Android with OpenVPN.

 

I have tried different config files, but without success. I am uneducated in the science of VPNs and would like to know how do we set this up in Android.

 

This may be a dumb question, but I am lost.

Share this post


Link to post

Hello!

 

In Android, "OpenVPN for Android" and "openvpn-connect", as well as Eddie Android edition, are configured by default to accept the DNS push from the server, so the device will use VPN DNS. However it remains to be seen whether the Netflix application will bypass maliciously the system settings to send queries directly to a specific DNS and prevent the usage. We will investigate.

 

Kind regards

Share this post


Link to post

I'm using eddie for android and accessing Netflix US works great with Airvpn US servers, and just a note with BBC Iplayer Asterope server works 100%

 

 

Cheers

Thanks for your input.

I tried Eddie for Android with a config file for AirVPN US servers, and I could see the Netflix US content, but it wouldn't play because it said I was using a blocker or proxy. Maybe I'm doing the config file incorrectly.  I can also see the Netflix US content when I use the OpenVPN Client, but it won't play.

Share this post


Link to post

 

Rabbit.it - host a private room (or let everyone in, that's up to use). Netflix works fine this way.

 

This link leads to an Italian site about rabbits - quite nice, but I think you meant https://www.rabb.it/.

 

 

A site about rabbits is fantastic, too bad i can't read italian.

Share this post


Link to post

Hello!

 

On top of that, you can now access Netflix USA from all Air VPN servers except UK servers, provided that you use VPN DNS. Can you please test?

 

 

I just tried connecting to the “north America” pool and Netflix still blocks me. I’m based in North America, so works without VPN. I am using the VPN DNS.

Share this post


Link to post

I have been doing some experimenting, and Netflix American content works with AirVPN ok on my Android tablets, and on my Windows 10 computer, but it does not work ok on my Android TV boxes. On the boxes, when I am connected to an AirVPN server, I can see the Netflix American content listings, but when I try to play something, I am blocked, saying I am using an unblocker or proxy. It seems odd that the problem is only on the Android TV boxes. I am using the same config files on both the tablets and the TV boxes.

Share this post


Link to post

I have been doing some experimenting, and Netflix American content works with AirVPN ok on my Android tablets, and on my Windows 10 computer, but it does not work ok on my Android TV boxes. On the boxes, when I am connected to an AirVPN server, I can see the Netflix American content listings, but when I try to play something, I am blocked, saying I am using an unblocker or proxy. It seems odd that the problem is only on the Android TV boxes. I am using the same config files on both the tablets and the TV boxes.

 

It works for my Shield (android) TV as I route it through a VPN tunnel on my pfsense box.  How is your VPN for Android TV setup? 

 

I think what happens is that Android TV allows apps to "hardcode" DNS (google), which means they'll use google DNS along with the DHCP DNS.

 

I think that's what trips alarms.  So, you must actively block any DNS other than AirVPN.

 

However, even though I actively block any other DNS my roku ultra Netflix was able to determine I'm on a VPN.  So, maybe they have other tricks.

Share this post


Link to post

So.... to add some useful information. On my GNU/Linux server I set up a complex system: briefly, AirVPN is always on but it's only used for torrenting, because I configured iptables and iprouting in such a way that, if a TCP/IP packet doesn't come from or to the process owned by the deluge user, it's processed by the common eth0 interface and therefore it uses my public common IP.

 

This means that, while browsing, I use my common IP. Nonetheless, since a few days Netflix (Italy) does not work if my tun0 interface is up and, precisely, it does not load the webpage at all. Odd enough, because Netflix should not be able to know that I'm using AirVPN, since AirVPN is not used for browsing and it's excluded from common Internet purposes other than torrenting.

 

Therefore, I suspect that some script from Netflix inspects the network interfaces active on the computer, regardless of the connection, and refuses to load if it finds VPN interfaces. This or some other wizardry by Netflix coders.

 

Anyway, it would be great if you could solve the issue. I wouldn't like to give up watching Netflix by my browser kiosk and be obliged to buy a Fire TV or some other device

 

Inviato dal mio BLA-L29 utilizzando Tapatalk

Share this post


Link to post

 

I have been doing some experimenting, and Netflix American content works with AirVPN ok on my Android tablets, and on my Windows 10 computer, but it does not work ok on my Android TV boxes. On the boxes, when I am connected to an AirVPN server, I can see the Netflix American content listings, but when I try to play something, I am blocked, saying I am using an unblocker or proxy. It seems odd that the problem is only on the Android TV boxes. I am using the same config files on both the tablets and the TV boxes.

 

It works for my Shield (android) TV as I route it through a VPN tunnel on my pfsense box.  How is your VPN for Android TV setup? 

 

I think what happens is that Android TV allows apps to "hardcode" DNS (google), which means they'll use google DNS along with the DHCP DNS.

 

I think that's what trips alarms.  So, you must actively block any DNS other than AirVPN.

 

However, even though I actively block any other DNS my roku ultra Netflix was able to determine I'm on a VPN.  So, maybe they have other tricks.

On Android I am using an AirVPN generated script with the OpenVPN Client Free on my tablets and my TV boxes, but Netflix only works on the tablets, even though the VPN is set up the same on all  of those devices. Strange behaviour. If as sarum4n says, Netflix has a script to detect network interfaces, then what is different between the tablets and the TV boxes. I am at a loss.

Share this post


Link to post

 

 

I have been doing some experimenting, and Netflix American content works with AirVPN ok on my Android tablets, and on my Windows 10 computer, but it does not work ok on my Android TV boxes. On the boxes, when I am connected to an AirVPN server, I can see the Netflix American content listings, but when I try to play something, I am blocked, saying I am using an unblocker or proxy. It seems odd that the problem is only on the Android TV boxes. I am using the same config files on both the tablets and the TV boxes.

 

It works for my Shield (android) TV as I route it through a VPN tunnel on my pfsense box.  How is your VPN for Android TV setup? 

 

I think what happens is that Android TV allows apps to "hardcode" DNS (google), which means they'll use google DNS along with the DHCP DNS.

 

I think that's what trips alarms.  So, you must actively block any DNS other than AirVPN.

 

However, even though I actively block any other DNS my roku ultra Netflix was able to determine I'm on a VPN.  So, maybe they have other tricks.

On Android I am using an AirVPN generated script with the OpenVPN Client Free on my tablets and my TV boxes, but Netflix only works on the tablets, even though the VPN is set up the same on all  of those devices. Strange behaviour. If as sarum4n says, Netflix has a script to detect network interfaces, then what is different between the tablets and the TV boxes. I am at a loss.

 

Well, I'm not surprised that Android TV behavior is different from Android tablet.  It could still be the DNS problem as I hypothesized. 

Share this post


Link to post

I tried to set up the DNS using a primary DNS 10.4.0.1 and secondary DNS 0.0.0.0 and adapting the instructions on this site:

https://www.cactusvpn.com/tutorials/how-to-set-up-smart-dns-on-android-tv-box/

My WIFI still worked but when I tried to connect to an AirVPN server, the openVPN client could not resolve the host. This web site might be on the right track, but I am just not using the right numbers.

Share this post


Link to post

I tried to set up the DNS using a primary DNS 10.4.0.1 and secondary DNS 0.0.0.0 and adapting the instructions on this site:

https://www.cactusvpn.com/tutorials/how-to-set-up-smart-dns-on-android-tv-box/

My WIFI still worked but when I tried to connect to an AirVPN server, the openVPN client could not resolve the host. This web site might be on the right track, but I am just not using the right numbers.

 

Change your openvpn configs to use resolved hosts, not domain name.  Thus, no need to resolve the host to connect to VPN server.  If you can just edit your config all you have to do is change from domain name to IP address.

 

Pick your favorite server and resolve it.   For example, nslookup ran.airservers.org = 199.249.230.26

Share this post


Link to post

 

I tried to set up the DNS using a primary DNS 10.4.0.1 and secondary DNS 0.0.0.0 and adapting the instructions on this site:

https://www.cactusvpn.com/tutorials/how-to-set-up-smart-dns-on-android-tv-box/

My WIFI still worked but when I tried to connect to an AirVPN server, the openVPN client could not resolve the host. This web site might be on the right track, but I am just not using the right numbers.

Change your openvpn configs to use resolved hosts, not domain name.  Thus, no need to resolve the host to connect to VPN server.  If you can just edit your config all you have to do is change from domain name to IP address.

 

Pick your favorite server and resolve it.   For example, nslookup ran.airservers.org = 199.249.230.26

Thanks for the advice, but when I try to edit the config in the OpenVPN Client, I don't see anything that remotely looks to me what you are suggesting. I've also tried to edit the config in a text editor, and still don't see an option like that. For now if I want to watch Netflix USA on the TV I will have to hook up my laptop using a HDMI cable. Not convenient, but it works. 

Share this post


Link to post

Holy shit it works hahaha! Im on Merope and watching Real Genius as I type!! YAAAAAAAS! No more having to switch to my TV app to watch it haha.

Can you give a step by step of what you did?

Share this post


Link to post

 

 

I tried to set up the DNS using a primary DNS 10.4.0.1 and secondary DNS 0.0.0.0 and adapting the instructions on this site:

https://www.cactusvpn.com/tutorials/how-to-set-up-smart-dns-on-android-tv-box/

My WIFI still worked but when I tried to connect to an AirVPN server, the openVPN client could not resolve the host. This web site might be on the right track, but I am just not using the right numbers.

Change your openvpn configs to use resolved hosts, not domain name.  Thus, no need to resolve the host to connect to VPN server.  If you can just edit your config all you have to do is change from domain name to IP address.

 

Pick your favorite server and resolve it.   For example, nslookup ran.airservers.org = 199.249.230.26

Thanks for the advice, but when I try to edit the config in the OpenVPN Client, I don't see anything that remotely looks to me what you are suggesting. I've also tried to edit the config in a text editor, and still don't see an option like that. For now if I want to watch Netflix USA on the TV I will have to hook up my laptop using a HDMI cable. Not convenient, but it works. 

 

 

If you can't do it by just editing the config, then generate a new config using advanced mode and select "resolved hosts in .ovpn file" to the right side of the screen under the Advanced header.

Share this post


Link to post

 

 

 

I tried to set up the DNS using a primary DNS 10.4.0.1 and secondary DNS 0.0.0.0 and adapting the instructions on this site:

https://www.cactusvpn.com/tutorials/how-to-set-up-smart-dns-on-android-tv-box/

My WIFI still worked but when I tried to connect to an AirVPN server, the openVPN client could not resolve the host. This web site might be on the right track, but I am just not using the right numbers.

Change your openvpn configs to use resolved hosts, not domain name.  Thus, no need to resolve the host to connect to VPN server.  If you can just edit your config all you have to do is change from domain name to IP address.

 

Pick your favorite server and resolve it.   For example, nslookup ran.airservers.org = 199.249.230.26

Thanks for the advice, but when I try to edit the config in the OpenVPN Client, I don't see anything that remotely looks to me what you are suggesting. I've also tried to edit the config in a text editor, and still don't see an option like that. For now if I want to watch Netflix USA on the TV I will have to hook up my laptop using a HDMI cable. Not convenient, but it works. 

 

 

If you can't do it by just editing the config, then generate a new config using advanced mode and select "resolved hosts in .ovpn file" to the right side of the screen under the Advanced header.

Thanks again for trying to help. I did what you suggested, but Netflix still would not play any content.

Share this post


Link to post

Thanks again for trying to help. I did what you suggested, but Netflix still would not play any content.

 

Hello!

 

Please do not hesitate to report the server names from which you can't access Netflix USA.

 

IMPORTANT: you can't access Netflix USA from UK servers. We left them outside the geo-routing because they could access Netflix UK, at least up to a week ago.

 

Kind regards

Share this post


Link to post

 

Thanks again for trying to help. I did what you suggested, but Netflix still would not play any content.

 

Hello!

 

Please do not hesitate to report the server names from which you can't access Netflix USA.

 

IMPORTANT: you can't access Netflix USA from UK servers. We left them outside the geo-routing because they could access Netflix UK, at least up to a week ago.

 

Kind regards

Hello,

I have tried servers in the USA, Canada and the Netherlands. I have tried specific servers in Toronto, Los Angeles and Chicago, but I didn't write down which ones I used. I have used 4 config files which would randomly pick a server and they are for Canada, USA, Netherlands and America. On all of them I could access Netflix USA and see the selection of titles available, but Netflix would not allow me to play any of the content because I was using an unblocker or proxy. This is occurring only on my Android TV boxes. My Android tablets and Windows PCs are working well with Netflix USA on any server that I have tried so far.

 

Hope this helps.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...