Jump to content


Photo

Latest Windows 10 Build breaks OpenVPN TAP Driver?


Best Answer Staff, 16 November 2015 - 02:00 PM

Hello!

 

We confirm issues related to Windows 10 latest build (13-14 Nov 2015) and tun/tap driver installation.

 

On all of our tested systems we managed to solve the problem in this way:

  • make sure that Eddie client is not running
  • remove tun/tap driver via Control Panel
  • reboot the system (mandatory)
  • re-install tun/tap driver

Kind regards

Go to the full post


  • This topic is locked This topic is locked
24 replies to this topic

#21 francisuk1989

francisuk1989

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 09 April 2016 - 07:45 PM

I have just done a fresh install of build on x64, So far no issues, Speed is great but i only have a 50Mb DL / 3Mb UL cable line.

 

I have downloaded openvpn from https://openvpn.net/index.php/open-source/downloads.html choosing Vista or later

 

Now i went to Client area > Config Genertor

 

Selected Windows > by continents (recommended) Europe for me) and downloaded them all in a zip file

 

Went to C:\Program Files\OpenVPN\config (Yes even for 64bit) and copy and pasted my .ovpn files

 

Right clicked on OpenVPN in the taskbar and connected to a server

 

Happy days.



#22 Flx11

Flx11

    Advanced Member

  • Members2
  • PipPipPip
  • 47 posts

Posted 12 April 2016 - 09:27 PM

I have to do this every time i start up my computer.
It's becomming very very annoying!

Is there no permanent fix?

 

 

1)This small batch file(see below) will ensure that the TAP-adapter will not disconnect.
---------------------------------dhcp.tap.adapter.bat-------------------------------------------
@ECHO OFF
:LOOP
ECHO Waiting for 300 seconds....
timeout /t 300
netsh interface ip set address tapadapter DHCP
netsh interface ip set address tapadapter DHCP
netsh int ip set dns name = "tapadapter" source = dhcp
ipconfig /all
GOTO LOOP
---------------------------------dhcp.tap-adapter.bat-------------------------------------------

2)After the connection has been established to AirVPN(UDP/TCP or OpenVPN over SSL/SSH) run the above file dhcp.tap.adapter.bat.
Run as Admin if elevation is required.
Regards,
Flex



#23 thetechdude

thetechdude

    Member

  • Members
  • PipPip
  • 19 posts

Posted 16 June 2016 - 12:05 AM

For whatever reason it seems that the tap kills my AirVPN connection when I torrent sometimes; my data transfers torrent or otherwise slow to under 1bs and then cease, but does not disconnect.  I have the most recent version of Viscosity with the recommended Windows 10 tap. It's not a server issue because I can re-connect right away every time. Perhaps it's UDP flooding?  I've heard that downgrading the TAP won't do anything on Windows 10.



#24 an4rew

an4rew

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 07 July 2016 - 07:29 AM

I have a strange problem with OpenVpn, it says i'm connected properly to a dutch server and seems like i have a dutch ip but i cant access any sites blocked by my isp here in the uk.

When i use the AirVPN client i can.



#25 blackmatt

blackmatt

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 09 August 2016 - 08:12 PM

OK, I just upgraded my 32bit Win7 system to 64bit Win10 (fresh install) and I'm now getting a disconnect every time I try to run eMule. 

 

I've tried removing the TAP drivers in device manager and then letting the client reinstall them but the problem remains the same.

 

Basically, I can log in to AirVPN with the client and then connect to a recommended server.  The connection seems to stay stable with light surfing.  I've left the machine idle for up to an hour and the connections holds.

 

However, as soon as I start eMule and start to transfer files I get a 'Disconnecting' notification.

The client tries to reconnect to another server, I get the 'Connecting to xxxxxxxxxx' notification.

Then I get a notification 'Authorization check failed, continue anyway' notification.

It then appears to connect to another server but there's no data transfer, I then usually get another diconnect .....  ad-infinitum.

 

If I try to logout generally nothing happens.  If I close the client then it appears to close OK but then my main internet connection is non-functional and I have to reboot my machine to get connectivity back.

 

I did have issues with the client and Win7 but changing the TAP drivers to older ones worked in that case.

 

I saved the log file, here's a relevant (I think) part:

 

! 2016.08.09 20:49:57 - Connected.
. 2016.08.09 20:49:57 - OpenVPN > MANAGEMENT: Client connected from [AF_INET]127.0.0.1:3100
. 2016.08.09 20:49:57 - OpenVpn Management > >INFO:OpenVPN Management Interface Version 1 -- type 'help' for more info
. 2016.08.09 20:53:27 - OpenVPN > [server] Inactivity timeout (--ping-restart), restarting
. 2016.08.09 20:53:27 - OpenVPN > SIGUSR1[soft,ping-restart] received, process restarting
. 2016.08.09 20:53:27 - OpenVPN > Restart pause, 2 second(s)
! 2016.08.09 20:53:27 - Disconnecting
. 2016.08.09 20:53:27 - Management - Send 'signal SIGTERM'
. 2016.08.09 20:53:27 - OpenVPN > MANAGEMENT: CMD 'signal SIGTERM'
. 2016.08.09 20:53:27 - OpenVPN > MANAGEMENT: Client disconnected
. 2016.08.09 20:53:27 - OpenVPN > Assertion failed at misc.c:779
. 2016.08.09 20:53:27 - OpenVPN > Exiting due to fatal error
. 2016.08.09 20:53:27 - OpenVpn Management > SUCCESS: signal SIGTERM thrown
. 2016.08.09 20:53:27 - OpenVpn Management > >FATAL:Assertion failed at misc.c:779
. 2016.08.09 20:53:27 - Connection terminated.
I 2016.08.09 20:53:27 - DNS of a network adapter restored to original settings (Broadcom NetXtreme 57xx Gigabit Controller)
I 2016.08.09 20:53:27 - DNS of a network adapter restored to original settings (TAP-Windows Adapter V9)
I 2016.08.09 20:53:30 - Checking authorization ...
W 2016.08.09 20:54:11 - Authorization check failed, continue anyway ({1])

 

 

Any ideas?







Similar Topics Collapse

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

Servers online. Online Sessions: 13809 - BW: 44998 Mbit/sYour IP: 34.229.175.129Guest Access.