Jump to content
Not connected, Your IP: 52.90.49.108
Staff

Eddie Desktop 2.21 beta released

Recommended Posts

18 hours ago, Maggie144 said:

It runs fine on macOS Catalina 10.15.7, especially thankful that the "refresh connection list, ping"-button it's now working properly and fast.
Previous version would result in the ping-stats being left blank.
Hummingbird is lightning fast, it only has some hickups while "checking dns" this can sometimes take a felt eternity while a few tries are being done before it disconnects finally and I have to chose another server.
Running Hummingbird alone in the Terminal does not have this problem.
Is it safe to disable "check AirVPN DNS" in settings?


We just re-tested under macOS Catalina with or without Hummingbird, in our labs "Checking DNS" step are performed in a fraction of second... 
you can post here the "Logs -> Lifebelt" report? Only the first part until (and include) the paragraph "Important options not at defaults"? Thanks

Someone else have hickups in "Checking DNS" step under macOS? Thanks

Share this post


Link to post
Posted ... (edited)

Suggestion: Implement a system where all warnings, errors and messages that say "contact eddie staff" are logged separately. These might be considered "fatal" or "critical" errors (along with 'warnings'). It may also be worth considering an OPT-IN telemetry system, where I can review the data being sent and click a button to send that to AirVPN automatically. I think there's a lot of room to capture errors you're not hearing about to improve eddie stability. Not everyone is going to come onto a forum, register an account, provide detailed logs and engage with the devs, this software should be smart enough to present issues to the user (which it does) and get that to the devs in an error report (with OS version etc)

My crashing error for example would really benefit.

 

Edited ... by airvpnforumuser

Share this post


Link to post
1 hour ago, Clodo said:

@koob
Not sure how you reach the WireGuard error, WireGuard is implemented but only for selected beta-tester for the moment.
You find "WireGuard" in "Protocol" section, OR you see the tab "Providers"?

Just encountered while doing apt get upgrade on Debian and this showed in the log file .

Share this post


Link to post
18 hours ago, puff-m-d said:

Hello,

I am having one issue with this new beta version. When I boot my system (with Eddie set to start with system), I now get an UAC prompt from Windows for Eddie-UI.exe that I must confirm. I have not seen this since the Eddie-Service-Elevated.exe was added to the Eddie package and Eddie-UI.exe was rewritten several versions back.

I did a complete removal of Eddie (including profile and tunnel drivers), then did a fresh install leaving all settings at default. I still get an UAC prompt for Eddie-UI.exe from Windows at boot that must be confirmed.

This seems to be a bug but of course there is always the possibility that I may be doing something wrong.

Windows 10 Pro 64-bit Version 21H1 (OS Build 19043.1110)


Mmmm
Try to launch, confirm prompt UAC, Preferences -> General check "Don't ask elevation every run", EXIT Eddie.
Now, with Eddie closed, Windows -> Services , "Eddie Elevation Service" is running ? If yes, relaunch Eddie, ask again UAC? Thanks

Share this post


Link to post

I installed the beta on top of 2.20 on 64bit 21H1, and I started getting Wireguard error where it automatically started connecting with WireGuard and failing over and over again without me changing any option. Changing protocol settings in the menu also didn't last but was always reset to Automatic. Once I removed Eddie, rebooted and installed the beta again it connected normally without trying to use WireGuard.

Share this post


Link to post

Hello @Clodo,
 

2 hours ago, Clodo said:

Try to launch, confirm prompt UAC, Preferences -> General check "Don't ask elevation every run", EXIT Eddie.

Confirmed, "Don't ask elevation every run" is checked.
2 hours ago, Clodo said:

Now, with Eddie closed, Windows -> Services , "Eddie Elevation Service" is running ?

Yes.
2 hours ago, Clodo said:

If yes, relaunch Eddie, ask again UAC?

No, an UAC prompt does not appear.

The strange thing is that I only get an UAC prompt from Windows on boot if I have Eddie set to "Start with System". Any manual start of Eddie never produces an UAC prompt...

I hope that this helps...

Share this post


Link to post

here is the debug log for macOS 10.15.7 DNS hick-up.
The first two tries are when Eddie is being started while wlan is off, the third try is when wlan is on while Eddie was started (only 10s wait-time compared to the first 2 tries) strange..

The "refresh connection list, ping"-button is only working in the beginning. When Eddie is running for a while it results in an empty Latency column.

eddie_2021-07-26.log

Share this post


Link to post
Posted ... (edited)

Here is my error I was describing earlier, after a cold boot (PC was off for several hours)

F - Unexpected crash of elevated helper:An existing connection was forcibly closed by the remote host814642687_eddieerror.PNG.ad8a0876e61ae1874c9b9c4fe7e9ddf0.PNG


I can also +1 the bug @puff-m-d is facing, I get the same errors (sometimes) with regards to UAC being weird.

Edited ... by airvpnforumuser

Share this post


Link to post
11 hours ago, Clodo said:

After the testing, our Config Generator will be able to create WireGuard .conf file, usable without Eddie (wg / wg-quick or any official WireGuard app).
Awesome work, thank you! :)

Share this post


Link to post
On 7/22/2021 at 10:53 PM, iwih2gk said:

Then I went back to Eddie 2.20 and see the debian version is recognized as 11.

. 2021.07.22 20:05:49 - Cannot retrieve information about AirVPN: Object reference not set to an instance of an object
 


"Object reference not set to an instance of an object" is a generic error.
In this case, occur because 2.21 update your profile, and when you return to 2.20 stable, 2.20 can't read it.
This will be fixed soon, in the mean-time, delete your profile file to avoid this error.
 
On 7/22/2021 at 10:53 PM, iwih2gk said:

******************** ps - I forgot to watch the apt-get closely and was wondering if 2.21 called some debian updates at the same time.  Does 2.21 add extra files to the OS or not?
 


No.


Also, you have IPv6 disabled as os-level, that cause an issue in the 2.21beta that prevent connection.
Please wait, we will release a new version in a few days that fix also this issue.

Share this post


Link to post
21 hours ago, puff-m-d said:

Hello @Clodo,
 

Confirmed, "Don't ask elevation every run" is checked. Yes. No, an UAC prompt does not appear.

The strange thing is that I only get an UAC prompt from Windows on boot if I have Eddie set to "Start with System". Any manual start of Eddie never produces an UAC prompt...

I hope that this helps...

Thanks. Probably Eddie UI start BEFORE the service, and try to relaunch. I'm investigating this issue, i hope a fix in the next release in few days. Thanks again.

Share this post


Link to post
8 hours ago, Clodo said:

"Object reference not set to an instance of an object" is a generic error.
In this case, occur because 2.21 update your profile, and when you return to 2.20 stable, 2.20 can't read it.
This will be fixed soon, in the mean-time, delete your profile file to avoid this error.
 
No.


Also, you have IPv6 disabled as os-level, that cause an issue in the 2.21beta that prevent connection.
Please wait, we will release a new version in a few days that fix also this issue.


Yep.  Still "old school" running the OS with IPv6 prevented at system boot.  For sure no leaks on "6" that way, LOL!

I appreciate the follow through on your part.  I could not figure out what I might do to correct it.  I am in no hurry and have gone back to 2.20 running Bullseye.  Slick as hell.  Like the 5.0 + image/kernel on Bullseye.  Several pieces of software unrelated to AirVpn are running much better on Bullseye.

Share this post


Link to post

WireGuard support is welcomed, but how will the privacy issues of the WG server daemon be handled, namely, the static assignment of internal IP addresses? Will AirVPN use a dynamic WG https://git.zx2c4.com/wg-dynamic/about/docs/idea.md? If not, how is AirVPN able to offer similar level of privacy for customers using WireGuard as for those using OpenVPN?
How about obfuscation of WireGuard packets? Are you planning to include a self-made patch to hide the usage of WireGuard or do you trust to SSH and TLS tunneling?

Share this post


Link to post

Hello,

staff offered me to share any bugs in this thread.

I just wanted to let you know that no connection is possible if IPv6 is disabled system-wide. Although i set "Ipv6 layer" to "Block" in the Eddie client, the connection still fails.

I reverted to v2.20.0 for now.

Here is my full log from Eddie, "Lifebelt" - Icon

Thank you!

Regards

BB

Eddie System/Environment Report - 7/27/2021 - 5:34 PM UTC
 
Eddie version: 2.21.0beta
Eddie OS build: linux_x64
Eddie architecture: x64
OS type: Linux
OS name: Unknown
OS version: Linux RYZEN 5.11.0-25-generic #27-Ubuntu SMP Fri Jul 9 23:06:29 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
OS architecture: x64
Mono /.Net Framework: 6.12.0.122 (tarball Mon Feb 22 17:33:28 UTC 2021); Framework: v4.0.30319
TUN driver: /dev/net/tun
OpenVPN: 2.5.3 - OpenSSL 1.1.1j  16 Feb 2021, LZO 2.10 (/usr/local/sbin/openvpn)
Hummingbird:  ()
WireGuard: 1.0.0
SSH: OpenSSH_8.4p1 Ubuntu-5ubuntu1, OpenSSL 1.1.1j  16 Feb 2021 (/usr/bin/ssh)
SSL: stunnel 5.56 (/usr/bin/stunnel4)
curl: 7.74.0 (/usr/bin/curl)
Profile path: /home/b0t0x/.config/eddie/default.profile
Data path: /home/b0t0x/.config/eddie
Application path: /usr/lib/eddie-ui
Executable path: /usr/lib/eddie-ui/eddie-ui.exe
Command line arguments: (2 args) path.resources="/usr/share/eddie-ui" path.exec="/usr/bin/eddie-ui"
Network Lock Active: No
Connected to VPN: No
Detected DNS: 127.0.0.53
Test DNS IPv4: Ok
Test DNS IPv6: Failed
Test Ping IPv4: 31 ms
Test Ping IPv6: Failed
Test HTTP IPv4: Ok
Test HTTP IPv6: Error: curl: (7) Couldn't connect to server
Test HTTPS: Ok
----------------------------
Important options not at defaults:
 
login: (omissis)
password: (omissis)
remember: True
key: (omissis)
updater.channel: beta
areas.blacklist: us,de,ca,se,ua,ee,sg,jp,nz,lv,br
mode.type: openvpn
mode.protocol: UDP
mode.port: 1194
mode.alt: 2
netlock.mode: linux_iptables
netlock.allow_private: False
netlock.allow_dhcp: False
network.entry.iplayer: ipv4-only
network.ipv6.mode: block
openvpn.custom: mssfix 1400
reneg-sec 1800
openvpn.sndbuf: 524288
openvpn.rcvbuf: 524288
advanced.expert: True
advanced.manifest.refresh: 10
gui.notifications: False
 
----------------------------
Logs:
 
. 2021.07.27 19:33:45 - Eddie version: 2.21.0beta / linux_x64, System: Linux, Name: Unknown, Version: Linux RYZEN 5.11.0-25-generic #27-Ubuntu SMP Fri Jul 9 23:06:29 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux, Mono/.Net: 6.12.0.122 (tarball Mon Feb 22 17:33:28 UTC 2021); Framework: v4.0.30319
. 2021.07.27 19:33:45 - Command line arguments (2): path.resources="/usr/share/eddie-ui" path.exec="/usr/bin/eddie-ui"
. 2021.07.27 19:33:45 - Raise system privileges
. 2021.07.27 19:33:52 - Reading options from /home/b0t0x/.config/eddie/default.profile
. 2021.07.27 19:33:53 - Tun Driver - /dev/net/tun
. 2021.07.27 19:33:53 - OpenVPN - Version: 2.5.3 - OpenSSL 1.1.1j  16 Feb 2021, LZO 2.10 (/usr/local/sbin/openvpn)
. 2021.07.27 19:33:53 - SSH - Version: OpenSSH_8.4p1 Ubuntu-5ubuntu1, OpenSSL 1.1.1j  16 Feb 2021 (/usr/bin/ssh)
. 2021.07.27 19:33:53 - SSL - Version: stunnel 5.56 (/usr/bin/stunnel4)
. 2021.07.27 19:33:53 - curl - Version: 7.74.0 (/usr/bin/curl)
I 2021.07.27 19:33:54 - Ready
. 2021.07.27 19:33:55 - Collect information about AirVPN completed
I 2021.07.27 19:34:35 - Session starting.
I 2021.07.27 19:34:35 - Checking authorization ...
! 2021.07.27 19:34:36 - Connecting to Alzirr (Netherlands, Alblasserdam)
. 2021.07.27 19:34:36 - Routes, add 213.152.187.207/32 for interface "enp3s0".
. 2021.07.27 19:34:36 - Routes, add 213.152.187.207/32 for interface "enp3s0", already exists.
. 2021.07.27 19:34:36 - OpenVPN > OpenVPN 2.5.3 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD] built on Jul  4 2021
. 2021.07.27 19:34:36 - OpenVPN > library versions: OpenSSL 1.1.1j  16 Feb 2021, LZO 2.10
. 2021.07.27 19:34:36 - OpenVPN > Outgoing Control Channel Encryption: Cipher 'AES-256-CTR' initialized with 256 bit key
. 2021.07.27 19:34:36 - OpenVPN > Outgoing Control Channel Encryption: Using 256 bit message hash 'SHA256' for HMAC authentication
. 2021.07.27 19:34:36 - OpenVPN > Incoming Control Channel Encryption: Cipher 'AES-256-CTR' initialized with 256 bit key
. 2021.07.27 19:34:36 - OpenVPN > Incoming Control Channel Encryption: Using 256 bit message hash 'SHA256' for HMAC authentication
. 2021.07.27 19:34:36 - OpenVPN > TCP/UDP: Preserving recently used remote address: [AF_INET]213.152.187.207:1194
. 2021.07.27 19:34:36 - OpenVPN > Socket Buffers: R=[212992->425984] S=[212992->425984]
. 2021.07.27 19:34:36 - OpenVPN > UDP link local: (not bound)
. 2021.07.27 19:34:36 - OpenVPN > UDP link remote: [AF_INET]213.152.187.207:1194
. 2021.07.27 19:34:36 - OpenVPN > TLS: Initial packet from [AF_INET]213.152.187.207:1194, sid=6099ec9c d6432d02
. 2021.07.27 19:34:36 - OpenVPN > VERIFY OK: depth=1, C=IT, ST=IT, L=Perugia, O=airvpn.org, CN=airvpn.org CA, emailAddress=info@airvpn.org
. 2021.07.27 19:34:36 - OpenVPN > VERIFY KU OK
. 2021.07.27 19:34:36 - OpenVPN > Validating certificate extended key usage
. 2021.07.27 19:34:36 - OpenVPN > ++ Certificate has EKU (str) TLS Web Server Authentication, expects TLS Web Server Authentication
. 2021.07.27 19:34:36 - OpenVPN > VERIFY EKU OK
. 2021.07.27 19:34:36 - OpenVPN > VERIFY OK: depth=0, C=IT, ST=IT, L=Perugia, O=airvpn.org, CN=Alzirr, emailAddress=info@airvpn.org
. 2021.07.27 19:34:36 - OpenVPN > Control Channel: TLSv1.3, cipher TLSv1.3 TLS_CHACHA20_POLY1305_SHA256, peer certificate: 4096 bit RSA, signature: RSA-SHA512
. 2021.07.27 19:34:36 - OpenVPN > [Alzirr] Peer Connection Initiated with [AF_INET]213.152.187.207:1194
. 2021.07.27 19:34:36 - OpenVPN > PUSH: Received control message: 'PUSH_REPLY,comp-lzo no,redirect-gateway ipv6 def1 bypass-dhcp,dhcp-option DNS 10.8.194.1,dhcp-option DNS6 fde6:7a:7d20:4c2::1,tun-ipv6,route-gateway 10.8.194.1,topology subnet,ping 10,ping-restart 60,ifconfig-ipv6 fde6:7a:7d20:4c2::1077/64 fde6:7a:7d20:4c2::1,ifconfig 10.8.194.121 255.255.255.0,peer-id 5,cipher AES-256-GCM'
. 2021.07.27 19:34:36 - OpenVPN > Pushed option removed by filter: 'redirect-gateway ipv6 def1 bypass-dhcp'
. 2021.07.27 19:34:36 - OpenVPN > Pushed option removed by filter: 'dhcp-option DNS 10.8.194.1'
. 2021.07.27 19:34:36 - OpenVPN > Pushed option removed by filter: 'dhcp-option DNS6 fde6:7a:7d20:4c2::1'
. 2021.07.27 19:34:36 - OpenVPN > Pushed option removed by filter: 'tun-ipv6'
. 2021.07.27 19:34:36 - OpenVPN > Pushed option removed by filter: 'ifconfig-ipv6 fde6:7a:7d20:4c2::1077/64 fde6:7a:7d20:4c2::1'
. 2021.07.27 19:34:36 - OpenVPN > OPTIONS IMPORT: timers and/or timeouts modified
. 2021.07.27 19:34:36 - OpenVPN > OPTIONS IMPORT: compression parms modified
. 2021.07.27 19:34:36 - OpenVPN > OPTIONS IMPORT: --ifconfig/up options modified
. 2021.07.27 19:34:36 - OpenVPN > OPTIONS IMPORT: route-related options modified
. 2021.07.27 19:34:36 - OpenVPN > OPTIONS IMPORT: peer-id set
. 2021.07.27 19:34:36 - OpenVPN > OPTIONS IMPORT: adjusting link_mtu to 1625
. 2021.07.27 19:34:36 - OpenVPN > OPTIONS IMPORT: data channel crypto options modified
. 2021.07.27 19:34:36 - OpenVPN > Data Channel: using negotiated cipher 'AES-256-GCM'
. 2021.07.27 19:34:36 - OpenVPN > Outgoing Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key
. 2021.07.27 19:34:36 - OpenVPN > Incoming Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key
. 2021.07.27 19:34:36 - OpenVPN > TUN/TAP device tun0 opened
. 2021.07.27 19:34:36 - OpenVPN > net_iface_mtu_set: mtu 1500 for tun0
. 2021.07.27 19:34:36 - OpenVPN > net_iface_up: set tun0 up
. 2021.07.27 19:34:36 - OpenVPN > net_addr_v4_add: 10.8.194.121/24 dev tun0
. 2021.07.27 19:34:41 - OpenVPN > Initialization Sequence Completed
. 2021.07.27 19:34:42 - DNS of the system updated to VPN DNS (Rename method: /etc/resolv.conf generated)
. 2021.07.27 19:34:42 - Routes, add 0.0.0.0/1 for interface "tun0".
. 2021.07.27 19:34:42 - Routes, add 128.0.0.0/1 for interface "tun0".
. 2021.07.27 19:34:42 - Routes, add 213.152.187.205/32 for interface "tun0".
W 2021.07.27 19:34:42 - Routes, add 2a00:1678:1337:7a20:5bfe:98a:a67c:3dd3/128 for interface "tun0" failed: Exception: exit:2; err:RTNETLINK answers: Operation not supported
! 2021.07.27 19:34:42 - Disconnecting
. 2021.07.27 19:34:42 - Sending soft termination signal
. 2021.07.27 19:34:42 - OpenVPN > event_wait : Interrupted system call (code=4)
. 2021.07.27 19:34:42 - OpenVPN > SIGTERM received, sending exit notification to peer
. 2021.07.27 19:34:47 - OpenVPN > Closing TUN/TAP interface
. 2021.07.27 19:34:47 - OpenVPN > net_addr_v4_del: 10.8.194.121 dev tun0
. 2021.07.27 19:34:47 - OpenVPN > SIGTERM[soft,exit-with-notification] received, process exiting
. 2021.07.27 19:34:47 - Routes, delete 0.0.0.0/1 for interface "tun0", not exists.
. 2021.07.27 19:34:47 - Routes, delete 128.0.0.0/1 for interface "tun0", not exists.
. 2021.07.27 19:34:47 - Routes, delete 213.152.187.207/32 for interface "enp3s0".
. 2021.07.27 19:34:47 - Routes, delete 213.152.187.205/32 for interface "tun0", not exists.
. 2021.07.27 19:34:47 - Routes, delete 2a00:1678:1337:7a20:5bfe:98a:a67c:3dd3/128 for interface "tun0", not exists.
. 2021.07.27 19:34:47 - Routes, delete 213.152.187.207/32 for interface "enp3s0", not exists.
. 2021.07.27 19:34:47 - DNS of the system restored to original settings (Rename method)
. 2021.07.27 19:34:47 - Connection terminated.
I 2021.07.27 19:34:49 - Cancel requested.
! 2021.07.27 19:34:49 - Session terminated.
 
----------------------------
Network Interfaces and Routes:
 
{
    "support_ipv4": true,
    "support_ipv6": false,
    "routes": [
        {
            "destination": "0.0.0.0\/0",
            "gateway": "192.168.0.1",
            "interface": "enp3s0",
            "metric": "100",
            "proto": "dhcp"
        },
        {
            "destination": "169.254.0.0\/16",
            "interface": "enp3s0",
            "metric": "1000",
            "scope": "link"
        },
        {
            "destination": "192.168.0.0\/24",
            "interface": "enp3s0",
            "metric": "100",
            "proto": "kernel",
            "scope": "link",
            "src": "192.168.0.115"
        }
    ],
    "ipv4-default-gateway": "192.168.0.1",
    "ipv4-default-interface": "enp3s0",
    "interfaces": [
        {
            "friendly": "lo",
            "id": "lo",
            "name": "lo",
            "description": "lo",
            "type": "Loopback",
            "status": "Unknown",
            "bytes_received": "135692",
            "bytes_sent": "135692",
            "support_ipv4": true,
            "support_ipv6": false,
            "ips": [
                "127.0.0.1"
            ],
            "bind": true
        },
        {
            "friendly": "enp3s0",
            "id": "enp3s0",
            "name": "enp3s0",
            "description": "enp3s0",
            "type": "Ethernet",
            "status": "Up",
            "bytes_received": "92216249",
            "bytes_sent": "3377401",
            "support_ipv4": true,
            "support_ipv6": false,
            "ips": [
                "192.168.0.115"
            ],
            "bind": true
        }
    ]
}
----------------------------
ip addr show:
 
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
2: enp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether b4:2e:99:95:97:ab brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.115/24 brd 192.168.0.255 scope global dynamic noprefixroute enp3s0
       valid_lft 603016sec preferred_lft 603016sec
----------------------------
ip link show:
 
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT group default qlen 1000
    link/ether b4:2e:99:95:97:ab brd ff:ff:ff:ff:ff:ff

 

 


AMD Ryzen 3950X @ 105W PPL

Gigabyte X570 Aorus Elite

AMD RX 5700 XT

Corsair DDR4-3200 32GB

 

Share this post


Link to post
On 7/28/2021 at 6:37 PM, BlueBanana said:

I just wanted to let you know that no connection is possible if IPv6 is disabled system-wide. Although i set "Ipv6 layer" to "Block" in the Eddie client, the connection still fails.


Yes, is a bug in this version, will be fixed in the next release.

To all: i wrote some posts ago that a new version will be released in a few days: sorry but we discovered an issue that requires time, a new beta version is expected to be released in mid-August. Please have patience, and revert to stable version in the meantime. Thanks.

Share this post


Link to post

I'm already running wireguard client on my pfsense box to another VPN provider.  If you need anybody to be testing from that environment give me a shout.

Share this post


Link to post

Hello, 
I'm running
Edition    Windows 10 Pro
Version    20H2
Installed on    ‎15/‎02/‎2021
OS build    19042.1110
Experience    Windows Feature Experience Pack 120.2212.3530.0
Upon upgrading to the new beta version, my IPv4 address was exposed. After disconnecting, I couldn't get Eddie to connect again. The logfile is attached.
Fortunately, downgrading to Eddie 2.20.0 appears to have solved the problem.
Another problem I would appreciate help with is that after using Eddie's network lock feature, my box will not connect without Eddie installed, running and connected.

Thank you

Eddie_20210804_073600.txt

Share this post


Link to post

Hi volkhart,
the problem seems to be a filtering rule in the windows firewall.
"W 2021.08.04 07:35:43 - Windows WFP, unexpected: Rule 'dns_block_all' already exists
! 2021.08.04 07:35:43 - Disconnecting"


Greets
kiwi

Share this post


Link to post
16 hours ago, kiwi said:

Hi volkhart,
the problem seems to be a filtering rule in the windows firewall.
"W 2021.08.04 07:35:43 - Windows WFP, unexpected: Rule 'dns_block_all' already exists
! 2021.08.04 07:35:43 - Disconnecting"


Greets
kiwi

Thank you. That might explain why I could not connect again. But I am still at a loss how this setting came to be after Version 2.21 had already been running. And how was the problem solved when I downgraded back to Version 2.20? And why was my provider's IPv4 address exposed under Version 2.21 in the first place?

Share this post


Link to post

Having a weird issue using Hummingbird 1.1.2 with the new Eddie, that happened once in a blue moon in the last version too but not as bad as it is now.. This is still all on the latest Big Sur.. 
Seems like when my internet connection really gets going, say downloading a public torrent that will come in at like 30MiB/s, Hummingbird starts making the Mac's Notifications start freaking out. 
Yesterday while downloading something, internet kicked up to 30MiB/s in QBitTorrent (300 mbits in Eddie's meter), and just a flood of errors while transferring about no buffer space being available. Was about to blame QBitTorrent, but it also happens in good old Safari, or even copying something directly from my Mac to my NAS drive over the local 192.x.x.x network. The minute the connection gets 'up to speed' it will start spitting out those errors, I had over 200 in the few minutes it took to download a torrent yesterday. The files and everything are coming through ok, but those notices just keep popping up every few seconds on the Mac when it happens and my Notification Center is constantly popping up while Im trying to do something else

Turned off Hummingbird last night and not a single issue since. Looks like my log file was wiped when I reconnected but if you need the exact error, I can always recheck Hummingbird and all I need to do is download something that will really kick up my bandwidth and the errors will start flooding in if you need it. This has happened occasionally with Hummingbird, although its way more often now to the point its frustrating when the flood of notifications won't stop. Before this it was manageable and only happened once in awhile.

Share this post


Link to post
@Monotremata

Hello!

Yes, please send us (in a ticket maybe, because this thread is for Eddie) the complete Eddie log (Eddie log will include any log by Hummingbird) pertaining to the event. From your description it definitely sounds like some unexpected OpenVPN3-AirVPN library problem. Do you connect in TCP or UDP?

Kind regards
 

Share this post


Link to post
On 8/10/2021 at 3:45 AM, Staff said:
@Monotremata

Hello!

Yes, please send us (in a ticket maybe, because this thread is for Eddie) the complete Eddie log (Eddie log will include any log by Hummingbird) pertaining to the event. From your description it definitely sounds like some unexpected OpenVPN3-AirVPN library problem. Do you connect in TCP or UDP?

Kind regards
 

I leave it on the default so it connects over UDP every time. Ill grab a log and everything for a ticket. It shouldn't be too hard to make it happen I just need to copy a big file like a movie or something over to my NAS and it should start popping up pretty quickly.

Share this post


Link to post

Version 2.21.1 (Thu, 19 Aug 2021 12:19:20 +0000)

  • [change] [windows] OpenVPN 2.5.3 also in Windows 7/8
  • [change] [linux] Removed "libappindicator1" dependency in .deb package
  • [bugfix] [linux] Fixed an issue with portable/AppImage packages ('cannot open shared object file')
  • [bugfix] [windows] Fixed Windows 7 issues
  • [bugfix] [all] Fixed an issue when IPv6 is disabled at system level
  • [bugfix] [windows] Updated libcurl
  • [change] [all] New ping engine


Windows users: now if Wintun is used (default from this version), a network adapter is created when session starts and destroyed when session ends.
Wintun driver is installed (or upgraded) when the adapter is created and removed when the adapter is removed.
We added an option to keep the adapter in Preferences->Advanced window.

Windows/Linux/macOS: we rewrote the latency/ping system to make it work better and faster, resolve some UI issues in Linux and provide more accurate results in macOS.

@airvpnforumuser and other: issues after system suspension, and the error "Windows WFP, unexpected: Rule 'ipv6_block_all' already exists" is still under investigation, it is our next priority.

About Windows OS compatibility: Windows 8 works exactly like Windows 10.  In Windows 7 the latest Wintun driver doesn't work for some currently unknown reason, so it is not used (OpenVPN works with the tapdriver6), and for the same reason Wireguard (which can use ONLY Wintun) will not be supported on Win7.

Kind regards and datalove

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...