Jump to content
Not connected, Your IP: 35.173.57.84
ueYgswKJ

Eddie Version 2.18.6 always crashes on start / macOS 10.14.6

Recommended Posts

Just upgraded from 2.18.5 to 2.18.6
Always fails to start. 
- "Raise system privileges" windows appears.
- I enter computer password
- "Collecting Network information"
- Crash

- Tried a couple of times, also restarted the computer.
- Installed 2.18.5 again. Now crashing on launch as well.
- Uninstalled everything with iTrash (cleaning some preferences & other data)
- Installed 2.18.6 again to try if it works now with cleaned up system. Doesn't work, crash again.
- Uninstalled with iTrash, and installed 2.18.5 again. This works now

Crashlog attached.
 

eddie crash.txt

Share this post


Link to post

Unfortunately, we can't reproduce the issue right now to fix it.
It's not the first time users report this kind of error, for example here .
I honestly don't think it's a problem of Eddie version, something changed if you have now a working 2.18.5.
It's something specific to special permission, the main error is ''NSInvalidArgumentException', reason: 'launch path not accessible''.

Two questions:
1- You installed in path "/Applications/Eddie.localized/Eddie.app". Did you manually build that path (the .localized part) or was it automatic?
2- If you download 2.18.6, put in another folder (like documents or Download itself) and launch it, does it throw the same error? 

Thanks for any help, this is an old issue, it occurs sporadically, and we need to understand how to reproduce it to fix it.
 

Share this post


Link to post

Dear Clodo,
thanks for reaching out. And sorry for the late reply, i was travelling.

About your questions:
1- it was automatic
2- i didn't test now, because i just saw 2.18.7 was out — I installed that version (with the package installer, as i always do) and it works perfectly. So i assume the bug was fixed in the meantime. I get back to you if the crash happens in a future version again.

Also feel free to write again if i should test something.

Share this post


Link to post

mine is not starting either
iMac running 10.13.6
Does Eddie update automatically?

EDIT:  Actually I think I just didn't see the request for my password - nevermind!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...