Jump to content
Not connected, Your IP: 3.231.229.89
Staff

Eddie Desktop 2.18beta released

Recommended Posts

On 9/12/2019 at 9:06 AM, Clodo said:

 

  Correct, now UI is totally separated from an executable/daemon (launchd) that performs elevated actions.
With launchd daemon, it's not expected anymore the prompt every time.
Please report any issue.

 

Well, I just found out the beta was updated about 5 minutes ago so I just barely updated to it.. For beta 1 though, after almost a week or so, I dont even notice Eddie running at all. It just WORKS and stays out of the way and never bothers me. I had it randomly disconnect Saturday night on its own for whatever reason but eh, I jumped right back on and it was fine. Just finished installing the beta and getting connected, launchd is working perfect, I didnt even get asked for my password and here I am typing. 

Share this post


Link to post
I am running Windows 8.1.  When I try to connect to a server Eddie tries to install TAP driver 9.23.3.  The installation always fails with an error message.  I did see a  message once that the driver was signed by Microsoft for some versions of Windows, but not the version I am using.  I see on the Openvpn site that they have different download versions to address this problem.  I believe a version of the driver signed for Windows 8.1 is needed.


















 

Share this post


Link to post
19 hours ago, amateur25 said:
I am running Windows 8.1.  When I try to connect to a server Eddie tries to install TAP driver 9.23.3.  The installation always fails with an error message.  I did see a  message once that the driver was signed by Microsoft for some versions of Windows, but not the version I am using.  I see on the Openvpn site that they have different download versions to address this problem.  I believe a version of the driver signed for Windows 8.1 is needed.

For Windows 8.1 I'd recommend staying with the latest stable version of Eddie (2.16.3) and the older TAP driver 9.21.2; even the old beta client (2.17.2) had issues on one of my Windows 8.1 desktops.
















 

Share this post


Link to post
On 9/18/2019 at 5:22 AM, amateur25 said:
I am running Windows 8.1.  When I try to connect to a server Eddie tries to install TAP driver 9.23.3.  The installation always fails with an error message.  I did see a  message once that the driver was signed by Microsoft for some versions of Windows, but not the version I am using.  I see on the Openvpn site that they have different download versions to address this problem.  I believe a version of the driver signed for Windows 8.1 is needed.

@monstrocity and @amateur25

Confirmed,  the "Windows 10/8.1/8" download doesn't work on Win 8, it fails to install TAP driver 9.23.3.
The "Windows 7" download works as expected on Win 8. Please try this version.
If it works, fine.  We will switch the version label when 2.18 becomes stable.

To everybody else: we are working on every feedback, we expect to release a new beta version as soon as possible.


 

Share this post


Link to post

1. openvpn via ssl doesnt work at all, ssh works fine.  connecting to server => disconnecting => fatal error =>  same again

2.  getting aead decrypt errors bad packet id very very very freguently and logs say it repeated more than 60000 times , i used udp port 443

3.  where is source code for the latest build? its most damn important question.

Share this post


Link to post
10 hours ago, ozzie said:

1. openvpn via ssl doesnt work at all, ssh works fine.  connecting to server => disconnecting => fatal error =>  same again

What OS (Win7? Win10? Linux/macOS)?
10 hours ago, ozzie said:

2.  getting aead decrypt errors bad packet id very very very freguently and logs say it repeated more than 60000 times , i used udp port 443

Please post a full log. Open a ticket if you don't want to post here, thx.
10 hours ago, ozzie said:

3.  where is source code for the latest build? its most damn important question.

Source code will be released as soon as possible, for sure when we release a stable version (outside this beta-test).

Share this post


Link to post

On openSUSE 15.1 I already had eddie crash a few times on flushing dns.
Can't do anything anymore, just Ctrl-Alt-Backspace.
and then a restart.

can't find much in the log file?

. 2019.09.19 11:51:14 - Routes, added a new route, 213,152,162,165 for gateway 10.8.250.1
. 2019.09.19 11:51:14 - Routes, added a new route, 2a00: 1678: 2470: 16: 2536: 2634: 117a: ef44 for gateway fde6: 7a: 7d20: 4fa :: 1
. 2019.09.19 11:51:14 - Flushing DNS
. 2019.09.19 11:57:24 - Received signal SIGHUP
. 2019.09.19 11:57:24 - Received signal SIGTERM

Share this post


Link to post

Network lock not working on debian buster

Hi,
On debian 10 (buster), when starting eddie or trying to activate network lock, I get the following error:
Exception: ip6tables don't reply, probabily kernel modules issue
I get a similar error on my laptop, which has the same operating system.
Thus I am unable to activate the network lock.
Version 2.17 was working fine, hence I assume that this is not a kernel modues issue .-).

On the other hand, there is a minor issue with KDE: when the eddie window is active, the KDE applications menu stops reacting to the mouse on that desktop. But when the eddie window is inactive or minimized, the applications menu works as usual.

Otherwise, eddie connects and works fine.

. 2019.09.19 19:01:16 - Eddie version: 2.18.2beta / linux_x64, System: Linux, Name: Debian GNU/Linux 10 \n \l, Version: Linux debian-desktop 4.19.0-6-amd64 #1 SMP Debian 4.19.67-2 (2019-08-28) x86_64 GNU/Linux, Mono/.Net: 5.18.0.240 (Debian 5.18.0.240+dfsg-3 Wed Apr 17 16:37:36 UTC 2019); Framework: v4.0.30319
. 2019.09.19 19:01:16 - Command line arguments (2): path.resources="/usr/share/eddie-ui" path.exec="/usr/bin/eddie-ui"
. 2019.09.19 19:01:16 - Profile path: /home/jaume/.config/eddie/default.profile
. 2019.09.19 19:01:16 - Reading options from /home/jaume/.config/eddie/default.profile
. 2019.09.19 19:01:17 - OpenVPN Driver - Found, /dev/net/tun
. 2019.09.19 19:01:17 - OpenVPN - Version: 2.4.7 - OpenSSL 1.1.1c  28 May 2019, LZO 2.10 (/sbin/openvpn)
. 2019.09.19 19:01:17 - SSH - Version: OpenSSH_7.9p1 Debian-10, OpenSSL 1.1.1c  28 May 2019 (/usr/bin/ssh)
. 2019.09.19 19:01:17 - SSL - Version: stunnel 5.50 (/usr/bin/stunnel4)
. 2019.09.19 19:01:17 - curl - Version: 7.64.0 (/usr/bin/curl)
. 2019.09.19 19:01:17 - Certification Authorities: /usr/share/eddie-ui/cacert.pem
! 2019.09.19 19:01:17 - Activation of Network Lock - Linux iptables
F 2019.09.19 19:01:17 - Exception: ip6tables don't reply, probabily kernel modules issue
I 2019.09.19 19:01:21 - Ready
. 2019.09.19 19:01:21 - Collect information about AirVPN completed
! 2019.09.19 19:01:36 - Activation of Network Lock - Linux iptables
F 2019.09.19 19:01:36 - Exception: ip6tables don't reply, probabily kernel modules issue
I 2019.09.19 19:02:01 - Session starting.
I 2019.09.19 19:02:01 - Checking authorization ...
! 2019.09.19 19:02:01 - Connecting to Diadema (Belgium, Brussels)
. 2019.09.19 19:02:01 - OpenVPN > OpenVPN 2.4.7 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Feb 20 2019
 

 

 

 

Share this post


Link to post
On 9/13/2019 at 5:39 PM, debu said:
 
The problem is after the error message Eddie doesn't complete opening so I am unable to go into preferences to change the User Data Protection option.

Have tried uninstalling with Revo and reinstalling but issue persists. 2.16.3 works normally.

I'm not having this issue on another Win10 1809 machine and 2.18.2 opens normally.

 
On 9/13/2019 at 4:59 PM, amilino said:

On lates Raspbian on RPi4 I am getting error and not able to use latest beta version:

Unable to obtain elevated privileges (required): eddie_file_get_runasroot

I have the same problem on Mac OS 10.14.6. I can not start Eddy 2 .18.2, I get the message that I do not have the higher permissions to have access to Eddy's login. I tried with the root user and I have the same message. I tried to modify Eddy's permissions directly on Eddy by (read the information-permissions) and I lost full access to my user accounts. Fortunately I had made a backup on Time Machine before. Uninstalling Eddy 2.17.2 by deleting the default file, does not fix the problem. After reinstalling 2.17.2 everything works again.

Share this post


Link to post
On 9/19/2019 at 7:19 PM, nlbRxwy said:

Exception: ip6tables don't reply, probabily kernel modules issue


Expected. Debian 10 moved to nftables, using the new nf_tables and related kernel modules available since early this year or so.

iptables v1.8 introduced a "small" change in naming:
  • The old iptables is now iptables-legacy. Keeps using the old established kernel modules. Least work to do, but the devs made it clear they're deprecating them.
  • Transition/compatibility packages configure a iptables-nft binary, using nft with iptables syntax. The old iptables-save, -restore, etc. have also been "ported" to iptables-nft-save, -restore, etc.
  • The primary binary for nftables is now nft with a similar syntax as pf from OpenBSD (around which pfSense is built by the way, hence the name). It is definitely recommended to switch to it since it's more modern and therefore comes with certain advantages over iptables-legacy (performance!), but also has the disadvantage of not yet having some very advanced features iptables has. There's a wiki entry for that, probably more interesting for others, but anyway.
One workaround might be to simply symbolic link iptables to iptables-nft, since that is used by default, anyway (sudo iptables --version prints v1.x.x (nf_tables) if iptables-nft is used). But ip6tables does not exist anymore, because I see the IP versions being -4 and -6 switches on iptables-legacy/-nft now. Something clodo should look at.
 
Quote
Version 2.17 was working fine, hence I assume that this is not a kernel modues issue .-).

I can freely assume that you made a package upgrade through apt(-get), replacing both iptables and eddie-ui with new versions. If 2.17.x is still working now, my educated nftables guess might not be completely true, apart from it being a fact :D
 
Quote
On the other hand, there is a minor issue with KDE: when the eddie window is active, the KDE applications menu stops reacting to the mouse on that desktop. But when the eddie window is inactive or minimized, the applications menu works as usual.

Cannot reproduce on KDE Plasma 5.14.5.

Four simple things:
There's a guide to AirVPN. Before you ask questions, take 30 minutes of your time to go through it.

Amazon IPs are not dangerous here. It's the fallback DNS.
Running TOR exits is discouraged. They're subject to restrictions on the internet and harm all AirVPN users.

Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, you'll be unique among the mass again.

 

XMPP: gigan3rd@xmpp.airvpn.org or join our lounge@conference.xmpp.airvpn.org

Share this post


Link to post
On 9/19/2019 at 7:19 PM, nlbRxwy said:


On the other hand, there is a minor issue with KDE: when the eddie window is active, the KDE applications menu stops reacting to the mouse on that desktop. But when the eddie window is inactive or minimized, the applications menu works as usual.

 

 

** (eddie-tray:4500): WARNING **: Invalid borders specified for theme pixmap:
        /usr/share/themes/Breeze/gtk-2.0/../assets/line-h.png,
borders don't fit within the image


its freezing eddie every time.

i am back to 2.13.6, this works well on openSUSE 15.1

Share this post


Link to post
19 hours ago, giganerd said:

Expected. Debian 10 moved to nftables, using the new nf_tables and related kernel modules available since early this year or so.

iptables v1.8 introduced a "small" change in naming:
  • The old iptables is now iptables-legacy. Keeps using the old established kernel modules. Least work to do, but the devs made it clear they're deprecating them.
  • Transition/compatibility packages configure a iptables-nft binary, using nft with iptables syntax. The old iptables-save, -restore, etc. have also been "ported" to iptables-nft-save, -restore, etc.
  • The primary binary for nftables is now nft with a similar syntax as pf from OpenBSD (around which pfSense is built by the way, hence the name). It is definitely recommended to switch to it since it's more modern and therefore comes with certain advantages over iptables-legacy (performance!), but also has the disadvantage of not yet having some very advanced features iptables has. There's a wiki entry for that, probably more interesting for others, but anyway.
One workaround might be to simply symbolic link iptables to iptables-nft, since that is used by default, anyway (sudo iptables --version prints v1.x.x (nf_tables) if iptables-nft is used). But ip6tables does not exist anymore, because I see the IP versions being -4 and -6 switches on iptables-legacy/-nft now. Something clodo should look at.

I'm missing this transaction :P
The next 2.18 release will detect correctly the "legacy environment", and network lock will work on Debian 10 (already done and tested).
We are working on other priority issues, a native nft network lock will be implemented in future releases.
Thanks

Share this post


Link to post

On Mac OS 10.14.6,  I can not start Eddy 2 .18.2, I get the message that I do not have the higher permissions to have access to Eddy's login. I tried with the root user and I have the same message. I tried to modify Eddy's permissions directly on Eddy by (read the information-permissions) and I lost full access to my user accounts. Fortunately I had made a backup on Time Machine before. Uninstalling Eddy 2.17.2 by deleting the default file, does not fix the problem. I reset my account permission and reinstalling 2.17.2, everything works fine again on that version, but it’s impossible with 2.18.2 .

Share this post


Link to post
4 hours ago, Atomas said:

On Mac OS 10.14.6,  I can not start Eddy 2 .18.2, I get the message that I do not have the higher permissions to have access to Eddy's login. I tried with the root user and I have the same message. I tried to modify Eddy's permissions directly on Eddy by (read the information-permissions) and I lost full access to my user accounts. Fortunately I had made a backup on Time Machine before. Uninstalling Eddy 2.17.2 by deleting the default file, does not fix the problem. I reset my account permission and reinstalling 2.17.2, everything works fine again on that version, but it’s impossible with 2.18.2 .

I read that, i keep you informed when i have a solution, thanks.

Share this post


Link to post
59 minutes ago, harold.lewis said:

what happened with Eddie 2.17.2?  I'm using that now...

+1 for the portable version

Eddie 2.17.2 is an older beta and no longer eligible for download. It has been replaced by the current beta, 2.18.2.

Regards,

BB

Share this post


Link to post
On 9/14/2019 at 4:45 PM, amilino said:
It doesn't exist.

Tried purging of eddie-ui package and installation from scratch and same thing, no folder is created.
Hi,
Similar problem with Ubuntu 18.04.3 LTS "Unable to obtain elevated privileges..."  when starting from desktop icon.
However $sudo -H eddie-ui appears to run OK but icons disappear when minimising.

. 2019.09.23 21:40:37 - Eddie version: 2.18.2beta / linux_x64, System: Linux, Name: Ubuntu 18.04.3 LTS \n \l, Version: Linux ********** 4.15.0-64-generic #73-Ubuntu SMP Thu Sep 12 13:16:13 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux, Mono/.Net: 4.6.2 (Debian 4.6.2.7+dfsg-1ubuntu1); Framework: v4.0.30319
. 2019.09.23 21:40:37 - Command line arguments (2): path.resources="/usr/share/eddie-ui" path.exec="/usr/bin/eddie-ui"
. 2019.09.23 21:40:37 - Profile path: /usr/lib/eddie-ui/default.profile
. 2019.09.23 21:40:38 - Reading options from /usr/lib/eddie-ui/default.profile
. 2019.09.23 21:40:39 - OpenVPN Driver - Found, /dev/net/tun
. 2019.09.23 21:40:39 - OpenVPN - Version: 2.4.4 - OpenSSL 1.1.1  11 Sep 2018, LZO 2.08 (/usr/sbin/openvpn)
. 2019.09.23 21:40:39 - SSH - Version: OpenSSH_7.6p1 Ubuntu-4ubuntu0.3, OpenSSL 1.0.2n  7 Dec 2017 (/usr/bin/ssh)
. 2019.09.23 21:40:39 - SSL - Version: stunnel 5.44 (/usr/bin/stunnel4)
. 2019.09.23 21:40:39 - curl - Version: 7.58.0 (/usr/bin/curl)
. 2019.09.23 21:40:39 - Certification Authorities: /usr/share/eddie-ui/cacert.pem
I 2019.09.23 21:40:41 - Ready
. 2019.09.23 21:40:41 - Collect information about AirVPN completed

No "default.profile" is created in ~/.config


 

Share this post


Link to post

Does the updated Eddie Client look any different visually? Just curious. I will wait to install it until it is out of beta. 

Share this post


Link to post
8 minutes ago, whiskey_76 said:

Does the updated Eddie Client look any different visually? Just curious. I will wait to install it until it is out of beta. 

No, same interface.

Share this post


Link to post

sudo -H eddie-ui is not helping in my case. Still same issue with permissions.

Share this post


Link to post

Hi BB,
The authenticate window is visually different but the main window interface looks the same as 2.16.3 and appears to be functionally identical.
Amilino
I suspect our problems may be unrelated. Synaptic stopped loading from the desktop while I was trying to get pkexec gedit to work and I may have messed up some configuration files. I found I could not start eddie-ui 2.16.3 either so I uninstalled it and tried 2.18.2. Problem fixed by fresh install of Ubuntu 19.04. Eddie 2.18.2 beta works as expected. (Still can't get pkexec gedit to work though that's nothing to do with eddie.)
G

Share this post


Link to post

Version 2.18.3 (Fri, 27 Sep 2019 11:07:42 +0000)

  • [change] Switched 'ping' method in Linux and macOS
  • [change] Code cleanup
  • [change] macOS - Direct invocation with AuthorizationExecuteWithPrivileges for superuser privileges
  • [change] Linux - "Minimize to tray" false by default
  • [change] Linux - Mono, Portable and AppImage editions
  • [change] Minor UI improvements
  • [change] Better log of issues
  • [change] Better log of dns flush actions
  • [bugfix] Linux - Icon and Window glitch in KDE
  • [bugfix] macOS - SSH connection
  • [bugfix] macOS - Show/Hide Main Window issues
  • [bugfix] OS Keyring conflicts with multiple profiles
  • [bugfix] Linux - Raspberry, ARMHF build, fixed issue 'file_getasroot'
  • [bugfix] Linux - Fixed a fatal crash with some UI tray icon issues
  • [bugfix] Linux - Detect and use iptables-legacy (nft transition)
  • [bugfix] Linux - Fixed a SSL connection issue (related to error 'Cannot create pid file')
  • [bugfix] Parser of OpenVPN version
  • [new] Linux - WM_CLASS registration
  • [new] Linux - New IPv6 block
  • [new] Latency test only about servers in whitelist
  • [deprecated] Option "Remove Default Gateway" (routes.remove_default) removed
  • [deprecated] Windows - Option "Switch DHCP to Static" (windows.dhcp_disable) removed

Share this post


Link to post
On 9/13/2019 at 1:48 AM, debu said:

2.18.2 installs but when trying to open Eddie I get this error message after which Eddie closes:

Unable to obtain from OS password required to unlock the profile.

Trying to open as Administrator produces same result.

No problems using 2.16.3

Win 10 1809

 

On 9/13/2019 at 11:52 AM, Rruud said:

@debu , @Rruud
Please retry with the 2.18.3.
If the system ask a "revert to default", reply yes for this time (it fix a bug).
Report again if occur again.

Share this post


Link to post
On 9/13/2019 at 4:49 PM, GJElde said:

on openSUSE 15.1 with eddie 2.18.2, just  a crash, nothing could be done with eddie anymore.
could only find this in the log;

Received signal SIGHUP
! 2019.09.13 16:38:06 - Disconnecting
F 2019.09.13 16:38:06 - Unexpected crash of elevated helper:Elevated communication closed

edit, and this
** (eddie-tray:5741): WARNING **: Invalid borders specified for theme pixmap:
        /usr/share/themes/Breeze/gtk-2.0/../assets/line-h.png,
borders don't fit within the image

more;

F 2019.09.13 17:06:38 - Unexpected error. Please contact our support staff. - ApplicationThread - Object reference not set to an instance of an object -   at Eddie.Forms.Forms.Settings.OnLoad (System.EventArgs e) [0x00494] in <8ffaac2cbc914bf78635113d27ef1091>:0
F 2019.09.13 17:06:38 -     at System.Windows.Forms.Form.OnLoadInternal (System.EventArgs e) [0x00023] in <64229ce348bf414baa325904e6b85bb9>:0

 


Please retry with the 2.18.3.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...