Jump to content
Not connected, Your IP: 3.214.184.196
Staff

Eddie Desktop 2.18beta released

Recommended Posts

2 hours ago, Gaechka said:

I want to have Eddie always with me on an encrypted flash drive. And maybe this can be sound paranoic, but I don't want it to be installed system-wide and be easy to discovered. There are countries where they can come for everyone just because they want to, and you want to protect yourself just in case ;) I'm using Debian Stretch. Anyways, aren't portable apps popular for many reasons these days, along with flatpaks, appimages and etc.?

Right, ok. I hope portable editions will be restored in the next beta release, please be patient.

Share this post


Link to post

On lates Raspbian on RPi4 I am getting error and not able to use latest beta version:

Unable to obtain elevated privileges (required): eddie_file_get_runasroot

Share this post


Link to post
11 hours ago, Rruud said:
21 hours ago, debu said:

Use in "Profile Data Protection" the option "plain, no password asked".

 
The problem is after the error message Eddie doesn't complete opening so I am unable to go into preferences to change the User Data Protection option.

Have tried uninstalling with Revo and reinstalling but issue persists. 2.16.3 works normally.

I'm not having this issue on another Win10 1809 machine and 2.18.2 opens normally.

 

Share this post


Link to post

debu,
Try deleting the "default.profile" from location of your problem install, worked for me on W8.1.
Bubo

Share this post


Link to post
34 minutes ago, Bubo said:

debu,
Try deleting the "default.profile" from location of your problem install, worked for me on W8.1.
Bubo

Thank you, Bubo, but I don't see "default.profile" anywhere in the 2.18.2 folder (or 2.16.3 folder either when it is installed).  I must be missing something obvious...

Share this post


Link to post
23 minutes ago, debu said:
1 hour ago, Bubo said:

debu,
Try deleting the "default.profile" from location of your problem install, worked for me on W8.1.
Bubo

Thank you, Bubo, but I don't see "default.profile" anywhere in the 2.18.2 folder (or 2.16.3 folder either when it is installed).  I must be missing something obvious...

Found it and all is well! Thanks, again.

Share this post


Link to post
3 hours ago, amilino said:

I am on Linux, what do I need to delete? \root\.airvpn maybe?


Hello! What problem do you experience?

Default location for Eddie's default.profile file is ~/.config/eddie

Kind regards
 

Share this post


Link to post
11 hours ago, amilino said:

On lates Raspbian on RPi4 I am getting error and not able to use latest beta version:

Unable to obtain elevated privileges (required): eddie_file_get_runasroot

Share this post


Link to post
10 minutes ago, Staff said:

Hello! What problem do you experience?

Default location for Eddie's default.profile file is ~/.config/eddie

Kind regards
 
This folder does not exist.

Share this post


Link to post
19 minutes ago, amilino said:
29 minutes ago, Staff said:

Hello! What problem do you experience?

Default location for Eddie's default.profile file is ~/.config/eddie

Kind regards
 
This folder does not exist.

Hello!

That might be the problem. If you have removed ~/.config for your account please re-create it and try to re-run Eddie. If you are connecting to your Raspberry as superuser please switch to a normal user and then run Eddie.

Another potential cause which may explain the error message you reported might be when  your user is not a sudoer. In this case Eddie UI can't launch Eddie backend (another binary file) with root privileges from the account itself, so it will try to do it from root account, if possible (on some systems like Ubuntu root account exists but is disabled by default).

Kind regards
 

Share this post


Link to post
Posted ... (edited)

Linux sid debian unstable beta2 not working for me.

full log :

. 2019.09.14 09:59:38 - Eddie version: 2.18.2beta / linux_x64, System: Linux, Name: Debian GNU/Linux bullseye/sid \n \l, Version: Linux peter-mate 5.3.0-rc8-siduction-amd64 #1 SMP PREEMPT siduction 5.3~rc8-1~exp1 (2019-09-09) x86_64 GNU/Linux, Mono/.Net: 5.18.0.240 (Debian 5.18.0.240+dfsg-5 Tue Sep 10 13:23:34 UTC 2019); Framework: v4.0.30319
. 2019.09.14 09:59:38 - Command line arguments (2): path.resources="/usr/share/eddie-ui" path.exec="/usr/bin/eddie-ui"
. 2019.09.14 09:59:38 - Profile path: /home/peter/.config/eddie/default.profile
. 2019.09.14 09:59:39 - Reading options from /home/peter/.config/eddie/default.profile
. 2019.09.14 09:59:39 - OpenVPN Driver - Found, /dev/net/tun
. 2019.09.14 09:59:39 - OpenVPN - Version: 2.4.7 - OpenSSL 1.1.1c  28 May 2019, LZO 2.10 (/sbin/openvpn)
. 2019.09.14 09:59:39 - SSH - Version: OpenSSH_8.0p1 Debian-6, OpenSSL 1.1.1c  28 May 2019 (/usr/bin/ssh)
. 2019.09.14 09:59:39 - SSL - Version: stunnel 5.55 (/usr/bin/stunnel4)
. 2019.09.14 09:59:39 - curl - Version: 7.65.3 (/usr/bin/curl)
. 2019.09.14 09:59:39 - Certification Authorities: /usr/share/eddie-ui/cacert.pem
I 2019.09.14 09:59:40 - Ready
. 2019.09.14 09:59:40 - Collect information about AirVPN completed
I 2019.09.14 10:02:39 - Session starting.
I 2019.09.14 10:02:39 - Checking authorization ...
! 2019.09.14 10:02:39 - Connecting to Arion (United Kingdom of Great Britain and Northern Ireland, London)
E 2019.09.14 10:02:39 - OpenVPN > Error: Not supported OpenVPN config.
! 2019.09.14 10:02:39 - Disconnecting
. 2019.09.14 10:02:39 - Connection terminated.
I 2019.09.14 10:02:42 - Checking authorization ...
! 2019.09.14 10:02:43 - Connecting to Geminorum (United Kingdom of Great Britain and Northern Ireland, London)
E 2019.09.14 10:02:43 - OpenVPN > Error: Not supported OpenVPN config.
! 2019.09.14 10:02:43 - Disconnecting
. 2019.09.14 10:02:43 - Connection terminated.
I 2019.09.14 10:02:46 - Checking authorization ...
! 2019.09.14 10:02:46 - Connecting to Asterion (United Kingdom of Great Britain and Northern Ireland, London)
E 2019.09.14 10:02:46 - OpenVPN > Error: Not supported OpenVPN config.
! 2019.09.14 10:02:46 - Disconnecting
. 2019.09.14 10:02:46 - Connection terminated.
I 2019.09.14 10:02:49 - Checking authorization ...
! 2019.09.14 10:02:49 - Connecting to Westerlund (United Kingdom of Great Britain and Northern Ireland, Manchester)
E 2019.09.14 10:02:50 - OpenVPN > Error: Not supported OpenVPN config.
! 2019.09.14 10:02:50 - Disconnecting
. 2019.09.14 10:02:50 - Connection terminated.
I 2019.09.14 10:02:53 - Checking authorization ...
! 2019.09.14 10:02:53 - Connecting to Minkar (United Kingdom of Great Britain and Northern Ireland, Maidenhead)
E 2019.09.14 10:02:53 - OpenVPN > Error: Not supported OpenVPN config.
! 2019.09.14 10:02:53 - Disconnecting
. 2019.09.14 10:02:53 - Connection terminated.
I 2019.09.14 10:02:56 - Checking authorization ...
! 2019.09.14 10:02:56 - Connecting to Asterope (United Kingdom of Great Britain and Northern Ireland, Manchester)
E 2019.09.14 10:02:56 - OpenVPN > Error: Not supported OpenVPN config.
! 2019.09.14 10:02:56 - Disconnecting
. 2019.09.14 10:02:56 - Connection terminated.
I 2019.09.14 10:02:58 - Cancel requested.
! 2019.09.14 10:02:58 - Session terminated.


eddie 2.16.3 works fine and previous 2.17 works fine on the  screenshot  attached 


EDIT:
After editing the screenshot settings and then returning them to the same config, and amending device names in the client area eddie 2.18beta2 seems to work ok now. 

 

airvpn settings.png

Edited ... by pjnsmb
update

Share this post


Link to post
2 hours ago, Staff said:

Hello!

That might be the problem. If you have removed ~/.config for your account please re-create it and try to re-run Eddie. If you are connecting to your Raspberry as superuser please switch to a normal user and then run Eddie.

Another potential cause which may explain the error message you reported might be when  your user is not a sudoer. In this case Eddie UI can't launch Eddie backend (another binary file) with root privileges from the account itself, so it will try to do it from root account, if possible (on some systems like Ubuntu root account exists but is disabled by default).

Kind regards
 
I never had profile on that location. This is where my profile is located "/root/.airvpn/default.xml". Tried to delete folder and tried to run it without sudo with no luck. Also tried to use su -i but same result.

I can confirm that my pi user is sudero. It can run ALL commands with sudo access.

All previous versions are working very good. Not sure what to do to make it work?

Share this post


Link to post
@amilino
 
Quote

I never had profile on that location. This is where my profile is located "/root/.airvpn/default.xml"


Older than 2.18 Eddie version stored a profile in ~/.airvpn with the name "default.xml". Eddie 2.18.2 stores the profile in ~/.config/eddie and names it default.profile. So default.xml comes from some older Eddie that you were running with user "root" (and NOT with a normal user in the sudoers).
 
Quote

Also tried to use su -i but same result.


What does su have to do with sudo?
 
Quote

All previous versions are working very good. Not sure what to do to make it work?


Just to verify whether Eddie has at least created the proper directory, can you tell us whether the following directories of your regular account:
~/.config/eddie
~/.config

exist or not?

Kind regards
 

Share this post


Link to post
On 9/12/2019 at 12:06 PM, Clodo said:
On 9/11/2019 at 11:34 AM, EtV said:

Notifications:  In Preferences>UI, the "System notifications" box is check by default, and while there is a banner that pops up saying "1 new notification" from Eddie, no actual system notifications are showing up in the Notifications area of the sidebar.  I don't usually keep this enabled (personal preference), but I did notice the behavior when I first installed the new beta.

Cannot reproduce. In 2.18.2 we also improved some layout, but in any test System notifications are showed, in our Notifications area of the sidebar too. Please recheck.

Hi Clodo,
Thanks for going through the small stuff I was wondering about!  I've downloaded the new beta (2.18.2); same laptop as I was using before; running MacOS 10.14.6 (Mojave).  I've re-enabled notifications in the new beta and attached a screen grab of what I'm seeing.  I do get the pop-up window notifications from Eddie, but nothing is then appearing in the "Notifications" area of the OS sidebar.  Perhaps I'm just misunderstanding what is supposed to happen, and what I'm seeing is the intended behavior?  Either way, hopefully the attached grab helps to clarify things.  Thanks again!

eddie-beta-notifications.png

Share this post


Link to post
On 9/12/2019 at 12:06 PM, Clodo said:
On 9/11/2019 at 11:34 AM, EtV said:

Show/Hide Main Window (in Eddie menu bar drop-down):  I think this has been around a while, but it's definitely present in the beta so...after closing the Main window of Eddie, the drop-down in the menu bar will often list "Hide Main Window" as the option, instead of "Show Main Window".  Selecting this "Hide..." option will indeed bring up the Main window.  So, the functionality isn't 'broken' by any means, but the drop-down seems to lose track of Hide vs. Show.

Cannot reproduce. Sometimes, if you close the window with the X button, menu takes some seconds to update, but works coherently. If we use the minimize button, it looks always fine. Please recheck.

MacOS 10.14.6 (Mojave) - retested with latest Eddie beta (2.18.2).  Issue still appears to happen.  To reproduce, I did the following...
  • Click the Eddie icon in the menu bar and select "Show Main Window"
  • After the main window appears, close it by clicking the red dot in the upper left corner of the window
  • Click the Eddie icon in the menu bar, and you will see "Hide Main Window" in place of "Show Main Window"
  • That said, if you select "Hide Main Window" in that menu, the main window will indeed reappear
The attached screen grab was taken a few minutes after closing the main window, so I'm not sure it's a time-related issue, fwiw.  Hope that helps to clarify what I'm seeing a bit more.

eddie-beta-menu.png

Share this post


Link to post
2 hours ago, Staff said:
@amilino
 
Older than 2.18 Eddie version stored a profile in ~/.airvpn with the name "default.xml". Eddie 2.18.2 stores the profile in ~/.config/eddie and names it default.profile. So default.xml comes from some older Eddie that you were running with user "root" (and NOT with a normal user in the sudoers).
 
What does su have to do with sudo?
 
Just to verify whether Eddie has at least created the proper directory, can you tell us whether the following directories of your regular account:
~/.config/eddie
~/.config

exist or not?

Kind regards
 
It doesn't exist.

Tried purging of eddie-ui package and installation from scratch and same thing, no folder is created.

Share this post


Link to post

I'm using Eddie 2.18.2 on Arch Linux  It works for the most part, but here are two things (errors), that I observed.

1. Sometimes (not always) I get the following message, when I try to activate the Network Lock.

F 2019.09.14 11:55:59 - Operations that change non-concurrent collections must have exclusive access. A concurrent update was performed on this collection and corrupted its state. The collection's state is no longer correct.
When I exit Eddie and restart it, activating the Network Lock will work without fail.

2. Every time I exit Eddie via the main menu, I get the following error message(s).
. 2019.09.14 00:14:45 - Connection terminated.
. 2019.09.14 00:14:45 - DNS of the system restored to original settings (Rename method)
. 2019.09.14 00:14:45 - Flushing DNS
! 2019.09.14 00:14:45 - Session terminated.
. 2019.09.14 00:14:45 - Deactivation of Network Lock
F 2019.09.14 00:14:46 - Unexpected error. Please contact our support staff. - CurrentDomain - Object reference not set to an instance of an object -   at Eddie.Core.Engine.OnRefreshUi (Eddie.Core.Engine+RefreshUiMode mode) [0x002c4] in <340a1946f0a9426c8813241b7eee6ee9>:0
F 2019.09.14 00:14:46 -     at Eddie.Forms.Engine.OnRefreshUi (Eddie.Core.Engine+RefreshUiMode mode) [0x00000] in <5fbe796381a84f5a98be2d000f3cda3f>:0
F 2019.09.14 00:14:46 -     at Eddie.Core.Engine.DeAuth () [0x00037] in <340a1946f0a9426c8813241b7eee6ee9>:0
F 2019.09.14 00:14:46 -     at Eddie.Core.Engine.OnDeInit2 () [0x00020] in <340a1946f0a9426c8813241b7eee6ee9>:0
F 2019.09.14 00:14:46 -     at Eddie.Core.Engine.MainStepDeInit () [0x00027] in <340a1946f0a9426c8813241b7eee6ee9>:0
F 2019.09.14 00:14:46 -     at Eddie.Core.Engine.OnRun () [0x00016] in <340a1946f0a9426c8813241b7eee6ee9>:0
F 2019.09.14 00:14:46 -     at Eddie.Core.Thread.DoRun () [0x00000] in <340a1946f0a9426c8813241b7eee6ee9>:0
F 2019.09.14 00:14:46 -     at System.Threading.ThreadHelper.ThreadStart_Context (System.Object state) [0x00014] in <d59a6ed4e2f34efbabec0525e05bcea7>:0
F 2019.09.14 00:14:46 -     at System.Threading.ExecutionContext.RunInternal (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state, System.Boolean preserveSyncCtx) [0x00071] in <d59a6ed4e2f34efbabec0525e05bcea7>:0
F 2019.09.14 00:14:46 -     at System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state, System.Boolean preserveSyncCtx) [0x00000] in <d59a6ed4e2f34efbabec0525e05bcea7>:0
F 2019.09.14 00:14:46 -     at System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state) [0x0002b] in <d59a6ed4e2f34efbabec0525e05bcea7>:0
F 2019.09.14 00:14:46 -     at System.Threading.ThreadHelper.ThreadStart () [0x00008] in <d59a6ed4e2f34efbabec0525e05bcea7>:0
[ERROR] FATAL UNHANDLED EXCEPTION: System.NullReferenceException: Object reference not set to an instance of an object
  at Eddie.Core.Engine.OnRefreshUi (Eddie.Core.Engine+RefreshUiMode mode) [0x002c4] in <340a1946f0a9426c8813241b7eee6ee9>:0
  at Eddie.Forms.Engine.OnRefreshUi (Eddie.Core.Engine+RefreshUiMode mode) [0x00000] in <5fbe796381a84f5a98be2d000f3cda3f>:0
  at Eddie.Core.Engine.DeAuth () [0x00037] in <340a1946f0a9426c8813241b7eee6ee9>:0
  at Eddie.Core.Engine.OnDeInit2 () [0x00020] in <340a1946f0a9426c8813241b7eee6ee9>:0
  at Eddie.Core.Engine.MainStepDeInit () [0x00027] in <340a1946f0a9426c8813241b7eee6ee9>:0
  at Eddie.Core.Engine.OnRun () [0x00016] in <340a1946f0a9426c8813241b7eee6ee9>:0
  at Eddie.Core.Thread.DoRun () [0x00000] in <340a1946f0a9426c8813241b7eee6ee9>:0
  at System.Threading.ThreadHelper.ThreadStart_Context (System.Object state) [0x00014] in <d59a6ed4e2f34efbabec0525e05bcea7>:0
  at System.Threading.ExecutionContext.RunInternal (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state, System.Boolean preserveSyncCtx) [0x00071] in <d59a6ed4e2f34efbabec0525e05bcea7>:0
  at System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state, System.Boolean preserveSyncCtx) [0x00000] in <d59a6ed4e2f34efbabec0525e05bcea7>:0
  at System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state) [0x0002b] in <d59a6ed4e2f34efbabec0525e05bcea7>:0
  at System.Threading.ThreadHelper.ThreadStart () [0x00008] in <d59a6ed4e2f34efbabec0525e05bcea7>:0

If I perform the exiting manually, meaning
- Disconnect
- Deactivate Network Lock
- Logout
- Exit
then I don't get the aforementioned error.

Both problems do not prevent me from using Eddie, but I guess they warrant a closer look nonetheless.

Share this post


Link to post
On 9/12/2019 at 12:06 PM, Clodo said:
On 9/11/2019 at 11:34 AM, EtV said:

Preference>Advanced: I run Eddie on a laptop (and on a few different Wifi nets), and I'm noticing that I'm not getting IPv6 connections like I used to on the network I'm currently on today.  At this location, IPLeak.net would regularly show me both v4 and a v6, while with the new Eddie a few difference connections (different servers) have mostly not shown me the v6.  Admittedly, I don't use that much / at all, however it is a change in behavior that I've noticed, fwiw.

This need more investigation. Please report OS of the laptop, connection info (what servers) etc.

Hello again Clodo,
I've been working again at this location today and seen some of the same behavior in the new Eddie beta.  Information you asked for...
MacOS 10.14.6 (Mojave); Eddie beta 2.18.2; settings in Eddie Preferences>Networking are still the default, fwiw

Prior to this Eddie beta, when I would connect at this location to either of their wifi networks (2.4 or 5G), I would typically see both the IPv4 and IPv6 address of the AirVPN server I'd connected to, as expected, when I visited IPLeak.net.  With both versions of 2.18.x beta, I am not seeing the IPv6 most of time (and no, it's not a perfectly consistent behavior, alas).  Some servers I've connected to today that have exhibited this:  Ukdah, Yidun, Cursa, Microscopium...can't recall others off-hand (I run a laptop and often walk away from it, so it gets locked and Eddie then reconnects when I return and wake it).

I've attached a screen grab from IPLeak.net and the corresponding portion of the Eddie log for when I connected with Microscopium.  If this issue contains too many moving parts that aren't obviously related to the beta, just let me know...perhaps a ticket would be a better vehicle?  Up to you guys.

eddie-beta-noIPv6.png

eddie-beta-noIPv6-logs.txt

Share this post


Link to post

Hello!

Does anyone experience the following problem with "OpenVPN over SSL" connections in Linux, or similar issues in other systems? We have been asked to post it here by one of our customers. Can you please test on your systems?


Hello,

I have just installed your new Eddie client (2.18.2 beta) to try out i was on the previous (stable) version until now.Operation system is Debian based with latest update's However SSL protocol connections do not seam to work for me now thay did work before the Eddie update, and ssl works with the previous Eddie version on a windows client.

I have attached logs for each connection attempt all are successful except for the SSL option. All UDP SSH and other protocols/servers connect fine except when using SSL

Is there any issues with ssl at the moment. Please let me know how to proceed or if any further information is required.

Thank you for your time.

SSL


I 2019.09.13 14:05:58 - Checking authorization ...
! 2019.09.13 14:05:59 - Connecting to Lacerta (Canada, Montreal)
. 2019.09.13 14:05:59 - Routes, added a new route, 87.101.92.172 for gateway 192.168.239.2
. 2019.09.13 14:05:59 - SSL > 2019.09.13 14:05:59 LOG5[ui]: stunnel 5.55 on x86_64-pc-linux-gnu platform
. 2019.09.13 14:05:59 - SSL > 2019.09.13 14:05:59 LOG5[ui]: Compiled/running with OpenSSL 1.1.1c  28 May 2019
. 2019.09.13 14:05:59 - SSL > 2019.09.13 14:05:59 LOG5[ui]: Threading:PTHREAD Sockets:POLL,IPv6,SYSTEMD TLS:ENGINE,FIPS,OCSP,PSK,SNI Auth:LIBWRAP
. 2019.09.13 14:05:59 - SSL > 2019.09.13 14:05:59 LOG5[ui]: Reading configuration from file /home/unknown/.config/eddie/33e6d2ca44d2221880152d327a2db718cd5ffb8384b6377c13b1ffe5fb94550f.tmp.ssl
. 2019.09.13 14:05:59 - SSL > 2019.09.13 14:05:59 LOG5[ui]: UTF-8 byte order mark detected
. 2019.09.13 14:05:59 - SSL > 2019.09.13 14:05:59 LOG5[ui]: FIPS mode disabled
. 2019.09.13 14:05:59 - SSL > 2019.09.13 14:05:59 LOG6[ui]: Initializing service [openvpn]
. 2019.09.13 14:05:59 - SSL > 2019.09.13 14:05:59 LOG4[ui]: Service [openvpn] needs authentication to prevent MITM attacks
. 2019.09.13 14:05:59 - SSL > 2019.09.13 14:05:59 LOG5[ui]: Configuration successful
. 2019.09.13 14:05:59 - SSL > 2019.09.13 14:05:59 LOG6[ui]: Service [openvpn] (FD=9) bound to 127.0.0.1:37073
. 2019.09.13 14:05:59 - SSL > 2019.09.13 14:05:59 LOG3[ui]: Cannot create pid file /var/run/stunnel4.pid
. 2019.09.13 14:05:59 - SSL > 2019.09.13 14:05:59 LOG3[ui]: create: Permission denied (13)

! 2019.09.13 14:05:59 - Disconnecting

Share this post


Link to post
3 hours ago, Staff said:

Hello!

Does anyone experience the following problem with "OpenVPN over SSL" connections in Linux, or similar issues in other systems? We have been asked to post it here by one of our customers. Can you please test on your systems?

 


openSUSE 15.1 looks fine, nothing in the log file

Share this post


Link to post
6 hours ago, amilino said:
@radolkin how did you manage to run application on Linux? On Raspbian it is not even starting. 
Unfortunately, I don't own a Raspberry Pi, so I cannot test this myself, but I am pretty sure, that there are people here, who can.

In the different flavors of Linux, Eddie 2.18.2 beta seems to run just fine, apart from some minor problems here and there.

Share this post


Link to post
9 hours ago, Staff said:

Hello!

Does anyone experience the following problem with "OpenVPN over SSL" connections in Linux, or similar issues in other systems? We have been asked to post it here by one of our customers. Can you please test on your systems?


Hello,

I have just installed your new Eddie client (2.18.2 beta) to try out i was on the previous (stable) version until now.Operation system is Debian based with latest update's However SSL protocol connections do not seam to work for me now thay did work before the Eddie update, and ssl works with the previous Eddie version on a windows client.

I have attached logs for each connection attempt all are successful except for the SSL option. All UDP SSH and other protocols/servers connect fine except when using SSL

Is there any issues with ssl at the moment. Please let me know how to proceed or if any further information is required.

Thank you for your time.

SSL


I 2019.09.13 14:05:58 - Checking authorization ...
! 2019.09.13 14:05:59 - Connecting to Lacerta (Canada, Montreal)
. 2019.09.13 14:05:59 - Routes, added a new route, 87.101.92.172 for gateway 192.168.239.2
. 2019.09.13 14:05:59 - SSL > 2019.09.13 14:05:59 LOG5[ui]: stunnel 5.55 on x86_64-pc-linux-gnu platform
. 2019.09.13 14:05:59 - SSL > 2019.09.13 14:05:59 LOG5[ui]: Compiled/running with OpenSSL 1.1.1c  28 May 2019
. 2019.09.13 14:05:59 - SSL > 2019.09.13 14:05:59 LOG5[ui]: Threading:PTHREAD Sockets:POLL,IPv6,SYSTEMD TLS:ENGINE,FIPS,OCSP,PSK,SNI Auth:LIBWRAP
. 2019.09.13 14:05:59 - SSL > 2019.09.13 14:05:59 LOG5[ui]: Reading configuration from file /home/unknown/.config/eddie/33e6d2ca44d2221880152d327a2db718cd5ffb8384b6377c13b1ffe5fb94550f.tmp.ssl
. 2019.09.13 14:05:59 - SSL > 2019.09.13 14:05:59 LOG5[ui]: UTF-8 byte order mark detected
. 2019.09.13 14:05:59 - SSL > 2019.09.13 14:05:59 LOG5[ui]: FIPS mode disabled
. 2019.09.13 14:05:59 - SSL > 2019.09.13 14:05:59 LOG6[ui]: Initializing service [openvpn]
. 2019.09.13 14:05:59 - SSL > 2019.09.13 14:05:59 LOG4[ui]: Service [openvpn] needs authentication to prevent MITM attacks
. 2019.09.13 14:05:59 - SSL > 2019.09.13 14:05:59 LOG5[ui]: Configuration successful
. 2019.09.13 14:05:59 - SSL > 2019.09.13 14:05:59 LOG6[ui]: Service [openvpn] (FD=9) bound to 127.0.0.1:37073
. 2019.09.13 14:05:59 - SSL > 2019.09.13 14:05:59 LOG3[ui]: Cannot create pid file /var/run/stunnel4.pid
. 2019.09.13 14:05:59 - SSL > 2019.09.13 14:05:59 LOG3[ui]: create: Permission denied (13)

! 2019.09.13 14:05:59 - Disconnecting

Hello,

yes, same issue here:

2019.09.15 20:55:56 - Checking authorization ...
! 2019.09.15 20:55:56 - Connecting to Pyxis (Netherlands, Alblasserdam)
. 2019.09.15 20:55:56 - Routes, added a new route, 213.152.161.236 for gateway 192.168.0.1
. 2019.09.15 20:55:56 - SSL > 2019.09.15 20:55:56 LOG5[ui]: stunnel 5.50 on x86_64-pc-linux-gnu platform
. 2019.09.15 20:55:56 - SSL > 2019.09.15 20:55:56 LOG5[ui]: Compiled with OpenSSL 1.1.1a  20 Nov 2018
. 2019.09.15 20:55:56 - SSL > 2019.09.15 20:55:56 LOG5[ui]: Running  with OpenSSL 1.1.1c  28 May 2019
. 2019.09.15 20:55:56 - SSL > 2019.09.15 20:55:56 LOG5[ui]: Threading:PTHREAD Sockets:POLL,IPv6,SYSTEMD TLS:ENGINE,FIPS,OCSP,PSK,SNI Auth:LIBWRAP
. 2019.09.15 20:55:56 - SSL > 2019.09.15 20:55:56 LOG5[ui]: Reading configuration from file /home/b0rderline/.config/eddie/6d354c684bdb486ab946120a762eda4b90784209a9cd2849321999bde48110ab.tmp.ssl
. 2019.09.15 20:55:56 - SSL > 2019.09.15 20:55:56 LOG5[ui]: UTF-8 byte order mark detected
. 2019.09.15 20:55:56 - SSL > 2019.09.15 20:55:56 LOG5[ui]: FIPS mode disabled
. 2019.09.15 20:55:56 - SSL > 2019.09.15 20:55:56 LOG6[ui]: Initializing service [openvpn]
. 2019.09.15 20:55:56 - SSL > 2019.09.15 20:55:56 LOG4[ui]: Service [openvpn] needs authentication to prevent MITM attacks
. 2019.09.15 20:55:56 - SSL > 2019.09.15 20:55:56 LOG5[ui]: Configuration successful
. 2019.09.15 20:55:56 - SSL > 2019.09.15 20:55:56 LOG6[ui]: Service [openvpn] (FD=7) bound to 127.0.0.1:21741
. 2019.09.15 20:55:56 - SSL > 2019.09.15 20:55:56 LOG3[ui]: Cannot create pid file /var/run/stunnel4.pid
. 2019.09.15 20:55:56 - SSL > 2019.09.15 20:55:56 LOG3[ui]: create: Permission denied (13)
! 2019.09.15 20:55:56 - Disconnecting

OS:Ubuntu 19.04 Disco Dingo

Share this post


Link to post

Running Ubuntu 19.04, previous versions of Eddie didn't work with Wayland, so I ran X-org.  This beta, though, is working fine with Wayland, except for one thing:
When I started it up, I accidentally entered the wrong password.  i got an error message about entering an incorrect password, and everything involving Eddie froze.  I was unable to end or kill the process, restart Eddie, or do anything else with it until I rebooted.  After that, still on Wayland, I restarted Eddie, entered the RIGHT password, and it's been working fine.  (I havent yet tried entering the wrong password while running X-org - I guess I'll have to try that to see if this is Wayland-specific or not.)

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...