Jump to content
Not connected, Your IP:

ANSWERED AirVPN + OneNote/Word not connecting

Recommended Posts

Hi everyone,


I've been struggling for some time now to make Microsoft OneNote (2016 or win 10) and Word login to my account successfully through AirVPN.

So far no luck, the only way I managed it to work is by changing the DNS server which I do NOT want to do that for security reasons.


Has anyone found a better solution?


Thank you very much!

Share this post

Link to post


I tried the suggested fix last night and I can happily say that it works as expected, OneNote, Word, Windows Store now all work properly!


It was a very easy fix and I have spent too much time trying to solve it. However I never noticed that the gateway was empty, I saw it but thought since its a TAP adapter it is how it should be...it seems I was wrong.

This should be sticky somewhere.

I can't thank you enough!


As a development suggestion I would say it would be a nice addition to Eddie to auto populate the gateway of the TAP adapter with the gateway of your normal ethernet adapter if its empty. And probably have an app setting to let users override or disable that functionality. That way it will be auto resolved for most users with no technical knowledge.



Share this post

Link to post


We're very glad to know that the problem has been resolved!


Your suggestion is good and we will consider it seriously. With Microsoft, Eddie already implements various fixes (on the tun/tap interface, on global DNS missing implementation on all Windows systems, and even on the "new" crazy DNS handling in Windows 10 after the "Creator" update), although mis-behaving for a bug of someone else is theoretically not the right way to follow and keeping up with the all the Microsoft bugs is not so easy.


Kind regards

Share this post

Link to post
On 3/26/2019 at 4:55 AM, Staff said:



It sounds related to a notorious Office 365 bug which Microsoft refuses to patch so far. Please see here:



Verify whether that's really the source of the problem or not.


Kind regards

Oh, Lord! Thank you so much! This has been bugging (no pun intended) for the last 3-4 months. It was working fine and then an update to Office 365 fudged that up. Since then I haven't been able to use Office 365 because it wouldn't connect. I can happily say the instructions on that website worked for me (as of 08/25/2019).


Share this post

Link to post
I also encountered with same problem. As I search for the problem there are many suggestions but not worked any of it. Can any one help me.

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Security Check
    Play CAPTCHA Audio
    Refresh Image

  • Create New...