Jump to content
Not connected, Your IP: 34.239.167.74
ILP

AirVPN + OneNote/Word not connecting

Recommended Posts

Hi everyone,

 

I've been struggling for some time now to make Microsoft OneNote (2016 or win 10) and Word login to my account successfully through AirVPN.

So far no luck, the only way I managed it to work is by changing the DNS server which I do NOT want to do that for security reasons.

 

Has anyone found a better solution?

 

Thank you very much!

Share this post


Link to post

Hello,

I tried the suggested fix last night and I can happily say that it works as expected, OneNote, Word, Windows Store now all work properly!

 

It was a very easy fix and I have spent too much time trying to solve it. However I never noticed that the gateway was empty, I saw it but thought since its a TAP adapter it is how it should be...it seems I was wrong.

This should be sticky somewhere.

I can't thank you enough!

 

As a development suggestion I would say it would be a nice addition to Eddie to auto populate the gateway of the TAP adapter with the gateway of your normal ethernet adapter if its empty. And probably have an app setting to let users override or disable that functionality. That way it will be auto resolved for most users with no technical knowledge.

 

Cheers!

Share this post


Link to post

Hello!

We're very glad to know that the problem has been resolved!

 

Your suggestion is good and we will consider it seriously. With Microsoft, Eddie already implements various fixes (on the tun/tap interface, on global DNS missing implementation on all Windows systems, and even on the "new" crazy DNS handling in Windows 10 after the "Creator" update), although mis-behaving for a bug of someone else is theoretically not the right way to follow and keeping up with all the Microsoft bugs is not so easy.

 

Kind regards

Share this post


Link to post
On 3/26/2019 at 4:55 AM, Staff said:

Hello!

 

It sounds related to a notorious Office 365 bug which Microsoft refuses to patch so far. Please see here:

https://www.macwheeler.com/windows-10-office-365-cannot-connect-over-openvpn-fixed/

 

Verify whether that's really the source of the problem or not.

 

Kind regards


Oh, Lord! Thank you so much! This has been bugging (no pun intended) for the last 3-4 months. It was working fine and then an update to Office 365 fudged that up. Since then I haven't been able to use Office 365 because it wouldn't connect. I can happily say the instructions on that website worked for me (as of 08/25/2019).

 

Share this post


Link to post
I also encountered with same problem. As I search for the problem there are many suggestions but not worked any of it. Can any one help me.

Share this post


Link to post
On 3/26/2019 at 6:55 PM, Staff said:

Hello!

 

It sounds related to a notorious Office 365 bug which Microsoft refuses to patch so far. Please see here:

https://www.macwheeler.com/windows-10-office-365-cannot-connect-over-openvpn-fixed/

 

Verify whether that's really the source of the problem or not.

 

Kind regards


Hi, are there any security issues if I change the default gateway IP as suggested in this article ?

Share this post


Link to post
On 3/26/2019 at 11:55 AM, Staff said:

Hello!

 

It sounds related to a notorious Office 365 bug which Microsoft refuses to patch so far. Please see here:

https://www.macwheeler.com/windows-10-office-365-cannot-connect-over-openvpn-fixed/

 

Verify whether that's really the source of the problem or not.

 

Kind regards


This worked before, but how to fix with new WINTUN (openvpn 2.5) adapter ?

Share this post


Link to post
On 4/23/2020 at 6:35 AM, H8SOCIETY said:

This worked before, but how to fix with new WINTUN (openvpn 2.5) adapter ?


TLDR: Used the same guide with TAP on WINTUN, it works but it is complicated.

I tried to find the information about setting default gateway for WINTUN but the information seem not out there. I tried to use the same process that was used on TAP and do it on WINTUN. The first roadblock is that for me to set the default gateway in WINTUN, I need to set the IP address in Advanced TCP/IP Setting or it will not accept the default gateway. I checked TAP and it appeared that TAP have 'DHCP Enabled' in IP Address, whereas WINTUN does not & there are no option to add 'DHCP Enabled' in WINTUN. So I tried to use Eddie to connect via WINTUN and then disconnect it. I went back to the setting and see that Eddie put down the IP, so I merely add my default gateway to it. Then told Eddie to reconnect again. It seem to work just fine. But I am not sure if it will be a problem. When I start Eddie with WINTUN, it will remove the default gateway. I checked the log and it said "ROUTE_GATEWAY 192.168.29.1" which it seem that it is using the gateway that I put down. When I disconnected Eddie, I went to check the gateway setting in WINTUN, the default gateway is blank. So I have to put my gateway back on in WINTUN every time I disconnect Eddie. The gateway is persistence with TAP, but not in WINTUN. I am curious why WINTUN is not keeping my gateway after disconnection? Perhaps that was intentional or it is a bug?

Share this post


Link to post

Yeah, i checked this method too..... But editing Wintun adapter with every new Eddie Connection is no solution at all. So i switched from Outlook to "eM Client" and it works without any problems.

Share this post


Link to post
4 hours ago, Background said:

Has anyone found a better solution?


The better solution falls on Microsoft's responsibility. They the one who developed NSCI (dating back to 2008) and made the software that fully relies on NSCI without a fallback option, they should be the one to fix their software. I came across a few posts in system admin and networking subs that complained about NSCI and it been causing them problems. This spokes in volume of how much NSCI are PITA in their system. NSCI have their place only if the software have a fallback option. If they didn't include the fallback option, then that is, IMO, a terrible design process.

Honestly, other software that are not developed by MS are functioning fine without NSCI and they don't rely on gateway for network activity. So this is not VPN software problem as they are operating as they should be.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...