Jump to content
Not connected, Your IP: 18.208.132.33
gflaubert

Cannot connect to server anymore

Recommended Posts

Hi

I have problems with ipv6. About a week ago, I lost patience after a large numbers of trials. I tried to connect again yesterday and I counted about 52 automatic trials without success. I read a few posts and got a few ideas. So I enabled logging, and today I installed the latest version of eddie (2.16.3), and also I disabled ipv6 in settings. But it was not enough, eddie is still checking ipv6 and disconnecting. I dont know what to do, so I am attaching 2 log files. Please help.

I use linux mint with the debian 64-bit version of eddie.

 

eddie-logs.zip

Share this post


Link to post

Hello!

 

It's an Eddie bug which checks IPv6 routing even when IPv6 routes are not pushed (our servers do not push IPv6 routes to OpenVPN versions older than 2.4 because such versions had various issues with IPv6).

 

The bug is resolved in Eddie 2.17beta. If you don't feel like testing a beta version, the quick ,alternative workarounds are:

 

1.

  • open "Preferences" > "Networking" from Eddie main window
  • set "IPv6 Layer" to "Block"
  • click "Save"

 

2.

  • upgrade to OpenVPN 2.4.x and don't touch Eddie IPv6 layer configuration.

 

Solution "2." is recommended because it allows you to use IPv6 from AirVPN servers.

 

Kind regards

Share this post


Link to post

I am having the same problem. Will not connect to any server. My computer has IPv6 disabled on the adapter and Eddie already has it set to block. Last week I was able to use it fine and nothing has changed. I have tried many different protocols and ports.

Share this post


Link to post

I think I have the same problem and need some assistance. I tried the first option and then the second one. Here is my log:

 

. 2018.09.24 19.26.47 - Eddie version: 2.17.2 / windows_x64, System: Windows, Name: Windows 10 Pro, Version: Microsoft Windows NT 10.0.17134.0, Mono/.Net: v4.0.30319
. 2018.09.24 19.26.47 - Reading options from C:\Users\User\AppData\Local\AirVPN\default.xml
. 2018.09.24 19.26.47 - Command line arguments (1): path="home"
. 2018.09.24 19.26.47 - Profile path: C:\Users\User\AppData\Local\AirVPN\default.xml
. 2018.09.24 19.26.53 - OpenVPN Driver - TAP-Windows Adapter V9, version 9.21.2
. 2018.09.24 19.26.53 - OpenVPN - Version: 2.4.6 - OpenSSL 1.1.0h  27 Mar 2018, LZO 2.10 (H:\Program Files\AirVPN\openvpn.exe)
. 2018.09.24 19.26.53 - SSH - Version: plink 0.67 (H:\Program Files\AirVPN\plink.exe)
. 2018.09.24 19.26.53 - SSL - Version: stunnel 5.40 (H:\Program Files\AirVPN\stunnel.exe)
. 2018.09.24 19.26.53 - curl - Version: 7.54.1 (H:\Program Files\AirVPN\curl.exe)
. 2018.09.24 19.26.53 - Certification Authorities: H:\Program Files\AirVPN\res\cacert.pem
I 2018.09.24 19.26.54 - Ready
. 2018.09.24 19.26.54 - Collect information about AirVPN completed
I 2018.09.24 19.26.55 - Session starting.
I 2018.09.24 19.26.58 - Checking authorization ...
. 2018.09.24 19.26.59 - IPv6 disabled with packet filtering.
! 2018.09.24 19.26.59 - Connecting to Azmidiske (Sweden, Uppsala)
. 2018.09.24 19.26.59 - OpenVPN > OpenVPN 2.4.6 x86_64-w64-mingw32 [sSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [AEAD] built on Apr 27 2018
. 2018.09.24 19.26.59 - OpenVPN > Windows version 6.2 (Windows 8 or greater) 64bit
. 2018.09.24 19.26.59 - OpenVPN > library versions: OpenSSL 1.1.0h  27 Mar 2018, LZO 2.10
. 2018.09.24 19.26.59 - Connection to OpenVPN Management Interface
. 2018.09.24 19.26.59 - OpenVPN > MANAGEMENT: TCP Socket listening on [AF_INET]127.0.0.1:3100
. 2018.09.24 19.26.59 - OpenVPN > Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
. 2018.09.24 19.26.59 - OpenVPN > Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
. 2018.09.24 19.26.59 - OpenVPN > TCP/UDP: Preserving recently used remote address: [AF_INET]62.102.148.141:443
. 2018.09.24 19.26.59 - OpenVPN > Socket Buffers: R=[65536->262144] S=[65536->262144]
. 2018.09.24 19.26.59 - OpenVPN > UDP link local: (not bound)
. 2018.09.24 19.26.59 - OpenVPN > UDP link remote: [AF_INET]62.102.148.141:443
. 2018.09.24 19.27.02 - OpenVPN > MANAGEMENT: Client connected from [AF_INET]127.0.0.1:3100
. 2018.09.24 19.27.31 - OpenVPN > [uNDEF] Inactivity timeout (--ping-exit), exiting
. 2018.09.24 19.27.31 - OpenVPN > SIGTERM received, sending exit notification to peer
. 2018.09.24 19.27.36 - OpenVPN > SIGTERM[soft,exit-with-notification] received, process exiting
! 2018.09.24 19.27.36 - Disconnecting
. 2018.09.24 19.27.36 - Connection terminated.
. 2018.09.24 19.27.36 - IPv6 restored with packet filtering.
I 2018.09.24 19.27.39 - Checking authorization ...
. 2018.09.24 19.27.40 - IPv6 disabled with packet filtering.
! 2018.09.24 19.27.40 - Connecting to Alula (Sweden, Uppsala)
. 2018.09.24 19.27.40 - OpenVPN > OpenVPN 2.4.6 x86_64-w64-mingw32 [sSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [AEAD] built on Apr 27 2018
. 2018.09.24 19.27.40 - OpenVPN > Windows version 6.2 (Windows 8 or greater) 64bit
. 2018.09.24 19.27.40 - OpenVPN > library versions: OpenSSL 1.1.0h  27 Mar 2018, LZO 2.10
. 2018.09.24 19.27.40 - Connection to OpenVPN Management Interface
. 2018.09.24 19.27.40 - OpenVPN > MANAGEMENT: TCP Socket listening on [AF_INET]127.0.0.1:3100
. 2018.09.24 19.27.40 - OpenVPN > Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
. 2018.09.24 19.27.40 - OpenVPN > Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
. 2018.09.24 19.27.40 - OpenVPN > TCP/UDP: Preserving recently used remote address: [AF_INET]62.102.148.151:443
. 2018.09.24 19.27.40 - OpenVPN > Socket Buffers: R=[65536->262144] S=[65536->262144]
. 2018.09.24 19.27.40 - OpenVPN > UDP link local: (not bound)
. 2018.09.24 19.27.40 - OpenVPN > UDP link remote: [AF_INET]62.102.148.151:443
. 2018.09.24 19.27.43 - OpenVPN > MANAGEMENT: Client connected from [AF_INET]127.0.0.1:3100
! 2018.09.24 19.28.12 - Disconnecting
. 2018.09.24 19.28.12 - Sending management termination signal
. 2018.09.24 19.28.12 - Management - Send 'signal SIGTERM'
. 2018.09.24 19.28.12 - OpenVPN > [uNDEF] Inactivity timeout (--ping-exit), exiting
. 2018.09.24 19.28.12 - OpenVPN > SIGTERM received, sending exit notification to peer
. 2018.09.24 19.28.12 - OpenVPN > MANAGEMENT: CMD 'signal SIGTERM'
. 2018.09.24 19.28.12 - OpenVPN > SIGTERM[hard,] received, process exiting
. 2018.09.24 19.28.12 - Connection terminated.
. 2018.09.24 19.28.12 - IPv6 restored with packet filtering.
I 2018.09.24 19.28.12 - Cancel requested.
! 2018.09.24 19.28.12 - Session terminated.

Share this post


Link to post

I think I have the same problem and need some assistance. I tried the first option and then the second one. Here is my log:

 

Hello!

 

It's a different problem. In your case UDP packets are blocked. Please check any packet filtering tool both in your system and router. If the problem is not caused by any of those maybe your ISP is blocking UDP and/or OpenVPN. In such a case please test the following connection mode:

  • entry-IP address 3
  • protocol TCP
  • port 443

You can change connection mode in Eddie window "Preferences" > "Protocols": untick "Automatic", pick the appropriate mode (the related row will be highlighted in blue) and click "Save".

 

Kind regards

Share this post


Link to post

I am having the same problem. Will not connect to any server. My computer has IPv6 disabled on the adapter

 

Hello!

 

Therefore it sounds like a totally different problem but without log or system report it's not possible to say anything more. Remember to always include them otherwise you might get random, useless help or no help at all. Also consider to open a ticket, our support team will assist you quickly.

 

Kind regards

Share this post


Link to post

 

I think I have the same problem and need some assistance. I tried the first option and then the second one. Here is my log:

 

Hello!

 

It's a different problem. In your case UDP packets are blocked. Please check any packet filtering tool both in your system and router. If the problem is not caused by any of those maybe your ISP is blocking UDP and/or OpenVPN. In such a case please test the following connection mode:

  • entry-IP address 3
  • protocol TCP
  • port 443

You can change connection mode in Eddie window "Preferences" > "Protocols": untick "Automatic", pick the appropriate mode (the related row will be highlighted in blue) and click "Save".

 

Kind regards

I found a setting in my router that had IPv6 disabled. After enabling it, it asks in the IPv6 settings about the Connection type: Native, Static IPv6, Passthrough, FLET's IPv6 service, Tunnel 6to4, Tunnel 6in4, Tunnel 6rd. Which is it? I tried Native, but that didn't work.

Share this post


Link to post

Thank you for your reply, but how do I install openvpn 2.4 ? I searched the site and the help file, and I didn't find a thing. The explanations on the openvpn site are too complex for me.

 

I have eddie 2.16.3 in linux mint 18.3

Share this post


Link to post

I followed your instructions and I think that 2.4.6 was installed. How do I check, please ?

 

Edit

I understand that there should exist a .ovpn file in my home dir. I made a system wide search and I got this:

client.ovpn   274 bytes

sample.ovpn   3.0 k

server.ovpn   328 bytes

all in my home dir.

 

I tried this: sudo openvpn ./server.ovpn

and I got an "options error".

I think I need more help.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...