Jump to content
Not connected, Your IP: 54.152.38.154
Staff

Announcement for Eddie Windows edition users

Recommended Posts

Hello!

 

We would like to inform you that according to hundreds of reports we have been receiving in the last weeks, Eddie 2.10.3 and older versions stopped working properly in Windows 7, 8 and 10. While they seem to run correctly, they are not able to establish any connection with any connection mode.

 

While we ignore the reason of this malfunction, we will probably not investigate, because Eddie 2.10.3 and older versions are no more supported since a long ago.

 

We remind you that Eddie 2.10.3 is a three years old version and that it is deprecated. The only non-deprecated Eddie versions are 2.13.6 and 2.15.2 (as well as 2.16.1 which is currently under testing). We strongly recommend that you don't use any Eddie version older than 2.13.6.

 

We kindly ask you to check your version in "AirVPN" > "About" and upgrade to Eddie latest release if necessary. Eddie for Windows can be downloaded here:

https://airvpn.org/windows

 

Kind regards

AirVPN Staff

Share this post


Link to post

I was using an even older version (one that wasn't even named Eddie) and had this happen. Upgraded to 2.15.2 but seems like the problems are still the same. Very hard to connect to any servers, though some work.

 

Hope the following part of the logs help:
 

- Flushing DNS
- Checking route IPv4
- curl: (7) Failed to connect to salm_exit.airservers.org port 89: Bad access
- Checking route (2° try)
- curl: (7) Failed to connect to salm_exit.airservers.org port 89: Bad access
- Checking route (3° try)
- curl: (7) Failed to connect to salm_exit.airservers.org port 89: Bad access
- Checking route IPv4 failed.

Share this post


Link to post

Interesting I'm on an even older version 2.8.8 - because frankly if it ain't broke don't fix it. Namely I had to go though some hell years back to get tunnel adapter driver version right for any decent throughput performance on winsrv2k8r2 in vm or out, got everything just right finally using older version tap and so was paranoid about the 2.10.x+ installers trying to automatically install a new one - or so I read at the time, along with auto enabling all this network lock stuff I don't need\want by default that I forever pushed off touching anything.  Anyway, I've had no problems of late with 2.8.8 that the post is about. 

 

That said I got the popup message today via the software that I should upgrade, and it's been on my mind anyway (was waiting for 2.16. with ip6 to get stable\mature before screwing with it) but will attempt to move to 2.15.x give the nudge from air and 2.0 infrastructure rolling out.  Can anyone anwser off hand if 2.15.x it's going to try to install the newer tap driver and turn on network lock by default or are those options during\before install now in 2.15.x?  Guess I should go find that old thread thread with the 9.something.2 and .3 driver before starting so I have it as a backup, cause I'm nearly positve the latest will be problematic - for me.

Share this post


Link to post

Interesting I'm on an even older version 2.8.8 - because frankly if it ain't broke don't fix it. Namely I had to go though some hell years back to get tunnel adapter driver version right for any decent throughput performance on winsrv2k8r2 in vm or out, got everything just right finally using older version tap and so was paranoid about the 2.10.x+ installers trying to automatically install a new one - or so I read at the time, along with auto enabling all this network lock stuff I don't need\want by default that I forever pushed off touching anything.  Anyway, I've had no problems of late with 2.8.8 that the post is about. 

 

That said I got the popup message today via the software that I should upgrade, and it's been on my mind anyway (was waiting for 2.16. with ip6 to get stable\mature before screwing with it) but will attempt to move to 2.15.x give the nudge from air and 2.0 infrastructure rolling out.  Can anyone anwser off hand if 2.15.x it's going to try to install the newer tap driver and turn on network lock by default or are those options during\before install now in 2.15.x?  Guess I should go find that old thread thread with the 9.something.2 and .3 driver before starting so I have it as a backup, cause I'm nearly positve the latest will be problematic - for me.

 

 

Network lock will not run at installation and by default does not run when the app is started.  (you can enable it to run at app startup if you wanted to do so)  So, you should be happy with that.

 

I haven't heard much complaining of tap drivers for a while now so the newest one may be OK???  Somebody else will have to answer that specific question. 

Share this post


Link to post

@go558a83nk

 

Thanks so much for the quick anwser about network lock and lack of tap issues with 9.21.x line recently. I'll see what happens at the tail end of the weekend when I plan to attempt and update.

/me crosses fingers. 

Share this post


Link to post

Port 89 is not supported.

 

Check the config generator

 

The interesting thing is that this is when using the AirVPN client so the config generator is not needed. Also nowhere in settings can I find anything about the url or port 89.

Share this post


Link to post

Hi everyone I need some help. I have been using airvpn for a few years now and have been very happy with it. But yesterday when I tried to login it told me I was using an outdated version and to upgrade. I downloaded the new install file from here for my computer (Win 8.0) and installed it. This included installing Eddie, my old UI was not named eddie. Since I have run the install program I have not been able to use airvpn at all. I have tried reading through the guides in the forms here but nothing is working. No matter what I have tried it tries to install the tunnel driver and fails. Please can anyone help me with this? My log is below. Also how do I hide my log with a spoiler tag?

 

. 2018.08.04 12:16:38 - Eddie version: 2.15.2 / windows_x64, System: Windows, Name: Windows 8, Version: Microsoft Windows NT 6.2.9200.0, Mono/.Net: v4.0.30319
. 2018.08.04 12:16:38 - Reading options from C:\Program Files (x86)\AirVPN\default.xml
. 2018.08.04 12:16:38 - Profile options not found, using defaults.
. 2018.08.04 12:16:40 - Command line arguments (0):
. 2018.08.04 12:16:40 - Profile path: C:\Program Files (x86)\AirVPN\default.xml
. 2018.08.04 12:16:42 - Cannot find tunnel adapter.
E 2018.08.04 12:16:43 - OpenVPN Driver - Not available - Will be installed at next connection.
. 2018.08.04 12:16:43 - OpenVPN - Version: 2.4.6 - OpenSSL 1.1.0h  27 Mar 2018, LZO 2.10 (C:\Program Files (x86)\AirVPN\openvpn.exe)
. 2018.08.04 12:16:43 - SSH - Version: plink 0.67 (C:\Program Files (x86)\AirVPN\plink.exe)
. 2018.08.04 12:16:43 - SSL - Version: stunnel 5.40 (C:\Program Files (x86)\AirVPN\stunnel.exe)
. 2018.08.04 12:16:43 - curl - Version: 7.54.1 (C:\Program Files (x86)\AirVPN\curl.exe)
. 2018.08.04 12:16:43 - Certification Authorities: C:\Program Files (x86)\AirVPN\res\cacert.pem
. 2018.08.04 12:16:48 - Updating systems & servers data ...
I 2018.08.04 12:16:48 - Ready
. 2018.08.04 12:16:49 - Systems & servers data update completed
I 2018.08.04 12:18:27 - Checking login ...
! 2018.08.04 12:18:27 - Logged in.
I 2018.08.04 12:18:32 - Session starting.
. 2018.08.04 12:18:32 - Cannot find tunnel adapter.
! 2018.08.04 12:18:32 - Installing tunnel driver
. 2018.08.04 12:18:36 - Cannot find tunnel adapter.
F 2018.08.04 12:18:36 - Driver installation failed.
. 2018.08.04 12:18:48 - Above log line repeated 1 times more
I 2018.08.04 12:18:48 - Session starting.
. 2018.08.04 12:18:48 - Cannot find tunnel adapter.
! 2018.08.04 12:18:48 - Installing tunnel driver
. 2018.08.04 12:18:53 - Cannot find tunnel adapter.
F 2018.08.04 12:18:53 - Driver installation failed.
. 2018.08.04 12:19:04 - Above log line repeated 1 times more
I 2018.08.04 12:19:04 - Session starting.
. 2018.08.04 12:19:04 - Cannot find tunnel adapter.
! 2018.08.04 12:19:04 - Installing tunnel driver
. 2018.08.04 12:19:09 - Cannot find tunnel adapter.
F 2018.08.04 12:19:09 - Driver installation failed.
 

Share this post


Link to post

Hi everyone I need some help. I have been using airvpn for a few years now and have been very happy with it. But yesterday when I tried to login it told me I was using an outdated version and to upgrade. I downloaded the new install file from here for my computer (Win 8.0) and installed it. This included installing Eddie, my old UI was not named eddie. Since I have run the install program I have not been able to use airvpn at all. I have tried reading through the guides in the forms here but nothing is working. No matter what I have tried it tries to install the tunnel driver and fails. Please can anyone help me with this? My log is below. Also how do I hide my log with a spoiler tag?

 

. 2018.08.04 12:16:38 - Eddie version: 2.15.2 / windows_x64, System: Windows, Name: Windows 8, Version: Microsoft Windows NT 6.2.9200.0, Mono/.Net: v4.0.30319

. 2018.08.04 12:16:38 - Reading options from C:\Program Files (x86)\AirVPN\default.xml

. 2018.08.04 12:16:38 - Profile options not found, using defaults.

. 2018.08.04 12:16:40 - Command line arguments (0):

. 2018.08.04 12:16:40 - Profile path: C:\Program Files (x86)\AirVPN\default.xml

. 2018.08.04 12:16:42 - Cannot find tunnel adapter.

E 2018.08.04 12:16:43 - OpenVPN Driver - Not available - Will be installed at next connection.

. 2018.08.04 12:16:43 - OpenVPN - Version: 2.4.6 - OpenSSL 1.1.0h  27 Mar 2018, LZO 2.10 (C:\Program Files (x86)\AirVPN\openvpn.exe)

. 2018.08.04 12:16:43 - SSH - Version: plink 0.67 (C:\Program Files (x86)\AirVPN\plink.exe)

. 2018.08.04 12:16:43 - SSL - Version: stunnel 5.40 (C:\Program Files (x86)\AirVPN\stunnel.exe)

. 2018.08.04 12:16:43 - curl - Version: 7.54.1 (C:\Program Files (x86)\AirVPN\curl.exe)

. 2018.08.04 12:16:43 - Certification Authorities: C:\Program Files (x86)\AirVPN\res\cacert.pem

. 2018.08.04 12:16:48 - Updating systems & servers data ...

I 2018.08.04 12:16:48 - Ready

. 2018.08.04 12:16:49 - Systems & servers data update completed

I 2018.08.04 12:18:27 - Checking login ...

! 2018.08.04 12:18:27 - Logged in.

I 2018.08.04 12:18:32 - Session starting.

. 2018.08.04 12:18:32 - Cannot find tunnel adapter.

! 2018.08.04 12:18:32 - Installing tunnel driver

. 2018.08.04 12:18:36 - Cannot find tunnel adapter.

F 2018.08.04 12:18:36 - Driver installation failed.

. 2018.08.04 12:18:48 - Above log line repeated 1 times more

I 2018.08.04 12:18:48 - Session starting.

. 2018.08.04 12:18:48 - Cannot find tunnel adapter.

! 2018.08.04 12:18:48 - Installing tunnel driver

. 2018.08.04 12:18:53 - Cannot find tunnel adapter.

F 2018.08.04 12:18:53 - Driver installation failed.

. 2018.08.04 12:19:04 - Above log line repeated 1 times more

I 2018.08.04 12:19:04 - Session starting.

. 2018.08.04 12:19:04 - Cannot find tunnel adapter.

! 2018.08.04 12:19:04 - Installing tunnel driver

. 2018.08.04 12:19:09 - Cannot find tunnel adapter.

F 2018.08.04 12:19:09 - Driver installation failed.

 

 

Fully uninstall Eddie and your tap adapter, and reinstall from scratch.

Share this post


Link to post

@Lunabear or others going from really old to newer versions on win7 or higher platforms.

 

I think that can happen going from ndis5 version of tap driver older(9.9.x.x) to ndis6 newer(9.21.x.x)

https://github.com/OpenVPN/tap-windows6/issues/17

 

The work around is apparently to remove the tap driver before upgrading (unless you want to manually add registry entries).

 

@5YmkoLQZ's advice should work, uninstall both, (optionally reboot), Attempt new install of 2.15.2 (run it as 'administrator'\with elevated privileges, tap install should complete.

 

If not and you run into something screwy where the old one doesn't uninstall properly, or you want to manually install new one,

or wipe all traces, or want to roll back to 9.9.x tap after the Eddie upgrade,here are two links that have helped me over the years:

 

https://community.openvpn.net/openvpn/wiki/ManagingWindowsTAPDrivers

 

https://openvpn.net/index.php/open-source/downloads.html [bottom of page is tap driver downloads and warns about the 9.9.x to 9.21.x issue]

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...