Jump to content
Not connected, Your IP: 54.87.61.215
ccp4vpn

ANSWERED Kaspersky Anti-Virus 19.0.0.1088(a) conflict

Recommended Posts

Had no problem whatsoever with the previous version (18.x). The moment I upgraded to the latest KAV build (Stable, not beta, “Technical Release”, etc.) all Hell broke loose

The only way to get connected, is to pause (or shut down) the Anti-Virus.

I’ve tried adding Eddie to the "Trusted Applications", tweak a few things here and there (...), nothing seems to work

 

Any suggestions? (Something that doesn’t include the terms "Downgrade" or "Rollback")

I’m all ears.

Share this post


Link to post

Never used Kaspersky, but maybe only adding Eddie to trusted applications is not enough. Have you checked if other executables such as openvpn.exe or curl.exe that come with Eddie are getting blocked? Also, I'm quite sure that Kasperky reports files/processes it deems malicious. Even if heuristic analysis is the culprit, there must be some report which processes are getting blocked and why. If you want you can post which threats Kaspersky is detecting here, so we can help you determining which processes belong to Eddie and can be trusted.

Share this post


Link to post

That’s the thing: There are no warnings at all, no pop-up messages, no log entries etc. KAV doesn’t detect a *threat*, it just blocks Eddie (which keeps attempting to connect and failing).

I’ve even included "CLI.exe", "curl.exe" and "openvpn.exe" to Kaspersky’s Trusted Applications. Didn’t make a difference. There are still a few executable left out though...

Here’s how it looks so far:

 

KAV2019_Trusted_applications.png

Share this post


Link to post

Strange, does Kapsersky 19 come with a set of firewall rules or uses filter lists to block traffic or anything like that? What do Eddie/OpenVPN logs say? Maybe there is a clue; please also try if using only OpenVPN (without Eddie) works or not.

Share this post


Link to post

Same issue here, got prompted to update to the latest version of Kaspersky and AirVPN won't connect unless you disable the protection. I also have another VPN which has no issues with it.

Share this post


Link to post

Same for me.. glad im not alone. have anyone reported to Kaspersky?

 

Not yet. But I'm waiting for the angry mob to show on Kaspersky forums in the next few hours

As long as V18 works I'll hang fire till Kaspersky issue a fix.

Share this post


Link to post

Had same issue as other posters here and had to uninstall KIS 2019 then re-install 2018 which was a pain. Hope we get an answer / solution from Kaspersky soon.

Share this post


Link to post

That's really wired because I have done Kaspersky antivirus update and it is working fine. However, one of my relative has troubleshooting since the update...

Share this post


Link to post

Hi everybody!

 

I think I have found a solution:

 

Open Eddie --> Preferences --> Protocols --> Select

Protocol: SSL

Port: 28439

IP: 1

 

(Normally, this is the choice before the last one of the list)

 

Then Save

 

 

PS: Please do that before: https://airvpn.org/topic/17433-how-tofix-disconect-problems-with-kaspersky/?hl=kaspersky

 

 

We would like to underline that the problem, if confirmed, is obviously NOT on our side.

 

This is a momentary workaround that can't be accepted as a good solution. It is unacceptable that you are compelled to add an additional tunnel and force OpenVPN to work in TCP mode, causing a serious performance harm,  to bypass a block caused by an application that you are paying for.

 

Kaspesrsky must resolve the problem or, leaving apart technical inadequacy, shadows and doubts of anti-competitive behavior and unfair business practices could thicken as a consequence of this problem.

 

Please keep the thread up to date if you find anything new. We would also recommend that you hammer Kaspersky customer care pushing them to solve the problem in the nearest future.

 

Kind regards

Share this post


Link to post

 

Hi everybody!

 

I think I have found a solution:

 

Open Eddie --> Preferences --> Protocols --> Select

Protocol: SSL

Port: 28439

IP: 1

 

(Normally, this is the choice before the last one of the list)

 

Then Save

 

 

PS: Please do that before: https://airvpn.org/topic/17433-how-tofix-disconect-problems-with-kaspersky/?hl=kaspersky

 

 

We would like to underline that the problem, if confirmed, is obviously NOT on our side.

 

This is a momentary workaround that can't be accepted as a good solution. It is unacceptable that you are compelled to add an additional tunnel and force OpenVPN to work in TCP mode, causing a serious performance harm,  to bypass a block caused by an application that you are paying for.

 

Kaspesrsky must resolve the problem or, leaving apart technical inadequacy, shadows and doubts of anti-competitive behavior and unfair business practices could thicken as a consequence of this problem.

 

Please keep the thread up to date if you find anything new. We would also recommend that you hammer Kaspersky customer care pushing them to solve the problem in the nearest future.

 

Kind regards

 

We know. See the Kaspersky forums for the nightmares others are having with KIS 2019 regarding other apps and web pages.

 

Only one person on the Kaspersky forums has raised the VPN issue and received a half baked response. Remember the issue with KIS 2018 and the length of time it took Kaspersky to solve the problem?

It seems we are back to square one with KIS 2019.

Share this post


Link to post

 

Hi everybody!

 

I think I have found a solution:

 

Open Eddie --> Preferences --> Protocols --> Select

Protocol: SSL

Port: 28439

IP: 1

 

(Normally, this is the choice before the last one of the list)

 

Then Save

 

 

PS: Please do that before: https://airvpn.org/topic/17433-how-tofix-disconect-problems-with-kaspersky/?hl=kaspersky

 

 

We would like to underline that the problem, if confirmed, is obviously NOT on our side.

 

This is a momentary workaround that can't be accepted as a good solution. It is unacceptable that you are compelled to add an additional tunnel and force OpenVPN to work in TCP mode, causing a serious performance harm,  to bypass a block caused by an application that you are paying for.

 

Kaspesrsky must resolve the problem or, leaving apart technical inadequacy, shadows and doubts of anti-competitive behavior and unfair business practices could thicken as a consequence of this problem.

 

Please keep the thread up to date if you find anything new. We would also recommend that you hammer Kaspersky customer care pushing them to solve the problem in the nearest future.

 

Kind regards

 

You only need to change the port from the default 443 to something else, the SSL tunnel is not needed so it should not harm performance. Nevertheless it is still unacceptable from Kaspersky, especially since it is 17 days and counting with no fix.

Share this post


Link to post

I've got the same issue.

Found my own "work around": exit Kaspersky altogether, establish a VPN and then re-enable KAV19.

As this is (of course) unacceptable, I contacted Kaspersky tech support. I send some logs and traces and they found a bug. (2810880)

Tech support was fairly fast, so hopefully they can come up with a fix soon.

Share this post


Link to post

J'ai le même problème avec Kapersky depuis la dernière MAJ de sécurité. La connexion à Air VPN revient si je désactive "Anti-virus internet" et "navagation privée" ainsi que "gestionnaire de programme". Le reste des fonctions ne bloque pas la connexion... mais il y a un problème.

En attendant que Kapersky résolve le problème, comment faire pour revenir à la version précédente ?

Share this post


Link to post

Hello!

 

With the permission of the user, we reproduce here the intercourse between this user and Kaspersky support team, in order to keep you updated and let you know that Kaspersky IS aware of the problem but is not acting effectively to resolve it.

 

Please find attached, if you are interested following my email exchanges
with Kaspersky regarding my claim on AirVPN / Kaspersky bug:

/_20 june 2018 fr__om Kaspersky_  :/
/Dear customer//
//We thank you for your patience.//
//
//Please follow the instructions provided below://
//
//1. Launch Kaspersky Internet Security//
//2. Click Configuration> Protection//
//3. Disable all protection modules.//
//4. Restart your computer.//
//5. Try to connect via AIRVPN.//
//
//Please inform us if it works, please tell us and then do this://
//1. Launch Kaspersky Internet Security//
//2. Click Configuration> Protection//
//3. Activate the Antivirus Files module.//
//
//If it works, please let us know, otherwise activate one by one the
modules until the problem appears (always disabling the other modules so
that it only has one active at a time) and then do what follows://
//
//Please send us the traces of the problem you are having://
//
//1. Disable all components in the protection.//
//Click Configuration (gear icon)> Protect and disable all components
(the switch to the right of each component should turn gray).//
//
//2. Activate only the component of the protection that is recognized as
the source of the error.//
//
//3. Activate the recording.//
//To do this, click on the "Technical Support" icon (headphone icon with
headphones, bottom right of the gear icon), then click "Support Tools"
and then "Activate Registration" , and then restart your computer.//
//
//4. Reproduce the problem.//
//
//5. Disable the recording.//
//To do this, click again on Technical Support> Support Tools and
finally "Disable Registration" (the small red square).//
//
//6. Reactivate all modules of the protection you were using.//
//
//7. Please send us the report of Kaspersky's analysis://
//
//Once the tracing has been deactivated, please click on "Send the
report to the Technical Support" and then on "Save the report" at the
bottom right.//
//Enter the no trace by clicking "Save".//
//
//8. Please send this archive as an attachment, in response to this
message./

//

_Here is *my answer to Kaspersky lab*__on 02 july 2018 _:
-When all modules are disabled, AirVPN Eddie connects normally.

-When only the *Antivirus module files* is activated, the connection is
normal too
-When only *Internet Antivirus* is enabled, Error No AirVPN connection
report in PJ
-*Anti-banners* alone enabled also causes problem, no VPN connection
from the beginning (see PJ)
-*Program Manager *also causes problems after a few minutes. Sometimes
it takes a while to disconnect!
-*Bank protection *also prevents Eddie AirVPN's connection from the very
beginning ...

_Conclusion :_ on modules that do not seem to be problematic at first,
the connection break can occur later !
I feel like I'm doing your job because the problem of incompatibility
seems to appear in most users of AirVPN / Kaspersky/ windows in most
modules at one time or another ... I'm not the alone.
I'm getting discouraged

Share this post


Link to post

Pilou34

Je confirme le contenu de la communication du staff concernant mon échange de mails avec Kapersky sur le bug AirVPN/Kapersky/windows. Quand Kapersky est activé, Eddie ne peut pas se connecter. J'ai eu l'impression d'être "balladée" avec des demandes de manipulations redondantes. J'ai sagement répondu à leurs demandes. Finalement je leur ai répondu que j'avais l'impression qu'ils me faisaient faire leur travail car ils ne peuvent ignorer que les utilisateurs de AirVPN rencontrent le même problème que moi... L'activation des modules de protection de Kapersky rendent impossible la connexion d'Eddie, soit immédiatement soit quelques instants après.

Il est certain qu'on peut s'interroger sur la réalité de leurs efforts pour régler le problème et se poser la question d'une concurrence déloyale de la part d'un fournisseur d'antivirus... et de VPN.

J'attends donc leur réponse.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...