Jump to content
Not connected, Your IP: 100.24.125.162
ccp4vpn

ANSWERED Kaspersky Anti-Virus 19.0.0.1088(a) conflict

Recommended Posts

I had an issue with resolving hosts getting stuck. But since I use third-party DNS servers with dnscrypt, I routed my DNS requests to my normal servers since my requests are also encrypted and I get very good speed with Eddie without that problem. I didn't think it was related to Kaspersky. I figured I just worked around a bug in the current version of Eddie. Now I just need to get help in my other thread for the speed of my router. But not letting Eddie handle DNS requests gets me the full speed of my line over the VPN when using Eddie.

Share this post


Link to post

Anyone having problems still? For about one week, I haven't been able to connect. It just keeps trying new servers to no avail. Just before this happened, I installed an update to Kaspersky which required a reboot. Not sure if it's connected. (Everything works fine on other devices.)

Share this post


Link to post
1 hour ago, Snobbias said:

Anyone having problems still? For about one week, I haven't been able to connect. It just keeps trying new servers to no avail. Just before this happened, I installed an update to Kaspersky which required a reboot. Not sure if it's connected. (Everything works fine on other devices.)


Never mind, I completely uninstalled Kaspersky, still get the "exiting due to fatal error". I'll have to try something else.

Here is the log if anyone else has some advice:

I 2019.12.28 21:09:11 - Session starting.
I 2019.12.28 21:09:11 - Checking authorization ...
. 2019.12.28 21:09:11 - IPv6 disabled with packet filtering.
! 2019.12.28 21:09:11 - Connecting to Alphirk (Netherlands, Alblasserdam)
. 2019.12.28 21:09:11 - OpenVPN > OpenVPN 2.4.6 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [AEAD] built on Apr 27 2018
. 2019.12.28 21:09:11 - OpenVPN > Windows version 6.2 (Windows 8 or greater) 64bit
. 2019.12.28 21:09:11 - OpenVPN > library versions: OpenSSL 1.1.0h  27 Mar 2018, LZO 2.10
. 2019.12.28 21:09:11 - Connection to OpenVPN Management Interface
W 2019.12.28 21:09:13 - No connection could be made because the target machine actively refused it 127.0.0.1:3100
. 2019.12.28 21:09:13 - OpenVPN > Outgoing Control Channel Encryption: Cipher 'AES-256-CTR' initialized with 256 bit key
. 2019.12.28 21:09:13 - OpenVPN > Outgoing Control Channel Encryption: Using 256 bit message hash 'SHA256' for HMAC authentication
. 2019.12.28 21:09:13 - OpenVPN > Incoming Control Channel Encryption: Cipher 'AES-256-CTR' initialized with 256 bit key
. 2019.12.28 21:09:13 - OpenVPN > Incoming Control Channel Encryption: Using 256 bit message hash 'SHA256' for HMAC authentication
. 2019.12.28 21:09:13 - OpenVPN > TCP/UDP: Preserving recently used remote address: [AF_INET]109.202.107.149:443
. 2019.12.28 21:09:13 - OpenVPN > Socket Buffers: R=[65536->262144] S=[65536->262144]
. 2019.12.28 21:09:13 - OpenVPN > TCP/UDP: Socket bind failed on local address [AF_INET]192.168.1.100:1194
. 2019.12.28 21:09:13 - OpenVPN > Exiting due to fatal error
! 2019.12.28 21:09:13 - Disconnecting
. 2019.12.28 21:09:13 - Connection terminated.
. 2019.12.28 21:09:13 - IPv6 restored with packet filtering.
I 2019.12.28 21:09:15 - Cancel requested.
! 2019.12.28 21:09:15 - Session terminated.

EDIT: Trying the portable version it works. I can live with that.

 

Share this post


Link to post
On 1/7/2020 at 8:07 PM, goduke said:

Why you use old version of openvpn  2.4.6 from 04/2018 ?

Latest is 2.4.8
https://openvpn.net/community-downloads/


Do you have issues with Eddie or openvpn (from above link) ?



I installed from your link, but Eddie still uses 2.4.6. How do I make Eddie use the new version of Openvpn?

It works fine when importing ovpn-file, but I can't find any network lock (maybe not available in that software?)

I've used Eddie for two years without problems, so I'm still curious why it's not working anymore using the old version of openvpn. If I try to import using a custom path to the new openvpn I get this error:


. 2020.01.11 21:35:29 - Unexpected bundle executable error openvpn (C:\Program Files\OpenVPN\bin\openvpn-gui.exe). Dumping report.

I'd also like to know why the latest openvpn isn't integrated with Eddie in the first place.
Cheers!

(Please quote on reply so I get notified)

 

Share this post


Link to post

Just for test i downloaded latest stable Eddie (eddie-ui_2.16.3_windows-7_x64_portable) and i see it uses OpenVPN 2.4.6.
If you wanna use OpenVPN 2.4.8 you could copy "c:\Program Files\OpenVPN\bin\openvpn.exe"  (OpenVPN 2.4.8) to folder, where you have Eddies version of  OpenVPN 2.4.6 (openvpn.exe) located.


As for portable 
Eddie it works fine.
After modification check Eddie - Logs to see if it loads OpenVPN 2.4.8 or 2.4.6.


edit
Or can you just choose experminetal version of Eddie, (edit2, just checked what is inside "eddie-ui_2.18.5_windows-7_x64_portable.zip", it is OpenVPN version 2.4.7).

 .

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...