Jump to content
Not connected, Your IP: 100.26.179.196
Staff

Eddie 2.13beta released

Recommended Posts

 

 

Confirmed, will be fixed in the next release.
 

Running 2.13.3 on my Manjaro Linux system.
 
It won't connect to any server with the "Check AirVPN DNS" setting enabled....it tries 3 times then fails, moving on to the next server and failure.

 

Hello!
 
Eddie 2.13.4beta is now available in experimental section.
 
Changelog 2.13.3 -> 2.13.4

[bugfix] Windows - Speed Tab
[new] Report different IPv4 and IPv6 exit addresses
[bugfix] Autofix of relative path in .ovpn configs
[new] Detection of exit-IP address when using OpenVPN provider
[change] New System Report window
[change] Better dump of failed HTTP requests with detection of 302 redirection (typical hotel login)
[change] macOS - Dump additional info if PF failed to start.
[change] Network Lock -> Allow DNS - Now default to false. Added warning if hostname is used in routes
[new] macOS - Multi-provider UI interface
[new] New UI option to skip processes check
[change] macOS - Internal cleanup of some shell
[change] macOS - Network Lock, changed denied packets from 'drop' to 'return'
[bugfix] Linux - OpenVPN in portable edition now built with enable-iproute2 flags.
[bugfix] Linux - Better DNS resolution method (compatible if 'host' is not available)
[change] Linux - Improved DNS flush
[bugfix] Linux - Pinger issue
[change] Linux - Some fixes on Manjaro/OpenSUSE and other distro
[change] Linux - Improved UI responsiveness
[change] Improved checks if a Network Lock mode is available
[bugfix] Linux - Better detection if Network Lock is started
[change] macOS - Network lock, allow IPv6 in LAN
[change] Hostname/DNS in custom routes resolved before the activation of Network Lock

About macOS, the issue about "Checking Environment" is still under investigation. Please report if something has changed in this version. If it still doesn't work, try to uncheck "Preferences -> Advanced -> Skip processes checking" and report if that resolves the issue. Thanks.
The issue about slow connection we hope are now resolved.

We hope that problems with some distribution, such as Manjaro and openSUSE, are now resolved. Please test.
 
Kind regards

Every time my Mac goes to sleep when connect to the vpn and I wake it hours later it keeps getting stuck on. "Waiting for latency tests (3 to go)".

I get that same message time and it does not go away. I Did not have this issue on 2.13.3 But it keeps occurring on 2.13.4

I also get stuck  at "Waiting for latency tests (3 to go)" every time I start Eddie and it is set to automatically connect to a vpn.

I captured a log right after the error occurred.

new Eddie_20170818_185947 copy.txt

Startup "Waiting for latency tests (3 to go)" log

startup connection log.txt

Share this post


Link to post

I have been using eddie 2.13.3 (and previous betas ) on linux quite successfully without any problems until today when I have updated to 2.13.4

 

copy of the log :

 

Eddie_20170819_051722.txt

 

The lines  in the log of interest are :

 

F 2017.08.19 05:16:21 - ip6tables v1.6.1: can't initialize ip6tables table `filter': Address family not supported by protocol
F 2017.08.19 05:16:21 - Perhaps ip6tables or your kernel needs to be upgraded.
 
This is stopping eddie connecting and it stalls at "waiting for latency tests - (3 to go) "
 
Anyone any ideas as to I can alter my settings to make it work please ?
 
I do not have  a 2.13.3 .deb file to downgrade ..............
 
Are the previous beta editions available for download from  anywhere ?
 
thanks
pjnsmb
 
 
 
 
 

 

 

 

 

 

 

 

 

 

 

 

Share this post


Link to post

Updated my Win 10 64bit OS to v2.13.4 from a clean install this morning. Have noticed that when eg opening my browser it would hang for a while before connecting and the same happened when accessing my other internet browsing shortcuts. Found a solution which entailed that, as soon as the browser/internet link opens and starts hanging, I exit it and immediately re-open it and it connects very fast the second time. Anyone have any ideas on why this happens?.

Share this post


Link to post
Guest

Hello.

Installed Eddie 2.13.4 Beta and when I try to connect to a recommended Server a message pops up and Eddie freezes. Network Lock is activated. Can't close the message or Eddie. I have to restart the PC. Below a screenshot of the message.

I use Linux Mint 18 64-bit and IPv6 is deactivated on my PC and on Eddie.

Hope this info helps to enhance Eddie.

Regards

 

Edit

With deactivated Network Lock Eddie is in an endless loop of waiting for latency tests (3 to go).

Screenshot below.

Can confirm and i am on windows 10 so it's a general issue.

obo0Sxi.png

Share this post


Link to post

 

Hello.

Installed Eddie 2.13.4 Beta and when I try to connect to a recommended Server a message pops up and Eddie freezes. Network Lock is activated. Can't close the message or Eddie. I have to restart the PC. Below a screenshot of the message.

I use Linux Mint 18 64-bit and IPv6 is deactivated on my PC and on Eddie.

Hope this info helps to enhance Eddie.

Regards

 

Edit

With deactivated Network Lock Eddie is in an endless loop of waiting for latency tests (3 to go).

Screenshot below.

Can confirm and i am on windows 10 so it's a general issue.

obo0Sxi.png

 

Same on mac os sierra 10.12.6 !

Share this post


Link to post

Eddie 2.13.5beta has been released.

 

[bugfix] Waiting for latency tests
[bugfix] Linux - IPv6 issue with Network Lock

 

Sorry for the issue with 2.13.4.

 

Kind regards

Share this post


Link to post

 

I have been using eddie 2.13.3 (and previous betas ) on linux quite successfully without any problems until today when I have updated to 2.13.4

 

copy of the log :

 

attachicon.gifEddie_20170819_051722.txt

 

The lines  in the log of interest are :

 

F 2017.08.19 05:16:21 - ip6tables v1.6.1: can't initialize ip6tables table `filter': Address family not supported by protocol
F 2017.08.19 05:16:21 - Perhaps ip6tables or your kernel needs to be upgraded.
 
This is stopping eddie connecting and it stalls at "waiting for latency tests - (3 to go) "
 
Anyone any ideas as to I can alter my settings to make it work please ?
 
I do not have  a 2.13.3 .deb file to downgrade ..............
 
Are the previous beta editions available for download from  anywhere ?
 
thanks
pjnsmb

 

 

problem sorted 

 

thanks a lot staff

 

pjnsmb

Share this post


Link to post

I am using Eddie 2.13.5beta on Mac Sierra 10.12.6, Mono/.Net Framework: v4.0.30319.

 

So far the issue of getting stuck on "Checking Environment" is resolved if in:

 

Eddie Preferences > Advanced > "Skip processes checking" is enabled (checked).

 

I have not encountered any other issue in this release so far, however, the stability of Eddie  when trying to reconnect after Mac OS is awakened from sleep (the ability to reconnect, keep the connection and not to freeze or go to connect/disconnect loop) should be extensively tested [i encountered this issue in 2.12.4 stable], I will update my post if find any issues with this release. Thank you AirVPN developers to address the "Checking Environment" issue, I was using Tunnel Blick for so long! but not anymore

 

Thanks!

Share this post


Link to post

with 2.13.5 Eddie still locks up with the dialog box about disabling IPv6. 

 

I also had an instance of the GUI disappearing as I went to look at preferences.

 

This on Mint 18.2, a virtualbox VM with windows 10 host.

Share this post


Link to post

i re-installed win8.1 and took the new 2.13.5 version of the AirVPN Client, and everything is working as long as i am not connected to any server.

 

but... when i'm connected to a server and go to the "Server" tab and click on the "Refresh connections list, ping results, discovered information" button, the list is actually not refreshing.

and when i disconnect from the server i am connected to, it's working again.

 

is it a problem on my end or...?


“We rip out so much of ourselves to be cured of things faster than we should that we go bankrupt by the age of thirty and have less to offer each time we start with someone new. But to feel nothing so as not to feel anything—what a waste!”
André Aciman

Share this post


Link to post

 

F 2017.08.19 05:16:21 - ip6tables v1.6.1: can't initialize ip6tables table `filter': Address family not supported by protocol

problem sorted  

thanks a lot staff

 

You can anyway:

1- Launch Eddie

2- Go to Preferences -> Log -> tick Log Debug

3- Enable Network Lock

4- Disable Network Lock, de-tick Log Debug

5- Go to Log -> click Support (lifebelt) button, and send to me (PM) or open a ticket with the report? Thx.

 

Ok, i don't need this anymore, thx anyway.

Share this post


Link to post

So far the issue of getting stuck on "Checking Environment" is resolved if in:

You can de-check temporarly 'Skip processes checking' and send the same report with 'debug log' i asked above? Thx.

 

It's very strange, it seem that Eddie stuck when run "ps -eo pid,command".. The new option checked simply skip it.

Share this post


Link to post

Updated from 2.12.4 to 2.13.5 and confirmed working on WIN 8.1 x64  

 

A few Questions:

 

1. Why is Network lock - Windows Firewall not recommended and how does Automatic / filtering platform mode work?

3. What is skip processes checking & Multi-Providers support ?

4. What function has Experimental checkbox under ensure dns lock?

Share this post


Link to post

1. Why is Network lock - Windows Firewall not recommended and how does Automatic / filtering platform mode work?

Only because are redundant. WPF 'Filtering platform' it's the recommended, 'Windows Firewall' was the first method, and now must be used only temporarly if some issue/bug with WPF exists. Maybe deprecated in future if WPF works for all.

3. What is skip processes checking

If checked, Eddie skip to check if OpenVPN (or stunnel/ssh tools) are already running. We add an option because some users on macOS have an issue with it.

& Multi-Providers support ?

If checked, Eddie can be used with any VPN providers. See https://airvpn.org/topic/19909-eddie-with-other-providers-or-custom-openvpn-configuration-files/

4. What function has Experimental checkbox under ensure dns lock?

Don't check it. Sometime we put some additional stuffs to understand issue for debugging purpose, and we ask to specific people to check it.

Share this post


Link to post

This on Mint 18.2, a virtualbox VM with windows 10 host.

I tested a Mint 18 Sarah, no issue (video).

with 2.13.5 Eddie still locks up with the dialog box about disabling IPv6.

What do you mean exacly? You can't click the button (neither Yes and No?) or stuck after click?

I also had an instance of the GUI disappearing as I went to look at preferences.

It's reproducible? Occur any time? Thx.

Share this post


Link to post

Hi...

On opensuse TW eddie-ui_2.13.5_linux_x64_rpm.rpm has problems to start...

This is the message I see:

airvpn
I 2017.08.22 20:14:46 - Eddie version: 2.13.5 / linux_x64, System: Linux, Name: Welcome to openSUSE Tumbleweed 20170817 - Kernel \r (\l).eno1: \4{eno1} \6{eno1}, Version: Linux linux-ohkx 4.12.7-1-default #1 SMP PREEMPT Sun Aug 13 08:27:21 UTC 2017 (7dae241) x86_64 x86_64 x86_64 GNU/Linux, Mono/.Net Framework: v4.0.30319
. 2017.08.22 20:14:46 - Reading options from /root/.airvpn/AirVPN.xml
. 2017.08.22 20:14:47 - Command line arguments (1): path="/root/.airvpn"
I 2017.08.22 20:14:48 - OpenVPN Driver - Found, /dev/net/tun
I 2017.08.22 20:14:48 - OpenVPN - Version: 2.4.2 - OpenSSL 1.0.2l-fips  25 May 2017, LZO 2.10 (/usr/sbin/openvpn)
I 2017.08.22 20:14:48 - SSH - Version: OpenSSH_7.2p2, OpenSSL 1.0.2l-fips  25 May 2017 (/usr/bin/ssh)
W 2017.08.22 20:14:48 - SSL - Not available
I 2017.08.22 20:14:48 - curl - Version: 7.54.1 (/usr/bin/curl)
I 2017.08.22 20:14:48 - Certification Authorities: /usr/share/AirVPN/cacert.pem
. 2017.08.22 20:14:48 - Updating systems & servers data ...
! 2017.08.22 20:14:48 - Ready
. 2017.08.22 20:14:48 - Systems & servers data update completed
I 2017.08.22 20:14:51 - Session starting.
mono: Fatal IO error 11 (Recurso no disponible temporalmente) on X server :0.0.

 

eddie-ui_2.12.4_linux_x64_rpm.rpm is OK

Share this post


Link to post

 

This on Mint 18.2, a virtualbox VM with windows 10 host.

I tested a Mint 18 Sarah, no issue (video).

>with 2.13.5 Eddie still locks up with the dialog box about disabling IPv6.

What do you mean exacly? You can't click the button (neither Yes and No?) or stuck after click?

I also had an instance of the GUI disappearing as I went to look at preferences.

It's reproducible? Occur any time? Thx.

 

 

 

I can't click any button, yes or no.

 

No, GUI disappearance isn't reproducible. 

Share this post


Link to post

I had Eddie running and my I put my Mac to sleep, the next day I woke my Mac and the kernel panicked, looking at Eddie logs it looks like it might of caused it.

 

The panic occurred around 2017.08.22 15:55 

Here is the log eddie_2017-08-22.log 3.zip

Share this post


Link to post

Whats the button for? Can not be pressed....

 

It's meant to rename an .ovpn profile if a non-AirVPN provider is used.

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...