Jump to content
Not connected, Your IP: 54.161.31.247
Stan464

Issues With New DD-WRT OpenVPN Config Since Update

Recommended Posts

Hi All,

 

Since the Update, Im unable to connect via my DD-Wrt Setup Router, Using the OpenVPN Client..

 

I've Re-Downloaded the Keys/Certs & Re-Copied them, Iv'e checked 3 Times to see if they are in the correct Boxes.

 

 

 

Iv'e tried Adding the "TLS-DHE-RSA ETC" 256 Bit.

 

But it sticks & dosn't even Log anything. Does Nothing..

 

When i Choose "None" It goes into a Loop.

 

 

******Date & TIme Is Correct" As that error does point to a date error, but the date is fine.. as ive said, everything has been working Prior to the update...*****

 

 

 

 

 

 

Share this post


Link to post

 

Checked that Guide, Sadly "Tomato" isnt "Dd-Wrt" Nor Is the Setup Sequence very close. 

As the options & Settings are displayed differentley.

 

But The 2nd Image does have Similarities, But i have Entered the "Static Key"

 

 

But thanks though .

 

It Did "Jack All" lol.

 

Also Changed the "TLS" To "TLS-DHE-256-SHA" ETC.

 

But it does "Jack" Aswell...

Share this post


Link to post

I have a Asus n66u using merlinware which the modems openvpn page says my openvpn client is running but none of my traffic is runnig through it. Once I upload the .ovpn file all the configuration files are filled in automatically including the 2048 static key. In the custom configuration I insert

 

resolv-retry infinite
ns-cert-type server
comp-lzo no
explicit-exit-notify 5

 

I'm not sure what I am doing wrong. The Hmac is set to Outgoing (1). All the configuration files are filled in.

Share this post


Link to post

Sadly Since the update, it has made my paid VPN Service utter useless,

I Did everything from scratch 3 Times with the same result..

Share this post


Link to post

Hello all,

 

Having similar issues here on DD-WRT. I have upgraded all certificates and added the new Static Key as well. As far as the "EXTRA HMAC AUTHORIZATION (TLS-AUTH)" goes.... I don't see this option in dd-wrt.

 

I've attempted to add a screenshot but the 27.32k upload limit will not let me attached my images...

 

 

 

 

Share this post


Link to post

Hello all,

 

Having similar issues here on DD-WRT. I have upgraded all certificates and added the new Static Key as well. As far as the "EXTRA HMAC AUTHORIZATION (TLS-AUTH)" goes.... I don't see this option in dd-wrt.

 

I've attempted to add a screenshot but the 27.32k upload limit will not let me attached my images...

 

Hello!

 

You should see a "TLS Cipher" combo box in your DD-WRT OpenVPN client configuration page. Different builds need different settings according to a confusing pattern that we can't identify. Some work with "None" and some work with "TLS-DHE-RSA-WITH-AES-128-CBC-SHA" (both wrong, but they work...).

 

The upload limit is around 1 MB per picture, can you please try again?

 

Kind regards

Share this post


Link to post

Hello!

 

Ok. The "TLS Cipher" is wrong. Try with "None". If it does not work, try with "TLS-DHE-RSA-WITH-AES-128-CBC-SHA".

 

Check keys and certificates carefully. TLS Auth is empty, you need to paste there ta.key. Delete everything from "Static key".

 

Kind regards

Share this post


Link to post

Okay!! Success! Got it working now. It ends up I was putting the TLS auth in the wrong spot. The words "static key" were throwing me for a loop.

 

Attached are my new settings. Hopefully this will help others out.

 

Thanks AirVPN for the great support as always.

 

Share this post


Link to post

Sometimes you might run into issues with explicit-exit-notify 5 as well, so you may have success with removing that line (I think the latest version of OpenVPN just ignores it, but the older versions would hang on it)

Share this post


Link to post

does the 128 mean it is less secure?

 

Hello!

 

No, the Data Channel remains encrypted with AES-256-CBC cipher, regardless of what DD-WRT pretends. Our servers are not configured to provide an AES-128 OpenVPN Data Channel cipher. It's just one of the many DD-WRT OpenVPN configuration page bugs.

 

Kind regards

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...