Jump to content


Photo

Careful: ncurses 6.1-3 on Arch breaks Eddie

arch eddie ncurses

Best Answer Clodo, 20 February 2018 - 07:20 PM

Thx for the feedback.
As explained here a bugfix exists: https://github.com/lewurm/mono/commit/f1361193d559a132cc356e03d2673bbcb9a05277 not sure when it will be deployed on AUR.
In the meantime, to avoid downgrade of ncurses,

TERM=xterm

it's a working workaround.

Go to the full post


  • Please log in to reply
5 replies to this topic

#1 ezd

ezd

    Member

  • Members
  • PipPip
  • 17 posts

Posted 18 February 2018 - 07:03 PM

On Arch I 

 

upgraded ncurses (6.0+20170902-3 -> 6.1-3)
 

 

 which broke eddie. There were lots of error messages and I downgraded again. Now it works again.



#2 LZ1

LZ1

    It's nice to be nice to nice people

  • Moderators
  • 1800 posts

Posted 18 February 2018 - 07:37 PM

Hello!

 

If by downgraded you mean you were using the experimental, then please post here.


Hi there, are you new to AirVPN? Many of your questions are already answered in this guide. Its Guides Section has guides on Linux/Torrenting/Blocked sites & many other topics too.
Moderators do not speak on behalf of AirVPN. Only the Official Staff account does. Please read the First Questions section in the link above for more details, thank you.
Did you make a guide or how-to for something? Then contact me to get it listed in my new user guide's Guides Section, so that the community can find it more easily.

Tired of Windows? Why Linux Is Better.

#3 ezd

ezd

    Member

  • Members
  • PipPip
  • 17 posts

Posted 18 February 2018 - 07:47 PM

Sorry, no, I downgraded ncurses to the previous version (as in the upgrade path).



#4 pingo_doce

pingo_doce

    Newbie

  • New Members
  • Pip
  • 1 posts

Posted 19 February 2018 - 08:59 PM

I can confirm this.

 

Eddie runs fine with ncurses 6.0+20170902-3 and fails to even start with ncurses 6.1-3.

This holds true for both Eddie 2.13.6 and 2.14.2 (experimental). I use the mono version btw.

 

System here ist Antergos Linux with kernel 4.15.3.



#5 ezd

ezd

    Member

  • Members
  • PipPip
  • 17 posts

Posted 20 February 2018 - 07:25 AM

If you're on Arch too and still want to keep your system updated you can always use the --ignore option:

 

 

sudo pacman -Syu --ignore=ncurses

# or if you use pacaur like me:

pacaur -Syu --ignore=ncurses
 


#6 Clodo

Clodo

    AirVPN Team

  • Staff
  • PipPipPip
  • 273 posts
  • LocationItaly

Posted 20 February 2018 - 07:20 PM   Best Answer

Thx for the feedback.
As explained here a bugfix exists: https://github.com/lewurm/mono/commit/f1361193d559a132cc356e03d2673bbcb9a05277 not sure when it will be deployed on AUR.
In the meantime, to avoid downgrade of ncurses,

TERM=xterm

it's a working workaround.







Similar Topics Collapse

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Servers online. Online Sessions: 14008 - BW: 35381 Mbit/sYour IP: 54.162.227.37Guest Access.