Jump to content


Photo

win10 : airvpn gui main windows dissapeared - tray works??

airvpn client windows 10

  • Please log in to reply
16 replies to this topic

#1 bts3232

bts3232

    Newbie

  • New Members
  • Pip
  • 1 posts

Posted 06 March 2016 - 08:44 AM

suddenly when i start up airvpn client in windows 10 i do not see the login page, but the tray icon dissapears, it is like the main window is 'off screen'. (taskbar appears as well as working tray icon through which i can connect. anybody else has these problems, thanksq



#2 sfasdfs

sfasdfs

    Newbie

  • New Members
  • Pip
  • 2 posts

Posted 08 March 2016 - 09:40 AM

I'm having the same issues on Windows 10 but also on Windows 8.1... No tray icon sometimes and not sure how to bring the GUI back without the tray icon.

 

On Windows 8.1 I've had this issue for years now. The tray icon sometimes dissapears when minimizing. In Win10 the AirVPN tray icon is often gone after coming back out of sleep, but AirVPN is still running in the background (no way to control it through GUI though). 

 

 

Kind of an irritating bug that has been around for very long... 



#3 elviin

elviin

    Newbie

  • New Members
  • Pip
  • 1 posts

Posted 16 March 2016 - 07:25 AM

For Windows 7 it is ok for me. But for Mac OSX 10.11.13 I can see just the main top bar. There is no login window.



#4 mr_anderson

mr_anderson

    Newbie

  • New Members
  • Pip
  • 1 posts

Posted 20 March 2016 - 03:20 AM

Just started doing this to me in Windows 7 yesterday. I've uninstalled and reinstalled, don't know what else to do, and would appreciate some suggestions.



#5 mehāniskākaravīrs935

mehāniskākaravīrs935

    Advanced Member

  • Members
  • PipPipPip
  • 146 posts
  • LocationUranus

Posted 21 March 2016 - 05:56 PM

I personally have not had this issue, but i would reccomend reinstalling and if issues persist submit a support ticket.



#6 CL4PTP

CL4PTP

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 26 July 2016 - 10:51 PM

I am having this problem also. With both the stable and beta release.



#7 LZ1

LZ1

    It's nice to be nice to nice people

  • Moderators
  • 1801 posts

Posted 26 July 2016 - 11:03 PM

Hello !

Do the windows event logs say anything?


Hi there, are you new to AirVPN? Many of your questions are already answered in this guide. Its Guides Section has guides on Linux/Torrenting/Blocked sites & many other topics too.
Moderators do not speak on behalf of AirVPN. Only the Official Staff account does. Please read the First Questions section in the link above for more details, thank you.
Did you make a guide or how-to for something? Then contact me to get it listed in my new user guide's Guides Section, so that the community can find it more easily.

Tired of Windows? Why Linux Is Better.

#8 Zod

Zod

    Newbie

  • New Members
  • Pip
  • 1 posts

Posted 29 September 2016 - 01:02 PM

Killing explorer.exe and restarting it brings the icon back for me on Win10.



#9 Dewey Banks

Dewey Banks

    Member

  • Members
  • PipPip
  • 10 posts

Posted 08 July 2017 - 06:42 PM

I am running Windows 10 64 bit and have been using airvpn for about six months now.  I have had occasional problems with the GUI disappearing and up till now killing the procedures and restarting the program has been the answer.  However, all of a sudden this morning, I run airvpn and no GUI displays so I have zero control over my VPN.  I can't even tell if its on or off.  Restarting and killing the procedures doesn't help anymore.  This is very frustrating.  I love airvpn - consider it best vpn option out there but now if I can't resolve this issue in a timely manner I'm going to have switch to one of the less reputable ( really it seems most all these companies except air are simply 'me too's' in it for qwuick bucks and how can you trust them? ) options out there.  This situation sucks.  Any advice would be more than appreciated.

 

Many thanks in advance for your input,

DB



#10 Clodo

Clodo

    AirVPN Team

  • Staff
  • PipPipPip
  • 273 posts
  • LocationItaly

Posted 09 July 2017 - 11:43 AM

I never encounter this issue, and i need help to understand why this happen. It's also reported on github issue tracker.
I found a lot of similar issue around, for example about PIA and also in other kind of software, ex. Probably it's a Windows issue.

If anyone hit this issue, please report:

1- OS

2- What has disappeared exactly, tray icon or window or both?

3- If tray icon, check if was automatically moved by Windows under the arrow-up icon e17f36c4cabb9e5e59677641a6fd8cc1181e0be8.

4- If both, is Eddie really running? Is AirVPN.exe process is running, or only openvpn.exe?

4- Did it happen randomly or after an action (resume from sleep, only at boot, minimizing the window etc.)? Is it reproducible?

5- If tray icon, is it restored by killing "explorer.exe" and restarting it?

Thanks for any feedback.



#11 blq

blq

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 14 July 2017 - 10:31 AM

I´m also having this issue for the last week.

 

Windows 10 Home edition

Both window and tray icon disappeared, although monitor ("Ctrl+Capitals+Esc") shows Eddie is there and running.

I had none of them (AirVPN.exe / openvpn.exe) but "Eddie - Windows UI"

It happened randomly, although I restarted several times and the problem was there (I was not able to see neither the window nor the icon tray at any time).

I've restarted twice the explorer and it is back now. After the first restart, the problem was still there.



#12 species8472

species8472

    Newbie

  • New Members
  • Pip
  • 1 posts

Posted 22 August 2017 - 02:53 AM

me too.

restarting doesn't help, reinstalling doesn't help, ending tasks doesn't help.

1- Windows 10

2- What has disappeared exactly, tray icon or window or both? just window

3- If tray icon, check if was automatically moved by Windows under the arrow-up icon

nope.

4- If both, is Eddie really running? Is AirVPN.exe process is running, or only openvpn.exe? yes

4- Did it happen randomly or after an action (resume from sleep, only at boot, minimizing the window etc.)? Is it reproducible? it started when i got a 4K monitor but i also have my regular monitor and it won't show up on either display. sometimes it works if i set my 4k mintor to 100%, anything else breaks it.

5- If tray icon, is it restored by killing "explorer.exe" and restarting it? no



#13 soma11

soma11

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 24 January 2018 - 10:50 AM

If anyone hit this issue, please report:

1- OS

2- What has disappeared exactly, tray icon or window or both?

3- If tray icon, check if was automatically moved by Windows under the arrow-up icon e17f36c4cabb9e5e59677641a6fd8cc1181e0be8.

4- If both, is Eddie really running? Is AirVPN.exe process is running, or only openvpn.exe?

4- Did it happen randomly or after an action (resume from sleep, only at boot, minimizing the window etc.)? Is it reproducible?

5- If tray icon, is it restored by killing "explorer.exe" and restarting it?

Thanks for any feedback.

 
 
# updated
 
 
Hi, I have experienced the missing tray icon since my very first installation of Eddie (2.13.6).
 
I have noticed that this issue seems much related to another topic.
 
 
1. Windows 8.1 64-bit
 
2. The "GUI" and "tray icon" is missing in explorer.exe
 
3. No, "tray icon" is not under the "arrow-up" icon
 
4.a. Yes, everything seem to be working fine in the background, only missing the visual part in explorer
 
4.b. It only happens when the option "start with windows" is checked OR if "Eddie" is manually set to start with windows in the "Task Scheduler"
 
5. Yes, the "tray icon" is showing again, if a new instance of "explorer.exe" is created after ALL instances of explorer have been killed
 
 
I guess, maybe one possible solution would be to delay the GUI a little WHEN "start with windows" is checked. Then I would assume explorer could be fully loaded BEFORE the instance of the GUI is running.
 
 
I hope you find an easy solution for the conflicting issue with windows.
 
 
 
# Temporary Solution
 
 I posted the following "temporary solution", in the topic referred to above, which is to refresh explorer in a Task:
 
 

  • Make sure "Start with windows" is checked in Eddie
     
  • Run 'Task Scheduler' by using "WINDOWS BUTTON + r" and type 'taskschd.msc' followed by "Enter"
     
  • Select "Create Task" and a dialog should popup
     
  • At the "General" tab, write some name (e.g. Delayed Explorer or Refresh Tray Icons)
     
  • Select the "Tiggers" tab and click on "New...". Then select "At log on" in the dropdown-list of "Begin the task" and click "OK"
     
  • Select the "Actions" tab and click on "New...". Then select "Start a program" in the dropdown-list of "Action". Then write 'C:\Windows\explorer.exe' in the "Program/script" text field and click "OK"
     
  • Select the "Conditions" tab and make sure everything is unchecked
     
  • Select the "Settings" tab and make sure everything is unchecked. Then select "Stop the existing instance" in the dropdown-list of the "If the task is already running, (...)". Finally click "OK" to finish the task.
The new task can be seen in the "Task Scheduler Library" by expanding it, in the "MyTask" folder.

After the new task is ready, the explorer will refresh an extra time after restarting windows, thus showing the 'GUI' and 'tray icon' as intended.

One downside about this, is that explorer will open a new window every time Windows starts!


#14 soma11

soma11

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 18 February 2018 - 11:14 PM

I may have found a possible solution for the missing tray icon..?

For me the tray icon of Eddie has started showing without the fix above. I noticed it started showing after having done two changes in Windows that maybe was conflicting with the startup of Eddie.

  • I'm using "ExpressCache" on a SSD to make windows load faster. What I did was to clean the disk with "diskpart", thus flushing it and then re-partitioning the disk as cache storage.
  • I'm currently using BitDefender as antivirus and was recently reinstalling after removing it.
I don't know which of these actions have solved the missing icon, but I think one of them did, and therefore I've mentioned both.

Now everything seem to be working with Eddie showing up (a bit delayed) as a tray icon while starting windows.

UPDATE!

The steps above has not solved Eddie's missing "tray icon".

It has clearly been an improvement from not showing at all, but still after having booted, the tray icon can be missing. It's still missing maybe 1 out of 4 times (more or less).



#15 tetsuo73

tetsuo73

    Newbie

  • New Members
  • Pip
  • 1 posts

Posted 27 March 2018 - 02:24 PM

I am having the same issue both on Linux Mint 17.2 and Fedora 27. Eddie dies after a day or so but the openvpn connection and client continues to work fine. If I try to run Eddie again I am getting the "Openvpn is already running" error.



#16 LZ1

LZ1

    It's nice to be nice to nice people

  • Moderators
  • 1801 posts

Posted 27 March 2018 - 02:34 PM

I am having the same issue both on Linux Mint 17.2 and Fedora 27. Eddie dies after a day or so but the openvpn connection and client continues to work fine. If I try to run Eddie again I am getting the "Openvpn is already running" error.

Please try the experimental client and report back in that thread. :)


Hi there, are you new to AirVPN? Many of your questions are already answered in this guide. Its Guides Section has guides on Linux/Torrenting/Blocked sites & many other topics too.
Moderators do not speak on behalf of AirVPN. Only the Official Staff account does. Please read the First Questions section in the link above for more details, thank you.
Did you make a guide or how-to for something? Then contact me to get it listed in my new user guide's Guides Section, so that the community can find it more easily.

Tired of Windows? Why Linux Is Better.

#17 soma11

soma11

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 19 April 2018 - 08:31 AM

After having solved a conflict in AirVPN between some old TAP-interfaces used by an earlier install of OpenVPN, the tray-icon now only disappear very rarely, maybe 1 out of 20 times.

 

All I did was to delete all TAP-interfaces and reinstall AirVPN.







Similar Topics Collapse


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

Servers online. Online Sessions: 12382 - BW: 35918 Mbit/sYour IP: 54.198.158.24Guest Access.