Jump to content


Photo

DNS problem on Windows 10

DNS Windows 10 slow lookup fail

  • Please log in to reply
3 replies to this topic

#1 zimwebob

zimwebob

    Member

  • Members
  • PipPip
  • 11 posts

Posted 10 February 2016 - 01:42 AM

I have a dual boot system with Windows 7 Ultimate 64 and Windows 10 Pro 64. With the latest OpenVPM and TAP, and Eddie 2.10.3, everything works perfectly on Windows 7. Great speeds, no connection lag.

 

However, with the EXACT same setup on Windows 10, the client will sit in an infinite loop trying to Check Route before failing. This is with Preferences->Advanced->DNS set to Automatic.

 

If I manually set my Ethernet and Tap adapter DNS server to 10.50.0.1, and set Preferences->Advanced->DNS to Disable, and enter 10.50.0.1 in the server list there, the client will connect, but DNS lookups take 30+ seconds and frequently timeout, and leak tests reveal that my ISP DNS is being used, probably as a fallback.

 

Is this a known bug with the Eddie client and Windows 10? Is there any way to solve this?



#2 zimwebob

zimwebob

    Member

  • Members
  • PipPip
  • 11 posts

Posted 10 February 2016 - 09:48 PM

Working with the helpful support staff combined with some research on my own, this problem came down to two things:

 

  • Disable IPv6 (in the adapter AND in the OS itself
  • Uninstall the Ethernet Adapter from Device Manager (not TAP, and do NOT select option to remove driver/software).
  • Reboot

Here is a guide how to disable IPv6:

http://www.techunboxed.com/2014/10/how-to-disable-ipv6-in-windows-10.html

 

My problem didn't clear up until I had uninstalled the neetwork adapter and let it re-detect, however. Make sure and disable all the superfluous protocols again after doing so.

 

Also, there is currently a bug with Eddie (confirmed) where the custome path to OpenVPN is being ignored, and it will use the version that packs with Eddie regardless. You can solve this by backing up the version of openvpn.exe in your AirVPN folder and replacing it with the one from your OpenVPN folder after doing a separate install.

 

The reason I would recommend installing the latest OpenVPN separately and using that executable is that it supports the block-outside-dns command which prevents DNS leaks, while Eddie's version does not.

 

To enable this important feature, go into your AirVPN preferences -> Advanced -> OVPN directives and enter block-outside-dns in the left side.



#3 voodude

voodude

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 03 December 2016 - 01:27 PM

zimwebob, you are a legend! I have spent hours trying to fix this and by following your bullet points and making sure ipvs 6 was turned off after the reboot it worked!

 

It's so strange because after my first install and initial use it worked fine. Then, on a whim, I decided to switch servers. From here it didn't connect to ANY server until I followed your steps.

 

What I tried:

  • turning off "check if tunnel effectively works" in advanced settings.
  • uninstalling, rebooting and re-installing program.
  • switching protocols from "automatic" to various others, without success
  • drinking alcohol, which inhibited my decision making by 80%

 

Thank you.



#4 LZ1

LZ1

    It's nice to be nice to nice people

  • Moderators
  • 1953 posts

Posted 03 December 2016 - 04:12 PM

Hello!

 

Sometimes route checking will still fail if *both* checking of the tunnel and DNS aren't unchecked :).


Hi there, are you new to AirVPN? Many of your questions are already answered in this guide. Its Guides Section has guides on Linux/Torrenting/Blocked sites & many other topics too.
Moderators do not speak on behalf of AirVPN. Only the Official Staff account does. Please read the First Questions section in the link above for more details, thank you.
Did you make a guide or how-to for something? Then contact me to get it listed in my new user guide's Guides Section, so that the community can find it more easily.

Tired of Windows? Why Linux Is Better.





Similar Topics Collapse


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Servers online. Online Sessions: 14122 - BW: 52607 Mbit/sYour IP: 54.197.24.206Guest Access.