Jump to content


Photo

OpenVPN is already running

disconnection bug

  • Please log in to reply
4 replies to this topic

#1 4s9TgChc

4s9TgChc

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 20 June 2014 - 04:24 AM

This is a super annoying bug if I get disconnected (either through loss of wifi signal or disconnected ethernet wire) while I'm connected to a session. When I re-establish the connection over the network I cannot re-establish a connection with AirVPN I get "OpenVPN is already running".

 

The only thing that works to fix this is a machine reboot!



#2 Artful Dodger

Artful Dodger

    Advanced Member

  • Members
  • PipPipPip
  • 47 posts

Posted 20 June 2014 - 01:51 PM

You do not have to reboot, press Ctrl+Alt+Delete on your keyboard, run task manager and then select openvpn.exe and press "end process". Air client should run OK then. That is in Windows 7.



#3 Tald0r

Tald0r

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 07 June 2015 - 12:16 PM

Hi everyone,

 

I installed AirVPN yesterday on my laptop with windows 8.1 and have very similar problems as OP.

 

But the solution doesn't work since I can't end / terminate / kill openvpn.exe, not by Task Manager, nor by Process Hacker, nor by cmd. I've been googling for hours, tried to disconnect all possible devices and disabling/enabling all possible drivers. I do have OpenVPN installed as well but the GUI isn't running (and openvpn.exe wasn't running either before installing). Openvpn.exe doesn't show any sort of cpu activity. The problems started after reopening my laptop (sleep mode).

 

I know I've been avoiding the most relevant solution ("have you tried turning it off and on again") but I'd really like not to restart my computer as there are other programs running in which I can't save my activity.

 

Have I missed something obvious or is there no other solution but a clean restart and not to use sleep mode anymore? In that case I'm afraid I'll have to look for alternatives.

 

On a side note, yesterday I tried a couple of servers in the Netherlands, and got about 5Mb/s downloadspeed in tunnel and ~22Mb/s outside the tunnel. Upload speed was only slightly affected. Is this considered normal?



#4 giganerd

giganerd

    I shall have no title

  • Members2
  • PipPipPip
  • 2687 posts
  • LocationGermany

Posted 07 June 2015 - 10:14 PM

Sleep mode is a bad thing when OpenVPN is running. Windows resets the routing table on every ACPI state change from S0 (sleep, hibernation, shutdown, see the link for details), so after wakeup the whole OpenVPN config is gone. It may explain why OpenVPN is acting that way...


Always remember:
There's a guide to AirVPN,

Amazon IPs are not dangerous here,
running TOR exits is discouraged,

using spoilers for your logs helps us read your thread.

~ Furthermore, I propose that your paranoia is to be destroyed. ~

Instead of writing me a personal mail, consider contacting me via XMPP at gigan3rd@xmpp.airvpn.org or join the lounge@conference.xmpp.airvpn.org. I might read the mail too late whereas I'm always available on XMPP ;)


#5 cspalletta

cspalletta

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 05 February 2017 - 10:13 PM

[SOLVED]

 

I had the same problem I received a message that OpenVPN GUI is already running; and even after killing the process with Task Manager and restarting it, I couldn't find the program in the system tray.

 

I finally figured out that if I clicked on the tiny arrow head to the left of the system tray and moused over the icons shown in a popup until I found openvpn-gui, then dragged it from the popup to the system tray, it would remain there. 

 

Click on it and if it is properly configured it will offer you working connection options.  If the icon of a locked tty turns green, that means it is connected.







Similar Topics Collapse


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

Servers online. Online Sessions: 15663 - BW: 65976 Mbit/sYour IP: 18.206.175.155Guest Access.