Jump to content
Not connected, Your IP: 3.90.56.90
4s9TgChc

OpenVPN is already running

Recommended Posts

This is a super annoying bug if I get disconnected (either through loss of wifi signal or disconnected ethernet wire) while I'm connected to a session. When I re-establish the connection over the network I cannot re-establish a connection with AirVPN I get "OpenVPN is already running".

 

The only thing that works to fix this is a machine reboot!

Share this post


Link to post

Hi everyone,

 

I installed AirVPN yesterday on my laptop with windows 8.1 and have very similar problems as OP.

 

But the solution doesn't work since I can't end / terminate / kill openvpn.exe, not by Task Manager, nor by Process Hacker, nor by cmd. I've been googling for hours, tried to disconnect all possible devices and disabling/enabling all possible drivers. I do have OpenVPN installed as well but the GUI isn't running (and openvpn.exe wasn't running either before installing). Openvpn.exe doesn't show any sort of cpu activity. The problems started after reopening my laptop (sleep mode).

 

I know I've been avoiding the most relevant solution ("have you tried turning it off and on again") but I'd really like not to restart my computer as there are other programs running in which I can't save my activity.

 

Have I missed something obvious or is there no other solution but a clean restart and not to use sleep mode anymore? In that case I'm afraid I'll have to look for alternatives.

 

On a side note, yesterday I tried a couple of servers in the Netherlands, and got about 5Mb/s downloadspeed in tunnel and ~22Mb/s outside the tunnel. Upload speed was only slightly affected. Is this considered normal?

Share this post


Link to post

Sleep mode is a bad thing when OpenVPN is running. Windows resets the routing table on every ACPI state change from S0 (sleep, hibernation, shutdown, see the link for details), so after wakeup the whole OpenVPN config is gone. It may explain why OpenVPN is acting that way...


Always remember:
There's a guide to AirVPN,

Amazon IPs are not dangerous here,
running TOR exits is discouraged,

using spoilers for your logs helps us read your thread.

~ Furthermore, I propose that your paranoia is to be destroyed. ~

Instead of writing me a personal mail, consider contacting me via XMPP at gigan3rd@xmpp.airvpn.org or join the lounge@conference.xmpp.airvpn.org. I might read the mail too late whereas I'm always available on XMPP

Share this post


Link to post

[sOLVED]

 

I had the same problem I received a message that OpenVPN GUI is already running; and even after killing the process with Task Manager and restarting it, I couldn't find the program in the system tray.

 

I finally figured out that if I clicked on the tiny arrow head to the left of the system tray and moused over the icons shown in a popup until I found openvpn-gui, then dragged it from the popup to the system tray, it would remain there. 

 

Click on it and if it is properly configured it will offer you working connection options.  If the icon of a locked tty turns green, that means it is connected.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...