Jump to content
Not connected, Your IP: 18.206.13.39
flashung

Utorrent and uploading speeds/forwarding

Recommended Posts

I have a problem with Utorrent and uploading. My internet connection is 50/50 fiber and gives me these speeds. I didn't expect this for VPN, but I do actually get decent download speeds, so that's good.

 

However, I do not manage to upload much at all. I have forwarded a port on from your web-console: 35295. This has then been setup as the listening port in Utorrent. I have turned off all portforwarding for this port or utorrent on the router. Your web-console shows thee port as open, but Utorrent setup guide reports that port is not open. Utorrent seems to be conflicting itself, cause the little checkmark in the bottom right corner turns green. The max speed i have seen uploading so far has been 250kbps or so, very sad story and not usable. 

 

I have included 3 screenshots showing my settings, utorrent status and your web-console. 

 

I have tried disabling my Comodo firewall just to see if it makes a difference, but it did not. 

 

I only use AirVPN for torrents at the moment, so I don't have it enabled all the time.

What am I doing wrong, and what can I do to solve it?

 

 

Share this post


Link to post

That network connection test in uTorrent does not seem to be useful when using the VPN. For me, it always says there is a problem, even though I can see connections that have come in from peers ("I" flag in "Flags" column in the "Peers" tab for "Detailed info").

 

The reason for disabling UPnP (I would disable it in your router too) is to ensure that you are not receiving incoming connections via your router (uTorrent can use UPnP to set this right back up again). Then you can get a green sign because connections have come in from the real IP (from peers who remember you or due to tracker registrations that were left in place and have not timed out yet), even if they are not coming in on the VPN IP.

 

Can you see any peers that have the "I" flag? if not, you may not be connectable (port forwarding not working right). In the guide I wrote I suggest downloading the current ubuntu desktop torrent which usually has a huge swarm going (and no copyright issues), while monitoring uTorrent with "Process Explorer". The guide has links to these and explains a bit more:

 

https://airvpn.org/topic/9549-guide-to-setting-up-vpn-just-for-torrenting-on-windows-thanks-to-nadre/

 

If you see no evidence of incoming connections while downloading ubuntu, the port forwarding must not be working.

 

It is also possible to directly test that port forwarding is working using a version of "netcat" (renamed to "ncat") that comes with "Nmap". But I have not explained how to do that in the guide. I thought using Processor Explorer and just looking for the "I" flag would be easier for most people.

Share this post


Link to post

I did try disabling upnp, but no change. I could see the I flag, but after leaving it to upload for 10 hours and it had only uploaded 2.5GB with the ubuntu torrent pluss others, I got quite despaired. I need a good ratio..I used procexp and watched utorrent for quite a while and the listening ports looked rather strange. Turns out I did some changes to my hosts file when I first got the vpn. some random suggestion from the forums here, and I had forgotten about that.

 

Now that I have removed those adresses from the hosts file everything is working very well. Uploads regularly peak at much higher speeds. I haven't seen anything at proper high speeds yet, but hopefully it will come. Will report back, when i'm certain the problem is solved.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...