Jump to content
Not connected, Your IP: 18.215.161.19
Sign in to follow this  
chiquito50

[SOLVED] Connects but IP doesn't change on Windows Server Essentials 2012

Recommended Posts

I'm having trouble connecting properly on a fresh install of Server 2012 Essentials.

I can login and connect OK, but my IP address doesn't change and the bandwidth meter doesn't show any traffic going through the VPN when I load webpages etc.

I've tried with 32bit and 64bit Windows 8 versions. I've tried with COMODO on and off. The client works fine on a Windows 7 PC on the same network.

Here is my log:

11/03/2013 - 15:17 AirVPN client version: 1.8

11/03/2013 - 15:17 Reading options from C:\xxx\AppData\Roaming\AirVPN\Air\1.0.0.0\AirVPN.xml

11/03/2013 - 15:17 OpenVPN bundle version: OpenVPN 2.3.0

11/03/2013 - 15:17 OpenVPN current version: OpenVPN 2.3.0

11/03/2013 - 15:17 Ready.

11/03/2013 - 15:17 Login...

11/03/2013 - 15:17 Login success.

11/03/2013 - 15:17 Contacting service...

11/03/2013 - 15:17 Connecting...

11/03/2013 - 15:17 OpenVPN 2.3.0 x86_64-w64-mingw32 [sSL (OpenSSL)] [LZO] [PKCS11] [eurephia] [iPv6] built on Jan 8 2013

11/03/2013 - 15:17 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables

11/03/2013 - 15:17 Socket Buffers: R=[65536->65536] S=[65536->65536]

11/03/2013 - 15:17 UDPv4 link local: [undef]

11/03/2013 - 15:17 UDPv4 link remote: [AF_INET]109.163.230.232:443

11/03/2013 - 15:17 TLS: Initial packet from [AF_INET]109.163.230.232:443, sid=2f99a70c 37c1e125

11/03/2013 - 15:17 VERIFY OK: depth=1, C=IT, ST=IT, L=Perugia, O=airvpn.org, CN=airvpn.org CA, emailAddress=info@airvpn.org

11/03/2013 - 15:17 VERIFY OK: nsCertType=SERVER

11/03/2013 - 15:17 VERIFY OK: depth=0, C=IT, ST=IT, L=Perugia, O=airvpn.org, CN=server, emailAddress=info@airvpn.org

11/03/2013 - 15:17 Data Channel Encrypt: Cipher 'AES-256-CBC' initialized with 256 bit key

11/03/2013 - 15:17 Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication

11/03/2013 - 15:17 Data Channel Decrypt: Cipher 'AES-256-CBC' initialized with 256 bit key

11/03/2013 - 15:17 Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication

11/03/2013 - 15:17 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 2048 bit RSA

11/03/2013 - 15:17 [server] Peer Connection Initiated with [AF_INET]109.163.230.232:443

11/03/2013 - 15:17 SENT CONTROL [server]: 'PUSH_REQUEST' (status=1)

11/03/2013 - 15:17 PUSH: Received control message: 'PUSH_REPLY,redirect-gateway def1,dhcp-option DNS 10.4.0.1,comp-lzo no,route 10.4.0.1,topology net30,ping 10,ping-restart 60,ifconfig 10.4.8.170 10.4.8.169'

11/03/2013 - 15:17 OPTIONS IMPORT: timers and/or timeouts modified

11/03/2013 - 15:17 OPTIONS IMPORT: LZO parms modified

11/03/2013 - 15:17 OPTIONS IMPORT: --ifconfig/up options modified

11/03/2013 - 15:17 OPTIONS IMPORT: route options modified

11/03/2013 - 15:17 OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified

11/03/2013 - 15:17 do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0

11/03/2013 - 15:17 open_tun, tt->ipv6=0

11/03/2013 - 15:17 TAP-WIN32 device [Local Area Connection] opened: \\.\Global\{B6829E3F-7266-4341-8D24-A0ACF2E10A0B}.tap

11/03/2013 - 15:17 TAP-Windows Driver Version 9.9

11/03/2013 - 15:17 Notified TAP-Windows driver to set a DHCP IP/netmask of 10.4.8.170/255.255.255.252 on interface {B6829E3F-7266-4341-8D24-A0ACF2E10A0B} [DHCP-serv: 10.4.8.169, lease-time: 31536000]

11/03/2013 - 15:17 Successful ARP Flush on interface [25] {B6829E3F-7266-4341-8D24-A0ACF2E10A0B}

11/03/2013 - 15:18 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down

11/03/2013 - 15:18 Route: Waiting for TUN/TAP interface to come up...

11/03/2013 - 15:18 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down

11/03/2013 - 15:18 Route: Waiting for TUN/TAP interface to come up...

11/03/2013 - 15:18 AirVPN Windows 8 Interface Hack executed (Interface: 'Local Area Connection').

11/03/2013 - 15:18 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down

11/03/2013 - 15:18 Route: Waiting for TUN/TAP interface to come up...

11/03/2013 - 15:18 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down

11/03/2013 - 15:18 Route: Waiting for TUN/TAP interface to come up...

11/03/2013 - 15:18 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down

11/03/2013 - 15:18 Route: Waiting for TUN/TAP interface to come up...

11/03/2013 - 15:18 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down

11/03/2013 - 15:18 Route: Waiting for TUN/TAP interface to come up...

11/03/2013 - 15:18 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down

11/03/2013 - 15:18 Route: Waiting for TUN/TAP interface to come up...

11/03/2013 - 15:18 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down

11/03/2013 - 15:18 Route: Waiting for TUN/TAP interface to come up...

11/03/2013 - 15:18 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down

11/03/2013 - 15:18 Route: Waiting for TUN/TAP interface to come up...

11/03/2013 - 15:18 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down

11/03/2013 - 15:18 Route: Waiting for TUN/TAP interface to come up...

11/03/2013 - 15:18 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down

11/03/2013 - 15:18 Route: Waiting for TUN/TAP interface to come up...

11/03/2013 - 15:18 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down

11/03/2013 - 15:18 Route: Waiting for TUN/TAP interface to come up...

11/03/2013 - 15:18 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down

11/03/2013 - 15:18 Route: Waiting for TUN/TAP interface to come up...

11/03/2013 - 15:18 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down

11/03/2013 - 15:18 Route: Waiting for TUN/TAP interface to come up...

11/03/2013 - 15:18 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down

11/03/2013 - 15:18 Route: Waiting for TUN/TAP interface to come up...

11/03/2013 - 15:18 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down

11/03/2013 - 15:18 Route: Waiting for TUN/TAP interface to come up...

11/03/2013 - 15:18 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down

11/03/2013 - 15:18 Route: Waiting for TUN/TAP interface to come up...

11/03/2013 - 15:18 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down

11/03/2013 - 15:18 Route: Waiting for TUN/TAP interface to come up...

11/03/2013 - 15:18 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down

11/03/2013 - 15:18 Route: Waiting for TUN/TAP interface to come up...

11/03/2013 - 15:18 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down

11/03/2013 - 15:18 Route: Waiting for TUN/TAP interface to come up...

11/03/2013 - 15:18 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down

11/03/2013 - 15:18 Route: Waiting for TUN/TAP interface to come up...

11/03/2013 - 15:18 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down

11/03/2013 - 15:18 Route: Waiting for TUN/TAP interface to come up...

11/03/2013 - 15:18 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down

11/03/2013 - 15:18 Route: Waiting for TUN/TAP interface to come up...

11/03/2013 - 15:18 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down

11/03/2013 - 15:18 Route: Waiting for TUN/TAP interface to come up...

11/03/2013 - 15:18 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down

11/03/2013 - 15:18 C:\Windows\system32\route.exe ADD 109.163.230.232 MASK 255.255.255.255 192.168.1.1

11/03/2013 - 15:18 ROUTE: CreateIpForwardEntry succeeded with dwForwardMetric1=20 and dwForwardType=4

11/03/2013 - 15:18 Route addition via IPAPI succeeded [adaptive]

11/03/2013 - 15:18 C:\Windows\system32\route.exe ADD 0.0.0.0 MASK 128.0.0.0 10.4.8.169

11/03/2013 - 15:18 Warning: route gateway is not reachable on any active network adapters: 10.4.8.169

11/03/2013 - 15:18 Route addition via IPAPI failed [adaptive]

11/03/2013 - 15:18 Route addition fallback to route.exe

11/03/2013 - 15:18 env_block: add PATH=C:\Windows\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem

11/03/2013 - 15:18 OK!

11/03/2013 - 15:18 C:\Windows\system32\route.exe ADD 128.0.0.0 MASK 128.0.0.0 10.4.8.169

11/03/2013 - 15:18 Warning: route gateway is not reachable on any active network adapters: 10.4.8.169

11/03/2013 - 15:18 Route addition via IPAPI failed [adaptive]

11/03/2013 - 15:18 Route addition fallback to route.exe

11/03/2013 - 15:18 env_block: add PATH=C:\Windows\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem

11/03/2013 - 15:18 OK!

11/03/2013 - 15:18 C:\Windows\system32\route.exe ADD 10.4.0.1 MASK 255.255.255.255 10.4.8.169

11/03/2013 - 15:18 Warning: route gateway is not reachable on any active network adapters: 10.4.8.169

11/03/2013 - 15:18 Route addition via IPAPI failed [adaptive]

11/03/2013 - 15:18 Route addition fallback to route.exe

11/03/2013 - 15:18 env_block: add PATH=C:\Windows\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem

11/03/2013 - 15:18 OK!

11/03/2013 - 15:18 SYSTEM ROUTING TABLE

11/03/2013 - 15:18 .1 p=0 i=12 t=4 pr=3 a=1852 h=0 m=20/0/0/0/0

11/03/2013 - 15:18 169 p=0 i=12 t=4 pr=3 a=1 h=0 m=21/0/0/0/0

11/03/2013 - 15:18 10.4.8.169 p=0 i=12 t=4 pr=3 a=0 h=0 m=21/0/0/0/0

11/03/2013 - 15:18 2 10.4.38.66 p=0 i=25 t=3 pr=2 a=368 h=0 m=286/0/0/0/0

11/03/2013 - 15:18 5 10.4.38.66 p=0 i=25 t=3 pr=2 a=368 h=0 m=286/0/0/0/0

11/03/2013 - 15:18 5 10.4.38.66 p=0 i=25 t=3 pr=2 a=368 h=0 m=286/0/0/0/0

11/03/2013 - 15:18 55.255 192.168.1.1 p=0 i=12 t=4 pr=3 a=1 h=0 m=20/0/0/0/0

11/03/2013 - 15:18 .0.1 p=0 i=1 t=3 pr=2 a=1891 h=0 m=306/0/0/0/0

11/03/2013 - 15:18 127.0.0.1 p=0 i=1 t=3 pr=2 a=1891 h=0 m=306/0/0/0/0

11/03/2013 - 15:18 55.255 127.0.0.1 p=0 i=1 t=3 pr=2 a=1891 h=0 m=306/0/0/0/0

11/03/2013 - 15:18 8.169 p=0 i=12 t=4 pr=3 a=0 h=0 m=21/0/0/0/0

11/03/2013 - 15:18 192.168.1.33 p=0 i=12 t=3 pr=2 a=1852 h=0 m=276/0/0/0/0

11/03/2013 - 15:18 255 192.168.1.33 p=0 i=12 t=3 pr=2 a=1852 h=0 m=276/0/0/0/0

11/03/2013 - 15:18 .255 192.168.1.33 p=0 i=12 t=3 pr=2 a=1852 h=0 m=276/0/0/0/0

11/03/2013 - 15:18 .0.1 p=0 i=1 t=3 pr=2 a=1891 h=0 m=306/0/0/0/0

11/03/2013 - 15:18 68.1.33 p=0 i=12 t=3 pr=2 a=1883 h=0 m=276/0/0/0/0

11/03/2013 - 15:18 38.66 p=0 i=25 t=3 pr=2 a=770 h=0 m=286/0/0/0/0

11/03/2013 - 15:18 55.255 127.0.0.1 p=0 i=1 t=3 pr=2 a=1891 h=0 m=306/0/0/0/0

11/03/2013 - 15:18 55.255 192.168.1.33 p=0 i=12 t=3 pr=2 a=1883 h=0 m=276/0/0/0/0

11/03/2013 - 15:18 55.255 10.4.38.66 p=0 i=25 t=3 pr=2 a=770 h=0 m=286/0/0/0/0

11/03/2013 - 15:18 SYSTEM ADAPTER LIST

11/03/2013 - 15:18 TAP-Windows Adapter V9

11/03/2013 - 15:18 Index = 25

11/03/2013 - 15:18 341-8D24-A0ACF2E10A0B}

11/03/2013 - 15:18 .255.252

11/03/2013 - 15:18 MAC = 00:ff:b6:82:9e:3f

11/03/2013 - 15:18 55.255.255

11/03/2013 - 15:18 255.255.255.255

11/03/2013 - 15:18 on Mar 11 15:12:24 2013

11/03/2013 - 15:18 ue Mar 11 15:12:24 2014

11/03/2013 - 15:18 .255.255.255

11/03/2013 - 15:18 t Ethernet

11/03/2013 - 15:18 Index = 12

11/03/2013 - 15:18 A94-93F6-D4992C41814B}

11/03/2013 - 15:18 55.255.0

11/03/2013 - 15:18 MAC = 00:9c:02:97:5b:03

11/03/2013 - 15:18 55.255.255.255

11/03/2013 - 15:18 /255.255.255.255

11/03/2013 - 15:18 on Mar 11 14:47:41 2013

11/03/2013 - 15:18 hu Mar 14 14:47:41 2013

11/03/2013 - 15:18 5.255.255.255

11/03/2013 - 15:18 Initialization Sequence Completed With Errors ( see http://openvpn.net/faq.html#dhcpclientserv )

11/03/2013 - 15:18 Starting Management Interface...

11/03/2013 - 15:18 Checking...

11/03/2013 - 15:18 Retrieve statistics...

11/03/2013 - 15:18 Connected.

 

Share this post


Link to post

Hello!

From the logs it appears that on your Windows 8 the TAP-Win32 interface does not come up.. not even with the Air client 'hack'.

First, you can try a Winsock and stack reset (from a command prompt with administrator privileges):

Reset WINSOCK entries to installation defaults:

netsh winsock reset catalog

Reset IPv4 TCP/IP stack to installation defaults:

netsh int ipv4 reset reset.log

After the above commands are issued a reboot is unfortunately mandatory.

If the above does not solve the problem, can you please make sure that:

- no programs (especially antivirus and firewall) are interfering with airvpn.exe, openvpn.exe and tap09*.sys (the driver for the tun/tap interface)

- the Air client can elevate to administrator privileges

- OpenVPN can elevate to administrator privileges

- the DHCP *client* service is running

- TAP driver is installed correctly (in case of doubt, try to uninstall OpenVPN completely and re-install it, making sure to authorize the installation of any driver)

Kind regards

Share this post


Link to post

the first 2 commands did not solve my issue in my case.

But instead this did:

 Allow DHCP "negotiation":
Allow IP In/Out From MAC Any To IP 255.255.255.255 Where Protocol Is Any

this setting in my Firewall was missing. And it was preventing the TAP to change info.

Hope it might helps someone.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

×
×
  • Create New...