Jump to content
Not connected, Your IP: 100.24.113.182
Sign in to follow this  
djonbrooks

[SOLVED] port forwarding and vuze

Recommended Posts

So I have read a few people who say they're new to this game and then proceed to write things even I don't understand so when I say I'm new I mean it. I want airvpn mainly for Vuze- I've gotten some emails from comcast stating they know I've downloaded some stuff so I'm trying to compensate for that. Anywho - I'm trying to forward a port and unfortunately I'm the type of guy that needs step 1, 2, 3 etc... and airvpn doesn't seem to offer that. So I'm looking to this forum. I've been trying all types of stuff with no avail. Here's the steps i take - where am i going wrong???

step 1 - turned off windows firewall

step 2 - turned off microsoft security essentials

step 3- connect to vpn server

step 4 - go to airvpn speed check and it is good (16mbps download and about 4mbps upload)

step 5 - go to airvpn port forwarding page and click "add" to which it gives me port 4524

step 6- click check -(see pic - at top of page it says check completed but at bottom it says waiting for a check and the ball next to the check button is white)

step 7 - open vuze

step 8 - go to options>connection>set incoming TCP listen port to 4524 and UDP listen port to 4524 (see pic)

step 9 - do a vuze search and stuff shows up so vuze is working and connected but how do i know if I'm actually port forwarding?

Share this post


Link to post

Hello!

The steps you describe are correct but please be aware that currently account "djonbrooks" has no remotely forwarded ports. If you deleted them from your account it's ok, but if you wish to re-perform the test please make sure that Vuze is launched after the connection to an Air server and that it is running while the port check is performed.

Also, Vuze has an interesting bind feature, please make sure that you did not modify the default configuration. You might like to bind Vuze to your system tun adapter (generally "tun0" on Linux, *BSD and Unix systems, "TAP-Win32" in Windows systems), so that Vuze will not be able to send or receive packets when your system is not connected to the VPN (not applicable if you use a Tomato / DD-WRT / OpenWRT router to connect to an Air server directly from the router).

Kind regards

Share this post


Link to post

But how do you set this up if you are using a Tomato router to connect to AirVPN? One of the computers behind the router will run Vuze, how do I get that forwarded port to the computer running Vuze?

Share this post


Link to post

So what if I am running Vuze on a virtual machine using VirtualBox? By default Virtual Box configures the network settings of the VM as "NAT". Other options are "NAT Network", "Bridged Adapter", "Internal Only", "Host-only Adapter". In order to get an IP address on the VM that is on the same subnet as the rest of my network I have to select "Bridged Adapter". Does the VM have to be on the same subnet in order to setup the port forwarding properly?

 

Is it more secure to have the network in the VM on another subnet? I'm worried about local security if someone hacks my Vuze VM over the Internet, I don't want them to be able to access my local network. That is why I am running Vuze in a VM, to keep it isolated and my local network protected.

Share this post


Link to post

Hello,

 

when the VM is attached to the host via NAT and OpenVPN runs on the host, make sure to forward (via the host virtualization software) the proper ports to the guest. If OpenVPN runs on the guest machine that's not necessary.

 

If OpenVPN runs neither on the host nor on the VM, but it runs on an external device, and the VM is attached via NAT, make sure to build the appropriate DNAT on that device, and then forward the proper ports via the host virtualization software to the guest.

 

Kind regards

Share this post


Link to post

Hi, i'm running openvpn on my DD-WRT router, and I have Vuze on my Windows 7 PC but it isn't working.  I followed instructions on this page AND also the ones here https://airvpn.org/topic/9270-how-to-forward-ports-in-dd-wrt-tomato-with-iptables/ but I'm getting the following issues:

 

1. When I go to airvpn port forwarding page and I do a check, it tells me Not reachable on server IP over the external port 39947, tcp protocol. Error : 111 - Connection refused

2. Vuze firewall/NAT test gives me this message:

Testing port TCP 39947 ... 

Unable to test: Invalid port given, or test service failed.
Another application may already be using this port.. 
(Error: Unexpected end of file from server).
 
FYI, on my DD-WRT router I have the following firewall rules:
 
iptables -I FORWARD -i br0 -o tun1 -j ACCEPT
iptables -I FORWARD -i tun1 -o br0 -j ACCEPT
iptables -I INPUT -i tun1 -j REJECT
iptables -t nat -A POSTROUTING -o tun1 -j MASQUERADE

iptables -I FORWARD -i tun1 -p udp -d 192.168.1.113 --dport 39947 -j ACCEPT
iptables -I FORWARD -i tun1 -p tcp -d 192.168.1.113 --dport 39947 -j ACCEPT
iptables -t nat -I PREROUTING -i tun1 -p tcp --dport 39947 -j DNAT --to-destination 192.168.1.113
iptables -t nat -I PREROUTING -i tun1 -p udp --dport 39947 -j DNAT --to-destination 192.168.1.113
 
192.168.1.113 is my PC running Vuze.
 
Help!

Share this post


Link to post

It's behind the ISP's modem.  The ISP installed this modem device in every home as part of their fiber-to-the-home infrastructure.  From this box I get my internet, TV and fixed phone line services.  I have an ethernet cable going from this box to my DD-WRT router's WAN port for internet.  The DD-WRT router is also hard wired to a couple of access points I set up around the home for coverage.  I know my ISP blocks third party DNS and has a transparent proxy (if this is relevant to this issue).

 

Thanks

Share this post


Link to post

Good day all,

 

i've the same problem. 

My netowork is composed by :

- modem adsl router

- dd-wrt router

- server and pc's on the LAN side of the router dd-wrt

 

I try to forward some ports but i can't reach my internal server-

 

I need some help.

 

Thank you

Share this post


Link to post

Hi all I have same issue and despite in this title mentioned SOLVED but I can't see the rest of lines which you guys SOLVED is there any one to help me in this regards as below I have issues.

 

- I am using DSL modem from ISP and I have DD-WRT Router which I am using AirVPN with port forwarding to my local port but alas this is not working even I run some firewall script in order to allow PC's local port.

 

pls help me guys 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

×
×
  • Create New...