Jump to content
Not connected, Your IP:

ANSWERED Raspbian: Cannot access my server via airdns.org

Recommended Posts

Posted ... (edited)

In the past, from time to time I used to set up an Apache Server on my Raspi2b using Eddie and airdns.org. Worked flawless.

Now, I freshly installed the latest 2021-05-07-raspios-buster-armhf-full with Apache 2.4.38 and the recommended Eddie 2.20.0 (which is apparently beta) for ARM32.

Eddie 2.20.0 froze all the time - useless.
So I installed Eddie 2.16.3, which worked so far that I could access web sites through the VPN.

I set up a virtual host for Apache anyname.airdns.org, listening on port, say 55555.
I waited til DNS was correctly updated according to DNS report.

But I cannot access http://anyname.airdns.org:55555 from any machine (not behind VPN)

But - if put in /etc/hosts on the Raspi, I can access the documents from the Raspi via  http://anyname.airdns.org:55555. So Apache must be working properly.

I am really stuck at the moment, maybe I have a blind spot and the problem is something quite simple?
Any Help would be much appreciated!

PS: I tried the same thing on my desktop PC, Linux Buster, Apache, and Eddie 2.20.0. It didn't work either. What am I doing wrong?

Edited ... by MarxBrother

Share this post

Link to post
Posted ... (edited)
1 hour ago, Staff said:


You forwarded remotely several ports, but port 55555 is not one of them, can you please check?

Kind regards

Thank you for guiding me into the right direction!

55555 was just an arbitrary example, not a real port of mine - but:

It was all my silly mistake. Yes, the port number!
I always looked at the "port number", alas, there is also a "local port".
With all my reserved ports, both are identical. Except one. THE one!

"With glasses on, this would not have happened!" :) Edited ... by MarxBrother
My mistake

Share this post

Link to post

Please make sure that no firewall blocks incoming packets while the system is in the VPN and that the listening software does not bind, even as an aftermath of UPnP or other  automated port mapping, to the physical network interface and/or localhost. Therefore, please check any bind option and also check any UPnP and similar option.

If the above has been already verified and the problem endures, please open a ticket. The support team, in private, may support you more effectively.

Kind regards

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Security Check
    Play CAPTCHA Audio
    Refresh Image

  • Create New...