Jump to content
Not connected, Your IP: 18.207.129.82
Staff

Eddie Desktop 2.19.7 released

Recommended Posts

Hello!

We're very glad to inform you that a new stable release of Eddie is now available for Linux (various ARM based architectures included), Mac, Windows.

Eddie is a free and open source (GPLv3) OpenVPN GUI and CLI by AirVPN with many additional features such as:

  • traffic leaks prevention via packet filtering rules
  • DNS handling
  • optional connections over Tor or a generic proxy
  • customizable events
  • traffic splitting on a destination IP address or host name basis
  • complete and swift integration with AirVPN infrastructure
  • white and black lists of VPN servers
  • ability to support IPv4, IPv6 and IPv6 over IPv4


What's new in Eddie 2.19.7

 
  • enhanced wintun support in Windows, resolving TAP driver adapter issues and boosting performance
  • Hummingbird 1.1.1 support in Linux and macOS for increased performance (up to 100% boost in macOS i7 systems when compared against OpenVPN 2)
  • portable version for macOS which does not require Mono package installation
  • nftables support by Network Lock in Linux via nft
  • new aarch64 support through a Raspberry OS 64 bit beta specific build
  • improved IPv6 support
  • many bug fixes




Eddie GUI and CLI now run with normal user privileges, while only a "backend" binary, which communicates with the user interface with authentication, gains root/administrator privileges, with important security safeguards in place:

  • stricter parsing is enforced before passing a profile to OpenVPN in order to block insecure OpenVPN directives
  • external system binaries which need superuser privileges (examples: openvpn, iptables, hummingbird) will not be launched if they do not belong to a superuser
  • Eddie events are no more run with superuser privileges: instead of trusting blindly user's responsibility and care when dealing with events, now the user is required to explicitly operate to run something with high privileges, if necessary

Backend binary is written in C++ on all systems (Windows included), making the whole application faster.

Settings, certificates and keys of your account stored on your mass storage can optionally be encrypted on all systems either with a Master Password or in a system key-chain if available.

Eddie 2.19.7 can be downloaded here:
https://airvpn.org/linux - Linux version
https://airvpn.org/macos - Mac version
https://airvpn.org/windows - Windows version

Eddie is free and open source software released under GPLv3. Source code is available on GitHub: https://github.com/AirVPN/Eddie

Complete changelog can be found here.

Kind regards & datalove
AirVPN Staff
 

Share this post


Link to post

This new version of Eddie works great on Ubuntu 20.04, but sadly I can't get it to start on Windows 10 for some reason. Every time I start it up on Windows it says 

Unable to obtain elevated privileges (required): Unable to start (unable to initialize service)
(Even though I always click "Yes" on the User Account Control "Do you want to allow this app to make changes to your device?" dialog box, for some reason it says it doesn't have the permissions, but I gave it the permissions!
Is anyone else experiencing a similar issue?

Share this post


Link to post
Posted ... (edited)
2 minutes ago, User of AirVPN said:

Tämä uusi Eddie-versio toimii hyvin Ubuntu 20.04: ssä, mutta valitettavasti en voi saada sitä käynnistymään Windows 10: ssä jostain syystä. Joka kerta kun käynnistän sen Windowsissa, siinä sanotaan 



 
(Vaikka napsautan aina "Kyllä" Käyttäjätilien hallinta "Haluatko antaa tämän sovelluksen tehdä muutoksia laitteeseesi?" -Valintaikkunassa, jostain syystä se sanoo, ettei sillä ole käyttöoikeuksia, mutta annoin sille käyttöoikeudet!
Onko kukaan muu kokee samanlaisen ongelman?

I work fine with Windows 10 and Windows 7 with this new 2.19.7 version. Could you take a picture of the problem? Maybe I can help you. Edited ... by Mazufa

Share this post


Link to post
9 hours ago, User of AirVPN said:

This new version of Eddie works great on Ubuntu 20.04, but sadly I can't get it to start on Windows 10 for some reason. Every time I start it up on Windows it says 


Unable to obtain elevated privileges (required): Unable to start (unable to initialize service)
(Even though I always click "Yes" on the User Account Control "Do you want to allow this app to make changes to your device?" dialog box, for some reason it says it doesn't have the permissions, but I gave it the permissions!
Is anyone else experiencing a similar issue?
Hi,
same issue for me with Windows 10

Share this post


Link to post
11 hours ago, User of AirVPN said:

This new version of Eddie works great on Ubuntu 20.04, but sadly I can't get it to start on Windows 10 for some reason. Every time I start it up on Windows it says 


Unable to obtain elevated privileges (required): Unable to start (unable to initialize service)
(Even though I always click "Yes" on the User Account Control "Do you want to allow this app to make changes to your device?" dialog box, for some reason it says it doesn't have the permissions, but I gave it the permissions!
Is anyone else experiencing a similar issue?

Installed on latest WIN 10 x64, works without problems. (Did a complete uninstall with 2.19.5 before)

Share this post


Link to post
1 minute ago, H8SOCIETY said:

Installed on latest WIN 10 x64, works without problems.


I had this same problem this morning.

1: Go to Device Manager

2: Open the network devices there

3: Remove the TAP driver from there

4: Go to the Program files folder, and open the AirVPN folder there.

5: Click the tap-windows icon in the AirVPN folder, and install the new TAP driver. After this, the problem should be fixed! :) This helped me this morning when I had this same problem.

Share this post


Link to post
12 hours ago, cambell said:

The same as the beta, or not?🤔

just checked and it seems like it, same sha256 sum (at least the macOS version I use)

Share this post


Link to post

lots of servers rated 0 stars even though they look to be better on all areas then other servers rated 2-3 stars
has been an issue since 2.19.2

Untitled.png

Share this post


Link to post

On MacOS Catalina, Eddie hangs at startup. "Connect with daemon for system privileges". Will post logs if someone can tell me where to find them. Thanks for your help!

Using the portable version... although I've had this problem on the beta version using the .dmg available for download as well.

Share this post


Link to post

2.19.7 gives me "Exception, Rules not loaded" and dumps the pfctl config.
Had this on the 2.19.6 Beta also and reported to AirVPN Staff.

 

Share this post


Link to post

Hi All
Eddie 2.18.9 working well with WinTun driver. Even so, decided to install 2.19.7 over it with the result that the new Eddie loaded - but went into a connecting/disconnecting loop at the end of the script.
Don't know what AirVPN's recommendations are here, but if uninstalling the earlier version is important than perhaps a warning note to help newbies such as myself might help before we stuff the install up?
After a lot of manual mucking about, 2.19.7 is now working, but the Log has an error line:
OpenVPN > NOTE: GetBestInterfaceEx returned error: Element not found.   (code=1168)
Is this serious?
To be truthful, I am not convinced that my downloads are any faster than before this upgrade, but then there may well be some misconfiguration issues so I'll reserve judgement.
Would appreciate any comments from those more experienced!
Thanks all.

Eddie 2.19.7 Report.txt

Share this post


Link to post

I opened a ticket with support and they suggested I download the latest version of openvpn. I did this then re-installed 2.19.7 and everything was OK - once again AirVpn support saves the day!
Link to official openvpn site posted below.

https://airvpn.orgindex.php?app=core&module=system&controller=redirect&url=https%3A%2F%2Fopenvpn.net%2Fcommunity-downloads%2F&key=f0b86cf5c7363e8de077ca9b38e9737fc0a9c3223adbe81e4d76b7afa5d1df3a&resource=

Share this post


Link to post
Posted ... (edited)

I had the same issue as Philiberti, I did what he did quoted below, it worked to install openvpn, then reinstall new version of Eddie. 
Hope it works for you too.  I did have to change my DNS to a valid IP address.  I changed to 8.8.8.8 and 8.8.4.4  which is Google.  I plan to change to more secure less intrusive DNS right away.

6 hours ago, Philiberti said:

I opened a ticket with support and they suggested I download the latest version of openvpn. I did this then re-installed 2.19.7 and everything was OK - once again AirVpn support saves the day!
Link to official openvpn site posted below.

https://airvpn.orgindex.php?app=core&module=system&controller=redirect&url=https%3A%2F%2Fopenvpn.net%2Fcommunity-downloads%2F&key=f0b86cf5c7363e8de077ca9b38e9737fc0a9c3223adbe81e4d76b7afa5d1df3a&resource=

Edited ... by bookreader
added DNS explanation

Share this post


Link to post

I thought that since v2.19.6 openvpn was incorporated in AirVPN?. After installing v2.19.6 I uninstalled openvpn and AirVPN working perfectly and upgraded to v2.19.7 without any problems. On reading the posts above I checked my programs list in Win10 and see that it now says Eddie - OpenVPN UI where before it just said Eddie iirc. Anyway mine is working fine so am unsure why Air support is saying to install the latest version of openvpn?.

Share this post


Link to post
@bluesjunior

It was just for the specific case of the customer who had previously installed some OpenVPN 2.5 beta version that did not support data-ciphers directive. Therefore OpenVPN failed when Eddie ran it with a profile containing that directive, which is supported by OpenVPN 2.5 release.

Kind regards
 

Share this post


Link to post
On 1/19/2021 at 5:45 PM, User of AirVPN said:

This new version of Eddie works great on Ubuntu 20.04, but sadly I can't get it to start on Windows 10 for some reason. Every time I start it up on Windows it says 


Unable to obtain elevated privileges (required): Unable to start (unable to initialize service)
(Even though I always click "Yes" on the User Account Control "Do you want to allow this app to make changes to your device?" dialog box, for some reason it says it doesn't have the permissions, but I gave it the permissions!
Is anyone else experiencing a similar issue?

same issue for me but I am using it on Mac OS.

Share this post


Link to post

Mazufa,

Can I ask what the latest version of C++ Redistributable is on your Win7 machine? 

On my Win7 32 bit machine I have C++ Redistributable 2015-2019 and Eddie v. 2.19.6 works well but I am unable to install v. 2.19.7 because the C++ Restributable download fails, I suspect because the installer is trying to install an older C++ Redistributable version this is not back comaptible with 2015-2019.  So wondering if I should uninstall the 2015-2019 version so that the Eddie installer can install the version it wants.  Just a theory...

Any thoughts about how to wrestle v 2.19.7 on to a Win7 32 bit machine appreciated.

Share this post


Link to post
On 1/22/2021 at 4:45 AM, stevehere said:

same issue for me but I am using it on Mac OS.

Go into the preferences, uncheck the launch daemon at startup option. Save and close Eddie. Reopen Eddie, go back into prefs and recheck the daemon option. Save, close Eddie again. Now fire up Eddie, put in your password, see if it sticks. 
Sometimes it gets stuck when you upgrade, let it redo the whole thing and it usually gets right back up and running. Changes to Eddies preferences don't go into affect until you restart it either, hence all the closing/opening you need to do each step.

Share this post


Link to post
Posted ... (edited)
On 1/19/2021 at 11:45 PM, User of AirVPN said:

I can't get it to start on Windows 10 for some reason. Every time I start it up on Windows it says 


Unable to obtain elevated privileges (required): Unable to start (unable to initialize service)
me too, but only on my laptop. My PC works just fine with version 2.19.7. Both have Windows 10 Pro 20H2 fully updated. Both have TAP-Windows 9.24.2 installed. Both use ESET Internet Security. In Computer Settings-> Services and Applications-> Services-> Eddie Elevation Service, I'm unable to start it on my laptop. One difference: my PC runs on AMD Ryzen 7 3700X 8-Core and my laptop runs on Intel Core-i7-6700HQ CPU.

PROBLEM SOLVED!!  ... The Eddie Elevation Service was present even when Eddie had been de-installed, and it was not possible to start this service manually. Installing OpenVPN did not help so I de-installed it too. By this time TAP-Windows 9.24.2 had disappeared. I then deleted the following key manually in the Registry Editor: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\EddieElevationService. (There are cleaner ways to remove Services.) After that, installing Eddie 2.19.7 worked perfectly. Note that before this I had been using Eddie 2.18.9 (and earlier versions) for ages without a problem. Edited ... by Auri
Problem Solved + typo

Share this post


Link to post

Anyone else having Eddie 2.19.7 crash immediately after adding another "Generic OpenVPN provider"? As soon as I hit "save" it always crashes.
It has been working perfectly with 2.18.9.
Sadly none of the 2.19 beta versions are available anymore so I can't test any of them.

I'm on Windows 10 Enterprise 2016 LTSB by the way.

Share this post


Link to post

Hi guys!

Windows 8.1 x64

The same problem appears since v18.9

Eddie doesn't succeed to connect after installing Tap-Driver v9.24.2 and Eddie v18.9 and v19.7 doesn't work with Tap-Driver v9.21.2.

So, I have no choice to re-install Eddie v2.16.3 (with Tap-Driver v9.21.2) and disabling driver update.

So, suggestions ?

Thanks

Share this post


Link to post
On 1/27/2021 at 1:58 PM, Auri said:
me too, but only on my laptop. My PC works just fine with version 2.19.7. Both have Windows 10 Pro 20H2 fully updated. Both have TAP-Windows 9.24.2 installed. Both use ESET Internet Security. In Computer Settings-> Services and Applications-> Services-> Eddie Elevation Service, I'm unable to start it on my laptop. One difference: my PC runs on AMD Ryzen 7 3700X 8-Core and my laptop runs on Intel Core-i7-6700HQ CPU.

PROBLEM SOLVED!!  ... The Eddie Elevation Service was present even when Eddie had been de-installed, and it was not possible to start this service manually. Installing OpenVPN did not help so I de-installed it too. By this time TAP-Windows 9.24.2 had disappeared. I then deleted the following key manually in the Registry Editor: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\EddieElevationService. (There are cleaner ways to remove Services.) After that, installing Eddie 2.19.7 worked perfectly. Note that before this I had been using Eddie 2.18.9 (and earlier versions) for ages without a problem.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...