Jump to content
Not connected, Your IP: 3.80.5.103

Recommended Posts

Hi, 
First of all, I want to express thanks to anyone who can help me.

I also want to mention I've looked at these posts and they seem to have different problems compared to the one I have:
https://airvpn.org/forums/topic/5070-port-forwarding-with-plex-server/#5072
https://airvpn.org/forums/topic/6503-setup-airvpn-to-work-with-plex-media-server/
https://airvpn.org/forums/topic/26233-having-issues-with-plex-and-airvpn/

The problem I'm having with plex is consistent around the network adapter that airvpn uses. I've tested my port forward and it is reachable when plex is running so I know that part work. I've also port forwarded for my torrent client and that works too.
The issue I'm having is plex won't detect the correct network adapter (TAP-Windows Adapter V9).
I'm not sure what to do at this point.
I've turned off port forwarding on my router like I'm supposed to since I'm using airvpn to port forward but if I turn off the VPN and turn my router port forward back on it works again. 
I've tried manually selecting a network adapter in plex but the only one that appears is my ethernet adapter.

image.png.81e0c0a00483c1e70454ebd22f2b09ef.pngimage.png.cff778b8808d283fb713b0b30534ec97.png


Is there any way around this? (like forcing plex to use that adapter somehow?)
or is it possible I'm looking at this problem the wrong way?

Thanks in advance!

Share this post


Link to post
Posted ... (edited)

Pretty sure mine worked ok with Plex last time i tried it, try downloading the experimental version and trying the WinTun driver
Could always try this too - https://r1ch.net/projects/forcebindip i used it successfully for other network related thingies

Edited ... by Bishi

Share this post


Link to post
Posted ... (edited)

could you clarify what you mean by the experimental version of plex? I've searched online and I can't seem to find anything on an experimental version. 
Thanks for the forcebindIP suggestion, I thought it would work, but either I'm setting it up wrong or it doesn't work for me. 
I keep getting an error saying "The System cannot find the file specified" but I'm following the syntax it requires and also tried copying the .dll's to the plex media server folder.
if what I'm doing seems wrong please let me know, otherwise, any other suggestions would be appreciated!

this is what I'm entering in cmd for forcebindIP "C:\Program Files (x86)\ForceBindIP\ForceBindIP.exe" x.x.x.x "C:\Program Files (x86)\Plex\Plex Media Server.exe"

the IP i am using for x.x.x.x is the IP address of the TAP adapter

i also found a post on plex saying that plex ignores forcebindIP but its fairly old so I thought it could still work
https://forums.plex.tv/t/bind-to-ip-address/187688/2

Edited ... by Babywise
adding info

Share this post


Link to post
Posted ... (edited)

ForceBindIP might not work any more, like i say it has been years since i tried.
experimental version is on the download page, click windows then other versions then get the beta. It has the WinTun driver on the advanced settings page once you install

Edited ... by Bishi

Share this post


Link to post
Posted ... (edited)

alrighty, that's fair, I appreciate you trying to help.

If you referring to the downloads page on the plex website, that has been updated into the plex app control, there is no longer a beta section for plex downloads on their website.

I have selected beta in the app but sadly doesn't work, I'm assuming this means it doesn't include the WinTun driver because of this?

if I try to use Wire Guard from https://www.wireguard.com/ that win tune is intended for, would plex see those adapters? I'm curious if I can create an adapter route it to the correct adapter and have it work that way?
 

Edited ... by Babywise
Grammer

Share this post


Link to post

From just a glance at the images provided, it seems as if PLEX is seeing what's there. In your Network Manager in Windows, what adapters are listed? PLEX is only going to see what adapters Windows reports as physical hardware (wired or wireless). At least in my experience.

Share this post


Link to post

To: @Bishi
oohhhh thankss didnt know about the experiement version of eddie!
I uninstalled the version I had and installed that one, I tried using it with the openvpn directive like it says over here: https://airvpn.org/forums/topic/46535-how-to-use-wintun-driver-in-windows/ 
however this didn't work for me....

BUT i installed openVPN with wintun selection ticked and generated a .ovpn through https://airvpn.org/generator/ and it finally worked!

To: @SumRndmDude
unfortunately plex only sees 1 adapter, I would love to keep using the eddie UI if possible, but this doesn't seem to be possible for me
here are all my adapters, I would think more than 1 would show up, but with plex this isn't the case
image.thumb.png.2fa3e1928e1ec9c8df78efec41cd457a.png

Share this post


Link to post

Right, it's only seeing the physical adapter that is enabled. The others being virtual or disabled. If you enable a wireless adapter and connect it to an AP, does PLEX then display this adapter? If so, then it seems that's all that PLEX will attempt to latch onto, a physical device that is also enabled.

Share this post


Link to post

for some reason no, even if im connected to the wifi it only shows 1 option, but my thinking is because its the same network, so the local IP is the same.
when i use win tune with openVPN the adapter still don't show up, but it automatically choosing the correct adapter so I'm not sure whats going on with plex

Share this post


Link to post

If you really want to nail this down as the issue, enable wired and wireless at the same time to get two different IP's from your router. Restart PLEX and see if it shows both. If so, we can confirm it will only display enabled, physical interfaces. My NAS has two NICs that connect to two different LAN's and they display as expected in PLEX, hence my thoughts about the virtual/physical issue.

Share this post


Link to post

you are correct, if I switch to a different network with the wifi while the ethernet is connected to the main network, both network adapters then show up in the plex interface

Share this post


Link to post

Well, I'm glad to confirm my theory. Sorry it doesn't help you much in the long-run though. I have my connections to the VPN at the router level, so I never have to worry about whether a given adapter dictates the connection. I also strictly control the DHCP server, so, again, a non-issue. At least we now know the cause for the behavior you've seen.

Share this post


Link to post

haha its all good, im glad it works for now, I would do the router solution, but 1) I don't have a router, I just use the modem from rogers and my speeds are up to par, and 2) I'm not the only person using the network and I didn't want to hinder anyone else on the network in my family with the VPN. i might consider doing it tho when I can afford the router I've been looking at, its just a little out of my price range atm.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...