Jump to content
Not connected, Your IP: 3.80.6.131
magnumpi

Port Forwarding with Plex Server

Recommended Posts

Create the port forward on this website first, that matches the port you're using on the Plex server.

Then add a line like:

iptables -t nat -I PREROUTING -i tun1 -p tcp --dport 12345 -j DNAT --to-destination 192.168.1.50

to your firewall.

12345 is the port number

192.168.1.50 is the IP of the machine running plex

As long as the VPN is connected, plex should work.

Share this post


Link to post

Sorry to revive an old post.  I'm trying to get this to work as well.

 

I just setup AirVPN on OSX and its working great.  I setup a port forward on this website (51060) and matched that same port in the Plex Media Server.  I also opened that port for Plex on my modem/router (2wire 3801).  I'm not sure how to "add a line" to my firewall, however.

 

I got the following message when I tried to check the port from this website:

Not reachable on server IP over the external port 51060, tcp protocol. Error : 111 - Connection refused

 

Would someone be so kind as to explain exactly how I might open up that port on my firewall?

Share this post


Link to post

Sorry to revive an old post.  I'm trying to get this to work as well.

 

I just setup AirVPN on OSX and its working great.  I setup a port forward on this website (51060) and matched that same port in the Plex Media Server.  I also opened that port for Plex on my modem/router (2wire 3801).  I'm not sure how to "add a line" to my firewall, however.

 

I got the following message when I tried to check the port from this website:

Not reachable on server IP over the external port 51060, tcp protocol. Error : 111 - Connection refused

 

Would someone be so kind as to explain exactly how I might open up that port on my firewall?

 

In your case I don't believe that is necessary. The ipTables entry is only needed if you are running OpenVPN on the router using DD-WRT firmware. Just forward the local port in your 2wire. Don't forget about any software firewall as well.

Share this post


Link to post

In your case I don't believe that is necessary. The ipTables entry is only needed if you are running OpenVPN on the router using DD-WRT firmware. Just forward the local port in your 2wire. Don't forget about any software firewall as well.

Then what am I missing?  I got everything setup as stated above: port forward setup in this website, same port specified in Plex Media Server, and the same port forwarded in my 2wire.  But I can't connect to my Plex server remotely.  When I'm not connected to the VPN it works.  When I'm connected to the VPN, it doesn't.  Not sure about any software firewall-- what might that be...?

Share this post


Link to post
It is important that you use the correct port (REMOTE PORT) in your Plex settings. The remote port resolves to the local port as it passes through the VPN.

 

Be sure your Plex Server is mapped to port 37222 (For this example)

 

In Plex go to "Settings/MyPlex" and click on "Show Advanced Settings".

 

Manually specify port 37222 <--- This should be the REMOTE port used when setting up your port forward on AirVPN.

 

 

37222

Protocol: TCP & UDP

Local port: 32400

DDNS: myplexserver

TCP Test: Reachable on server IP over the external port 37222, tcp protocol.

 

Hope this makes sense. If not I can try again...

 

As for a Software firewall... I do not use OSX, but if the port gets through without the VPN you should be okay. If not, someone else may need to answer the FW question.

 

Edit : My use of port 37222 is for example only. You can allow the port forward generator to pick one for you or pick your own. Also, you want to be sure your local port number is different from the external port.

Share this post


Link to post

I understand that the remote port must be routed to the local port.  This problem seems to have resolved itself after I deleted the port forward on this website and then added it again.  I'm pretty sure I entered everything correctly when I entered it the first time, but maybe not...

 

Just to confirm a couple things:

 

1) Should I remove the port forward on my modem?  I don't want to lose access to my Plex Server if the VPN service goes down.  It is a nuisance to configure the port forward on my modem.  So, it is, perhaps, preferable if I can avoid having to do it every time the VPN might become unavailable.

 

2) There's no additional software firewalls or anything in the AirVPN service-- right?

 

Thanks.

Share this post


Link to post

I understand that the remote port must be routed to the local port.  This problem seems to have resolved itself after I deleted the port forward on this website and then added it again.  I'm pretty sure I entered everything correctly when I entered it the first time, but maybe not...

 

Just to confirm a couple things:

 

1) Should I remove the port forward on my modem?  I don't want to lose access to my Plex Server if the VPN service goes down.  It is a nuisance to configure the port forward on my modem.  So, it is, perhaps, preferable if I can avoid having to do it every time the VPN might become unavailable.

 

2) There's no additional software firewalls or anything in the AirVPN service-- right?

 

Thanks.

 

The answer to question 1 is no. You need to have the port forward in the router so the traffic can be forwarded correctly to Plex, or whatever the case may be.

 

The answer to question 2 is also no.

 

Just a suggestion... If you are not running a software firewall, I would recommend you consider using one. OSX may have one by default, not sure, but I would check to be sure.

Share this post


Link to post

I just want to confirm that this does work

 

 

It is important that you use the correct port (REMOTE PORT) in your Plex settings. The remote port resolves to the local port as it passes through the VPN.
 
Be sure your Plex Server is mapped to port 37222 (For this example)
 
In Plex go to "Settings/MyPlex" and click on "Show Advanced Settings".
 
Manually specify port 37222 <--- This should be the REMOTE port used when setting up your port forward on AirVPN.
 
 
37222
Protocol: TCP & UDP
Local port: 32400
DDNS: myplexserver
TCP Test: Reachable on server IP over the external port 37222, tcp protocol.
 
Hope this makes sense. If not I can try again...
 
As for a Software firewall... I do not use OSX, but if the port gets through without the VPN you should be okay. If not, someone else may need to answer the FW question.
 
Edit : My use of port 37222 is for example only. You can allow the port forward generator to pick one for you or pick your own. Also, you want to be sure your local port number is different from the external port.

 

I just wanted to confirm that the above does work correctly

 

In Plex you need to 

 

Manually specify port

   37222

 

 

The when when setting up port forwarding here in AirVPN, use 37222 as the new port number and enter 32400 as the local port

Share this post


Link to post

I tried these settings and plex worked or 1 day and now it will not connect

 

I tried, example, port8286 to local port 32400 and plex was left at 32400, doesn't connect

tried port 8286 to 8286 and changed plex to 8286 and didn't work

port forwarded the ports on my router no work

 

an ideas, because I  had it working last night. went to bed and it stopped working

I just want to confirm that this does work

 

 

 

It is important that you use the correct port (REMOTE PORT) in your Plex settings. The remote port resolves to the local port as it passes through the VPN.
 
Be sure your Plex Server is mapped to port 37222 (For this example)
 
In Plex go to "Settings/MyPlex" and click on "Show Advanced Settings".
 
Manually specify port 37222 <--- This should be the REMOTE port used when setting up your port forward on AirVPN.
 
 
37222
Protocol: TCP & UDP
Local port: 32400
DDNS: myplexserver
TCP Test: Reachable on server IP over the external port 37222, tcp protocol.
 
Hope this makes sense. If not I can try again...
 
As for a Software firewall... I do not use OSX, but if the port gets through without the VPN you should be okay. If not, someone else may need to answer the FW question.
 
Edit : My use of port 37222 is for example only. You can allow the port forward generator to pick one for you or pick your own. Also, you want to be sure your local port number is different from the external port.

I just wanted to confirm that the above does work correctly

 

In Plex you need to 

 

Manually specify port

   37222

 

 

The when when setting up port forwarding here in AirVPN, use 37222 as the new port number and enter 32400 as the local port

Share this post


Link to post

Hi Plex user here. I have no problems with airVPN and Plex.  

 

In my case for example:

 

airVPN settings Forwarded Ports 59421, Protocol TCP & UDP, Local Port 32400

 

Plex Server Settings-> Connect-> Manually Specify Port ticked & port 59421 filled in.

 

Plex will show something like this in the log when successful  "INFO - NAT: Mapping changed 37.48.80.175:59421 -> 10.4.86.206:32400"  The first IP addess is airVPN server specific and the second is the local airVPN TUN port on your plex server.

Share this post


Link to post

Im having a siimilar problem with Plex.  The forwarded ports says "Not reachable on server IP over the external port 22515 tcp protocol.  Error - 110 - connection timed out.  However im using pfsense and have set up port forwarding and I still cant get it to connect outside of my network.

Share this post


Link to post

Make sure that the device on the "outside." That you are trying to connect is looking for plex on the New port number on the AirVPN server. The client needs the AirVPN port and the server needs to think it's talking over the local port. There will be two different port numbers in use by the server and the client, but the traffic will match up anyway.

Share this post


Link to post

Hi there!

I'm running into the same kind of problems here...
I got an ubuntu 16.04 server with plexmedia server headless on it.
Now I installed airvpn which works just fine. However, I can not connect to my plex server anymore.

 

Hi Plex user here. I have no problems with airVPN and Plex.  

 

In my case for example:

 

airVPN settings Forwarded Ports 59421, Protocol TCP & UDP, Local Port 32400

 

Plex Server Settings-> Connect-> Manually Specify Port ticked & port 59421 filled in.

 

Plex will show something like this in the log when successful  "INFO - NAT: Mapping changed 37.48.80.175:59421 -> 10.4.86.206:32400"  The first IP addess is airVPN server specific and the second is the local airVPN TUN port on your plex server.

The setup here is similar to yours Grazzy:

 

on airVPN:
External AirVPN Port 10317

Protocol: both
local port: 32400

on my router:
external port 32400 forwarded to port 32400 of my static ip server   (is that right?)

 

on Plex:

Public port: 10317

 

 

 

Now, if I try to connect to Plex using

 

'External-AirVPN-IP':10317/web

 

I actually find myself on a Plex log-in page. But as I'm logged in I see the Plex Main Window with the spinning wheel, "Looking for servers..."


Any ideas why I'm not able to connect Plex from outside?

Thanks a lot for any suggestion!

cheers

Kickvibepressure

Share this post


Link to post

Hi Plex user here. I have no problems with airVPN and Plex.  

 

In my case for example:

 

airVPN settings Forwarded Ports 59421, Protocol TCP & UDP, Local Port 32400

 

Plex Server Settings-> Connect-> Manually Specify Port ticked & port 59421 filled in.

 

Plex will show something like this in the log when successful  "INFO - NAT: Mapping changed 37.48.80.175:59421 -> 10.4.86.206:32400"  The first IP addess is airVPN server specific and the second is the local airVPN TUN port on your plex server.

 

Waisted a couple of hours before i found this but this also solved it for me, thank you very much!

Share this post


Link to post

I've tried this multiple times and it's still not working. To clarify, when the VPN isn't running, Plex Media Server works fine, when it's on, nothing. I've set public port 23344 to route to local port 32400 on AirVPN settings in the Client Area. I've added this to my Plex Media Server and it keeps telling me Remote Access is not available. Here is a screenshot >> https://i.imgur.com/HKAuZOj.jpg (this forum will NOT let me post this as an image no matter what I do so apologies for link)

Share this post


Link to post

 

In your case I don't believe that is necessary. The ipTables entry is only needed if you are running OpenVPN on the router using DD-WRT firmware. Just forward the local port in your 2wire. Don't forget about any software firewall as well.

Then what am I missing?  I got everything setup as stated above: port forward setup in this website, same port specified in Plex Media Server, and the same port forwarded in my 2wire.  But I can't connect to my Plex server remotely.  When I'm not connected to the VPN it works.  When I'm connected to the VPN, it doesn't.  Not sure about any software firewall-- what might that be...?

This is the issue I'm having right now.  It worked fine for the longest and now with the SAME setup that was working for the last TWO years is not working anymore.  When I disconnect from the vpn it works, when I connect to the VPN it stops working.  Tech support ran out of ideas.  Anyone have any ideas on how to fix this?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...