Jump to content
Not connected, Your IP: 18.206.194.134
Artist

Eddie freezes the MacBook

Recommended Posts

Hello,

I have problems with Eddie on MacOS and multiple users.

Initially I tried to move the app to the system /Applications folder, change the permissions to a group common for the users and added writing permissions for the group (drwxrwxr-x).
It didn't work and it started to crash my laptop every time I open Eddie (the UI opens for few seconds but then it freezes the system, probably when trying to initialise the network devices or the embedded OpenVPN).
The system freezes for some 5-10 seconds, spinning the fan at the maximum (CPU issue?) for 1 second, and then turns off completely.
I tried different times.


Doesn't what I did make sense?
How can I have a single installation for 2 users? (belonging to a custom group)

I also tried using a /Users/Shared/Applications folder (that maybe makes more sense, so is a custom folder with custom group, rather than for *all* the users). But still, same problem.


Temporary, I redownloaded and reinstalled Eddie for the secondary user and it worked again without problems. But after some hours of use it froze and shut-down again, after my laptop lost signal to the wifi.
So I am not even sure anymore that the problem is with the permissions.

Can you help me understand (and solve) the problem please?
 

Share this post


Link to post

I tried to remove the .airvpn from my home folder and now the app worked again, for some hours.

Then I tried to go in the Preferences of the app and it froze the system again.

Is AirVPN doing something else, outside of the application folder and outside the ~/.airvpn folder?
Is OpenVPN used in the background? If yes, where is this installed/configured?
Might be that it got some permission problem on the virtual network device that it creates? (if any; I dunno if it works the same as on Windows).

Share this post


Link to post
@pictor13

Hello!

Can you tell us your exact macOS version as well as the Eddie version you run?

Please consider to test also Eddie 2.18.7 beta if you haven't already done so. Eddie 2.18 resolves several issues that Eddie 2.16 may have especially in macOS Catalina. Please see here to download Eddie latest beta version:
https://airvpn.org/forums/topic/45326-eddie-desktop-218beta-released/

Kind regards

 

Share this post


Link to post
Posted ... (edited)
On 2/7/2020 at 5:29 PM, Staff said:
@pictor13

Can you tell us your exact macOS version as well as the Eddie version you run?

Please consider to test also Eddie 2.18.7 beta if you haven't already done so. Eddie 2.18 resolves several issues that Eddie 2.16 may have especially in macOS Catalina. Please see here to download Eddie latest beta version:
https://airvpn.org/forums/topic/45326-eddie-desktop-218beta-released/

It is giving the issue on Mojave 10.14.6 (18G95) and Eddie-2.16.3.
I am not moving to Catalina, for the moment.

Can you please tell me:
  •  what should be the permissions for the ~/.airvpn folder? Just to confirm everything is in order.
  • if the application runs as root or with some special privilege? It always asks me for the password before executing the app.
    • [I am asking because the default.xml configuration file under ~/.airvpn is being created with root as owner and has no read/write permissions for the group 
      -rw-------   1 root    mygroupname  141098 Feb  9 13:10 default.xml
      that sounds weird to me; I would expect the owner to be my running user]
so I can verify the permissions are in order? Edited ... by pictor13
add details

Share this post


Link to post

However, the freeze happens few seconds after I inserto my credentials and login. I am not even trying to connect to a server (so I dunno if OpenVPN is being initialised already).
If that can be of any help.
Let me know if you need some more info.

Share this post


Link to post
On 2/7/2020 at 5:29 PM, Staff said:
@pictor13
Please see here to download Eddie latest beta version:
https://airvpn.org/forums/topic/45326-eddie-desktop-218beta-released/

I've tried but on "MacOS page -> Older versions", clicking on Experimental does nothing, but I can see a message saying "Older versions are not available anymore for security reasons".

EDIT:
I got mislead by the message.
After clicking Experimental and choosing "Download" it actually downloads the 2.18_7, even if nothing seems to not change in the UI.

And it seems to run a lot more smoothly than with the crash-y version.
Thanks!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...