Jump to content
Not connected, Your IP: 3.235.29.190
go558a83nk

WINTUN replacement for Windows TAP driver

Recommended Posts

Windows 10 OpenVPN 2.5_git (Wintun) "small issue or bug":
On Reconnect or Disconnect/Connect to a different AirVPN server: the previous Assigned IP(fde6:) is still present in the routing table along with the new Assigned IPv6(fde6:).
@go558a83nk
Did you notice this behavior?




 

Share this post


Link to post

I use pfsense so I'm not using openvpn on windows.  I just posted it here as I figured there would be some people who'd like to use it.

Share this post


Link to post
1 hour ago, pfolk said:

how do I hook up and use the Wintun driver with AirVPN ? 

Add "windows-driver wintun" to .ovpn config, or
Add "--windows-driver wintun" to openvpn.exe command line
without the "quotes".
-----------------
auth sha512
windows-driver wintun
-----------------
Change the buffer like this if you want to achieve better speeds:
------------------
rcvbuf 562144
sndbuf 562144
------------------


 

Share this post


Link to post

 

1 hour ago, Flx said:
Add "windows-driver wintun" to .ovpn config, or
Add "--windows-driver wintun" to openvpn.exe command line
without the "quotes".

thanks !

but, where do I configure OpenVPN ? I've never done this before for AirVPN, simply installed Eddie and used as is...

 

Share this post


Link to post
14 hours ago, Flx said:

Under "custom OpenVPN directives." section in Eddie.
That is where you add your desired choices:
-------------------------------
windows-driver wintun
rcvbuf 562144
sndbuf 562144
------------------------------
 



does not work for me under Win 10 LTSC x64, Eddie 2.16.3... here's what I did:

1) Added the above directives to Eddie > Prefs > OpenVPN directives > Custom directives.
2) Then also uninstalled the current TAP driver via AirVPN (under Prefs > Advanced)
3) Rebooted.
4) Start AirVPN (it will say missing TAP driver and install TAP driver again), then I try to connect to any server. It keeps immediately aborting the connection and try another server... endless loop

Btw, since I installed openvpn-install-2.5_git_wintun-I607-Win10.exe, OpenVPN now pops up at every boot stating:

No readable connection profiles (config files) found.
Use the "Import File.." menu or copy your config files to "C:\Users\John\OpenVPN\config" or "C:\Program Files\OpenVPN\config".


do I need to configure something here ?

Thanks.

Share this post


Link to post
4 minutes ago, go558a83nk said:

You must be using at least openvpn 2.5 besides the wintun driver.


I did install openvpn-install-2.5_git_wintun-I607-Win10.exe, and Win > control panel > programs and features states that that version is installed...

Share this post


Link to post
1 hour ago, pfolk said:

I did install openvpn-install-2.5_git_wintun-I607-Win10.exe, and Win > control panel > programs and features states that that version is installed...

That's the wintun driver, not openvpn.

Look in your logs and it should say what version of openvpn is being used.

Share this post


Link to post
1 hour ago, go558a83nk said:

That's the wintun driver, not openvpn.

Look in your logs and it should say what version of openvpn is being used.

AirVPN logs say OpenVPN 2.4.6....

alright, so how do I install OpenVPN 2.5 ?

On their website under community downloads there is only the "OpenVPN 2.5_git wintun technology preview" package, which is a 4.4MB file, which is what I installed... so that 4.4MB is just for the wintun driver... ?

Share this post


Link to post
cannot get this to work...

under Eddie > Prefs > Advanced > OpenVPN Custom path I entered the path of the openvpn.exe that came with the OpenVPN 2.5_git wintun install, then added the custom OpenVPN directives...

everything seems to be working, it finally prints "OpenVPN > Route addition via IPAPI succeeded [adaptive]
"

but then hangs a bit and then prints "Windows WFP, Add rule failed: Interface ID '' unknown or disabled for the layer.:{2}
" and starts disconnecting...

Any idea what is missing ? 

Share this post


Link to post
2 minutes ago, pfolk said:
cannot get this to work...

under Eddie > Prefs > Advanced > OpenVPN Custom path I entered the path of the openvpn.exe that came with the OpenVPN 2.5_git wintun install, then added the custom OpenVPN directives...

everything seems to be working, it finally prints "OpenVPN > Route addition via IPAPI succeeded [adaptive]
"

but then hangs a bit and then prints "Windows WFP, Add rule failed: Interface ID '' unknown or disabled for the layer.:{2}
" and starts disconnecting...

Any idea what is missing ? 

Eddie probably needs updated for its network lock to work with the updated openvpn.  Turn off the network lock and see if that fixes it. 

Share this post


Link to post
5 hours ago, pfolk said:

under Eddie > Prefs > Advanced > OpenVPN Custom path I entered the path of the openvpn.exe that came with the OpenVPN 2.5_git wintun install, then added the custom OpenVPN directives...

Not to confuse anyone here:
I use Native OpenVPN 2.5_git with wintun not Eddie.
 

Share this post


Link to post
15 hours ago, Flx said:
Not to confuse anyone here:
I use Native OpenVPN 2.5_git with wintun not Eddie.
 

do you happen to know how to get it running with Eddie ?



 

Share this post


Link to post
On 12/24/2019 at 6:13 PM, pfolk said:

do you happen to know how to get it running with Eddie ?

I don't believe you can do that with Eddie client as of yet. Eddie will be updated ASAP to OpenVPN 2.5.x or maybe sooner. You can install the OpenVPN 2.5_git Preview from the official website on your own and do this yourself.

 

Share this post


Link to post
On 1/23/2020 at 9:01 AM, Flx said:

Other than the "small issue or bug" thread(above)which was an UDP session.
TCP session a few disconnects noted.
Stunnel session(SSL-443) did not encounter any disconnects.
Plink not tested yet.


Please be aware that wintun support functionality has been reviewed and merged into openvpn master. You can get latest snapshots from https://build.openvpn.net/downloads/snapshots/
For example, this is the current latest build.

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...