Jump to content
Not connected, Your IP: 3.91.106.223
Sign in to follow this  
Anonymousvpnuser1

curl certificate error in Eddie while trying to connect to AirVPN

Recommended Posts

I just upgraded Windows 10 Pro to version 1903.  

My other PC is still connected.  It seems to be an issue with new connections.  Curl.exe fails to authenticate the IPV4 route.  Bad certificate?  I didn't see anywhere to upgrade the certificates, I assumed Eddie did that automatically.

I was previously running OpenVPN without Eddie.  I decided to try it out.  Is anyone able to connect to servers via OpenVPN without the Eddie interface?

Share this post


Link to post

In the log files I found one line specifically that is causing me disconnects that I've never seen before:

. 2019.08.17 20:38:41 - curl: (60) SSL certificate problem: unable to get local issuer certificate
. 2019.08.17 20:38:41 -     More details here: https://curl.haxx.se/docs/sslcerts.html
. 2019.08.17 20:38:41 -     curl performs SSL certificate verification by default, using a "bundle"
. 2019.08.17 20:38:41 -     of Certificate Authority (CA) public keys (CA certs). If the default
. 2019.08.17 20:38:41 -     bundle file isn't adequate, you can specify an alternate file
. 2019.08.17 20:38:41 -     using the --cacert option.
. 2019.08.17 20:38:41 -     If this HTTPS server uses a certificate signed by a CA represented in
. 2019.08.17 20:38:41 -     the bundle, the certificate verification probably failed due to a
. 2019.08.17 20:38:41 -     problem with the certificate (it might be expired, or the name might
. 2019.08.17 20:38:41 -     not match the domain name in the URL).
. 2019.08.17 20:38:41 -     If you'd like to turn off curl's verification of the certificate, use
. 2019.08.17 20:38:41 -     the -k (or --insecure) option.
. 2019.08.17 20:38:41 -     HTTPS-proxy has similar options --proxy-cacert and --proxy-insecure.

I did go to the website and tried downloading a newer .prem bundle and tried replacing the CA Cert in the directory, tried adding them both, but still getting disconnects.

At this point I don't want to make the problem worse by throwing any google solution at it I can find, any help appreciated!

OS is Win 7 64-bit, nothing has changed since I used it in the last 24 hours, it just stopped working when I tried connecting this afternoon.

Share this post


Link to post

same issue here - I thought it was my old eddie client, so I updated, was on 2.15.xx, same issue both versions.

Share this post


Link to post
5 minutes ago, Anonymousvpnuser1 said:

Anyone experience with expressvpn vs nordvpn? I vaguely remember reading problems with expressvpn but i may be wrong. Definitely the priciest.

I've used Torguard but it doesn't let you open up ports.

Share this post


Link to post

Hello, I cannot connect to any VPN. My logs are as shown:

. 2019.08.17 21:56:41 - Eddie version: 2.16.3 / windows_x64, System: Windows, Name: Windows 10 Home, Version: Microsoft Windows NT 10.0.17763.0, Mono/.Net: v4.0.30319
. 2019.08.17 21:56:41 - Reading options from C:\Users\jtarl\AppData\Local\AirVPN\default.xml
. 2019.08.17 21:56:41 - Command line arguments (1): path="home"
. 2019.08.17 21:56:41 - Profile path: C:\Users\jtarl\AppData\Local\AirVPN\default.xml
. 2019.08.17 21:56:43 - OpenVPN Driver - TAP-Windows Adapter V9, version 9.21.2
. 2019.08.17 21:56:43 - OpenVPN - Version: 2.4.6 - OpenSSL 1.1.0h  27 Mar 2018, LZO 2.10 (C:\Program Files\AirVPN\openvpn.exe)
. 2019.08.17 21:56:43 - SSH - Version: plink 0.67 (C:\Program Files\AirVPN\plink.exe)
. 2019.08.17 21:56:43 - SSL - Version: stunnel 5.40 (C:\Program Files\AirVPN\stunnel.exe)
. 2019.08.17 21:56:43 - curl - Version: 7.54.1 (C:\Program Files\AirVPN\curl.exe)
. 2019.08.17 21:56:43 - Certification Authorities: C:\Program Files\AirVPN\res\cacert.pem
W 2019.08.17 21:56:44 - Recovery. Unexpected crash?
. 2019.08.17 21:56:44 - Routes, removed a route previously added, 184.75.221.59 for gateway 10.31.234.1
. 2019.08.17 21:56:44 - Routes, removed a route previously added, 2606:6080:1001:10:3c5b:63ff:df18:8486 for gateway fde6:7a:7d20:1bea::1
. 2019.08.17 21:56:44 - Updating systems & servers data ...
I 2019.08.17 21:56:44 - Ready
. 2019.08.17 21:56:45 - Systems & servers data update completed

Share this post


Link to post

Same here. Latest Eddie, Windows 10. All servers fail.

IPv4 checking route failed
SSL certificate problem: certificate has expired

Share this post


Link to post

Pity that the SSL cert seems to have expired at 0000UTC, not good for support from Europe. Worse chances on a Sunday morning.
Maybe not easily detected on the server, datacentre end. But a Eddie client watchdog robot could exist to bark an alert ?
 

Share this post


Link to post

The issue is with eddie. If you use the config generator and openvpn, it will work normally.

Share this post


Link to post

Root cause of this issue appears to be an expired certificate.  If you reset your system time to yesterday (I went back a week, so that my day of week will still be correct) or earlier, then I believe you should be able to connect.  It works for me.

And while I do work in support, I do not work for AirVPN support, so do not take this as an official answer from them.

p

Share this post


Link to post
37 minutes ago, eewshvpn said:

Same here. Latest Eddie, Windows 10. All servers fail.

IPv4 checking route failed
SSL certificate problem: certificate has expired

same error here

Admin should post an ackowledgement of the issue and how long til they fix

Share this post


Link to post
32 minutes ago, caseyjp1 said:

The issue is with eddie. If you use the config generator and openvpn, it will work normally.


Just to clarify, going forward I will need to use OpenVPN client instead of Eddie? There is literally no fix for AirVPN's client Eddie to fix the issue to continue using it?

Not that I care much which client I use, but it seems odd that it would just suddenly break over night, and not be recoverable again.

I appreciate the help!

Share this post


Link to post

Just curious if all those having problems are running Windows? I'm on a Mac and have no problems.

Share this post


Link to post

Windows 10 for me. So far, only the Los Angeles servers work for me. I usually connect to Dallas, ATL and Chicago...none of those work right now.

Share this post


Link to post

I'm on windows and have the problem. I suspect the problem came with a recent windows update, since some have reported they were able to reconnect by reverting to a previous day/version

Share this post


Link to post
Just now, harbingerzjc said:

some have reported they were able to reconnect by reverting to a previous day/version

This is not reverting to a previous configuration or version, just setting the time back.  The issue is that a certificate on a server expired (about 3 hours ago, I suspect).  By setting the clock back, your computer will see the certificate's expiration date, compare it to the computer's clock, and decide that it hasn't expired yet.
 

Share this post


Link to post
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...