Jump to content
Not connected, Your IP: 18.205.60.226
Sign in to follow this  
Anonymousvpnuser1

curl certificate error in Eddie while trying to connect to AirVPN

Recommended Posts

Also, it is possible that some servers are using different certificates than others.  Since I don't work for AirVPN, I do not have detailed knowledge of their infrastructure.  Heck, at this point I don't even know for sure what server they are trying to get a certificate from.

p

Share this post


Link to post

Win10 recently updated and thus rebooted. Same error as everyone else. I can confirm that moving the date back in Windows (I chose July 2019) worked for me!
Let's hope the ADMINs see this quickly and correct it.
Cheerio!

Share this post


Link to post
Just now, ps73 said:

Root cause of this issue appears to be an expired certificate.  If you reset your system time to yesterday (I went back a week, so that my day of week will still be correct) or earlier, then I believe you should be able to connect.  It works for me.

And while I do work in support, I do not work for AirVPN support, so do not take this as an official answer from them.

p


Just ran into this bug, skipped over here, and can confirm this worked for me as well. Everyone looking for a temp fix, try this!

Share this post


Link to post

Thanks guys, changing the date worked. Actually I remember awhile ago having a similar issue with airvpn where we had to set the clock back. Thank you this is good for a temporary fix but I think im going to look into another VPN, probably nord or express. So not t he first time with this issue and plus i get frequent disconnects on airvpn's servers and get auto reconnected to canadian servers. Got a couple months left on this sub. Plus 24/7 live support on express.

Share this post


Link to post

On Mac (and probably Linux) one can workaround the expired cert by adding the file ~/.curlrc with a single line: --insecure

Works for me, and seems a little less kludgy than setting the system clock backwards.  It's not a good idea to leave that in place though for long.  Hopefully they fix the issue correctly soon.

-k
 

Share this post


Link to post

This has been on and off for several days now, it's particularly bad tonight.

Restarting doesn't fix it, switching networks doesn't fix it, trying different servers and different countries doesn't fix it, all the meanwhile I'm connected and using the same servers that fail on my desktop on my phone, and everything's working fine on my phone.

The problem: the Eddie client appears to repeatedly try to connect to servers, but always ends up just randomly disconnecting just when it looks like it's about to connect,. Sometimes it'll connect to one for a few seconds then disconnect again. So far every time it's gone away on its own by just randomly trying different servers/Eddie restarts within 15-20 minutes of it starting, but it's very frustrating. Can anyone tell from the logs if it's something with my computer, something with eddie, or something with my account?

I only have 2 devices set up to connect to this account so it shouldn't be some issue with it kicking me off for trying to connect too many devices, I don't think.

https://pastebin.com/PDvxJwfT

I have no idea at all really but is it maybe something to do with those SSL certificate failures? I know stuff like that can happen on websites if your computer date and time is way off, but mine is dead accurate.

Share this post


Link to post
1 hour ago, kwolf said:

On Mac (and probably Linux) one can workaround the expired cert by adding the file ~/.curlrc with a single line: --insecure

Works for me, and seems a little less kludgy than setting the system clock backwards.  It's not a good idea to leave that in place though for long.  Hopefully they fix the issue correctly soon.

-k
 


Good call, kwolf.  and for Windows users, I found a way to do this as well... 

So for Windows, the default config file is named:
_curlrc
and it can be in a number of places (see https://ec.haxx.se/cmdline-configfile.html)

But a quick and easy way to correct this without needing to do anything with admin rights is to open a command prompt and execute this command:
echo --insecure> %APPDATA%\_curlrc
Please note that you cannot have (based on my testing) a space before the '>' symbol.  just copy and paste that into a command prompt (windows key, release windows key, type 'cmd', hit enter) and it will create a default config file for curl.  If you want to see exactly where it created the file, you can use this command:
dir %APPDATA%\_curlrc

If/When someone tries this, please let me know how it works.
 -p
ps - And if/when you want to delete the file (as kwolf points out, it might not be the best idea to leave it there) you can open a command prompt and type:
del %APPDATA%\_curlrc

Share this post


Link to post
2 hours ago, seamonster said:

Just to clarify, going forward I will need to use OpenVPN client instead of Eddie? There is literally no fix for AirVPN's client Eddie to fix the issue to continue using it?

Not that I care much which client I use, but it seems odd that it would just suddenly break over night, and not be recoverable again.

I appreciate the help!
The SSL certificate isn't something you can fix. Airvpn needs to update/resolve the issue. Once they do, then the eddie client will start working again.
Until then, you can use the config generator to connect manually...and beyond that is past the scope of my response. heh.

Share this post


Link to post

Setting the date back a week on my Mac worked for me. Everything is fine now, until AirVPN corrects it on their end.

Thanks ps73!
 

Share this post


Link to post
2 hours ago, caseyjp1 said:

The issue is with eddie. If you use the config generator and openvpn, it will work normally.


If I do so, I get dnsleak, so....

Share this post


Link to post

There are ways to work around the expired certificate.  You can set your system clock back.  Or on a Mac / Linux, you can create the file ~/.curlrc and have a single line in it: --insecure

Apparently there's also a way to do that on Windows, but I'm not much of a Windows guy so I can't comment about it.  Check out the other discussion threads on the topic.  Good luck!

Share this post


Link to post

I'm having the same problem, im switching to Nord, and yes I contacted customer service to and they where no help!!!

Share this post


Link to post

Having the same problem here MacOS.. I put the clock back a week to the 11th August.  Can connect now with no problems.  
Hopefully this is a simple work around until it is fixed.

I have to say though I have been with AirVPN for years now and never a hiccup, its unfortunate but these things do happen,
we are lucky this is a very rare thing and hopefully it will be fixed quickly.  I still have total faith in AirVPN and their services.

Share this post


Link to post

From the other thread Slackjawed Cletus posted:
 

Quote

Under the "DNS" settings tab, deselect "Check AirVPN DNS", then go to the "Advanced" tab and deselect "Check if the Tunnel Works".  Worked for me on v2.17.2.  Just a very temporary fix.


This worked for me, so I put my clock back to normal.  

Share this post


Link to post
Just now, pwolverine said:

From the other thread Slackjawed Cletus posted:
 


This worked for me, so I put my clock back to normal.  
Wouldn't that mean that our local DNS would be open to be seen? I am not all that educated on this subject.

I'm not really enjoying the setting the clock back fix either. Some things are not working with my clock set back. Tradingview isnt working, google isnt working etc.

Share this post


Link to post

Same here, cert expired. Lalande in Sao Paolo works. Hoping they fix this asap. An expired cert, really?

Share this post


Link to post

Add me to the list of those unable to connect.  Every time I try to connect to a server I get "flushing DNS," then "Connecting to Server," then "Disconnecting."  Then it tries another server with same result.  Rinse and repeat over and over. 🙁

BTW, using Windows 7 PC, 64 bit

Share this post


Link to post
10 minutes ago, mecdeva said:

Add me to the list of those unable to connect.  Every time I try to connect to a server I get "flushing DNS," then "Connecting to Server," then "Disconnecting."  Then it tries another server with same result.  Rinse and repeat over and over. 🙁


I''ve got same problem

Share this post


Link to post
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...