Jump to content
Not connected, Your IP:

Eddie 2.16.3 released

Recommended Posts


We're very glad to inform you that a new Eddie Air client version has been released: 2.16.3. As usual, Eddie is released as free and open source software under GPLv3.

Eddie 2.16.3 includes important bug fixes. Please see the changelog:


Eddie includes a full, seamless and integrated IPv6 support, as well as new features which will let you use our latest service additions including IPv6 and tls-crypt: https://airvpn.org/topic/28153-ipv6-support-and-new-smart-features/

Users who have only IPv4 connectivity will be able to access IPv6 services, At the same time users who have only IPv6 (and not IPv4) connectivity, will be able to use our service as well.

tls-crypt implementation provides a new, interesting way to efficiently bypass blocks and throttling against OpenVPN.

This version has been released for GNU/Linux, OS X (Mavericks or higher is required), macOS and Windows (Vista or higher is required).

2.16.3 version is compatible with several Linux distributions. For important notes about environments, please read here:

Just like previous versions, Eddie implements direct Tor support for OpenVPN over Tor connections. Eddie makes OpenVPN over Tor easily available to Linux, OS X and macOS users: no needs for Virtual Machines, middle boxes or other special configurations. Windows users will find a more friendly approach as well. This mode is specifically designed for Tor and therefore solves multiple issues, especially in Linux and OS X/macOS, including the "infinite routing loop" problem (see for example http://tor.stackexchange.com/questions/1232/me-tor-vpn-how/1235#1235 )

As far as we know, Eddie is the first and currently the only OpenVPN wrapper that natively allows OpenVPN over Tor connections for multiple Operating Systems. https://airvpn.org/tor Since version 2.14, Eddie sends a NEWNYM signal to Tor to ensure the use of a new circuit in every connection.

We recommend that you upgrade Eddie as soon as possible.

Eddie 2.16.3 for GNU/Linux can be downloaded here: https://airvpn.org/linux
Eddie 2.16.3 for Windows can be downloaded here: https://airvpn.org/windows
Eddie 2.16.3 for OS X Mavericks, Yosemite, El Capitan and macOS Sierra and High Sierra can be downloaded here: https://airvpn.org/macosx

PLEASE NOTE: Eddie 2.16.3 package includes an OpenVPN version re-compiled by us from OpenVPN 2.4.6 source code against OpenSSL 1.1.0h for security reasons and to fix this bug: https://community.openvpn.net/openvpn/ticket/328

Eddie overview is available here: https://airvpn.org/software
Eddie includes a Network Lock feature: https://airvpn.org/faq/software_lock
Eddie is free and open source software released under GPLv3. GitHub repository: https://github.com/AirVPN/airvpn-client

Kind regards & datalove
AirVPN Staff

Share this post

Link to post

Thank you for the great work!


Stupid question: When I used the beta before (2.16.3), I am up to date with this version? Meaning, they are the same?

Thank you for your help!

Share this post

Link to post

I have a problem with IPv6 not getting detected with Eddie Windows, this problem happened both in previous versions and the latest version.


When I go to ipleak.net or ip6.me , it shows that I have a valid IPv6 address, and I am able to load ipv6 only pages such as ipv6.google.com , but other websites such as whatismyipaddress.com say "IPv6 not detected"


Here is a screenshot

Share this post

Link to post

Tried to download the latest Eddie version for Arch via the AirVPN website, but always end up with an HTTP 500 error after clicking the download button. Download for the other Linux versions works fine.

Share this post

Link to post

2.16.2 and 2.16.3 does not work well on my Ubuntu 18.04.

Takes minutes to startup, but eventually it connects ok.

2.15.2 is much faster to startup.


Running portable mono version on mono 5.14.

Share this post

Link to post

Tried 2.16.3 on Opensuse.


With an alternative provider using password-authentication I always get AUTH_FAILED. After downgrading to 2.15.2 it's working again as expected, so the settings are correct.

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Security Check
    Play CAPTCHA Audio
    Refresh Image

  • Create New...