Jump to content
Not connected, Your IP: 3.226.251.81
Staff

Update on Netflix USA access

Recommended Posts

This is fantastic! I'm just not sure what it means by connect with VPN DNS. Please can someone explain or link to a guide. Thank you

 

By default that's what the Eddie app uses.

Share this post


Link to post

Was server hopping to check latency, routes, etc.. and noticed on Cursa I get the proxy/blocked message from Netflix. Wasn't so a few days ago.

 

Hello!

 

Just checked and it works perfectly as usual. Can you please make sure that your system queries VPN DNS? This is a strictly necessary requirement to access our geo-routing system. If you run Eddie, the Air free and open source software client, this will happen by default.

 

Kind regards

Share this post


Link to post

 

Was server hopping to check latency, routes, etc.. and noticed on Cursa I get the proxy/blocked message from Netflix. Wasn't so a few days ago.

 

Hello!

 

Just checked and it works perfectly as usual. Can you please make sure that your system queries VPN DNS? This is a strictly necessary requirement to access our geo-routing system. If you run Eddie, the Air free and open source software client, this will happen by default.

 

Kind regards

 

Hi,

 

What setting in the .ovpn config file will force VPN DNS? I'm currently running on a Raspberry PI and Netflix isnt showing anything with the VPN running.

Thanks.

Share this post


Link to post

The script already exists in my setup and cat /etc/resolv.conf shows the AirVPN DNS has been added. When I attempt to play something on Netflix though, it detects the VPN. My normal ISP DNS servers also exist in resolv.conf, should that be the case?

Share this post


Link to post

The script already exists in my setup and cat /etc/resolv.conf shows the AirVPN DNS has been added. When I attempt to play something on Netflix though, it detects the VPN. My normal ISP DNS servers also exist in resolv.conf, should that be the case?

 

Hello!

 

Maybe you try to access Netflix from a device which is behind the Raspberry box. In this case please check the DNS settings of such device, which of course take precedence over the Raspberry DNS.

 

Kind regards

Share this post


Link to post

As I've also got the Raspbian desktop installed I've used the Eddie client. This does remove the ISP name servers from resolv.conf when it starts the VPN connection so it looks like i will have to modify the push DNS script that is ran from command line to do the same.

Share this post


Link to post

Is this still working?

 

I have tested with my Nvidia Shield, FireTV and Roku (this one I knew would be difficult) and it didn't work.

 

According to ipleak.net, my Cursa server based  VPN internet connection is tight. But I am only getting that infamous message blocking me.

 

Please, let me know.

 

PS: Although is not the subject of this topic, Hulu is working on the NSTV and FT. Amazon Prime Video doesn't work at all. BTW, Amazon Music doesn't work either.

Share this post


Link to post

Hi! I have been trying to get Netflix to work via Nvidia Shield TV Eddie app but it is mostly hit and miss and recently it has stopped altogether. When I watch via my MacOS Eddie app, Netflix is working. Also using Asus-merlin firmware flashed router without any script, Netflix works without issues on US servers. How do I get to watch it via Shield TV? I am asking this because watching via router, here in China, the picture is not very clear and too much of buffering. Watching via Eddie seems to be faster and very little buffering. I have already tried to change the DNS of the primary router at 10.4.0.1 but the problem with Shield TV has not been resolved yet. What can I do to resolve this? Thanks in advance.

Share this post


Link to post

Netflix US is working perfectly from my Win machine and my Android tablet, running Eddie on both, no matter which VPN server I connect to. Great job guys!

Share this post


Link to post

something is up with the Android TV app though and I am wondering if you guys can pinpoint why I get the proxy error on that client. I can access Netflix fine on my phone behind the same router hosting the VPN tunnel and even do so on my computer as well but the Android TV app does not work. I actually tried smart DNS with the same results so apparently there is something more to the Android TV app that is detecting the tunnel. It's not hard coded DNS servers because I force redirected all DNS inquiries to the appropriate DNS server (yours or the smart DNS in my various tests).

Share this post


Link to post

Please look into your Netflix situation.  I just attempted to watch a video but the speed that could be sustained was so slow the video was unwatchable.  Playback on other video streaming services that worked through the VPN were quite speedy.  Vudu, for example, burst to 300mbit/s to buffer.  Curiousity Stream buffered at 100mbit/s.  Your netflix setup could only manage 5mbit/s.  Not near enough for a 4k stream.

Thanks.

Share this post


Link to post

Hello Staff and All,

Is Netflix still working for you, please? Unfortunately it doesn’t work for me. I am using Eddie on Win machine for my connections, VPN DNS and have no leaks which I checked on ipleak.net.

I have a Netflix account created in one of EU countries but according to previous comments that should not affect connection. I first used Netflix about a month ago and it was working relatively fine. I got occasional Streaming error due to proxy... but refreshing the page solved it and streaming continued.

It is a different story now. I have tried to connect from quite few US, UK, NL, SE… servers but I always get the same known Streaming error: You seem to be using an unblocker or proxy… and no matter what I try I cannot pass that. Interesting is that from some servers it started to stream the content but that worked for only few minutes then it stopped (sorry, I haven’t mark down specific servers). It looks like it is buffering but it never does and once I refresh the page I get the above mentioned error.

When I login to Netflix account I can see the following IP addresses as the ones used by my streaming activity:

Maryland (US) - 12.139.254.67

Virginia (US) - 65.220.84.18

Maryland (US) - 12.139.254.82

Maryland (US) - 12.139.255.63

Maryland (US) - 12.139.253.52

Does anyone have any suggestions what could be causing this and how to fix it, please? Thank you.

Share this post


Link to post

I've got pfsense working to redirect all DNS requests to 10.4.0.1 but still roku and shield tv Netflix does not work on Equuleus.  Apple TV netflix does work.

Somehow they are sniffing things out and I've confirmed that no DNS requests other than to 10.4.0.1 are sent by looking at my states table.

Share this post


Link to post

ok thanks for the reply im using a vpn router where you can put in a custom DNS. iv got netflix working on my pc but i still cant get it working on my android tv. 

Share this post


Link to post

Update to my previous post on 07/14/2019.
I have tried the netflix after 2 weeks. It connected me via different IPs than the ones I mentioned previously and it surprisingly worked without issues for 2 days. But the same Streaming error started to occur again today. It started in the middle of streaming and I cannot watch anything anymore again. I have tried several servers but it is still the same. I have not changed any settings or anything else. How could it be that it worked for 2 days and then it detects proxy in the middle of streaming? What does it influence and more importantly is there a way to overcome this behavior? Now I don't know when my streaming will stop (if it even starts) so it is really unreliable. Any help or suggestion would be much appreciated! Thank you. 

Share this post


Link to post
On 7/31/2019 at 10:50 AM, raix said:

Update to my previous post on 07/14/2019.
I have tried the netflix after 2 weeks. It connected me via different IPs than the ones I mentioned previously and it surprisingly worked without issues for 2 days. But the same Streaming error started to occur again today. It started in the middle of streaming and I cannot watch anything anymore again. I have tried several servers but it is still the same. I have not changed any settings or anything else. How could it be that it worked for 2 days and then it detects proxy in the middle of streaming? What does it influence and more importantly is there a way to overcome this behavior? Now I don't know when my streaming will stop (if it even starts) so it is really unreliable. Any help or suggestion would be much appreciated! Thank you. 

For what it is worth, I am having the exact same problem using Eddie in Windows 10. I have a work around, but it isn't very elegant. When Netflix stops streaming in the middle of watching a show, I don't close Netflix and just leave it buffering, and then I switch over to Eddie, and connect to a different server than the one that I was connected to. Most of the time, Netflix starts streaming again, but sometimes it doesn't. If it doesn't, I just keep trying different servers. Hope this helps.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...