Jump to content
Not connected, Your IP:

Recommended Posts

I recently upgraded to latest Ubuntu Version and just found out I'm leaking DNS. Even though I'm using Eddie v2.12.4 with network lock enabled.


I tried to add block-outside-dns to ovpn directives in Eddie settings but I'm still leaking DNS.

Didn't read correct, this works only in Windows.


edit: I tried to use OpenVPN with a config file and DNS push with resolvconf instead of Eddie with same results. Still leaking DNS.

Tried to use a VM with Ubuntu 16.10 configured DNS push and had no leaks. So I guess something is wrong with resolvconf in Ubuntu 17.04.


edit2: Seems to be a Ubuntu 17.04 problem. Many users seem to have problems with DNS.


Still looking for help here. If anyone has an idea.


Since this is no Eddie specific problem please push this topic to the right subforum.

Share this post

Link to post

DNS leaks do not exist in GNU/Linux. In Ubuntu 17, NetworkManager might be configured to modify frequently resolv.conf and overwrites changes made by Eddie. Make sure to disable this feature by adding in /etc/NetworkManager/NetworkManager.conf the following line in the [main] section:



The above should solve the problem.


Kind regards

Share this post

Link to post
This topic is now closed to further replies.

  • Create New...