Jump to content
Not connected, Your IP: 54.237.183.249
~Daniel~

Would love some troubleshooting assistance - no upload and issues with trackers

Recommended Posts

Good Morning!

 

I am currently within my 3-day trial period/account and am somehow getting pretty good downloads despite the fact that I don't seem to be uploading... which is weird.

 

In addition to starting out with fresh with AirVPN, I also decided to try the Windows version of Transmission as well (was previously using Deluge).  Probably also a good time to mention I am running Win10, and I use Comodo's CIS 10.

 

Transmission seems pretty straight forward, and I'm hoping it's not at the route of my issue as I do enjoy it's interface.

 

I'll try start at the beginning.

 

I enable the Network Lock (auto seems to be selecting WFP mode) and then connect to a VPN sever.  I made a whitelist, and just let Eddie (2.11.13) make a choice of the best from that list.

 

I've run some ookla speed tests while connected, and I've received 16-24 Mb speeds on my 25Mb max internet (DSL) service; respectable++.  I've also been loading the IPLeak.net page for comfort.

 

I've setup a port-forward in my Air VPN client area, and have pasted that port in Transmission, as well as disabled the "port changing" settings as suggested in the forums... UPnP/NAT-PMP and uTP

 

In case it is important, every time I've clicked the "Test Port" button, it has told me the TCP port is locked (never UDP, nor does it look like there is an option to change that).  ** possible Port Forward Issue? **  I have no port forwarding enabled on my home router, which I understand to be correct.

 

Despite that issue, I queue up a torrent download via magnetic link (as well as the IPLeak torrent test) and watched it chug away.  After a few minutes, I realize that I am ** not uploading **.  While trying to investigate, I discovered that all the torrents trackers have ** connection errors **

 

I also looked at the tracker for the IPLeak magnetic link; however, it shows that everything is fine.

 

Being really confused now (IPLeak tracker happy, torrent tracker sad) I decide to shut down Transmission, disconnect my Air VPN, connect with my soon to be expiring CactusVPN client, load up Transmission, flip to the Tracker screen... and watched the red errors flip over to green good-to-go messages like what I received with either VPN Service for the IPLeak torrent test.

 

So I scratched my head again and because I am not sure which symptoms are related, or prerequisites of each other.  The only thing I think I know at this point is that Eddie makes my torrent trackers sad, but as I am typing this out now, I can't remember if I even checked to see if I was uploading with CactusVPN as it brought joy to the trackers.

 

So here are my Eddie 2.11.13 settings:

  • Protocols = Automatic... although I thing i tried forcing this to TCP 443 at some point thinking that might make the transmission TCP port test happy
  • Open VPN Directive... Added "mssfix 1430" (without quotes) [after subtracting 40 from the decrement by 10 until the ping resolved at 1470 test {which I did before connecting to VPN Server or launching Eddie}]
    • Drop down arrow left at default (I think) "Append Custom Directives"
  • I've changed nothing in...
    • Proxy/Tor
    • Routes
    • DNS (Auto and checked... just in case)
    • Network Lock (Auto with Allow Lan/private checked, and Allow ping checked... just in case)
    • Logging
    • Events
  • Advanced... I don't recall what was default (but do remember upping the buffer sizes)

 

Please let me know if any further details would help iron unravel this riddle.

 

Thank You!

 

EDIT:  Added Eddie Log extract, added images to post, and wanted to note that after the torrent finished downloading, I noticed the Transmission did show some quick (1-2 second) spurts of uploading @ 130Kb, but with a long delay in between... 30-60 seconds... so the upload was probably trying, but not succeeding very well.

 

EDIT2: Looks like my PC's IP (LAN) outbound UDP communication is showing as being blocked in Comodo... might this be the WPS part of Network Lock, or a missing rule in CIS? More confused as why would the IPLeak Tracker always be successful... and why would the torrent tracker update when using Cactus VPN (Eddie/NL off)?

 

EDIT3:  Tried to prove Edit2 by disabling NL before starting another torrent.  Couldn't trigger a CIS Block with NL on or off.

Eddie_20170128_050518.txt

Share this post


Link to post

Hello!

 

I recommend turning off IPv6 on all network adapters, including TAP.

 

Making sure Comodo/CIS isn't blocking AirVPN.exe, openvpn.exe, tap.exe or qbittorrent.exe.

 

Checking you got the port right on the site and in the qBittorent client. In the Client Area, did you put the same number in the "Local Port" box as in the Top white box?

 

You may also want to edit the uploaded Eddie log and mask your name, if it's your real one, in the path.

 

I also still vouch for qBittorent . Lastly, it may also be good to check your network type.


Moderators do not speak on behalf of AirVPN. Only the Official Staff account does. Please also do not run Tor Exit Servers behind AirVPN, thank you.
Did you make a guide or how-to for something? Then contact me to get it listed in my new user guide's Guides Section, so that the community can find it more easily.

Share this post


Link to post

Thank You for the responses LZ1.

 

I guess I the "good news" is that (1) my downloading didn't seem to be impacted somehow and (2) IPLeaks reports no issues/leaks while using Eddie on the AirVPN network.  I just felt that I wasn't participating in the P2P spirit if I left it that way without trying to correct it.

 

Hello!

 

I recommend turning off IPv6 on all network adapters, including TAP.

Assuming your talking about a manual change to the OS network intrface, I'll definitely consider this in the future, but I feel good right now that IPLeaks reports no issues/leaks while behind Eddie/NL/AirVPN.  Maybe a false sense of security?

 

Or are you meaning to use some of these Advanced Eddie Settings:

  • IPv6: Currently Disabled, but has an option in the dropdown for None as well
  • [] Disable IPv6 at OS level if required

 

Making sure Comodo/CIS isn't blocking AirVPN.exe, openvpn.exe, tap.exe or qbittorrent.exe.

 

I recall training/setting them as "trusted", and see no evidence in the CIS logs of them being blocked... so I think I'm good here,  TAP and Transmission (and maybe openVPN) all seemed to be (at least partly) working (i.e. tracker communication happy) with the CactusVPN client... and AirVPN loads and connects me to the network, so I feel its functioning too.

 

Checking you got the port right on the site and in the qBittorent client. In the Client Area, did you put the same number in the "Local Port" box as in the Top white box?

I let the AirVPN site pick the port, and copy/pasted it into Transmission.

 

Protocol: TCP & UDP
Local Port: #####
DDNS: <empty>

 

You may also want to edit the uploaded Eddie log and mask your name, if it's your real one, in the path.

How can you tell i was tired and pulled an all nighter?  Will remember this in the future, and re-uploaded a tweaked log.

 

I also still vouch for qBittorent . Lastly, it may also be good to check your network type.

WF is not active in my case, and CIS is still in it's "Safe" mode (works well with truted apps).  I have made no edits to my CIS configuration, nor did it prompt me to add any networks when the VPN/TAP network is established... so it is not specifically allowed/disallowed in any way, nor considered to be a certain type.

 

As a test, I made a global rule to allow the AirVPN port IN, and then a rule for transmission to allow it IN as well... the side effect of this appeared to be that IPLeak started listing my IPv6 address in the torrent test, so I reversed the change and all things are "happy" on the IPLeak site once again.

 

... hmmmm... or maybe I needed to keep those CIS rules and just explore disabling IPv6 like you suggested?

Share this post


Link to post

IPv6 can just "confuse" (for lack of a better explanation) Eddie in some cases, I've experienced. Thus turning it off has been seen to help.


Moderators do not speak on behalf of AirVPN. Only the Official Staff account does. Please also do not run Tor Exit Servers behind AirVPN, thank you.
Did you make a guide or how-to for something? Then contact me to get it listed in my new user guide's Guides Section, so that the community can find it more easily.

Share this post


Link to post

Thank you for the reply LZ1.  I think I was editing my past as you asked this question... you asked

 

IPv6 can just "confuse" (for lack of a better explanation) Eddie in some cases, I've experienced. Thus turning it off has been seen to help.

 

and my revised details/questions were...

 

Assuming your talking about a manual change to the OS network intrface, I'll definitely consider this in the future, but I feel good right now that IPLeaks reports no issues/leaks while behind Eddie/NL/AirVPN.  Maybe a false sense of security?

 

Or are you meaning to use some of these Advanced Eddie Settings:

  • IPv6: Currently Disabled, but has an option in the dropdown for None as well
  • [] Disable IPv6 at OS level if required

Share this post


Link to post

It looks like the ultimate fix for me was to install a better/working bt client... Tixati!

 

Prior to doing that I had performed a CIS "Ratings scan" which found a LibPocketFirewall.dll under AirVPN which I allowed...

 

However, this never fixed the tracker issue in Transmission... and I still only saw some sporadic upload connections like I mentioned before (130k and crash, long pause, repeat).

 

But, right after installing and setting up tixati... BAM!  Upload connection looks good (and are working)...

 

And trackers appear to be happy...

 

AirVPN + Tixati FTW!

 

P.S. Tixati also allowed me to bind to the TAP interface, accepted (and uses) my AirVPN port forward, and let me set a restriction to IPv4 for my connections!!! 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...