Jump to content
Not connected, Your IP: 35.168.62.171
Artist

Client will never reconnect after standby

Recommended Posts

Hello,

 

I am having problems with the AirVPN client for Mac OSX.

  1. Every time that I put my computer in standby, and restoring, the app will never be able to reconnect again by itself.
    It tries to reconnect, but the process will always fail.
     
  2. After failure on one server it won't try any of the other servers in the Whitelist, insisting forever to try a connection to a server that doesn't work.
    Also, you should change the label of the button "Connect to a recommended server" with "Connect to the first server in alphabetic order"; if you get what I mean...
     
  3. Usually, after every standby/restore with no working reconnection, I have to proceed manually with
    - Cancelling the connection process
    - Logout
    - Login
    - Try to reconnect to a server

    But in the last days I am wasting so much time in performing connections. Things got worse.
    After the standby, no server will connect and I have to try so many of them, always proceeding with the steps mentioned above. I can say this is really annoying.

I would like to solve this issues, because being able to not reconnect automatically is a huge security issue (at least for me) that does not suit with a Private VPN service (imho).

 

Anyway my guess is that the issue is on the application, not with the servers themselves.

 

Could you please help me to solve them? Or fix the client?

 

Thank you

Share this post


Link to post

Hello!

 

1. Every time that I put my computer in standby, and restoring, the app will never be able to reconnect again by itself.
It tries to reconnect, but the process will always fail.

 

Solution is simple: make sure to disconnect your system from the VPN before putting it in standby. In standby the system will (almost completely) turn off network card to save power. Therefore VPN connection is lost but the default gateway and the routing table remain the same. When the system wakes up, OS X and OpenVPN may have problems in reconfiguring the networks.

 

Make sure to enable Network Lock to prevent any possible leak.

 

After failure on one server it won't try any of the other servers in the Whitelist, insisting forever to try a connection to a server that doesn't work.
Also, you should change the label of the button "Connect to a recommended server" with "Connect to the first server in alphabetic order"; if you get what I mean...

 

"Connect to a recommended server" is correct, "Connect to the first server in alphabetical order" would be nonsense / wrong. However, the behavior you report correctly has been reproduced. It appears it is a bug that needs to be fixed.

 

I would like to solve this issues, because being able to not reconnect automatically is a huge security issue (at least for me) that does not suit with a Private VPN service (imho).

 

In this case it appears that the problem is not on the Air software. Enable Network Lock, make sure to disconnect from the VPN before shutting the computer down, and everything should be fine.

 

Kind regards

Share this post


Link to post

You can also try to disable the standby mode. It works in windows, but im not sure if it does on osx. Something like "Do nothing when lid is shutdown"

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...