Jump to content
Not connected, Your IP: 34.201.18.139

Recommended Posts

hi all,

 

is it just me or others cannot watch netflix from usa servers?

it was working fine this morning...

Share this post


Link to post

Nope, Zosma doesn't work - connection via Openvpn app on Android tablet and it comes up as blocked.

Share this post


Link to post

Is there any news about this issue? It's not working on Android, iOS and Linux. As I understand it, for example the German servers are also redirecting to US Netflix - but they also do not work neither. It would be great if a staff member could either say something about this and/or update the thread in the blocked websites.

 

Sent from my Nexus 5 using Tapatalk

Share this post


Link to post

Is there any news about this issue? It's not working on Android, iOS and Linux. As I understand it, for example the German servers are also redirecting to US Netflix - but they also do not work neither. It would be great if a staff member could either say something about this and/or update the thread in the blocked websites.

 

Sent from my Nexus 5 using Tapatalk

 

Hello!

We have not detected and we do not detect any problem. Provided that your device queries VPN DNS and that your Netflix application does not surreptitiously send out information without your consent, access to Netflix USA has always been coherent to what reported here: https://airvpn.org/topic/9223-netflix/

 

The part in bold is particularly important because, for example, we have seen reports according to which Netflix proprietary, closed source software queries invariably Google DNS, regardless of the DNS settings of the device.

 

Kind regards

Share this post


Link to post

Hello!

We have not detected and we do not detect any problem. Provided that your device queries VPN DNS and that your Netflix application does not surreptitiously send out information without your consent, access to Netflix USA has always been coherent to what reported here: https://airvpn.org/topic/9223-netflix/

 

The part in bold is particularly important because, for example, we have seen reports according to which Netflix proprietary, closed source software queries invariably Google DNS, regardless of the DNS settings of the device.

 

Kind regards

 

Thanks for an answer staff!

 

I read that the Android Netflix application has Googles DNS hardcoded in it, and i do not know any fix for that except downgrade, but that's not so important to me.

 

I'm running on linux, and I used to use chrome to stream Netflix. I set up the AirVPN in my Network settings, even set up my DD-WRT to use AirVPN but still there is no way of getting into netflix, not even the local. Everytime the proxy-error message.

 

Could it be that the Netflix website (or, what's more likely google chrome) uses Googles DNS too to keep us out, regardless of settings? If so, can I and how do I change that? Browser recommendation?

 

As linux' Firefox does not support EME, html5 playback with netflix is not possible, so as an workaround, for anyone who's interested:

 

I tried Netflix with the Wine+Firefox "Netflix Desktop"-App for Linux, which at least works with the Servers from the Netherlands (just NL-content). Other Servers (USA, Germany) do not work because of a network error, not the proxy-error you get everywhere else (but still - no US content).

 

 

If anyone has another idea on how to fix this on linux, android and iOS it would be awesome if you share. 

 

 

 

EDIT:

 

Yes, chrome apparently uses googles own DNS internally, i disabled it with the --disable-async-dns command-line flag. It worked for a short period of time - and strangely only with dutch servers - but now the error message is back again.

Share this post


Link to post

Hello trueheadz...

 

...

 

Great Scott!

 

Actually it might be possible that:

 

- if your ISP supports IPv6

- if your system has IPv6 support enabled

- if your system does not have any IPv6 DNS servers defined

 

THEN

 

Chrome queries first Google DNS in IPv6; and only if it fails, it queries system IPv4 DNS.

 

https://www.reddit.com/r/chrome/comments/1xj69t/chrome_ignoring_system_dns_and_using_google_dns/

 

Kind regards

Share this post


Link to post

(...)

 

Actually it might be possible that:

 

- if your ISP supports IPv6

- if your system has IPv6 support enabled

- if your system does not have any IPv6 DNS servers defined

 

(...)

 

Thanks for these tips!

 

I dissabled IPv6 now, and the error is gone again for the dutch servers, but only for them.

 

Other servers still giving errors.

 

Kind regards!

Share this post


Link to post

Hello,

 

and NL servers do NOT have geo-routing for Netflix. It is the very same problem. It seems that your system is not querying VPN DNS when the problem occurs.

 

Kind regards

Share this post


Link to post

Hi, I'm new and I understand the gist of what VPN DNS is supposed to do (use different IP addresses so that companies can't just block known addresses, correct?), but I don't know how to make sure I am connecting with AirVPN DNS. In my preferences, I have DNS switch mode on Automatic (I am running Windows 10), and I have the box checked for "Check if the tunnel uses AirVPN DNS." Is there anything else I should be doing? How can I make sure it's working?

 

Connecting through both Canadian and American servers returns the proxy detected error message from Netflix. Also tried using Chrome, Firefox, and Edge. Is there any way around this? This there going to be? The devs keep saying "oh it's fine, it works" and pointing us to https://airvpn.org/topic/9223-netflix/ but honestly the sparse info on that page means very little to me. I need a step-by-step, someone, please, or there's no point in me continuing to pay for this service.

Share this post


Link to post

Here's my input, if more data is helpful:

 

US servers: no Netflix on Zosma, Metallah. Haven't tried others.

CA servers: Netflix works on Rana, Kraz, Almach

NL servers: Netflix works (I connect to "Netherlands" over OpenVPN GUI, no specific server info)

 

No IP or DNS leaks according to ipleaks.net

"Proxy detected" message occurs both through browser and Windows 10 Netflix app.

Same results with eddie and OpenVPN GUI.

I'm connecting from Germany, if that matters.

Share this post


Link to post

I am connected to Virginis and Netflix is not working for me either. My Apple TV tells me "This title is not available to stream instantly" on anything I try to watch. It is hooked up to a router which is connected to the VPN and using only the VPN's DNS. This setup usually works fine, it's only stopped working in the past few days. Restarting the connection, router, or ATV does nothing to help. It seems Netflix has blocked the IP range.

Share this post


Link to post

Just tried through five different US servers, including Zosma.  I get this: "You seem to be using an unblocker or proxy. Please turn off any of these services and try again."

Share this post


Link to post

wow..........i should it learn programing..!!

 

is a little over whelming, glad that I am US (maybe), but would love to watch Netflix from other part of the world.

 

You pay them, and watch a movie a time, what do they care where we watch their movies?

 


I've learned.... That being kind is more important than being right.

Share this post


Link to post

I read that the Android Netflix application has Googles DNS hardcoded in it, and i do not know any fix for that except downgrade, but that's not so important to me.

 

You mean try an old version of Netflix app?

 

Here i can stream Netflix on my Windows 8.1 PC using chrome through Pollux (USA) server. Unfortunately can't do the same on my android device (nexus 5 with marshmallow) and OpenVPN. Netflix USA show the usual main page, content and other stuff like my list, but when i play something, the block error coming up. A workaround is possible?

Share this post


Link to post

​Hello Staff,

 

same problem here, apps on FireTv,Ps4, etc all blocked. Using a native from your list, solves my problem.  

 

So my question, could you please put a US Native as well?

Share this post


Link to post

 

I read that the Android Netflix application has Googles DNS hardcoded in it, and i do not know any fix for that except downgrade, but that's not so important to me.

You mean try an old version of Netflix app?

 

Here i can stream Netflix on my Windows 8.1 PC using chrome through Pollux (USA) server. Unfortunately can't do the same on my android device (nexus 5 with marshmallow) and OpenVPN. Netflix USA show the usual main page, content and other stuff like my list, but when i play something, the block error coming up. A workaround is possible?

I must admit, for the moment I gave up on this.

 

Yes, you could try to downgrade the app itself, although I tried that and it did not work. But, as staff claims, I'm apparently somehow still not routing through the VPN DNS, although I set up everything correctly and no DNS leaks or others are reported. I can see the us Netflix, and their content, but streaming is not possible at the moment. I don't know if this is enough for Air to say it's "unblocked", for me at least it isn't.

There are no other ways I can think of to use Netflix than a browser, a console, a smartphone and a tablet - but all those "apps" are apparently using Google's DNS (afaik you can deactivate google chromes internal DNS rerouting, but you still will get the error).

 

 

I mean, I bet hundreds of customers here just want the service for Netflix, but Air is not focusing on this - which is absolutely OK with me because they have their priorities elsewhere - the privacy of the customers.

 

If you want to use US Netflix, maybe try another service which is focused on explicitly this issue. Friend of mine tried hola, which works. But I stay with Air for the customisation and supreme privacy.

 

 

 

Gesendet von meinem Nexus 5 mit Tapatalk

Share this post


Link to post

No, you don't seem to understand.  This isn't an AirVPN issue.  This is a "your box uses hard-coded Google DNS" issue.  There is nothing that AirVPN can do on their end to make your box stop talking to google over google's DNS (until one day when VPN programs will run natively on set-top boxes).  That's something that you have to do on your end with rules in your router and/or with something like pfsense.

 

If AirVPN provided a "US Native" server for Netflix purposes, netflix would ban those IPs in a couple of days, if they haven't already done so.  The only reason US Netflix works on AirVPN and almost nowhere else is precisely because of the DNS Wizardry that is going on behind the scenes.  If you are trying to use a box that stubbornly refuses to comply with external DNS settings, you can't blame AirVPN for that.

Share this post


Link to post

No, you don't seem to understand. This isn't an AirVPN issue. This is a "your box uses hard-coded Google DNS" issue. There is nothing that AirVPN can do on their end to make your box stop talking to google over google's DNS (until one day when VPN programs will run natively on set-top boxes). That's something that you have to do on your end with rules in your router and/or with something like pfsense.

 

If AirVPN provided a "US Native" server for Netflix purposes, netflix would ban those IPs in a couple of days, if they haven't already done so. The only reason US Netflix works on AirVPN and almost nowhere else is precisely because of the DNS Wizardry that is going on behind the scenes. If you are trying to use a box that stubbornly refuses to comply with external DNS settings, you can't blame AirVPN for that.

No, i absolutely understand this, but please define "my box" for me. Chrome is one of two choices I have to watch Netflix on Linux, the other is the Firefox/wine/silverlight workaround - and both give the same errors. I firewalled googles DNS, deactivated the internal routing from chrome, but still it did not work.

Don't get me wrong, I get it that the apps on android and iOS may not work again due to the hardcoded DNS, but i don't even use them. What other options are left for "my box"?

 

I had my ddwrt correctly set up, checked everything tenfold, and still could not stream. The content was correctly displayed as US content, but streaming was not possible.

 

And if Netflix streams are only possible with pfsense, then it should say so somewhere here.

 

Also, if this was a " my box" issue, why are there others with the same problem? If we all collectively are doing it wrong, it would be great if you could help us out and write down how we could narrow the error down.

 

Edit: I have to say I did not test it anymore since last week, so it could be working again but I can't check right now. Will update.

Share this post


Link to post

Four people having a problem isn't indicative of a systemic issue.  If, as you say, "hundreds of customers here just want the service for Netflix" then don't you think we would see many more posts and threads about this if it wasn't working?  My response was actually to the guy above you talking about Roku boxes and whatnot.  There are devices that will talk over 8.8.8.8 regardless of your router settings.  The devices don't care if you have AirVPN set up over DD-WRT, they are going to query 8.8.8.8 anyway.  I've yet to see anyone "properly" solve that problem.

 

If you are saying that you are using a Windows or Mac PC and can't get the DNS to work over your DD-WRT router, then that's a different issue that should be able to be solves.

Share this post


Link to post

I think that what is going on is the following. Netflix has already announced that it would crack down on users watching content from other countries. Well, they are walking the talk.

 

I hadn't watched on my phone for some time, but just now my android gave the same proxy/unblocker error. Haven't tried my Linux/chromium combination today, will report back when I have the opportunity...


Win7 | Manjaro Gnome | Eddie stable

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...