Jump to content
Not connected, Your IP: 34.238.190.122
bath_steam

Eddie Experimental 2.8RC1 problems

Recommended Posts

thanks

 

seem to have solve the previous instability problems i previously experienced.

 

unfortunately there seem to be some new bug in your software which make the installer version (debian/ubuntu 64) unable to launch


 

I 2014.12.20 21:36:39 - AirVPN client version: 2.8, System: Linux, Architecture: x64

Unhandled Exception:
System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary.
  at System.Collections.Generic.Dictionary`2[System.String,System.String].get_Item (System.String key) [0x00000] in <filename unknown>:0
  at AirVPN.Core.CommandLine.Get (System.String name, System.String def) [0x00000] in <filename unknown>:0
  at AirVPN.Core.Storage.Get (System.String name) [0x00000] in <filename unknown>:0
  at AirVPN.Core.Storage..ctor () [0x00000] in <filename unknown>:0
  at AirVPN.Core.Engine.Initialization () [0x00000] in <filename unknown>:0
  at AirVPN.UI.Linux.Program.Main () [0x00000] in <filename unknown>:0
[ERROR] FATAL UNHANDLED EXCEPTION: System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary.
  at System.Collections.Generic.Dictionary`2[System.String,System.String].get_Item (System.String key) [0x00000] in <filename unknown>:0
  at AirVPN.Core.CommandLine.Get (System.String name, System.String def) [0x00000] in <filename unknown>:0
  at AirVPN.Core.Storage.Get (System.String name) [0x00000] in <filename unknown>:0
  at AirVPN.Core.Storage..ctor () [0x00000] in <filename unknown>:0
  at AirVPN.Core.Engine.Initialization () [0x00000] in <filename unknown>:0
  at AirVPN.UI.Linux.Program.Main () [0x00000] in <filename unknown>:0

 

Share this post


Link to post

Hello!

Can you please try the new RC3 which has been just uploaded? The problem should have been fixed.

 

Kind regards

Share this post


Link to post

Hello!

Can you please try the new RC3 which has been just uploaded? The problem should have been fixed.

 

Kind regards

 

hmm the hash sums provided does not match, is this a mistake from your side or is my download corrupted?

 

sha1sum for my download: 9bd93abafe6b01569b523fe3533e590b4b95425f

Share this post


Link to post

 

Hello!

Can you please try the new RC3 which has been just uploaded? The problem should have been fixed.

 

Kind regards

hmm the hash sums provided does not match, is this a mistake from your side or is my download corrupted?

 

sha1sum for my download: 9bd93abafe6b01569b523fe3533e590b4b95425f

 

 

Hello,

 

what is your download (Operating System and type of Eddie package)?

 

Kind regards

Share this post


Link to post

 

 

Hello!

Can you please try the new RC3 which has been just uploaded? The problem should have been fixed.

 

Kind regards

hmm the hash sums provided does not match, is this a mistake from your side or is my download corrupted?

 

sha1sum for my download: 9bd93abafe6b01569b523fe3533e590b4b95425f

 

 

Hello,

 

what is your download (Operating System and type of Eddie package)?

 

Kind regards

 

 

the exprimental x64 debian/ubuntu package

Share this post


Link to post

Hello!

 

The problem has been fixed, can you please check now?

 

Kind regards

 

it checks out now thank you

Share this post


Link to post

Hello Air

 

Just to let you know that I installed 2.8 RC3 .deb Debian/Ubuntu Package (with correct hashes) on two systems:

Linux Mint 17, (Qiana) Cinnamon Ver 2.2.16, 64 bit, Linux Kernal 3.13.0-24 generic

Linux Mint 17.1, (Rebecca) Cinnamon Ver 2.4.5, 64 bit, Linux Kernal 3.13.0-37 generic

 

On both: It installed ok, but when I start the client window its appearance is distorted and it doesn't function.  It doesn't get as far as appearing in the active processes window in the System Monitor so I use sudo xkill and the cursor to close it. Tried a few times, same result.

 

I haven't tried the portable versions yet. I wasn't sure whether to use the "(mono required)" version or plain version. Or try both?

 

Hope this helps

 

(I use 2.7 portable on those systems for normal use)

Share this post


Link to post

network lock doesn't seem to work with v2.8 on OSX 10.10

Share this post


Link to post

Hello Air

 

Just to let you know that I installed 2.8 RC3 .deb Debian/Ubuntu Package (with correct hashes) on two systems:

Linux Mint 17, (Qiana) Cinnamon Ver 2.2.16, 64 bit, Linux Kernal 3.13.0-24 generic

Linux Mint 17.1, (Rebecca) Cinnamon Ver 2.4.5, 64 bit, Linux Kernal 3.13.0-37 generic

 

On both: It installed ok, but when I start the client window its appearance is distorted and it doesn't function.  It doesn't get as far as appearing in the active processes window in the System Monitor so I use sudo xkill and the cursor to close it. Tried a few times, same result.

 

I haven't tried the portable versions yet. I wasn't sure whether to use the "(mono required)" version or plain version. Or try both?

 

Hope this helps

 

(I use 2.7 portable on those systems for normal use)

 

Hello,

 

can you please provide a screenshot? We don't notice any problem with Mint 17.1 Rebecca. Make sure that you're really running version 2.8RC3 (run airvpn without arguments from a shell and look at the output). Try also portable version (NOT the portable version with Mono required).

 

Kind regards

Share this post


Link to post

network lock doesn't seem to work with v2.8 on OSX 10.10

 

Hello!

 

We don't experience any problem with 2.8RC3 on OS X 10.10. Can you please make sure that you're running RC3 (select "AirVPN" -> "About" menu item)? Can you please provide more details? Is pf running? If so, which rules does it have after you have enabled and activated Network Lock?

 

Kind regards

Share this post


Link to post

 

network lock doesn't seem to work with v2.8 on OSX 10.10

 

Hello!

 

We don't experience any problem with 2.8RC3 on OS X 10.10. Can you please make sure that you're running RC3 (select "AirVPN" -> "About" menu item)? Can you please provide more details? Is pf running? If so, which rules does it have after you have enabled and activated Network Lock?

 

Kind regards

 

yes, I'm running RC3. I tried with PF or automatic. In both cases after disconnecting from airvpn servers I do have a network lock active confirmation on the overview page of the eddie client. However I can connect to the internet via browsers or apps without any problem. Not sure I understand your question about rules in PF. I didn't change anything regarding routes in- or outside the tunnels or allowed adresses on the local network from eddie 2.7. network lock was working perfectly fine with 2.7. The PF file in the .airvpn folder contains a long list of IP adresses with "pass out quick inet from any to..."

 

let me know if you need any more details!

Share this post


Link to post

 

 

network lock doesn't seem to work with v2.8 on OSX 10.10

 

Hello!

 

We don't experience any problem with 2.8RC3 on OS X 10.10. Can you please make sure that you're running RC3 (select "AirVPN" -> "About" menu item)? Can you please provide more details? Is pf running? If so, which rules does it have after you have enabled and activated Network Lock?

 

Kind regards

 

yes, I'm running RC3. I tried with PF or automatic. In both cases after disconnecting from airvpn servers I do have a network lock active confirmation on the overview page of the eddie client. However I can connect to the internet via browsers or apps without any problem.

 

Hello,

 

in this situation, print out pf rules. Open a shell and type the command:

sudo pfctl -sr

 

Copy everything and paste into your message.

 

Do you know whether your ISP supports fully IPv6?

 

Kind regards

Share this post


Link to post

the output from terminal for sudo pfctl -sr:

 

No ALTQ support in kernel
ALTQ related functions disabled
scrub-anchor "com.apple/*" all fragment reassemble
anchor "com.apple/*" all

 

there's a lots-of-numbers.temp.pf.conf in Users/Me/.airvpn directory though that has a lot of rules in it. dunno if that's what you're asking for or why this isn't applied. the pf.conf in /private/etc seems untouched from airvpn.

Share this post


Link to post

OK, did some more reading and testing and have to revert my earlier statement. on an other machine running eddie 2.7 network lock doesn't work either. same behaviour as in 2.8 on my main machine. I tried to understand the entry about network lock in the help files and believe I may have missed something to make it work correctly.

 

 

Activation

  • Detect if it is already enabled or not. If not, activate it.
  • Load custom PF config file. It's created under the data directory.

 

Is this something I have to do manually, or is it done by the client? If I have to do something manually, how do I do this? I can find the pf.conf in the airvpn directory that has all the rules in it, but how do I load/activate it so eddie can work with it?

 

on a side note, when I activate network lock and restart my machine, connections seem to be blocked until airvpn connects to a server, but as soon as I disconnect from a a server network lock is shown as not active. this setting should be sticky, right?

 

thx for your help

Share this post


Link to post

OK, did some more reading and testing and have to revert my earlier statement. on an other machine running eddie 2.7 network lock doesn't work either. same behaviour as in 2.8 on my main machine. I tried to understand the entry about network lock in the help files and believe I may have missed something to make it work correctly.

 

 

Activation

  • Detect if it is already enabled or not. If not, activate it.
  • Load custom PF config file. It's created under the data directory.

 

Is this something I have to do manually, or is it done by the client? If I have to do something manually, how do I do this? I can find the pf.conf in the airvpn directory that has all the rules in it, but how do I load/activate it so eddie can work with it?

 

on a side note, when I activate network lock and restart my machine, connections seem to be blocked until airvpn connects to a server, but as soon as I disconnect from a a server network lock is shown as not active. this setting should be sticky, right?

 

thx for your help

 

Hello!

 

Everything is done automatically. The behavior you detect is anomalous and we can't reproduce it: Network Lock works properly in our test systems. We don't even have any warning from other OS X customers about this issue. We'll keep investigating. On your side, make sure that when you enable Network Lock you also activate it by clicking on the big button on the "Overview" window. The token must become green.

 

On the contrary, if you shut the client down properly, it's correct that Network Lock is de-activated. Network Lock, however, remains active if the client is killed or crashes, which is good for security.

 

Kind regards

Share this post


Link to post

Hello!

 

Everything is done automatically. The behavior you detect is anomalous and we can't reproduce it: Network Lock works properly in our test systems. We don't even have any warning from other OS X customers about this issue. We'll keep investigating. On your side, make sure that when you enable Network Lock you also activate it by clicking on the big button on the "Overview" window. The token must become green.

 

On the contrary, if you shut the client down properly, it's correct that Network Lock is de-activated. Network Lock, however, remains active if the client is killed or crashes, which is good for security.

 

Kind regards

 

ok, I think I found the issue. I had two local IP adresses in "adresses allowed" under the network lock tab. after removing them network lock indeed seems to work. don't know why this would break network lock but I found out local adresses stay connective anyways while network lock is active. so this seems to be resolved for my purposes.

 

regarding the deactivation of network lock after shutting down / exiting the client I don't really understand the logic behind it to be honest. Idealy I want network lock to stay active at all the time when I'm not connected to an airvpn server but having the eddie client running. I'm giving you an example: I activate network lock and have to restart my machine for whatever reason. eddie quits with the are you sure prompt. I agree. now eddie opens on startup and automatically reconnects to the last connected server - so far so good. If I lose VPN connection now though I'm left without protection because the network lock feature was deactivated in between sessions. If I deactivate the connect to last server automatically feature though so I can activate the network lock before eddie connects to any server I'm left without protection during the startup and launch process. do you get my point?

Share this post


Link to post

I have to come back to this topic once again unfortunatelly. after I figured out to get network lock to work I now have the problem that VNC (screen sharing and other services) don't work between the two machines on my local network once the feature is enabled. I can connect via finder but everything else is unable to connect. I tried putting the IPs of the machines into allowed adresses, routes or both in all available combinations one or both machines with no success. my networks IP range is 192.168.1.xxx. the connection is unavailable after network lock is activated, no matter if eddie is connected to a server or not.

 

I'm really frustrated having to put so much time into this feature. please let me know what I can do the solve this puzzle for good.

Share this post


Link to post

 

Hello!

 

Everything is done automatically. The behavior you detect is anomalous and we can't reproduce it: Network Lock works properly in our test systems. We don't even have any warning from other OS X customers about this issue. We'll keep investigating. On your side, make sure that when you enable Network Lock you also activate it by clicking on the big button on the "Overview" window. The token must become green.

 

On the contrary, if you shut the client down properly, it's correct that Network Lock is de-activated. Network Lock, however, remains active if the client is killed or crashes, which is good for security.

 

Kind regards

 

Idealy I want network lock to stay active at all the time when I'm not connected to an airvpn server but having the eddie client running.

 

Hello!

 

Yes, and that's exactly what happens. If you are disconnected from a VPN server but Eddie is not shut down, Network Lock remains active. If Eddie is killed without grace or crashes Network Lock remains active.

 

In the moment you shut down Eddie, we have no rights to interfere with your system and we have no will to make invasive software that permanently modifies your system settings. Routing table, DNS and all previous firewall rules will be restored.

 

Kind regards

Share this post


Link to post

Hello!

 

Yes, and that's exactly what happens. If you are disconnected from a VPN server but Eddie is not shut down, Network Lock remains active. If Eddie is killed without grace or crashes Network Lock remains active.

 

In the moment you shut down Eddie, we have no rights to interfere with your system and we have no will to make invasive software that permanently modifies your system settings. Routing table, DNS and all previous firewall rules will be restored.

 

Kind regards

 

Thanks for your reply. I perfectly understand what you're saying and agree that this is the way it should be BUT I think we're talking cross wires what the issue is I try to explain. When network lock is active when I shut down eddie I want it to remember that network lock was active and reapply network lock automatically once I re-launch the client. That's what I was saying when I said the setting is not sticky. I'm perfectly fine with previous firewall rules getting restored when client is shut down more so I think it's an absolutely necessary behavior.

Share this post


Link to post

 

Thanks for your reply. I perfectly understand what you're saying and agree that this is the way it should be BUT I think we're talking cross wires what the issue is I try to explain. When network lock is active when I shut down eddie I want it to remember that network lock was active and reapply network lock automatically once I re-launch the client. That's what I was saying when I said the setting is not sticky. I'm perfectly fine with previous firewall rules getting restored when client is shut down more so I think it's an absolutely necessary behavior.

 

Hello,

 

no problems, we understood. Yes, this setting (Network Lock enabled and active) is 'sticky'.

 

What you describe is an anomaly on your system that we would need to reproduce to understand why it happens on your system, if there's some hidden bug in the client etc.

 

Kind regards

Share this post


Link to post
Guest JWW

There seems to be an issue with server white-listing. In the screenshot you can see I have three UK servers listed. That's the result of white-listing the UK under the Countries tab and then blacklisting 'Nunki'. As I get the best speed results from 'Carinae' I tried white-listing that server which, according to the pop-up help should mean that Eddie only connects to 'Carinae' (if I'm understanding white-listing correctly). This has no effect however and Eddie will still choose whichever server it thinks best from the list of three.

Share this post


Link to post

okay unfortunately your client is still pretty buggy, at least for me.

 

  • the client crashes/exits after switching between tabs in the main menu and tells me to contact airvpn support just before existing (just as the previous version of the client has done.)
  • the client rewhite-lists countries that i previously has been white-listed after a few minutes of being unwhite-listed (has happened at least a dozen times and keeps on happening every time)

Share this post


Link to post

Hello Air

 

Just to let you know that I installed 2.8 RC3 .deb Debian/Ubuntu Package (with correct hashes) on two systems:

Linux Mint 17, (Qiana) Cinnamon Ver 2.2.16, 64 bit, Linux Kernal 3.13.0-24 generic

Linux Mint 17.1, (Rebecca) Cinnamon Ver 2.4.5, 64 bit, Linux Kernal 3.13.0-37 generic

 

On both: It installed ok, but when I start the client window its appearance is distorted and it doesn't function.  It doesn't get as far as appearing in the active processes window in the System Monitor so I use sudo xkill and the cursor to close it. Tried a few times, same result.

 

I haven't tried the portable versions yet. I wasn't sure whether to use the "(mono required)" version or plain version. Or try both?

 

Hope this helps

 

(I use 2.7 portable on those systems for normal use)

Hello,

 

can you please provide a screenshot? We don't notice any problem with Mint 17.1 Rebecca. Make sure that you're really running version 2.8RC3 (run airvpn without arguments from a shell and look at the output). Try also portable version (NOT the portable version with Mono required).

 

Kind regards

Air, I'm sorry to take so long to report back.

I did as you instructed and started the installed version of the client via command line and it started up, accepted the terms, it ran fine, I loaded a website, checked ipleak, logged out, exited etc. So it ran ok and will also start from the desktop link.

 

 

However I'm not sure whether to keep using it because I still get those GDI image rendering errors which in previous versions used to make it crash:

 

! 2015.01.08 02:06:06 - Logout ...

! 2015.01.08 02:06:06 - Logged out.

! 2015.01.08 02:06:09 - Exiting

F 2015.01.08 02:06:10 - Unexpected error. Please contact our support staff. - A null reference or invalid value was found [GDI+ status: InvalidParameter] -   at System.Drawing.GDIPlus.CheckStatus (Status status) [0x00000] in <filename unknown>:0

F 2015.01.08 02:06:10 - at System.Drawing.Graphics.GdipMeasureString (IntPtr graphics, System.String text, System.Drawing.Font font, System.Drawing.RectangleF& layoutRect, IntPtr stringFormat) [0x00000] in <filename unknown>:0

(it continues on for about 35 lines)

 

 

I haven't yet tried the portable version but will report back when I do.

(:

Share this post


Link to post

On OSX 10.9, client about says 2.8.6, the console fills with this message continuously while the app is running:

 

Jan 10 23:03:55 bobcat.local defaults[622]:
    The domain/default pair of (kCFPreferencesAnyApplication, AppleInterfaceStyle) does not exist

 

Also when I tried to revert back to 2.7 the Network Lock button disappeared.

 

Thanks

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...