Jump to content
Not connected, Your IP: 18.210.23.15

Recommended Posts

This is a super annoying bug if I get disconnected (either through loss of wifi signal or disconnected ethernet wire) while I'm connected to a session. When I re-establish the connection over the network I cannot re-establish a connection with AirVPN I get "OpenVPN is already running".

 

The only thing that works to fix this is a machine reboot!

Share this post


Link to post

You do not have to reboot, press Ctrl+Alt+Delete on your keyboard, run task manager and then select openvpn.exe and press "end process". Air client should run OK then. That is in Windows 7.

Share this post


Link to post

Hi everyone,

 

I installed AirVPN yesterday on my laptop with windows 8.1 and have very similar problems as OP.

 

But the solution doesn't work since I can't end / terminate / kill openvpn.exe, not by Task Manager, nor by Process Hacker, nor by cmd. I've been googling for hours, tried to disconnect all possible devices and disabling/enabling all possible drivers. I do have OpenVPN installed as well but the GUI isn't running (and openvpn.exe wasn't running either before installing). Openvpn.exe doesn't show any sort of cpu activity. The problems started after reopening my laptop (sleep mode).

 

I know I've been avoiding the most relevant solution ("have you tried turning it off and on again") but I'd really like not to restart my computer as there are other programs running in which I can't save my activity.

 

Have I missed something obvious or is there no other solution but a clean restart and not to use sleep mode anymore? In that case I'm afraid I'll have to look for alternatives.

 

On a side note, yesterday I tried a couple of servers in the Netherlands, and got about 5Mb/s downloadspeed in tunnel and ~22Mb/s outside the tunnel. Upload speed was only slightly affected. Is this considered normal?

Share this post


Link to post

Sleep mode is a bad thing when OpenVPN is running. Windows resets the routing table on every ACPI state change from S0 (sleep, hibernation, shutdown, see the link for details), so after wakeup the whole OpenVPN config is gone. It may explain why OpenVPN is acting that way...


Four simple things:
There's a guide to AirVPN. Before you ask questions, take 30 minutes of your time to go through it.

Amazon IPs are not dangerous here. It's the fallback DNS.
Running TOR exits is discouraged. They're subject to restrictions on the internet and harm all AirVPN users.

Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, you'll be unique among the mass again.

 

XMPP: gigan3rd@xmpp.airvpn.org or join our lounge@conference.xmpp.airvpn.org

Share this post


Link to post

[sOLVED]

 

I had the same problem I received a message that OpenVPN GUI is already running; and even after killing the process with Task Manager and restarting it, I couldn't find the program in the system tray.

 

I finally figured out that if I clicked on the tiny arrow head to the left of the system tray and moused over the icons shown in a popup until I found openvpn-gui, then dragged it from the popup to the system tray, it would remain there. 

 

Click on it and if it is properly configured it will offer you working connection options.  If the icon of a locked tty turns green, that means it is connected.

Share this post


Link to post

cspaletta's issue was something different and this is not solved.


What we're saying is, sometimes AirVPn conks out, and disconnects. The GUI shows it's still disconnecting(or that it apparently disconnected) though when you try to connect to a server again, the message appears 'OpenVPN is already running'
This is true, in process list Openvpn.exe is listed.

However you cannot kill the task either by Windows Gui, elevated command prompt or disabling the Lan adapter for that VPN.

Exiting Eddie does not resolve.
I've checked permissions on the AirVPN folder where the OpenVPN executable is and it has full rights, no limits.

For several years have been putting up with it, and it's tiresome. Rather than start a new thread, I'd like this to get solved once and for all here, as the title is apt and accurate.


 

Setup:

pfSense 2.1.5 on :

Dell PowerEdge R860

2x Xeon E5620 @2.6ghz
16GB DDR3 EEC
 

 

ISP :

BT Infinity Clearnet - 79.5mbps BRAS ; 74.3mbps DS  / 20.0mbps US
AirVPN -------------- - --------------------  ; 69.0mpbs DS /  19.50mbps US

Share this post


Link to post
@Lordvpn

Hello!

We can't see how the problem can be solved by Eddie, an application running in the userspace, when not even a system administrator in front of the keyboard can kill a process. If your report is accurate an immortal process that's not a zombie shows that the system is out of control. Not so surprising in Windows but please re-check your claims, just in case, i.e. is openvpn.exe really impossible to kill without rebooting the system?

Kind regards
 

Share this post


Link to post

Hello, I only have this issue with OpenVPN when installed by Eddie and resides in Eddie's directory.
Maybe the installer for Eddie does something to permissions.

And yes it may not be caused by Eddie specifically, and is not solvable by AirVPN. Rather I should have said I was hoping someone whom uses AirVPN whether staff or consumer, helps find a way to fix it.
 


Setup:

pfSense 2.1.5 on :

Dell PowerEdge R860

2x Xeon E5620 @2.6ghz
16GB DDR3 EEC
 

 

ISP :

BT Infinity Clearnet - 79.5mbps BRAS ; 74.3mbps DS  / 20.0mbps US
AirVPN -------------- - --------------------  ; 69.0mpbs DS /  19.50mbps US

Share this post


Link to post
2 hours ago, Lordvpn said:

Hello, I only have this issue with OpenVPN when installed by Eddie and resides in Eddie's directory.


In this case install OpenVPN vanilla and point Eddie to this binary. Workaround, I know, but I also don't see how this can be solved.

Besides, it's a thread from 2014 with an old Eddie binary, if it even was Eddie already back then. Today it should not be a problem anymore, but if it is, the reason is almost always exclusive to the user's setup (if it wasn't, people would create a hundred new threads about it). And this usually calls for new threads rather than violent hijacking or even resurrecting old ones. Besides..
 
7 hours ago, Lordvpn said:

For several years have been putting up with it, and it's tiresome.


This suggests you're on an old Eddie version and/or never changed your setup (hardware/OS version).

I'd also suggest to try Process Explorer. Usually gives more insight to such things.

Four simple things:
There's a guide to AirVPN. Before you ask questions, take 30 minutes of your time to go through it.

Amazon IPs are not dangerous here. It's the fallback DNS.
Running TOR exits is discouraged. They're subject to restrictions on the internet and harm all AirVPN users.

Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, you'll be unique among the mass again.

 

XMPP: gigan3rd@xmpp.airvpn.org or join our lounge@conference.xmpp.airvpn.org

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...