Jump to content
Not connected, Your IP: 3.236.143.154
Staff

AirVPN Client - Eddie - Beta testing phase

Recommended Posts

Staff,

 

Trying out the Eddie Linux client on a new 14.04 bare metal OS.

 

[ I know that 14.04 has a "bug" with pre-config VPN settings.  I tried it anyway and confirm its still not working (no surprise just confirming the bug has not been fixed yet).]

 

Now will somebody please tell me how to get around an issue I am having with the client.  Its on my end.

 

Scenario:  I downloaded Eddie using another machine and burned it to a CDR.  Then I fired up the 14.04 OS and copied the client to the desktop of 14.04.  Clicked on it and installed it.  I watched it install in the progress bar.  Seemed to go fine.  I can open Accessories and I see the AirVpn icon.  When I click on it a full screen appears with a launch button.  I click on LAUNCH and then nothing happens.  It just goes to full desktop view and I see nothing.

 

1. Do I need to change permission or go root, etc....?  If so how on the gui icon?

 

2. Should I run this from terminal and if so what commands are recommended?

 

3. Lastly, assuming I resolve this connection issue -------------- > is there anything in the client that will interfere with my still using a ufw firewall ruleset just to be sure?  I lock ufw down to: general block in and out, allow only the air entry IP, traffic only allow tun.  Not complex but its solid and never has leaked.

Share this post


Link to post

Feature request:

 

1.  I would like the ability to stop AirVPN from connecting to a server mid-connection.  It seems now that once you press connect, the client will attempt to connect to a server and nothing will stop it short of terminating the application.

 

2.  On the overview tab, the port you are connected to does not show.  Could this be added?

Share this post


Link to post

 

Hello!

 

The problem is here:

 

 

5/12/2014 - 9:04 AM    OpenVPN > resolvconf: Error: /etc/resolv.conf must be a symlink

 

It's not Eddie's problem, see here for a quick fix: http://askubuntu.com/a/172157

 

Kind regards

I tried the askubuntu link and all I could get is this (didn't work) :

 

update-rc.d: warning: resolvconf stop runlevel arguments (none) do not match LSB Default-Stop values (0 6)

 

I think my version of Ubuntu 10.04 Lucid is too old.  Guess I need to upgrade.  Thanks for the assistance.

 

 

 

 

Anyone with a suggestion of how I can fix this short of upgrading (which seems to have it's own issues) ?

Share this post


Link to post

Excellent, I've dreamed of a Linux client for AirVPN. I'm in Archlinux and everything is working great. There are great

features here and now I don't have to download any config files anymore

Share this post


Link to post

Any instructions on how to compile the client from the github source? My system is armhf so the regular x32/x64 builds are not compatible.
 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...