Jump to content


Photo

Won't Connect at checking Ipv6


  • Please log in to reply
10 replies to this topic

#1 whiskey_76

whiskey_76

    Advanced Member

  • Members
  • PipPipPip
  • 52 posts

Posted 02 July 2018 - 05:14 PM

Lately certain servers Eddie will not connect to at the checking IPV6 part of the process. Even servers that are not experimental and it's kind of annoying.

What could be causing that problem? I tried different settings in the network section of preferences but nothing seems to help. Eddie will fallback and connect to another server without any problems though.

For example, I just tried to connect to Acamar and it kept disconnecting after "checking route IPv6". Shouldn't it just be able to use IPV4?

 

Edit: The next time this happens I will post logs. I did see when I looked earlier it had something to do with CURL?



#2 whiskey_76

whiskey_76

    Advanced Member

  • Members
  • PipPipPip
  • 52 posts

Posted 02 July 2018 - 05:52 PM

I tweaked settings in network preferences and told it to block ipv6 and I could connect on first try, interesting.



#3 Spinone

Spinone

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 16 August 2018 - 11:20 AM

I have the same problem. I can connect to some servers, but others hang at "Checking route IPv6". The logs show cURL timing out after 20000ms, three times, before declaring "Checking route IPv6 failed" and disconnecting.

In options/Networking, I had the Layer IPv6 combo dropdown set to "Inside tunnel if supported, otherwise blocked" and had the "Switch to Block if issue is detected" checked.

By setting the Layer IPv6 combo dropdown to "Block", I can connect to servers which fail with the default settings active. All other selections result in the "Checking route IPv6 failed" error.

Something's not right - it would be nice to know what causes this.

Sample log excerpt and system report attached.

Attached Files



#4 firewalker

firewalker

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 31 August 2018 - 04:20 PM

I have run into a similar issue, so I switched back to the last version available in the changelog, the modern client seems to be giving me more trouble then the old.



#5 John Gow

John Gow

    Member

  • Members
  • PipPip
  • 22 posts

Posted 02 September 2018 - 05:50 AM

I had issues connecting to some servers with ipv6 (running  Linux) as described.

I changed airvpn settings to force UDP protocol (don't think that has anything to do with it though), then changed protocol settings:

Layer ipv4 inside tunnel

Layer ipv6 Block

Switch to block if issue Yes

 

IP used for connection: Ipv4, IPv6 , Automatic

 

It's weird but I think not having IPv6 enabled even though you're blocking it might be causing the connection issue. Looking through logs IPv6 is actually blocked on the WAN side but I am connecting to servers just fine now.



#6 scooby0786

scooby0786

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 25 September 2018 - 03:31 PM

Hi guys,

 

Works on my PC just fine as normal. Just installed on laptop, as unable to access PC as I'm bedridden. And have the same problems as above.

The above didn't generally help me, although I could connect Eddie to a server, it said network blocked when I tried accessing the net.

If the above doesn't help anyone else, try the following:

 

Preferences>Networking:

Layer ipv4: inside tunnel must be supported.

Switch to block ticked on.

Layer ipv6 blocked.

switch to block switched on and ticked.

Internet protocol used: ipv4 only (this I had to change, and different from previous posts). 

Interface for connection: Automatic. 

 

Hope that helps others in similar circumstances.

 

Also check this post: https://airvpn.org/topic/29401-checking-route-ipv6-failed-cannot-connect-to-vpn-server-using-eddie/



#7 xtrr

xtrr

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 31 October 2018 - 02:07 PM

Thank you John Gow!  Worked perfect!



#8 ld50ofmilk

ld50ofmilk

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 03 November 2018 - 05:49 PM

Hello! Got same issue, couldn't connect to vpn throu Eddie with default settings.

Always stuck at this thing in logs:

. 2018.11.03 20:48:34 - OpenVPN > do_ifconfig, tt->did_ifconfig_ipv6_setup=1
. 2018.11.03 20:48:35 - OpenVPN > NETSH: C:\Windows\system32\netsh.exe interface ipv6 set address ... store=active
. 2018.11.03 20:48:36 - OpenVPN > NETSH: C:\Windows\system32\netsh.exe interface ipv6 set dns ... validate=no
E 2018.11.03 20:49:21 - OpenVPN > ERROR: netsh command failed: returned error code 1

 

Disabled IpV6 in settings, that's solve my issue.

Layer ipv6 Block

Switch to block if issue Yes

Internet protocol used for connection IPv4 only

 

But i'm curious, what was the reason for errof?

Could it be that my ISP didn't support IpV6? And everything stuck at checking at this point?



#9 waterfall

waterfall

    Member

  • Members
  • PipPip
  • 25 posts

Posted 06 November 2018 - 03:57 PM

I was having the same problem since upgrading to 2.16.3. I made the changes listed above and connected effortlessly.

 

My question though has to do with blocking ipv6:

Doesn't doing so create some kind of limitation on access to websites that use that protocol? Or, is it not a problem until Ipv4 is finally declared obsolete?

 

Originally the connectivity to Air servers seemed to become less of a problem when I deactivated Network Lock on start-up, but I also like to have Network Lock enabled even when I am not online since it seems to function as a Firewall of sorts.



#10 Skicoach

Skicoach

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 19 November 2018 - 08:53 PM

... also had to block Ipv6 

Never had a problem until installing eddie yesterday. 

 



#11 jomamabasestar

jomamabasestar

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 24 November 2018 - 03:47 AM

I'm a new member running Airvpn on Ubuntu systems. I was able to log in with ipv6 blocked on the eddie UI but when I checked whatismyip.com it showed ipv6 address as my true address and the ipv4 as the VPN address. I disabled ipv6 on both my systems and now whatismyip.com only detects ipv4 VPN addresses and ipv6 not detected. It works but I am worried about not being able to access ipv6 protocol sites. Or is that even a thing yet?





Similar Topics Collapse

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Servers online. Online Sessions: 15333 - BW: 59957 Mbit/sYour IP: 54.82.10.219Guest Access.