Jump to content


Photo

Getting error when starting Eddie from a shell script

eddie cli error

  • Please log in to reply
No replies to this topic

#1 beefcake

beefcake

    Newbie

  • New Members
  • Pip
  • 1 posts

Posted 30 December 2017 - 12:06 PM

Hello,

 

I can successfully run the Eddie CLI and connect by issuing 

 

sudo ~/airvpn -cli -connect
 
However, I want to put this line into a shell script "vpn.sh" so that I con't have to type all this every time I connect, but instead just issue "vpn.sh". When I do this, the program doesn't connect but instead I get a small graphical window with the title "Eddie" and the content "Lib.Platform.Linux.Native.so".
 
This also happens when I set an alias for the long command in my .bashrc.
 
Does anyone know why that happens, and how to avoid it? If there's another, better solution to my problem, I'm also happy to hear about it.
 
Thanks in advance.
 
 
/Edit:
 
Okay, this is mighty weird:
*Sometimes*, this command throws the same error:
 
 sudo /home/beefcake/files/Software/eddie-ui_2.13.6_linux_x64_portable/airvpn -cli -connect
 
I've had two bash windows open where it worked in one, and failed in the other.
 
If I issue these commands, it works:
 
 cd /home/beefcake/files/Software/eddie-ui_2.13.6_linux_x64_portable/
 sudo ./airvpn -cli -connect






Similar Topics Collapse


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Servers online. Online Sessions: 13444 - BW: 40000 Mbit/sYour IP: 54.224.11.137Guest Access.