Jump to content


Photo

Route Check, DNS Check fails


  • Please log in to reply
15 replies to this topic

#1 TheHellSite

TheHellSite

    Member

  • Members
  • PipPip
  • 12 posts

Posted 02 May 2017 - 11:11 PM

I don't know what happend but I can't connect to AirVPN on my windows pc anymore.
"Checking Route" and "Checking DNS" always fails after 3rd try.

See the log: https://pastebin.com/cnVt8zCw

 

Hope you can help me out. Linux is working perfectly fine.



#2 LZ1

LZ1

    It's nice to be nice to nice people

  • Members
  • PipPipPip
  • 1449 posts

Posted 05 May 2017 - 03:17 AM

Hello!

 

This has been covered many times. You can go to Eddie's settings and uncheck "check if tunnel effectively works" under Advanced and "Check AirVPN DNS" under DNS.


Open This Spoiler If: A Website Is Blocked, You Want To Help AirVPN, Find The Beta/Experimental Client Or You're A New User Wanting Help/Information

Spoiler

Did you make a guide or how-to for something? Then contact me if you want me to index it in my new user guide, so that the community can find it more easily.

Tired of Windows? Why Linux Is Better.


#3 TheHellSite

TheHellSite

    Member

  • Members
  • PipPip
  • 12 posts

Posted 05 May 2017 - 09:20 PM

I already knew that, but what's the reason the problem? I mean these options are quite useless then.

 

EDIT: Once I am connected with the settings you mentioned, the internet stops working. But ping in cmd works fine.



#4 TheHellSite

TheHellSite

    Member

  • Members
  • PipPip
  • 12 posts

Posted 09 May 2017 - 09:42 PM

The same now happens on my linux system and with your settings the internet isn't working as well.
Which means: I can't use my vpn account at all.



#5 LZ1

LZ1

    It's nice to be nice to nice people

  • Members
  • PipPipPip
  • 1449 posts

Posted 10 May 2017 - 11:59 AM

You can try disabling IPv6.


Open This Spoiler If: A Website Is Blocked, You Want To Help AirVPN, Find The Beta/Experimental Client Or You're A New User Wanting Help/Information

Spoiler

Did you make a guide or how-to for something? Then contact me if you want me to index it in my new user guide, so that the community can find it more easily.

Tired of Windows? Why Linux Is Better.


#6 TheHellSite

TheHellSite

    Member

  • Members
  • PipPip
  • 12 posts

Posted 14 May 2017 - 08:01 PM

IPv6 is disabled on all my systems.



#7 TheHellSite

TheHellSite

    Member

  • Members
  • PipPip
  • 12 posts

Posted 16 May 2017 - 01:44 PM

I just discovered that connection is successful on both my linux (vm) and windows system when connected to my university network using wifi.

What could be the issue in my home network that is causing the problems? Hope you guys got any ideas for me.

I am using 1 main router and 2 APs. My pc is mostly connected via cable, sometimes with wifi.



#8 virginm

virginm

    Newbie

  • New Members
  • Pip
  • 2 posts

Posted 17 May 2017 - 01:35 PM

Had the same issue, answer 1 from LZ1 to uncheck "Check AirVPN DNS" did the job, thank you! 



#9 syrahrosso

syrahrosso

    Member

  • Members
  • PipPip
  • 11 posts

Posted 21 May 2017 - 09:10 PM

Did you try to select "TCP on port 443" in Preferences -> Protocols, instead of "automatic" ?



#10 TheHellSite

TheHellSite

    Member

  • Members
  • PipPip
  • 12 posts

Posted 30 May 2017 - 11:18 PM

I thought I already tried that. But seems like my ISP (Deutsche Telekom AG) blocks UDP connections.

I also figured out that if I disable the LTE on my router and only use DSL (I have a dsl hybrid connection), even UDP connections work just fine!

 

So it seems they only filter OpenVPN UDP connections on their DSL-LTE bonding servers.

To bad that TCP is way slower than UDP.



#11 zilkerpark

zilkerpark

    Newbie

  • New Members
  • Pip
  • 1 posts

Posted 01 June 2017 - 05:03 AM

Hi, this happens to me sometimes on Win10.

Here's how I fix it:

 

Control Panel

Network and Internet> Network and Sharing Center>Change Adapter Settings

Right Click on “Ethernet”

Click “properties”

Internet Protocol Version 4 > Properties

Click "use the following DNS server addresses"

Preferred DNS server—208.67.222.222

Alternate DNS Server – 208.67.220.220



#12 TheHellSite

TheHellSite

    Member

  • Members
  • PipPip
  • 12 posts

Posted 01 June 2017 - 10:22 PM

Thanks for the hint. But I am already using another open DNS server and like I said before: for me it has nothing to do with DNS problems. I can ping fine, even when being connected with route and dns check off, whilst having "no internet". This is simply due to the fact that my ISP filters the OpenVPN UDP traffic.



#13 TheHellSite

TheHellSite

    Member

  • Members
  • PipPip
  • 12 posts

Posted 09 August 2017 - 10:11 PM

It has been a long time, but I finally found a solution!

 

When my connection is in Hybrid Mode (LTE+DSL together), the MTU value is 1384.

In order to use AirVPN with full speed no mather if using UDP or TCP protocoI, I just had to apply this line to the OpenVPN directives in Eddie.

 

OpenVPN over UDP --> "mssfix 1356"

// Hybrid MTU 1384 - (UDP Header 8 Byte + IPv4 Header 20 Byte) = 1356

 

OpenVPN over TCP --> "mssfix 1344"

// Hybrid MTU 1384 - (TCP Header 20 Byte + IPv4 Header 20 Byte) = 1344

I know that the TCP header can be up to 60 byte large, but for me 1344 works just fine.

 

I can now use UDP protocol without any issues and even TCP now is almost as fast as UDP.

 

 

In case there are any other DSL Hybrid users out there having trouble with OpenVPN speeds.



#14 VPN1fiend

VPN1fiend

    Newbie

  • New Members
  • Pip
  • 2 posts

Posted 11 August 2017 - 12:45 PM

Same problem today again - see zerosum's opening post today.

 

HOWEVER: unchecking things that are there for safety reasons is not a valid suggestion - why not drop the VPN thing altogether and save 60 bucks a year???



#15 banshee28

banshee28

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 13 August 2017 - 03:17 PM

Hello!

 

This has been covered many times. You can go to Eddie's settings and uncheck "check if tunnel effectively works" under Advanced and "Check AirVPN DNS" under DNS.

I have been running 2.12.x for some time now, and just today updated to 2.13 on my Arch Linux system (airvpn-beta-bin 2.13.3-1). I am getting the same DNS checking error now trying to connect.

 

If I chose to disable "Check AirVPN DNS", it works! Thanks for the tip....

 

However, like LZ1, I dont like the idea of disabling things IF that could cause security issues. So does this option mean IF it finds AirVPN DNS is NOT working, it will ignore it and I would then revert back to my locally configured DNS servers??

 

Any other fixes?

 

Thanks



#16 organicchocolate

organicchocolate

    Newbie

  • New Members
  • Pip
  • 1 posts

Posted 20 October 2017 - 01:59 PM

Edit: issue resolved now, i did nothing. i have Preferences>DNS>Check AirVPN DNS (checked) and nothing in the IP fields (as recommended by airvpn). i can now connect as before.

 

i have the same issue starting about oct 12 after 4 months of no problems great service. i made no updates to my mac os, installed a few apps some time ago. seems this started out of the blue. did something change with my isp provider? banshee28 question is a valid question for those like me who are not technical and have no idea how this stuff works. "IF it finds AirVPN DNS is NOT working, it will ignore it and I would then revert back to my locally configured DNS servers?" i was on whatever Eddie from 4 months ago couldn't connect then updated to 2.13.6 which did not resolve the issue until i did the disable dns check.







Similar Topics Collapse

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

Servers online. Online Sessions: 13370 - BW: 38940 Mbit/sYour IP: 54.198.2.110Guest Access.