Jump to content


Photo

DD-WRT router behind DSL Router not connecting?


Best Answer wuffles, 24 July 2015 - 04:46 PM

Success, I think. Well, it's connected, so it was a simple case of 1. forgot to add a cert, 2. forgot to add an ntp server after the factory reset, 3. broke it completely and 4. unbroke it and reset it up again.

 

So, now I know it works I can take out the subscription, and with just 15 mins of life left in th 3 day trial too.

 

Do I just use the firmware update facility through the GUI? In which case is there a specific thing I should be looking for on the DD-WRT site. Presumably just seach for the correct model and take it from there?

 

Thanks for your help DJ77.

Go to the full post


  • Please log in to reply
50 replies to this topic

#1 wuffles

wuffles

    Advanced Member

  • Members
  • PipPipPip
  • 32 posts

Posted 23 July 2015 - 07:08 PM

Ok. Am on a trial usage at the moment because I didn't know if this was going to work, I'm fairly sure it's a port forwarding issue but can't seem to find an answer.

 

I have a DSL router connected to the Internet (A) which internally is connected to a Netgear DD-WRT (B) which in turn is connected to my computer (as I am testing). I have followed the config setup for the OpenVPN setup and can connect to the airvpn.org website through the router(s). However it says I am not connected to the VPN, also if I try to browse to anything else whilst connected to router B it fails to recognise. As you would expect, connecting directly through router A is fine as that's how it's always worked.

 

Do I need to port forward on router A to get something working on router B?

 

Could my config be wrong?

 

I haven't done the DHCP part of the setup on this page - https://airvpn.org/ddwrt/ - as I am only testing this via a wired connection and a fixed IP and don't want to disturb the eco system that is my LAN arrangement.

 

Status from the DD-WRT status/OpenVPN is "State Server: : Local Address: Remote Address: Client: : Local Address: Remote Address:" - which leads me to believe it's not even connecting.

 

Thanks in advance.



#2 wuffles

wuffles

    Advanced Member

  • Members
  • PipPipPip
  • 32 posts

Posted 23 July 2015 - 07:17 PM

And naturally it happens exactly at the time this happens at http://www.dd-wrt.com/wiki/index.php/Port_Forwarding_Troubleshooting -_-

DD-WRT Wiki has a problem

Sorry! This site is experiencing technical difficulties.



#3 wuffles

wuffles

    Advanced Member

  • Members
  • PipPipPip
  • 32 posts

Posted 23 July 2015 - 08:19 PM

An update.

 

I've enabled DHCP with the settings from the tutorial, placed router B in the DMZ for router A (as I don't know which port to forward if indeed any) and it's still not working. Can't browse to anything now.

 

I've done a couple of screen grabs as a picture, thousand words etc.

 

In the tutorial (which obviously wasn't written for my scenario) it leaves the gateway empty in the local network settings, I've had to assign router A or I wouldn't get very far, does that sounds about rght?

 

Capture.PNG

 

Capture2.PNG



#4 go558a83nk

go558a83nk

    Advanced Member

  • Members2
  • PipPipPip
  • 1699 posts

Posted 23 July 2015 - 08:51 PM

you'll need to paste here the logs of your dd-wrt router attempting to make an openvpn connection for us to begin to diagnose the problem.



#5 wuffles

wuffles

    Advanced Member

  • Members
  • PipPipPip
  • 32 posts

Posted 23 July 2015 - 08:57 PM

Yes, I am unfortunately stuck in a moderated time warp where my posts don't seem to get here on time.

 

/waves from the past.



#6 dj77

dj77

    Advanced Member

  • Members
  • PipPipPip
  • 117 posts

Posted 23 July 2015 - 10:34 PM

My ddwrt Router is on my dsl Router connected Standard Settings no fixed ip no Problem

#7 wuffles

wuffles

    Advanced Member

  • Members
  • PipPipPip
  • 32 posts

Posted 24 July 2015 - 07:21 AM

@DJ77 good to know, perhaps you can see exactly where I am going wrong when my posts arrive. I've got the trial until 6pm this evening, so hopefully before then or my testing won't be very fruitful.

 

Fingers crossed when this post gets modded and posted it'll be my 5th post and the moderation will cease.



#8 dj77

dj77

    Advanced Member

  • Members
  • PipPipPip
  • 117 posts

Posted 24 July 2015 - 09:24 AM

Without openvpn Internet work on r7000? Tls cipher try aes 128 and lzo compression adaptive are you sure the ip adress is correct? Try Domain Name se.vpn.airdns.org or nl.vpn.airdns.org Click Save and apply

Tls auth key / ca cert / Public Client / private Client should Start from ---Begin ....---- to -- end ...----


Do you Need fixed ip on r7000? You Could reset it and use Standard Setup (dhcp..)

#9 wuffles

wuffles

    Advanced Member

  • Members
  • PipPipPip
  • 32 posts

Posted 24 July 2015 - 10:11 AM

I've removed the remark lines from the top of TLS Auth Key. The tutorial does explicitly say "Open up "ta.key" and copy all of the contents into TLS Auth Key" so that's why they were in there.

 

 

I've switched the IP to the one you said to try and it appears to have made no difference.

 

It's acting like it's not even trying to bring up an OpenVPN connection. Nothing in status but with it plugged into router A I am able to browse the Internet without a problem.



#10 dj77

dj77

    Advanced Member

  • Members
  • PipPipPip
  • 117 posts

Posted 24 July 2015 - 10:16 AM

Can you reset r7000 and try with Standard Setup?

#11 wuffles

wuffles

    Advanced Member

  • Members
  • PipPipPip
  • 32 posts

Posted 24 July 2015 - 10:19 AM

How reset are we talking here? I could remove the iptables entries and disable OpenVPN if that's reset enough.

 

I didn't start down this route before checking it worked without all the OpenVPN stuff being added, so I know it works fine as a router through router A.



#12 wuffles

wuffles

    Advanced Member

  • Members
  • PipPipPip
  • 32 posts

Posted 24 July 2015 - 10:22 AM

Or rather, is there a way to force an OpenVPN connection into being brought up, then hopefully something will appear in the logs. Or a debug mode you know of?



#13 dj77

dj77

    Advanced Member

  • Members
  • PipPipPip
  • 117 posts

Posted 24 July 2015 - 10:23 AM

Administration tab them Factory default tab

Then Setup wlan password / save&apply

Basic Setup Page: save&apply
static dns1: 8.8.8.8
static dns2: 8.8.4.4
static dns3: 10.0.0.0

Openvpn Setup save&apply

Reboot router

#14 wuffles

wuffles

    Advanced Member

  • Members
  • PipPipPip
  • 32 posts

Posted 24 July 2015 - 10:34 AM

Ok, I've done that but when you say OpenVPN setup, you mean to just enable it or to go through and recreate everything in there that I had before before saving and applying?



#15 wuffles

wuffles

    Advanced Member

  • Members
  • PipPipPip
  • 32 posts

Posted 24 July 2015 - 10:36 AM

I will also have to change the IP of router B from the factory default and enter a gateway of router A or nothing's going to work. Ok?



#16 dj77

dj77

    Advanced Member

  • Members
  • PipPipPip
  • 117 posts

Posted 24 July 2015 - 10:37 AM

I mean Setup openvpn like on the Tutorial Page https://airvpn.org/ddwrt/

But on Basic Setup dont change anything like fixed ip only statistic dns 1-3

#17 dj77

dj77

    Advanced Member

  • Members
  • PipPipPip
  • 117 posts

Posted 24 July 2015 - 10:37 AM

Which ddwrt Version you use?

#18 wuffles

wuffles

    Advanced Member

  • Members
  • PipPipPip
  • 32 posts

Posted 24 July 2015 - 10:38 AM

V24-sp2



#19 dj77

dj77

    Advanced Member

  • Members
  • PipPipPip
  • 117 posts

Posted 24 July 2015 - 10:42 AM

Yes but exact Version number? Click on v24 there Must be a number 24xxx 25xxxx 26xxx

#20 wuffles

wuffles

    Advanced Member

  • Members
  • PipPipPip
  • 32 posts

Posted 24 July 2015 - 10:47 AM

dd-wrt v23-sp2 (03/25/13) vpn-small (SVN revision 21061)

 

How I bought it.







Similar Topics Collapse

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

Servers online. Online Sessions: 15926 - BW: 59956 Mbit/sYour IP: 54.90.204.233Guest Access.