Jump to content
Not connected, Your IP: 3.228.24.192
Sign in to follow this  
yorksky

ANSWERED Windows 8 - No Gateway Set, all traffic blocked

Recommended Posts

I've been through the ringer on this problem.  OpenVPN worked fine for a week, then one day it stopped and it hasn't worked since.  I'm using Open VPN 2.3.2 x64, but I've tried 2.2.2 as well as the AirVPN client, all with the same behavior.

 

In short, OpenVPN connects successfully, but as soon as the connection is established my continuously running pings to google begin giving "request timed out."  No traffic to any destination succeeds.  There is no gateway set for the tunnel adapter, so I suspect this to be the problem.  I have tried adding the "route-method exe" line to the config file, as well as "route-delay 5" or "route-delay 10 30".  I have uninstalled OpenVPN, including the TAP adapters, and reinstalled multiple versions.  I am running OpenVPN GUI as Administrator.  I have ensured the NetMan and RasMan services are set to automati.  Only when I disconnect from the VPN does my traffic begin flowing again.

 

I can ping my own TAP-adapter IP address, of course, but cannot ping anything else near that address, as indicated by the subnet mask, including the DHCP server that gave me my address.  Once again, there is no gateway specified.

 

So what's the deal?  Below is the log file from OpenVPN after the successful connection:

 

 

Wed Sep 04 13:32:32 2013 OpenVPN 2.3.2 x86_64-w64-mingw32 [sSL (OpenSSL)] [LZO] [PKCS11] [eurephia] [iPv6] built on Aug 22 2013
Enter Management Password:
Wed Sep 04 13:32:32 2013 MANAGEMENT: TCP Socket listening on [AF_INET]127.0.0.1:25340
Wed Sep 04 13:32:32 2013 Need hold release from management interface, waiting...
Wed Sep 04 13:32:33 2013 MANAGEMENT: Client connected from [AF_INET]127.0.0.1:25340
Wed Sep 04 13:32:33 2013 MANAGEMENT: CMD 'state on'
Wed Sep 04 13:32:33 2013 MANAGEMENT: CMD 'log all on'
Wed Sep 04 13:32:33 2013 MANAGEMENT: CMD 'hold off'
Wed Sep 04 13:32:33 2013 MANAGEMENT: CMD 'hold release'
Wed Sep 04 13:32:33 2013 Socket Buffers: R=[65536->65536] S=[65536->65536]
Wed Sep 04 13:32:33 2013 UDPv4 link local: [undef]
Wed Sep 04 13:32:33 2013 UDPv4 link remote: [AF_INET]95.211.186.65:443
Wed Sep 04 13:32:33 2013 MANAGEMENT: >STATE:1378326753,WAIT,,,
Wed Sep 04 13:32:33 2013 MANAGEMENT: >STATE:1378326753,AUTH,,,
Wed Sep 04 13:32:33 2013 TLS: Initial packet from [AF_INET]95.211.186.65:443, sid=618e3523 3b821f4b
Wed Sep 04 13:32:34 2013 VERIFY OK: depth=1, C=IT, ST=IT, L=Perugia, O=airvpn.org, CN=airvpn.org CA, emailAddress=info@airvpn.org
Wed Sep 04 13:32:34 2013 VERIFY OK: nsCertType=SERVER
Wed Sep 04 13:32:34 2013 VERIFY OK: depth=0, C=IT, ST=IT, L=Perugia, O=airvpn.org, CN=server, emailAddress=info@airvpn.org
Wed Sep 04 13:32:40 2013 Data Channel Encrypt: Cipher 'AES-256-CBC' initialized with 256 bit key
Wed Sep 04 13:32:40 2013 Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Wed Sep 04 13:32:40 2013 Data Channel Decrypt: Cipher 'AES-256-CBC' initialized with 256 bit key
Wed Sep 04 13:32:40 2013 Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Wed Sep 04 13:32:40 2013 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 2048 bit RSA
Wed Sep 04 13:32:40 2013 [server] Peer Connection Initiated with [AF_INET]95.211.186.65:443
Wed Sep 04 13:32:41 2013 MANAGEMENT: >STATE:1378326761,GET_CONFIG,,,
Wed Sep 04 13:32:42 2013 SENT CONTROL [server]: 'PUSH_REQUEST' (status=1)
Wed Sep 04 13:32:42 2013 PUSH: Received control message: 'PUSH_REPLY,redirect-gateway def1,dhcp-option DNS 10.4.0.1,comp-lzo no,route 10.4.0.1,topology net30,ping 10,ping-restart 60,ifconfig 10.4.10.54 10.4.10.53'
Wed Sep 04 13:32:42 2013 OPTIONS IMPORT: timers and/or timeouts modified
Wed Sep 04 13:32:42 2013 OPTIONS IMPORT: LZO parms modified
Wed Sep 04 13:32:42 2013 OPTIONS IMPORT: --ifconfig/up options modified
Wed Sep 04 13:32:42 2013 OPTIONS IMPORT: route options modified
Wed Sep 04 13:32:42 2013 OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified
Wed Sep 04 13:32:42 2013 do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
Wed Sep 04 13:32:42 2013 MANAGEMENT: >STATE:1378326762,ASSIGN_IP,,10.4.10.54,
Wed Sep 04 13:32:42 2013 open_tun, tt->ipv6=0
Wed Sep 04 13:32:42 2013 TAP-WIN32 device [Local Area Connection] opened: \\.\Global\{AA45687F-76BE-4A7E-A566-55607C177507}.tap
Wed Sep 04 13:32:42 2013 TAP-Windows Driver Version 9.9 
Wed Sep 04 13:32:42 2013 Notified TAP-Windows driver to set a DHCP IP/netmask of 10.4.10.54/255.255.255.252 on interface {AA45687F-76BE-4A7E-A566-55607C177507} [DHCP-serv: 10.4.10.53, lease-time: 31536000]
Wed Sep 04 13:32:42 2013 Successful ARP Flush on interface [20] {AA45687F-76BE-4A7E-A566-55607C177507}
Wed Sep 04 13:32:47 2013 TEST ROUTES: 2/2 succeeded len=1 ret=1 a=0 u/d=up
Wed Sep 04 13:32:47 2013 C:\windows\system32\route.exe ADD 95.211.186.65 MASK 255.255.255.255 192.168.1.1
Wed Sep 04 13:32:47 2013 ROUTE: CreateIpForwardEntry succeeded with dwForwardMetric1=25 and dwForwardType=4
Wed Sep 04 13:32:47 2013 Route addition via IPAPI succeeded [adaptive]
Wed Sep 04 13:32:47 2013 C:\windows\system32\route.exe ADD 0.0.0.0 MASK 128.0.0.0 10.4.10.53
Wed Sep 04 13:32:47 2013 ROUTE: CreateIpForwardEntry succeeded with dwForwardMetric1=30 and dwForwardType=4
Wed Sep 04 13:32:47 2013 Route addition via IPAPI succeeded [adaptive]
Wed Sep 04 13:32:47 2013 C:\windows\system32\route.exe ADD 128.0.0.0 MASK 128.0.0.0 10.4.10.53
Wed Sep 04 13:32:47 2013 ROUTE: CreateIpForwardEntry succeeded with dwForwardMetric1=30 and dwForwardType=4
Wed Sep 04 13:32:47 2013 Route addition via IPAPI succeeded [adaptive]
Wed Sep 04 13:32:47 2013 MANAGEMENT: >STATE:1378326767,ADD_ROUTES,,,
Wed Sep 04 13:32:47 2013 C:\windows\system32\route.exe ADD 10.4.0.1 MASK 255.255.255.255 10.4.10.53
Wed Sep 04 13:32:47 2013 ROUTE: CreateIpForwardEntry succeeded with dwForwardMetric1=30 and dwForwardType=4
Wed Sep 04 13:32:47 2013 Route addition via IPAPI succeeded [adaptive]
Wed Sep 04 13:32:47 2013 Initialization Sequence Completed
Wed Sep 04 13:32:47 2013 MANAGEMENT: >STATE:1378326767,CONNECTED,SUCCESS,10.4.10.54,95.211.186.65
 

Share this post


Link to post

Hello!

 

Actually we had never met this problem before (at least it was not in the knowledge base). As a coincidence, we had two more customers who had this very same problem with Windows 8 just a few hours ago, one of them solved it just with a TCP/IP stack and Winsock reset ( https://airvpn.org/topic/9946-no-connection-on-win-8-w-airvpn-client/ ). In order to perform the reset please see here:

 

https://airvpn.org/topic/8320-solved-connects-but-ip-doesnt-change-on-windows-server-essentials-2012/?do=findComment&comment=8321

 

Kind regards

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

×
×
  • Create New...