Jump to content
Not connected, Your IP: 100.24.113.182
Sign in to follow this  
BfX6bAtoD84Avlvjsg6A

ANSWERED Getting less than 10% of normal speeds

Recommended Posts

I have connected using the AirVPN client, SSL with stunnel, and SSH. For SSH and SSL both i used airvpn's configuration generator. But I am still consistently getting only 2-3Mb/s(sometimes less, sometimes around 5Mb/s MAX.) Any and all suggestions that might help with this would be much appreciated.

Thank You.

Share this post


Link to post

Hello!

 

It is probably normal, connecting over OpenVPN over SSH/SSL implies a severe performance hit. If your ISP allows that (i.e. if you're not in China or Iran, in general - of course there can be particular cases) try OpenVPN directly, no SSH, no SSL. 5 Mbit/s is anyway an excellent performance for OpenVPN over SSH.

 

Kind regards

Share this post


Link to post

I am getting even slower speeds when i use the regular AirVPN client without the ssl or ssh.

 

Here is the log, I didnt notice anything that raises a flag to my untrained eye.

 

5/25/2013 - 7:11 PM    AirVPN client version: 1.8    
5/25/2013 - 7:11 PM    Reading options from C:\Users\user\AppData\Roaming\AirVPN\Air\1.0.0.0\AirVPN.xml    
5/25/2013 - 7:11 PM    OpenVPN bundle version: OpenVPN 2.3.0    
5/25/2013 - 7:11 PM    OpenVPN current version: OpenVPN 2.3.0    
5/25/2013 - 7:11 PM    Login...    
5/25/2013 - 7:11 PM    Login success.    
5/25/2013 - 7:11 PM    Contacting service...    
5/25/2013 - 7:11 PM    Connecting...    
5/25/2013 - 7:11 PM    OpenVPN 2.3.0 x86_64-w64-mingw32 [sSL (OpenSSL)] [LZO] [PKCS11] [eurephia] [iPv6] built on Jan  8 2013    
5/25/2013 - 7:11 PM    NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables    
5/25/2013 - 7:11 PM    Socket Buffers: R=[8192->8192] S=[8192->8192]    
5/25/2013 - 7:11 PM    UDPv4 link local: [undef]    
5/25/2013 - 7:11 PM    UDPv4 link remote: [AF_INET]108.59.11.194:443    
5/25/2013 - 7:11 PM    TLS: Initial packet from [AF_INET]108.59.11.194:443, sid=717ffd7a a305c5cd    
5/25/2013 - 7:11 PM    VERIFY OK: depth=1, C=IT, ST=IT, L=Perugia, O=airvpn.org, CN=airvpn.org CA, emailAddress=info@airvpn.org    
5/25/2013 - 7:11 PM    VERIFY OK: nsCertType=SERVER    
5/25/2013 - 7:11 PM    VERIFY OK: depth=0, C=IT, ST=IT, L=Perugia, O=airvpn.org, CN=server, emailAddress=info@airvpn.org    
5/25/2013 - 7:11 PM    Data Channel Encrypt: Cipher 'AES-256-CBC' initialized with 256 bit key    
5/25/2013 - 7:11 PM    Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication    
5/25/2013 - 7:11 PM    Data Channel Decrypt: Cipher 'AES-256-CBC' initialized with 256 bit key    
5/25/2013 - 7:11 PM    Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication    
5/25/2013 - 7:11 PM    Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 2048 bit RSA    
5/25/2013 - 7:11 PM    [server] Peer Connection Initiated with [AF_INET]108.59.11.194:443    
5/25/2013 - 7:11 PM    SENT CONTROL [server]: 'PUSH_REQUEST' (status=1)    
5/25/2013 - 7:11 PM    PUSH: Received control message: 'PUSH_REPLY,redirect-gateway def1,dhcp-option DNS 10.4.0.1,comp-lzo no,route 10.4.0.1,topology net30,ping 10,ping-restart 60,ifconfig 10.4.58.114 10.4.58.113'    
5/25/2013 - 7:11 PM    OPTIONS IMPORT: timers and/or timeouts modified    
5/25/2013 - 7:11 PM    OPTIONS IMPORT: LZO parms modified    
5/25/2013 - 7:11 PM    OPTIONS IMPORT: --ifconfig/up options modified    
5/25/2013 - 7:11 PM    OPTIONS IMPORT: route options modified    
5/25/2013 - 7:11 PM    OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified    
5/25/2013 - 7:11 PM    do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0    
5/25/2013 - 7:11 PM    open_tun, tt->ipv6=0    
5/25/2013 - 7:11 PM    TAP-WIN32 device [Local Area Connection 2] opened: \\.\Global\{E893236F-169D-4CCB-B552-74E57CAACF51}.tap    
5/25/2013 - 7:11 PM    TAP-Windows Driver Version 9.9     
5/25/2013 - 7:11 PM    Notified TAP-Windows driver to set a DHCP IP/netmask of 10.4.58.114/255.255.255.252 on interface {E893236F-169D-4CCB-B552-74E57CAACF51} [DHCP-serv: 10.4.58.113, lease-time: 31536000]    
5/25/2013 - 7:11 PM    Successful ARP Flush on interface [20] {E893236F-169D-4CCB-B552-74E57CAACF51}    
5/25/2013 - 7:11 PM    TEST ROUTES: 2/2 succeeded len=1 ret=1 a=0 u/d=up    
5/25/2013 - 7:11 PM    C:\Windows\system32\route.exe ADD 108.59.11.194 MASK 255.255.255.255 10.0.1.1    
5/25/2013 - 7:11 PM    ROUTE: CreateIpForwardEntry succeeded with dwForwardMetric1=25 and dwForwardType=4    
5/25/2013 - 7:11 PM    Route addition via IPAPI succeeded [adaptive]    
5/25/2013 - 7:11 PM    C:\Windows\system32\route.exe ADD 0.0.0.0 MASK 128.0.0.0 10.4.58.113    
5/25/2013 - 7:11 PM    ROUTE: CreateIpForwardEntry succeeded with dwForwardMetric1=30 and dwForwardType=4    
5/25/2013 - 7:11 PM    Route addition via IPAPI succeeded [adaptive]    
5/25/2013 - 7:11 PM    C:\Windows\system32\route.exe ADD 128.0.0.0 MASK 128.0.0.0 10.4.58.113    
5/25/2013 - 7:11 PM    ROUTE: CreateIpForwardEntry succeeded with dwForwardMetric1=30 and dwForwardType=4    
5/25/2013 - 7:11 PM    Route addition via IPAPI succeeded [adaptive]    
5/25/2013 - 7:11 PM    C:\Windows\system32\route.exe ADD 10.4.0.1 MASK 255.255.255.255 10.4.58.113    
5/25/2013 - 7:11 PM    ROUTE: CreateIpForwardEntry succeeded with dwForwardMetric1=30 and dwForwardType=4    
5/25/2013 - 7:11 PM    Route addition via IPAPI succeeded [adaptive]    
5/25/2013 - 7:11 PM    Initialization Sequence Completed    
5/25/2013 - 7:11 PM    Starting Management Interface...    
5/25/2013 - 7:11 PM    Checking...    
5/25/2013 - 7:11 PM    Retrieve statistics...    
5/25/2013 - 7:11 PM    Connected.    
 

Any other suggestions out there, I've read through all the threads I could find about slow speeds but found nothing that really helped...

Thank you.

Share this post


Link to post

Hello,

 

actually there's nothing wrong in the logs. Would you be able to test another system on your same network to make a comparison?

 

Kind regards

Share this post


Link to post

Ok I'm having the same issue on my other laptop. Normally my max is around 40Mb/s. Still getting only around 3Mb/s. On my first machine I tried both wireless and ethernet as well with the same results. This is the log for laptop 2:

 

5/25/2013 - 9:24 PM    AirVPN client version: 1.8    
5/25/2013 - 9:24 PM    Reading options from C:\Users\user\AppData\Roaming\AirVPN\Air\1.0.0.0\AirVPN.xml    
5/25/2013 - 9:24 PM    OpenVPN bundle version: OpenVPN 2.3.0    
5/25/2013 - 9:24 PM    OpenVPN current version: OpenVPN 2.3.0    
5/25/2013 - 9:24 PM    Ready.    
5/25/2013 - 9:26 PM    Login...    
5/25/2013 - 9:26 PM    Already connected.    
5/25/2013 - 9:26 PM    Login...    
5/25/2013 - 9:26 PM    Login success.    
5/25/2013 - 9:26 PM    Contacting service...    
5/25/2013 - 9:26 PM    Connecting...    
5/25/2013 - 9:26 PM    OpenVPN 2.3.0 x86_64-w64-mingw32 [sSL (OpenSSL)] [LZO] [PKCS11] [eurephia] [iPv6] built on Jan  8 2013    
5/25/2013 - 9:26 PM    NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables    
5/25/2013 - 9:26 PM    Socket Buffers: R=[8192->8192] S=[8192->8192]    
5/25/2013 - 9:26 PM    UDPv4 link local: [undef]    
5/25/2013 - 9:26 PM    UDPv4 link remote: [AF_INET]108.59.11.194:443    
5/25/2013 - 9:26 PM    TLS: Initial packet from [AF_INET]108.59.11.194:443, sid=cdaf2cb7 bad31909    
5/25/2013 - 9:26 PM    VERIFY OK: depth=1, C=IT, ST=IT, L=Perugia, O=airvpn.org, CN=airvpn.org CA, emailAddress=info@airvpn.org    
5/25/2013 - 9:26 PM    VERIFY OK: nsCertType=SERVER    
5/25/2013 - 9:26 PM    VERIFY OK: depth=0, C=IT, ST=IT, L=Perugia, O=airvpn.org, CN=server, emailAddress=info@airvpn.org    
5/25/2013 - 9:26 PM    Data Channel Encrypt: Cipher 'AES-256-CBC' initialized with 256 bit key    
5/25/2013 - 9:26 PM    Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication    
5/25/2013 - 9:26 PM    Data Channel Decrypt: Cipher 'AES-256-CBC' initialized with 256 bit key    
5/25/2013 - 9:26 PM    Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication    
5/25/2013 - 9:26 PM    Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 2048 bit RSA    
5/25/2013 - 9:26 PM    [server] Peer Connection Initiated with [AF_INET]108.59.11.194:443    
5/25/2013 - 9:26 PM    SENT CONTROL [server]: 'PUSH_REQUEST' (status=1)    
5/25/2013 - 9:26 PM    PUSH: Received control message: 'PUSH_REPLY,redirect-gateway def1,dhcp-option DNS 10.4.0.1,comp-lzo no,route 10.4.0.1,topology net30,ping 10,ping-restart 60,ifconfig 10.4.58.114 10.4.58.113'    
5/25/2013 - 9:26 PM    OPTIONS IMPORT: timers and/or timeouts modified    
5/25/2013 - 9:26 PM    OPTIONS IMPORT: LZO parms modified    
5/25/2013 - 9:26 PM    OPTIONS IMPORT: --ifconfig/up options modified    
5/25/2013 - 9:26 PM    OPTIONS IMPORT: route options modified    
5/25/2013 - 9:26 PM    OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified    
5/25/2013 - 9:26 PM    do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0    
5/25/2013 - 9:26 PM    open_tun, tt->ipv6=0    
5/25/2013 - 9:26 PM    TAP-WIN32 device [Local Area Connection 2] opened: \\.\Global\{749018C9-8F0A-4FEB-A2AB-BA1AD8AB7E1B}.tap    
5/25/2013 - 9:26 PM    TAP-Windows Driver Version 9.9     
5/25/2013 - 9:26 PM    Notified TAP-Windows driver to set a DHCP IP/netmask of 10.4.58.114/255.255.255.252 on interface {749018C9-8F0A-4FEB-A2AB-BA1AD8AB7E1B} [DHCP-serv: 10.4.58.113, lease-time: 31536000]    
5/25/2013 - 9:26 PM    Successful ARP Flush on interface [45] {749018C9-8F0A-4FEB-A2AB-BA1AD8AB7E1B}    
5/25/2013 - 9:26 PM    TEST ROUTES: 2/2 succeeded len=1 ret=1 a=0 u/d=up    
5/25/2013 - 9:26 PM    C:\windows\system32\route.exe ADD 108.59.11.194 MASK 255.255.255.255 10.0.1.1    
5/25/2013 - 9:26 PM    ROUTE: CreateIpForwardEntry succeeded with dwForwardMetric1=25 and dwForwardType=4    
5/25/2013 - 9:26 PM    Route addition via IPAPI succeeded [adaptive]    
5/25/2013 - 9:26 PM    C:\windows\system32\route.exe ADD 0.0.0.0 MASK 128.0.0.0 10.4.58.113    
5/25/2013 - 9:26 PM    ROUTE: CreateIpForwardEntry succeeded with dwForwardMetric1=30 and dwForwardType=4    
5/25/2013 - 9:26 PM    Route addition via IPAPI succeeded [adaptive]    
5/25/2013 - 9:26 PM    C:\windows\system32\route.exe ADD 128.0.0.0 MASK 128.0.0.0 10.4.58.113    
5/25/2013 - 9:26 PM    ROUTE: CreateIpForwardEntry succeeded with dwForwardMetric1=30 and dwForwardType=4    
5/25/2013 - 9:26 PM    Route addition via IPAPI succeeded [adaptive]    
5/25/2013 - 9:26 PM    C:\windows\system32\route.exe ADD 10.4.0.1 MASK 255.255.255.255 10.4.58.113    
5/25/2013 - 9:26 PM    ROUTE: CreateIpForwardEntry succeeded with dwForwardMetric1=30 and dwForwardType=4    
5/25/2013 - 9:26 PM    Route addition via IPAPI succeeded [adaptive]    
5/25/2013 - 9:26 PM    Initialization Sequence Completed    
5/25/2013 - 9:26 PM    Starting Management Interface...    
5/25/2013 - 9:26 PM    Checking...    
5/25/2013 - 9:27 PM    Retrieve statistics...    
5/25/2013 - 9:27 PM    Connected.    
 

Again I didn't see anything that appears to be a problem in the log?

Thank you.

Share this post


Link to post

Hello!

 

If you get the identical performance from any server you try, you should inquire your ISP for clarifications about traffic shaping.

 

Kind regards

Share this post


Link to post

Hello!

 

If you get the identical performance from any server you try, you should inquire your ISP for clarifications about traffic shaping.

 

Kind regards

 

I was hoping that I did something wrong during setup, but I wouldn't be surprised if comcast throttles vpn's.

I appreciate the help though...

And what is the average speed most people should expect without any ssl/ssh on AirVPN when there is a lower server load?

Thank you.

Share this post


Link to post

Hello!

 

Here https://airvpn.org/status/ you can find, on the tables on the right, the top 10 clients speeds updated every 60 seconds. We have no further reports about Comcast throttling OpenVPN traffic at the moment, all in all nowadays VPNs are essential for many small, medium and large companies. Feel free to keep us informed if you get a feedback from Comcast customer support.

 

Kind regards

Share this post


Link to post

Hello!

 

Additional note: can you please try a connection with any antivirus, packet filtering tool (firewall etc.) disabled?

 

Kind regardas

Share this post


Link to post

Hello!

 

Here https://airvpn.org/status/ you can find, on the tables on the right, the top 10 clients speeds updated every 60 seconds. We have no further reports about Comcast throttling OpenVPN traffic at the moment, all in all nowadays VPNs are essential for many small, medium and large companies. Feel free to keep us informed if you get a feedback from Comcast customer support.

 

Kind regards

I spoke with a comcast rep and to his knowledge they don't have any restrictions in place for any vpn protocals.

 

 

Hello!

 

Additional note: can you please try a connection with any antivirus, packet filtering tool (firewall etc.) disabled?

 

Kind regardas

And I also tried disabling my firewall entirely with no luck. I'm stumped here.

I'll be double and triple checking all settings on my end. If anyone can think of anything else any suggestion would be appreciated.

Thank you.

Share this post


Link to post

Hello,

 

thank you for your inquiry with Comcast. Feel free to keep us updated.

 

Just an additional note (very unlikely it may help you, but it's worth checking), we have seen in the past the some custom network managers pre-installed on Windows by a computer manufacturer (we had (very few) cases with Asus and Acer) impair OpenVPN connections performance (for unknown reasons). Re-activating the default Windows network manager solved the problem.

 

Kind regards

Share this post


Link to post

I know this is a dead thread, but I believe the issue was the time capsule I was using for my router when this was originally posted. Just an update, hopefully that'll help with someone else's headache at some point...

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

×
×
  • Create New...