Jump to content
Not connected, Your IP: 3.214.216.26
Staff

Eddie Android edition 3.0 preview available

Recommended Posts

@harold.lewis

Hello!

Yes, please send us the report. As you notice, maybe it's not an Eddie bug. Let's see and check. Thank you for your tests again!

Kind regards
 

Share this post


Link to post
On 10/21/2022 at 2:10 PM, harold.lewis said:
https://twitter.com/GrapheneOS/status/1563215751833477120

Well, I've experienced disconnection without reconnection at list once a day, I've not posted the log because may not be related to Eddie but if you want I may post the log if needed...
I'm seeing the same thing, sometimes multiple times a day, since I updated to beta 3.
A support email with logs is in the making.

Share this post


Link to post

Hi, testing appears to work okay. I was getting random WG disconnections on one device however on the other (with a more newer kernel, grapheneOS) it works okay. Does the @Staff know whether latest Android/Pixel kernels have WG in the kernel or is this an app/userspace implementation?

Two suggestions:

1: When there is 5 or more devices connected there is no error notifying you of such, nor can you manage those devices. It may be worth adding the ability to use the API and manage devices within the app (renew keys with the new API, disconnect devices etc). At the moment it keeps infinitely trying to connect before giving up eventually.

The second is a bigger request but absolutely a desired feature

2: Connect per mode (Wifi/4G (/cellular)): When at home, the network runs via a VPN anyway, so a VPN is not needed although one can be used. When on 4G there is absolutely a need to use VPN. Can we have an option so that the VPN auto connects when using mobile data, at the moment it's quite a pain to manage it manually. So something like:

if(user turns on 4g)
if(VPN is not active/connected)
connectVPN()

A per SSID config would be great too, but at least ensuring that when 4G is connected the VPN is active (and if block mode is not set in system settings, the VPN lock is auto enabled as a best effort to avoid leaks).


Thanks!

Share this post


Link to post

deed e removal and a reinstall, from Saturday I was having no problem in disconnecting and reconnecting but today after all day with no problem, in the evening again not reconnecting,..
log in the client area
it seems that some servers are not giving problems but others have sometimes problem for reconnecting

Share this post


Link to post

Hello!

@airvpnforumuser

Thank you for your suggestions. In the current beta testing, main features are frozen and only bug fixes are implemented, in general, but for the next future release feedback will be taken into due consideration as usual.

@harold.lewis

Thank you for your tests again. We have some progress on the malfunction reported by various users. We have realized that it has been reported not infrequently on the Internet for WireGuard and only in Android 13, so it does not seem related to Eddie, but to the WireGuard library called by Eddie. We suspect that the problem should occur with WireGuard only, and only in Android 12 and 13. Investigation goes on.

Kind regards
 

Share this post


Link to post

Interesting! I am seeing this with wireguard and Android 13 so I switched to OpenVPN and will observe if that makes a difference.

Share this post


Link to post

Hello!

We're very glad to inform you that Eddie Android edition 3.0 Beta 4 is now available. The original post has been updated accordingly.
 

New in Beta 4:

  • Improved management of WireGuard in Android 13 to resolve a WireGuard issue related to system network changes

The mentioned issue has been found out by community testers and other persons using the official WireGuard client with any VPN service only in some Android 13 kernel releases. The implemented modification aims at resolving the problem at its root by having WireGuard re-connect every time the device records a network change, provided that "Always on VPN" and "Block connections without VPN" Android settings, as well as "VPN reconnection" Eddie option, are all enabled.

Find full description, download link and SHA256 signature in the first post of this very thread.

Thank you very much for your tests and please report and describe any bug you find!

Kind regards

Share this post


Link to post

not sure what happened but play protect prevented me from installing this and Avast mobile detects this as a trojan. virustotal also confirms this as a Trojan

Share this post


Link to post
2 hours ago, mamegoma said:

not sure what happened but play protect prevented me from installing this and Avast mobile detects this as a trojan. virustotal also confirms this as a Trojan


Hello!

Please check the APK SHA based signature (published in this thread 1st message) carefully to confirm that it's a false positive.

Kind regards
 

Share this post


Link to post
6 hours ago, Staff said:

Hello!

Please check the APK SHA based signature (published in this thread 1st message) carefully to confirm that it's a false positive.

Kind regards
 
 Yup i have verified and it is indeed the correct hash. Also by the way, the application on the play store is misspelt. i believe its missing "N" for the beta version.

Share this post


Link to post
16 hours ago, mamegoma said:
22 hours ago, Staff said:

Hello!

Please check the APK SHA based signature (published in this thread 1st message) carefully to confirm that it's a false positive.

Kind regards
 
 Yup i have verified and it is indeed the correct hash. Also by the way, the application on the play store is misspelt. i believe its missing "N" for the beta version.

Hello!

Eddie 3 beta versions are not available on the play store, can you please elaborate?

Kind regards
 

Share this post


Link to post
@mamegoma

It was a 2021 beta which is still there, as you can see from the date, only for those subscribed to beta testing phases. We will remove it even from beta testers as we see it causes confusion, thanks.

Kind regards
 

Share this post


Link to post
7 hours ago, 183aTr78f9o said:

Using 3.0 Beta 4, I noticed the app connects to some servers which aren't in my favorites.

I'm using OpenVPN with default options.

I don't think I've ever seen this behavior before, is it normal?


Hello!

No, it isn't expected. We are trying to reproduce the issue, in the meantime can you please send us a report generated just after the problem has occurred?

Kind regards
 

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...